NIS, group et carte audio

Le
Jean CARREEL
Bonjour à tous et bonne année,

J'ai installé un serveur NIS/NFS (sur le petit serveur NAS NSLU2 de Linksys
- http://jah.thomas.googlepages.com/linksysnslu2). C'est impressionnant !
Pour pas cher et une consommation de 15W en fonctionnement et 5W en veille,
je partage l'authentification et les fichiers sur tous les PC de la maison.
Pour 6 utilisateurs ma question ne présente que peu d'intérêts mais quand
il y en aura 300

Les faits :
Si je crée un nouvel utilisateur, la carte son ne fonctionne pas. Il s'agit
simplement d'un problème de droits puisqu'il suffit d'aller dans le
'/etc/group' de la machine sur laquelle il n'y a pas de son pour y ajouter
le nom d'utilisateur face au groupe 'audio' (Pour un user local, Ubuntu
fait çà tout seul comme un grand). Et tout rentre dans l'ordre

La question :
Connaissez vous une astuce pour ne pas être contraint de paramétrer chaque
poste client ?

En espérant que la question vous inspire je vous souhaite une bonne fin de
WE.

Jean
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Denis Leger
Le #1909540
Le Sun, 06 Jan 2008 16:57:31 +0100,

Les faits :
Si je crée un nouvel utilisateur, la carte son ne fonctionne pas. Il
s'agit simplement d'un problème de droits puisqu'il suffit d'aller
dans le '/etc/group' de la machine sur laquelle il n'y a pas de son
pour y ajouter le nom d'utilisateur face au groupe 'audio' (Pour un
user local, Ubuntu fait çà tout seul comme un grand). Et tout rentre
dans l'ordre...

La question :
Connaissez vous une astuce pour ne pas être contraint de paramétrer
chaque poste client ?


Au moment où tu crée le nouvel utilisateur, il suffit d'indiquer qu'il
appartient au groupe audio : utilise useradd avec l'option -G (man
useradd pourra t'aider).



--
Denis Léger
MP Maths -- Brest

YBM
Le #1909539
La question :
Connaissez vous une astuce pour ne pas être contraint de paramétrer chaque
poste client ?


Soit tu crées le groupe audio sur le serveur NIS (pas moyen d'utiliser
LDAP ?) et tu mets les utilisateurs dedans, soit sur chaque poste
client dans /etc/udev/rules.d/40-permissions.rules tu modifies la
ligne :

SUBSYSTEM=="sound", GROUP="audio"

en

SUBSYSTEM=="sound", GROUP="audio", MODE="0666"

et tu relances udevd (non testé).

Jean CARREEL
Le #1909538
Re,

YBM wrote:
Soit tu crées le groupe audio sur le serveur NIS


C'est fait mais çà ne marche pas. J'ai même pris le soin de supprimer la
ligne audio dans le "/etc/group" local de ma machine cliente mais rien n'y
fait.

(pas moyen d'utiliser LDAP ?)


Je n'ai pas encore testé. Le jeu en vaut la chandelle ?

, soit sur chaque poste
client dans /etc/udev/rules.d/40-permissions.rules tu modifies la
ligne :

SUBSYSTEM=="sound", GROUP="audio"

en

SUBSYSTEM=="sound", GROUP="audio", MODE="0666"

et tu relances udevd (non testé).


Si je ne trouve pas la solution 1, je me pencherai sur cette solution.
Merci et bonne fin de WE.

Jean

Jean CARREEL
Le #1909536
Re,

Denis Leger wrote:
Au moment où tu crée le nouvel utilisateur, il suffit d'indiquer qu'il
appartient au groupe audio : utilise useradd avec l'option -G (man
useradd pourra t'aider).


Oui, et dans ce cas je mets à jour le "/etc/group" de mon serveur mais j'ai
l'impression que ce n'est pas pris en compte sur ma machine cliente.

Merci pour cette piste.

Bonne fin de WE.

Jean

YBM
Le #1909530
Re,

YBM wrote:
Soit tu crées le groupe audio sur le serveur NIS


C'est fait mais çà ne marche pas. J'ai même pris le soin de supprimer la
ligne audio dans le "/etc/group" local de ma machine cliente mais rien n'y
fait.


"id <user>" ne montre pas "audio" comme groupe pour l'utilisateur ? Ça fait
pareil avec un groupe non système (ie de gid > 1000) ?

pense aussi à utiliser "getent passwd" et "getent group" sur le client
pour les tests.

(pas moyen d'utiliser LDAP ?)


Je n'ai pas encore testé. Le jeu en vaut la chandelle ?


C'est plus moderne, mieux maintenu, il y a plus d'outils d'admin, ça fait
plus pro, etc.


Philippe.Weill
Le #1909529
Jean CARREEL wrote:
Re,

Denis Leger wrote:
Au moment où tu crée le nouvel utilisateur, il suffit d'indiquer qu'il
appartient au groupe audio : utilise useradd avec l'option -G (man
useradd pourra t'aider).


Oui, et dans ce cas je mets à jour le "/etc/group" de mon serveur mais j'ai
l'impression que ce n'est pas pris en compte sur ma machine cliente.

Merci pour cette piste.

Bonne fin de WE.

Jean


Quel GID utilise tu pour le group audio des nis

je pense que par defaut si il est inférieur à 500 il n'est pas pris en compte
dans les NIS

la valeur min peut être modifiée dans /var/yp/Makefile

variable MINGID


Publicité
Poster une réponse
Anonyme