nom de l'hote

Le
cyril.hoeckman
bonjour,
je suis avec IIS 7, pour faire une connexion d'un site qui fonctionne , je
ne dois pas mettre de nom d'hôte.
ce qui fait que pour me connecter a un site du serveur pas le billet d'un
navigateur web, je doit utiliser l'adresse IP.
je suppose que j'ai dut louper une étape, mais je ne trouve pas laquelle.
pour la configuration elle est d'origine.
merci, Cyril.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
jbongran
Le #19883541
"cyril.hoeckman" de discussion :
bonjour,
je suis avec IIS 7, pour faire une connexion d'un site qui fonctionne , je
ne dois pas mettre de nom d'hôte.
ce qui fait que pour me connecter a un site du serveur pas le billet d'un
navigateur web, je doit utiliser l'adresse IP.
je suppose que j'ai dut louper une étape, mais je ne trouve pas laquelle.
pour la configuration elle est d'origine.
merci, Cyril.




Pour que iis réponde a un nom d'hôte, il faut:
Que le client accède a un mécanisme quelconque (fichier hosts, dns) qui fera
la traduction entre le nom d'hôte souhaité et l'adresse ip du site web IIS

Après, côté IIS, deux cas de figures:
Il n'y a qu'un seul site web, dans ce cas, il n'y a rien de plus à faire.
Si il y a plusieurs sites web, dans votre cas, il est probable que chaque
site écoute sur une ip distincte.
Soit vous mettez un nom d'hôte sur chaque site web (sauf un qui deviendra le
site qui sera joint quand aucun nom d'hôte configuré ne correspondra), et
ils pourront tous écouter sur le même port et la même IP.
Soit vous faites comme dans le cas ou il n'y aurait qu'un site web (mais ça
consomme de l'IP pour rien et multiplie les règles d'ouverture de ports dans
les firewalls.
--
Jerome Bongran - MVP IIS
hoppus
Le #20899431
cyril.hoeckman a écrit le 20/07/2009 à 13h04 :
bonjour,
je suis avec IIS 7, pour faire une connexion d'un site qui fonctionne , je
ne dois pas mettre de nom d'hôte.
ce qui fait que pour me connecter a un site du serveur pas le billet d'un
navigateur web, je doit utiliser l'adresse IP.
je suppose que j'ai dut louper une étape, mais je ne trouve pas
laquelle.
pour la configuration elle est d'origine.
merci, Cyril.


Bonjour

désolé de remonter un sujet si ancien mais c'est celui qui s'approche le + de mon problème !

Nous avons 2 sites à configurer, en Intranet.

Avant, dans IIS6, on créait nos 2 sites dans IIS et on pouvait y'arriver par http://adresseIP/NomHote sans aucun soucis.

Maintenant, sous II7, si on ne crée qu'un site on peut y'accéder sur http://adresseIP/ sans avoir à mettre de nom d'hôte mais si on met un nom d'hôte, il ne trouve pas le site, que ce soit http://adresseIP/NomHote ou http://NomHote/ ou http://NomHote:Port/ .

Quelle est la démarche à faire, en Intranet, pour que les noms d'hôtes soient reconnus ou qu'on puisse avoir 2 sites sur une même IP, avec juste le nom d'hote pour différencier ? (Sachant que IIS7 est installé sur Windows 7)

Merci beaucoup,

Fabien
Publicité
Poster une réponse
Anonyme