Nombre de grade dispensé pour chaque jour de semaine

Le
Menibelus
Bonjour,

J'ai une feuille avec en ligne 2 les jour de l'année sous forme
01/01/2010 format jj mmm, en ligne 3 la position de chaque personne G
pour garde, As pour astreinte,
J'aimerai comptabiliser le nombre de garde, d'astreinte faite suivant
le jour de la semaine exemple 3 gardes effectuées le mardi
J'ai donc écris cette formule
=SOMMEPROD((B3:EK3="G")*(JOURSEM(B2:EK2;1)=2)) mais fonctionne pas

Pourriez vous me dire ce que je peux faire
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jacky
Le #21499962
Bonjour,

.... exemple 3 gardes effectuées le mardi


A vérifier ..l'argument de ==>JOURSEM()

.....JOURSEM(B2:EK2;1)=2
Retourne le nombre de "Lundi"

...JOURSEM(B2:EK2;2)=2
ou
...JOURSEM(B2:EK2;1)=3
ou
...JOURSEM(B2:EK2)=3
Retourne le nombre de "Mardi"
-
Salutations
JJ


"Menibelus"
Bonjour,

J'ai une feuille avec en ligne 2 les jour de l'année sous forme
01/01/2010 format jj mmm, en ligne 3 la position de chaque personne G
pour garde, As pour astreinte, ...
J'aimerai comptabiliser le nombre de garde, d'astreinte faite suivant
le jour de la semaine exemple 3 gardes effectuées le mardi
J'ai donc écris cette formule
=SOMMEPROD((B3:EK3="G")*(JOURSEM(B2:EK2;1)=2)) mais fonctionne pas

Pourriez vous me dire ce que je peux faire
Menibelus
Le #21500032
On 5 avr, 07:53, "Jacky"
Bonjour,

>.... exemple 3 gardes effectu es le mardi

A v rifier ..l'argument de ==>JOURSEM()

.....JOURSEM(B2:EK2;1)=2
Retourne le nombre de "Lundi"

...JOURSEM(B2:EK2;2)=2
ou
...JOURSEM(B2:EK2;1)=3
ou
...JOURSEM(B2:EK2)=3
Retourne le nombre de "Mardi"
-
Salutations
JJ

"Menibelus"
Bonjour,

J'ai une feuille avec en ligne 2 les jour de l'ann e sous forme
01/01/2010 format jj mmm, en ligne 3 la position de chaque personne G
pour garde, As pour astreinte, ...
J'aimerai comptabiliser le nombre de garde, d'astreinte faite suivant
le jour de la semaine exemple 3 gardes effectu es le mardi
J'ai donc cris cette formule
=SOMMEPROD((B3:EK3="G")*(JOURSEM(B2:EK2;1)=2)) mais fonctionne pas

Pourriez vous me dire ce que je peux faire



J'ai vérifier mais marche toujours pas :'(
Menibelus
Le #21500022
On 5 avr, 07:53, "Jacky"
Bonjour,

>.... exemple 3 gardes effectu es le mardi

A v rifier ..l'argument de ==>JOURSEM()

.....JOURSEM(B2:EK2;1)=2
Retourne le nombre de "Lundi"

...JOURSEM(B2:EK2;2)=2
ou
...JOURSEM(B2:EK2;1)=3
ou
...JOURSEM(B2:EK2)=3
Retourne le nombre de "Mardi"
-
Salutations
JJ

"Menibelus"
Bonjour,

J'ai une feuille avec en ligne 2 les jour de l'ann e sous forme
01/01/2010 format jj mmm, en ligne 3 la position de chaque personne G
pour garde, As pour astreinte, ...
J'aimerai comptabiliser le nombre de garde, d'astreinte faite suivant
le jour de la semaine exemple 3 gardes effectu es le mardi
J'ai donc cris cette formule
=SOMMEPROD((B3:EK3="G")*(JOURSEM(B2:EK2;1)=2)) mais fonctionne pas

Pourriez vous me dire ce que je peux faire



Voici mon classeur http://cjoint.com/?efiMYrLlRZ
Charabeuh
Le #21500702
Bonjour,

D'après ce que j'ai vu et si j'ai compris ce que tu cherches à calculer, tu
cherches à connaitre le nombre de garde pour chaque sapeur en journée ou la
nuit sur la toute la période de ton tableau de garde pour chaque type de
jour de la semaine.

L'erreur, me semble t il, provient du fait que dans ton sommeprod se trouve
une zone avec des cellules fusionnées. Si tu fusionnes deux cellules, seule
la première cellule contient de l'information. Quand dans le sommeprod tu
références les deux cellules une seule contient de l'info.

Les cellules fusionnées sont à bannir ! (c'est mon opinion et d'autres la
partage)

Pour résoudre ton PB, j'ai rajouté une ligne dont les cellules contiennent
les dates, une date pour le jour et la même date pour la nuit (il suffit de
cacher cette ligne dans le tableau) et en fin de ligne le type de jour.

exemple : Le sommeprod devient :
=SOMMEPROD( -- (JOURSEM($H$3:$EQ$3;1)=ER$3) * ($H$4:$EQ$4 =ER$4)
*($H5:$EQ5 = "G" ) )
pour lundi matin du premier de garde

(J'ai aussi transformé la formule donnant les noms des sapeurs en
remplaçant )-3) par )-4) pour tenir compte de l'insertion de la ligne)

Attention: si tu as plus de 13 sapeurs en garde A, ton tableau est trop
petit !

Voir le fichier :
http://cjoint.com/?efkZu8V3sF

Ai je bien compris ?

Cdlt



"Menibelus" discussion :

On 5 avr, 07:53, "Jacky"
Bonjour,

>.... exemple 3 gardes effectu es le mardi

A v rifier ..l'argument de ==>JOURSEM()

.....JOURSEM(B2:EK2;1)=2
Retourne le nombre de "Lundi"

...JOURSEM(B2:EK2;2)=2
ou
...JOURSEM(B2:EK2;1)=3
ou
...JOURSEM(B2:EK2)=3
Retourne le nombre de "Mardi"
-
Salutations
JJ

"Menibelus"
Bonjour,

J'ai une feuille avec en ligne 2 les jour de l'ann e sous forme
01/01/2010 format jj mmm, en ligne 3 la position de chaque personne G
pour garde, As pour astreinte, ...
J'aimerai comptabiliser le nombre de garde, d'astreinte faite suivant
le jour de la semaine exemple 3 gardes effectu es le mardi
J'ai donc cris cette formule
=SOMMEPROD((B3:EK3="G")*(JOURSEM(B2:EK2;1)=2)) mais fonctionne pas

Pourriez vous me dire ce que je peux faire



Voici mon classeur http://cjoint.com/?efiMYrLlRZ
Charabeuh
Le #21500782
Errata:

La grosse faute de conjugaison (j'espère que c'est la seule) :
lire (c'est mon opinion et d'autres la partagent)
au lieu de (c'est mon opinion et d'autres la partage)



"Charabeuh" discussion : ulCL6$
Bonjour,

D'après ce que j'ai vu et si j'ai compris ce que tu cherches à calculer,
tu cherches à connaitre le nombre de garde pour chaque sapeur en journée
ou la nuit sur la toute la période de ton tableau de garde pour chaque
type de jour de la semaine.

L'erreur, me semble t il, provient du fait que dans ton sommeprod se
trouve une zone avec des cellules fusionnées. Si tu fusionnes deux
cellules, seule la première cellule contient de l'information. Quand dans
le sommeprod tu références les deux cellules une seule contient de l'info.

Les cellules fusionnées sont à bannir ! (c'est mon opinion et d'autres la
partage)

Pour résoudre ton PB, j'ai rajouté une ligne dont les cellules contiennent
les dates, une date pour le jour et la même date pour la nuit (il suffit
de cacher cette ligne dans le tableau) et en fin de ligne le type de jour.

exemple : Le sommeprod devient :
=SOMMEPROD( -- (JOURSEM($H$3:$EQ$3;1)=ER$3) * ($H$4:$EQ$4 =ER$4)
*($H5:$EQ5 = "G" ) )
pour lundi matin du premier de garde

(J'ai aussi transformé la formule donnant les noms des sapeurs en
remplaçant )-3) par )-4) pour tenir compte de l'insertion de la ligne)

Attention: si tu as plus de 13 sapeurs en garde A, ton tableau est trop
petit !

Voir le fichier :
http://cjoint.com/?efkZu8V3sF

Ai je bien compris ?

Cdlt



"Menibelus" de discussion :

On 5 avr, 07:53, "Jacky"
Bonjour,

>.... exemple 3 gardes effectu es le mardi

A v rifier ..l'argument de ==>JOURSEM()

.....JOURSEM(B2:EK2;1)=2
Retourne le nombre de "Lundi"

...JOURSEM(B2:EK2;2)=2
ou
...JOURSEM(B2:EK2;1)=3
ou
...JOURSEM(B2:EK2)=3
Retourne le nombre de "Mardi"
-
Salutations
JJ

"Menibelus"
Bonjour,

J'ai une feuille avec en ligne 2 les jour de l'ann e sous forme
01/01/2010 format jj mmm, en ligne 3 la position de chaque personne G
pour garde, As pour astreinte, ...
J'aimerai comptabiliser le nombre de garde, d'astreinte faite suivant
le jour de la semaine exemple 3 gardes effectu es le mardi
J'ai donc cris cette formule
=SOMMEPROD((B3:EK3="G")*(JOURSEM(B2:EK2;1)=2)) mais fonctionne pas

Pourriez vous me dire ce que je peux faire



Voici mon classeur http://cjoint.com/?efiMYrLlRZ



Jacky
Le #21502312
Re....
Teste ceci......
Quelques modif. de structure et de format sont nécessaire
En Er4
=SOMMEPROD(($H4:$EQ4="G")*(JOURSEM($H$2:$EQ$2;2)=ER$2)*($H$3:$EQ$3=ER$3))

Voir ici
http://www.cijoint.fr/cjlink.php?file=cj201004/cijDCLsIC2.xlsx


Ps les cellules fusionnées sont sujet à complication.
--
Salutations
JJ

--
Salutations
JJ


"Menibelus"
On 5 avr, 07:53, "Jacky"
Bonjour,

>.... exemple 3 gardes effectu es le mardi

A v rifier ..l'argument de ==>JOURSEM()

.....JOURSEM(B2:EK2;1)=2
Retourne le nombre de "Lundi"

...JOURSEM(B2:EK2;2)=2
ou
...JOURSEM(B2:EK2;1)=3
ou
...JOURSEM(B2:EK2)=3
Retourne le nombre de "Mardi"
-
Salutations
JJ

"Menibelus"
Bonjour,

J'ai une feuille avec en ligne 2 les jour de l'ann e sous forme
01/01/2010 format jj mmm, en ligne 3 la position de chaque personne G
pour garde, As pour astreinte, ...
J'aimerai comptabiliser le nombre de garde, d'astreinte faite suivant
le jour de la semaine exemple 3 gardes effectu es le mardi
J'ai donc cris cette formule
=SOMMEPROD((B3:EK3="G")*(JOURSEM(B2:EK2;1)=2)) mais fonctionne pas

Pourriez vous me dire ce que je peux faire



J'ai vérifier mais marche toujours pas :'(
Publicité
Poster une réponse
Anonyme