Nombre de valeurs unique

Le
Flag
Bonjour,

J'ai un fichier contenant des données dans une colonne. Je veux mettre un
total de valeur "Unique" que l'on retrouve dans la colonne.

Exemple: Couleur:
Bleu
Rouge
Jaune
Bleu
Bleu
Rouge
Total de valeur unique: 3

Bref je veux faire un "nombre" sans doublons!

Merci pour votre aide!
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Tatanka
Le #5328221
Salut Flag,

En supposant que tes couleurs sont en A1:A6 :
=SOMME(1/NB.SI(A1:A6;A1:A6))
(valider par Ctrl+Shift+Enter)

Serge


"Flag"
Bonjour,

J'ai un fichier contenant des données dans une colonne. Je veux mettre un
total de valeur "Unique" que l'on retrouve dans la colonne.

Exemple: Couleur:
Bleu
Rouge
Jaune
Bleu
Bleu
Rouge
Total de valeur unique: 3

Bref je veux faire un "nombre" sans doublons!

Merci pour votre aide!





FdeCourt
Le #5328211
Salut,

Une proposition :

=SOMME(SI(FREQUENCE(SI(NBCAR(A2:A10)>0;EQUIV(A2:A10;A2:A10;0);"");SI(NBCAR (A2:A10)>0;EQUIV(A2:A10;A2:A10;0);""))>0;1))

(cette formule doit être présente sur le site d'office, mais je ne
sais plus ou !!!!)

Cordialement,

F.

On 26 mar, 15:35, Flag
Bonjour,

J'ai un fichier contenant des données dans une colonne. Je veux mettre u n
total de valeur "Unique" que l'on retrouve dans la colonne.

Exemple:                   Couleur:
                                 Bleu
                                 Rouge
                                 Jaune
                                 Bleu
                                 Bleu
                                 Rouge
Total de valeur unique: 3

Bref je veux faire un "nombre" sans doublons!

Merci pour votre aide!


Flag
Le #5328201
Ça fonctionne!

Merci

"Tatanka" wrote:

Salut Flag,

En supposant que tes couleurs sont en A1:A6 :
=SOMME(1/NB.SI(A1:A6;A1:A6))
(valider par Ctrl+Shift+Enter)

Serge


"Flag"
Bonjour,

J'ai un fichier contenant des données dans une colonne. Je veux mettre un
total de valeur "Unique" que l'on retrouve dans la colonne.

Exemple: Couleur:
Bleu
Rouge
Jaune
Bleu
Bleu
Rouge
Total de valeur unique: 3

Bref je veux faire un "nombre" sans doublons!

Merci pour votre aide!










Misange
Le #5328181
Bonjour,

J'ai un fichier contenant des données dans une colonne. Je veux mettre un
total de valeur "Unique" que l'on retrouve dans la colonne.

Exemple: Couleur:
Bleu
Rouge
Jaune
Bleu
Bleu
Rouge
Total de valeur unique: 3

Bref je veux faire un "nombre" sans doublons!

Merci pour votre aide!



Bonjour

(de MichDenis et ChrisV)
en nommant la plage de données à analyser colA (insertion/nom/définir)

Cette formule te donne le nombre de valeur uniques.
=SOMMEPROD((ColA<>"")/(NB.SI(ColA;ColA)+(ColA="")))

et si tu as des cellules vides dans ta colonne A :
=SOMME(SI(ESTVIDE(ColA);"";1/NB.SI(ColA;ColA)))

ou encore ceci
http://www.excelabo.net/excel/denombrer.php#valdiff
ou encore (celle que perso j'utilise), avec un TCD (de laurent Longre)
http://www.excelabo.net/excel/denombrer.php#occurrences

plus d'une solution pour un problème courant :-)
--
Misange migrateuse
XlWiki : Participez à un travail collaboratif sur excel !
http://xlwiki.free.fr/wiki
http://www.excelabo.net

FdeCourt
Le #5328171
Serge,

Pour compléter ta formule (nettement plus jolie que celle que j'ai
mise), si il y a une cellule vide dans la liste des couleurs :

=SOMME(SI(ESTVIDE(A1:A6);0;1/NB.SI(A1:A6;A1:A6)))

A valider par CTRL + MAJ + ENTER


F.


On 26 mar, 15:55, "Tatanka"
Salut Flag,

En supposant que tes couleurs sont en A1:A6 :
=SOMME(1/NB.SI(A1:A6;A1:A6))
(valider par Ctrl+Shift+Enter)

Serge

"Flag"


Bonjour,

J'ai un fichier contenant des données dans une colonne. Je veux mettre un
total de valeur "Unique" que l'on retrouve dans la colonne.

Exemple:                   Couleur:
                                Bleu
                                Rouge
                                Jaune
                                Bleu
                                Bleu
                                Rouge
Total de valeur unique: 3

Bref je veux faire un "nombre" sans doublons!

Merci pour votre aide!- Masquer le texte des messages précédents -


- Afficher le texte des messages précédents -



Tatanka
Le #5328111
Et pour prévoir le coup des cellules vides en tenant compte des
nombreuses formules proposées :
=SOMME(SI(ESTVIDE(A1:A6);"";1/NB.SI(A1:A6;A1:A6)))

Serge


"Flag"
Bonjour,

J'ai un fichier contenant des données dans une colonne. Je veux mettre un
total de valeur "Unique" que l'on retrouve dans la colonne.

Exemple: Couleur:
Bleu
Rouge
Jaune
Bleu
Bleu
Rouge
Total de valeur unique: 3

Bref je veux faire un "nombre" sans doublons!

Merci pour votre aide!





Tatanka
Le #5328091
Et c'est moins fatigant de taper 0 plutôt que "" ;-)

"FdeCourt" Serge,

Pour compléter ta formule (nettement plus jolie que celle que j'ai
mise), si il y a une cellule vide dans la liste des couleurs :

=SOMME(SI(ESTVIDE(A1:A6);0;1/NB.SI(A1:A6;A1:A6)))

A valider par CTRL + MAJ + ENTER


F.


On 26 mar, 15:55, "Tatanka"
Salut Flag,

En supposant que tes couleurs sont en A1:A6 :
=SOMME(1/NB.SI(A1:A6;A1:A6))
(valider par Ctrl+Shift+Enter)

Serge

"Flag"


Bonjour,

J'ai un fichier contenant des données dans une colonne. Je veux mettre un
total de valeur "Unique" que l'on retrouve dans la colonne.

Exemple: Couleur:
Bleu
Rouge
Jaune
Bleu
Bleu
Rouge
Total de valeur unique: 3

Bref je veux faire un "nombre" sans doublons!

Merci pour votre aide!- Masquer le texte des messages précédents -


- Afficher le texte des messages précédents -



Publicité
Poster une réponse
Anonyme