Nombres dans une plage

Le
JLuc
Bonsoir les lecteurs,
J'ai un tableau de valeurs, et je voudrais recuperer le nombre de
valeurs compris dans une plage de valeur :/
Je sais pas si je suis clair, là :p

mes valeurs :
41.96
42
41.97
42.03
42.01
41.92



je voudrais le nombre de valeurs compris entre 41.96 et 42 (bornes
incluses)
ici : 3 (dans celles écrites :p)

Merci pour vos reponses

--
____
( O | O )
--
_oooO_ JLuc _Oooo_

O-O
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
JPMonnier
Le #5155711
Bonsoir
en f1 valeur > en f2 valeur < plage = plage de cellules nommée

Sub Compte()
For Each c In Range("plage")
If c >= ActiveSheet.[f1] And c <= ActiveSheet.[f2] Then
n = n + 1
End If
Next
MsgBox n

End Sub

--
Cordialement

"JLuc" news:
Bonsoir les lecteurs,
J'ai un tableau de valeurs, et je voudrais recuperer le nombre de valeurs
compris dans une plage de valeur :/
Je sais pas si je suis clair, là :p

mes valeurs :
41.96
42
41.97
42.03
42.01
41.92
...
...

je voudrais le nombre de valeurs compris entre 41.96 et 42 (bornes
incluses)
ici : 3 (dans celles écrites :p)

Merci pour vos reponses

--
____
( O | O )
--
_oooO_ JLuc _Oooo_

O-O




Tatanka
Le #5155701
Salut JLuc,

Quelque chose du genre :

=NB.SI($A$1:$A$6;"<B")-NB.SI($A$1:$A$6;"<41,96")

Serge

"JLuc"
Bonsoir les lecteurs,
J'ai un tableau de valeurs, et je voudrais recuperer le nombre de valeurs compris dans une plage de valeur :/
Je sais pas si je suis clair, là :p

mes valeurs :
41.96
42
41.97
42.03
42.01
41.92
...
...

je voudrais le nombre de valeurs compris entre 41.96 et 42 (bornes incluses)
ici : 3 (dans celles écrites :p)

Merci pour vos reponses

--
____
( O | O )
--
_oooO_ JLuc _Oooo_

O-O




JLuc
Le #5155681
*Bonjour Tatanka*,
C'est presque ça, en fait il me faudrai quelque chose du genre :
=NB.SI(valeurs;" mais sans les guillemets


Salut JLuc,

Quelque chose du genre :

=NB.SI($A$1:$A$6;"<B")-NB.SI($A$1:$A$6;"<41,96")

Serge

"JLuc"
Bonsoir les lecteurs,
J'ai un tableau de valeurs, et je voudrais recuperer le nombre de valeurs
compris dans une plage de valeur :/
Je sais pas si je suis clair, là :p

mes valeurs :
41.96
42
41.97
42.03
42.01
41.92
...
...

je voudrais le nombre de valeurs compris entre 41.96 et 42 (bornes
incluses)
ici : 3 (dans celles écrites :p)

Merci pour vos reponses

-- ____
( O | O )
--
_oooO_ JLuc _Oooo_

O-O





--
____
( O | O )
--
_oooO_ JLuc _Oooo_

O-O


JLuc
Le #5155671
*Bonjour JPMonnier*,
Je prefererais quelque chose sans fonction :p


Bonsoir
en f1 valeur > > en f2 valeur < > plage = plage de cellules nommée

Sub Compte()
For Each c In Range("plage")
If c >= ActiveSheet.[f1] And c <= ActiveSheet.[f2] Then
n = n + 1
End If
Next
MsgBox n

End Sub

--
Cordialement

"JLuc" news:
Bonsoir les lecteurs,
J'ai un tableau de valeurs, et je voudrais recuperer le nombre de valeurs
compris dans une plage de valeur :/
Je sais pas si je suis clair, là :p

mes valeurs :
41.96
42
41.97
42.03
42.01
41.92
...
...

je voudrais le nombre de valeurs compris entre 41.96 et 42 (bornes
incluses)
ici : 3 (dans celles écrites :p)

Merci pour vos reponses

-- ____
( O | O )
--
_oooO_ JLuc _Oooo_

O-O





--
____
( O | O )
--
_oooO_ JLuc _Oooo_

O-O


Philippe.R
Le #5155661
Bonsoir,
Quelques pistes, si j'ai bien compris :
http://www.excelabo.net/excel/denombrer.php#nbuniques
http://www.excelabo.net/excel/denombrer.php#nbnonredondants2
http://www.excelabo.net/excel/comparerdiv.php#valeursuniques
--
Avec plaisir
http://dj.joss.free.fr/trombine.htm
http://jacxl.free.fr/mpfe/trombino.html
Philippe.R
Pour se connecter au forum :
http://www.excelabo.net/mpfe/connexion.php
News://news.microsoft.com/microsoft.public.fr.excel
"JLuc" news:
Bonsoir les lecteurs,
J'ai un tableau de valeurs, et je voudrais recuperer le nombre de valeurs
compris dans une plage de valeur :/
Je sais pas si je suis clair, là :p

mes valeurs :
41.96
42
41.97
42.03
42.01
41.92
...
...

je voudrais le nombre de valeurs compris entre 41.96 et 42 (bornes
incluses)
ici : 3 (dans celles écrites :p)

Merci pour vos reponses

--
____
( O | O )
--
_oooO_ JLuc _Oooo_

O-O




JLuc
Le #5155641
Merci à tous, j'ai résolu mon problème par un sommeprod :
=SOMMEPROD((valeurs<±4)*(valeurs>¡4))

--
____
( O | O )
--
_oooO_ JLuc _Oooo_

O-O
Xavier powaga
Le #5155621
=NB.SI(Plage;"<="&B14)-NB.SI(Plage;"<="&A14)
et comme ça
"JLuc"
*Bonjour Tatanka*,
C'est presque ça, en fait il me faudrai quelque chose du genre :
=NB.SI(valeurs;" mais sans les guillemets


Salut JLuc,

Quelque chose du genre :

=NB.SI($A$1:$A$6;"<B")-NB.SI($A$1:$A$6;"<41,96")

Serge

"JLuc"
Bonsoir les lecteurs,
J'ai un tableau de valeurs, et je voudrais recuperer le nombre de
valeurs compris dans une plage de valeur :/
Je sais pas si je suis clair, là :p

mes valeurs :
41.96
42
41.97
42.03
42.01
41.92
...
...

je voudrais le nombre de valeurs compris entre 41.96 et 42 (bornes
incluses)
ici : 3 (dans celles écrites :p)

Merci pour vos reponses

-- ____
( O | O )
--
_oooO_ JLuc _Oooo_

O-O





--
____
( O | O )
--
_oooO_ JLuc _Oooo_

O-O






JLuc
Le #5155601
*Bonjour Xavier powaga*,
Merci, j'ai résolu avec un sommeprod :D

=NB.SI(Plage;"<="&B14)-NB.SI(Plage;"<="&A14)
et comme ça
"JLuc"
*Bonjour Tatanka*,
C'est presque ça, en fait il me faudrai quelque chose du genre :
=NB.SI(valeurs;" mais sans les guillemets


Salut JLuc,

Quelque chose du genre :

=NB.SI($A$1:$A$6;"<B")-NB.SI($A$1:$A$6;"<41,96")

Serge

"JLuc"
Bonsoir les lecteurs,
J'ai un tableau de valeurs, et je voudrais recuperer le nombre de valeurs
compris dans une plage de valeur :/
Je sais pas si je suis clair, là :p

mes valeurs :
41.96
42
41.97
42.03
42.01
41.92
...
...

je voudrais le nombre de valeurs compris entre 41.96 et 42 (bornes
incluses)
ici : 3 (dans celles écrites :p)

Merci pour vos reponses

-- ____
( O | O )
--
_oooO_ JLuc _Oooo_

O-O





-- ____
( O | O )
--
_oooO_ JLuc _Oooo_

O-O





--
____
( O | O )
--
_oooO_ JLuc _Oooo_

O-O




Modeste
Le #5155581
Bonsour® JLuc avec ferveur ;o))) vous nous disiez :

J'ai un tableau de valeurs, et je voudrais recuperer le nombre de
valeurs compris dans une plage de valeur :/
Je sais pas si je suis clair, là :p

mes valeurs :
41.96
42
41.97
42.03
42.01
41.92
...
je voudrais le nombre de valeurs compris entre 41.96 et 42 (bornes
incluses)
ici : 3 (dans celles écrites :p)


=SOMMEPROD(1*(Plage>A,96)*(Plage<B))

--
--
@+
;o)))

JLuc
Le #5155571
Merci Modeste, en fait j'avais trouvé


Bonsour® JLuc avec ferveur ;o))) vous nous disiez :

J'ai un tableau de valeurs, et je voudrais recuperer le nombre de
valeurs compris dans une plage de valeur :/
Je sais pas si je suis clair, là :p

mes valeurs :
41.96
42
41.97
42.03
42.01
41.92
...
je voudrais le nombre de valeurs compris entre 41.96 et 42 (bornes
incluses)
ici : 3 (dans celles écrites :p)


=SOMMEPROD(1*(Plage>A,96)*(Plage<B))

--


--
____
( O | O )
--
_oooO_ JLuc _Oooo_

O-O


Publicité
Poster une réponse
Anonyme