Non prise en compte des ZERO

Le
Philippe
Bonjour à toutes et à tous,

Je rencontre un petit problème à cause de ces "satanés" ZERO.
Je pense que la solution ne doit pas être compliquée, mais pour l'instant je
planche et je passe à côté.
Si quelqu'un peut jeter un oeil sur le ci-joint
Merci à vous tous.

http://cjoint.com/?fgnei75kre
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
JB
Le #6562591
Bonjour,

Outils/Options/Valeur zéro

JB

On 6 mai, 13:01, "Philippe"
Bonjour à toutes et à tous,

Je rencontre un petit problème à cause de ces "satanés" ZERO.
Je pense que la solution ne doit pas être compliquée, mais pour l'inst ant je
planche et je passe à côté.
Si quelqu'un peut jeter un oeil sur le ci-joint
Merci à vous tous.

http://cjoint.com/?fgnei75kre


Joël André
Le #6562581
Une idée qui pourrait éventuellement répondre aux attentes :
"Outils" puis "Option" et décocher la case "Zéro"
Bonne chance
"Philippe"
Bonjour à toutes et à tous,

Je rencontre un petit problème à cause de ces "satanés" ZERO.
Je pense que la solution ne doit pas être compliquée, mais pour l'instant
je planche et je passe à côté.
Si quelqu'un peut jeter un oeil sur le ci-joint
Merci à vous tous.

http://cjoint.com/?fgnei75kre



Sam
Le #6562571
Bonjour,
en mettant peut être en colonne D
=SI(ET(B5=0;C5=0);"";MIN(B5;C5))

nota : bizarre, en G7 tu sembles avoir une erreur (ou c'est mon IE qui ne
met pas à jour)
Cordialement
Michel

"Philippe"
Bonjour à toutes et à tous,

Je rencontre un petit problème à cause de ces "satanés" ZERO.
Je pense que la solution ne doit pas être compliquée, mais pour l'instant
je planche et je passe à côté.
Si quelqu'un peut jeter un oeil sur le ci-joint
Merci à vous tous.

http://cjoint.com/?fgnei75kre



Youky
Le #6563281
Salut Philippe,
Change la formule en D5 par
=SI(B5+C5=0;"";SI(B5=0;C5;SI(C5=0;B5;MIN(B5;C5))))
Tire en bas
et en G5
=SI(D5="";"";PETITE.VALEUR($D$5:$D$20;LIGNE()-4))
Tire en bas
Youky

"Philippe"
Bonjour à toutes et à tous,

Je rencontre un petit problème à cause de ces "satanés" ZERO.
Je pense que la solution ne doit pas être compliquée, mais pour l'instant
je planche et je passe à côté.
Si quelqu'un peut jeter un oeil sur le ci-joint
Merci à vous tous.

http://cjoint.com/?fgnei75kre



Sam
Le #6563661
Bonjour,
et en piquant l'idée de Youki :
en mettant en colonne D
=SI(B5+C5=0;"";MIN(B5;C5))

après le pb est de savoir si Philippe donne les points en commençant par 100
ou par 85
Il y aura aussi le pb des ex aequo à qui il faudra donner les même points.
Cordialement
Michel

"Sam" 48204afd$0$850$

Bonjour,


nota : bizarre, en G7 tu sembles avoir une erreur (ou c'est mon IE qui ne
met pas à jour)
Cordialement
Michel

"Philippe"
Bonjour à toutes et à tous,

Je rencontre un petit problème à cause de ces "satanés" ZERO.
Je pense que la solution ne doit pas être compliquée, mais pour l'instant
je planche et je passe à côté.
Si quelqu'un peut jeter un oeil sur le ci-joint
Merci à vous tous.

http://cjoint.com/?fgnei75kre







Youky
Le #6564011
Salut Sam,
Bien vu je me compliquais
En plus les égaux faut y penser tu as raison
J'ai donc fait mis une formule pour les points.
Voici le lien du fichier modifié pour Philippe
http://cjoint.com/?fgrzC4u7yH
Youky

"Sam" 48206ca1$0$907$

Bonjour,
et en piquant l'idée de Youki :
en mettant en colonne D
=SI(B5+C5=0;"";MIN(B5;C5))

après le pb est de savoir si Philippe donne les points en commençant par
100 ou par 85
Il y aura aussi le pb des ex aequo à qui il faudra donner les même points.
Cordialement
Michel

"Sam" 48204afd$0$850$

Bonjour,


nota : bizarre, en G7 tu sembles avoir une erreur (ou c'est mon IE qui ne
met pas à jour)
Cordialement
Michel

"Philippe"
Bonjour à toutes et à tous,

Je rencontre un petit problème à cause de ces "satanés" ZERO.
Je pense que la solution ne doit pas être compliquée, mais pour
l'instant je planche et je passe à côté.
Si quelqu'un peut jeter un oeil sur le ci-joint
Merci à vous tous.

http://cjoint.com/?fgnei75kre











Philippe
Le #6564841
Merci à tous de vous pencher sur le problème. Merci beaucoup.
J'ai enregisté toutes vos astuces et je vais les essayer.
Pour info --> les points attribués sont fixes et dégressifs (100, 99, 98,
...)
Les temps sont au millième, donc les exaequos sont rares, même très rares.
(mais merci pour les astuces)
De toute façon, en plus de ce tableau, il y a d'autres épreuves et tout les
résultats de ceux-ci sont addionnés, ce qui rend encore moins de possibilité
d'exaequos.
Si je peux me permettre de poser une question; pourquoi (dans un autre
tableau) lorsque je sélectionne un tableau complet (avec des lignes
vierges), le tri décroissant se retrouve en bas de tableau ? et les cellules
zéro en haut de tableau ?
Merci encore à vous tous.
Philippe
"Youky"
Salut Philippe,
Change la formule en D5 par
=SI(B5+C5=0;"";SI(B5=0;C5;SI(C5=0;B5;MIN(B5;C5))))
Tire en bas
et en G5
=SI(D5="";"";PETITE.VALEUR($D$5:$D$20;LIGNE()-4))
Tire en bas
Youky

"Philippe"
Bonjour à toutes et à tous,

Je rencontre un petit problème à cause de ces "satanés" ZERO.
Je pense que la solution ne doit pas être compliquée, mais pour l'instant
je planche et je passe à côté.
Si quelqu'un peut jeter un oeil sur le ci-joint
Merci à vous tous.

http://cjoint.com/?fgnei75kre







Youky
Le #6565361
Merci de ta réponse.
Pour le trie je suis prêt à parier qu'il s'agit d'un format de cellule qui
coince....
Pour essai sélectionne le tableau et va en Menu /edition/copier et collage
spécial>que les valeurs
et faire le trie....
Si cela ne marche pas revoir les formats
Youky

"Philippe"
Merci à tous de vous pencher sur le problème. Merci beaucoup.
J'ai enregisté toutes vos astuces et je vais les essayer.
Pour info --> les points attribués sont fixes et dégressifs (100, 99, 98,
...)
Les temps sont au millième, donc les exaequos sont rares, même très rares.
(mais merci pour les astuces)
De toute façon, en plus de ce tableau, il y a d'autres épreuves et tout
les résultats de ceux-ci sont addionnés, ce qui rend encore moins de
possibilité d'exaequos.
Si je peux me permettre de poser une question; pourquoi (dans un autre
tableau) lorsque je sélectionne un tableau complet (avec des lignes
vierges), le tri décroissant se retrouve en bas de tableau ? et les
cellules zéro en haut de tableau ?
Merci encore à vous tous.
Philippe
"Youky"
Salut Philippe,
Change la formule en D5 par
=SI(B5+C5=0;"";SI(B5=0;C5;SI(C5=0;B5;MIN(B5;C5))))
Tire en bas
et en G5
=SI(D5="";"";PETITE.VALEUR($D$5:$D$20;LIGNE()-4))
Tire en bas
Youky

"Philippe"
Bonjour à toutes et à tous,

Je rencontre un petit problème à cause de ces "satanés" ZERO.
Je pense que la solution ne doit pas être compliquée, mais pour
l'instant je planche et je passe à côté.
Si quelqu'un peut jeter un oeil sur le ci-joint
Merci à vous tous.

http://cjoint.com/?fgnei75kre











Modeste
Le #6566181
Bonsour® Philippe avec ferveur ;o))) vous nous disiez :

Pour info --> les points attribués sont fixes et dégressifs (100, 99,
98, ...)
Les temps sont au millième, donc les exaequos sont rares, même très
rares. (mais merci pour les astuces)
De toute façon, en plus de ce tableau, il y a d'autres épreuves et
tout les résultats de ceux-ci sont addionnés, ce qui rend encore
moins de possibilité d'exaequos.



nb : il y aura certainement des soucis , dans le cas de plus de 100 concurrents
.
;o))) ma solution sans Zéro superfétatoire pour 16 concurrents
http://cjoint.com/?fgw55YUCwy

comme précisé dans un post précédent la saisie des durées en seconde et 1000eme
peut préter à confusion.


--
@+
;o)))

Philippe
Le #6567071
Merci Youki et Modeste,
Justement Modeste, vous nous disiez ...
Je vous disais que votre ci-joint est impeccable (il n'y aura pas + de 100
concurrents, cela va de 5 à 12 ans par tranche d'âge) En plus, avec la
colonne "Rang" en plus, on peut intituler cette colonne "Place"
Pour le tri, Youki, comme tu me le précises, je vais revoir les formats.
Mais je précise que dans quasiement toutes les cellules, il y a des
formules, alors peut-être que ceci explique cela ... !!!
Merci à vous deux.
Philippe
"Modeste" %
Bonsour® Philippe avec ferveur ;o))) vous nous disiez :

Pour info --> les points attribués sont fixes et dégressifs (100, 99,
98, ...)
Les temps sont au millième, donc les exaequos sont rares, même très
rares. (mais merci pour les astuces)
De toute façon, en plus de ce tableau, il y a d'autres épreuves et
tout les résultats de ceux-ci sont addionnés, ce qui rend encore
moins de possibilité d'exaequos.



nb : il y aura certainement des soucis , dans le cas de plus de 100
concurrents .
;o))) ma solution sans Zéro superfétatoire pour 16 concurrents
http://cjoint.com/?fgw55YUCwy

comme précisé dans un post précédent la saisie des durées en seconde et
1000eme
peut préter à confusion.


--
@+
;o)))





Publicité
Poster une réponse
Anonyme