nouveau module carte son

Le
Philippe Merlin
Bonsoir,
Ayant un problème avec le son intégré de ma carte mère,=
ne voyant pas de
solution j'ai choisi d'acheter une nouvelle carte son compatible linux.
La carte son choisie est une terratec aureon 5.1 PCI et le driver snd-cmipc=
i
et là le bat blesse, je n'ai pas trouvé la méthode standard =
pour l'obtenir ou
le charger.
j'ai essayé comme une doc que j'ai trouvé de faire un :
dpkg-reconfigure alsa-base et là au lieu d'une liste de carte sons c=
omme
c'est indiqué je n'ai eu droit qu'à un retour charriot!!
j'ai essayé module-assistant sans succès .
Je ne sais quoi faire, votre aide sera la bienvenue.
Philippe

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Klaus Becker
Le #19302171
On Saturday 9 May 2009 22:04:17 Philippe Merlin wrote:
Bonsoir,
Ayant un problème avec le son intégré de ma carte mèr e, ne voyant pas de
solution j'ai choisi d'acheter une nouvelle carte son compatible linux.
La carte son choisie est une terratec aureon 5.1 PCI et le driver
snd-cmipci et là le bat blesse, je n'ai pas trouvé la méth ode standard pour
l'obtenir ou le charger.
j'ai essayé comme une doc que j'ai trouvé de faire un :
dpkg-reconfigure alsa-base et là au lieu d'une liste de carte sons comme
c'est indiqué je n'ai eu droit qu'à un retour charriot!!
j'ai essayé module-assistant sans succès .
Je ne sais quoi faire, votre aide sera la bienvenue.
Philippe



Bonsoir,

et si c'était tout simplement

# modprobe snd_cmipci ?

attention, c'est snd_cmipci et non pas snd-cmipci

Chez moi sous Lenny, ça marche.

en avant la musique !

Klaus

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Philippe Merlin
Le #19302341
Le samedi 9 mai 2009, Klaus Becker a écrit :
On Saturday 9 May 2009 22:04:17 Philippe Merlin wrote:
> Bonsoir,
> Ayant un problème avec le son intégré de ma carte mà ¨re, ne voyant pas de
> solution j'ai choisi d'acheter une nouvelle carte son compatible linux.
> La carte son choisie est une terratec aureon 5.1 PCI et le driver
> snd-cmipci et là le bat blesse, je n'ai pas trouvé la mé thode standard
> pour l'obtenir ou le charger.
> j'ai essayé comme une doc que j'ai trouvé de faire un :
> dpkg-reconfigure alsa-base et là au lieu d'une liste de carte so ns
> comme c'est indiqué je n'ai eu droit qu'à un retour charriot!!
> j'ai essayé module-assistant sans succès .
> Je ne sais quoi faire, votre aide sera la bienvenue.
> Philippe

Bonsoir,

et si c'était tout simplement

# modprobe snd_cmipci ?

attention, c'est snd_cmipci et non pas snd-cmipci

Chez moi sous Lenny, ça marche.

en avant la musique !

Klaus


Merci pour ton aide, malheureusement dans mon cas , cela ne marche pas, c' est
un noyau maison et je ne sais toujours pas comment m'en sortir.
module-assistant de quoi ? ou compiler le module avec alsa-source ?
Merci pour tout aide.
Philippe


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
plop
Le #19304691
Philippe Merlin a écrit :
Le samedi 9 mai 2009, Klaus Becker a écrit :
On Saturday 9 May 2009 22:04:17 Philippe Merlin wrote:
Bonsoir,
Ayant un problème avec le son intégré de ma carte mère, ne voyant pas de
solution j'ai choisi d'acheter une nouvelle carte son compatible linux.
La carte son choisie est une terratec aureon 5.1 PCI et le driver
snd-cmipci et là le bat blesse, je n'ai pas trouvé la méthode standard
pour l'obtenir ou le charger.
j'ai essayé comme une doc que j'ai trouvé de faire un :
dpkg-reconfigure alsa-base et là au lieu d'une liste de carte sons
[...]







Essaye aussi:
alsaconfig

Est ce que cette carte fonctionne avec une Ubuntu Live CD, et
quelles sont les modules chargés alors?

Bonne chance.
G

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Jean-Michel OLTRA
Le #19305661
Bonjour,


Le samedi 09 mai 2009, Philippe Merlin a écrit...


> # modprobe snd_cmipci ?
>
Merci pour ton aide, malheureusement dans mon cas , cela ne marche pas, c'est
un noyau maison et je ne sais toujours pas comment m'en sortir.
module-assistant de quoi ? ou compiler le module avec alsa-source ?



Je double le message, car le premier ne semble pas être arrivé : si
c'est un noyau maison, il te faut le reconfigurer, et le recompiler pour
y inclure ce pilote snd_cmipci

Le plus simple étant l'utilisation des noyaux Debian, qui fonctionnent
fort bien.

--
jm

A.E.L. Sarl (R.C.S CASTRES 490843240)
http://www.spidboutic.fr


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Philippe Merlin
Le #19306611
Le dimanche 10 mai 2009, Jean-Michel OLTRA a écrit :
Bonjour,


Le samedi 09 mai 2009, Philippe Merlin a écrit...

> > # modprobe snd_cmipci ?
>



Je double le message, car le premier ne semble pas être arrivé : si
c'est un noyau maison, il te faut le reconfigurer, et le recompiler pour
y inclure ce pilote snd_cmipci

Le plus simple étant l'utilisation des noyaux Debian, qui fonctionne nt
fort bien.




Oui vous avez tout à fait raison, mais enfin ! les habitudes ont du m al à
changer, j'ai donc recompilé mon noyau et j'ai rajouter le module mai ntenant
il apparaît dans un lsmod, mais toujours pas de son .
En faisant un aplay -l , j'ai deux cartes sons comme avant, ma troisiè me carte
est toujours ignorée.
Je ne sais pas quoi faire, les docs existantes sont souvent vieilles et non
adaptées à la version squeeze que j'ai, maintenant ou se trouve les
fichiers de config alsa et comment les modifier !!!.
Comment si je fait un dpkg-reconfigure alsa-base s'arrête sans messag e.
Alsaconf a également disparu, même si il n'était pas parfa it il rendait des
services.
Au secours, plus d'une journée pour configurer une carte son c'est pas
brillant !!!
A l'avance merci.
Philippe

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Philippe Merlin
Le #19312541
Bonsoir,
Le dimanche 10 mai 2009, Philippe Merlin a écrit :
Le dimanche 10 mai 2009, Jean-Michel OLTRA a écrit :
> Bonjour,
>
>
> Le samedi 09 mai 2009, Philippe Merlin a écrit...
>
> > > # modprobe snd_cmipci ?
>
> Je double le message, car le premier ne semble pas être arrivà © : si
> c'est un noyau maison, il te faut le reconfigurer, et le recompiler pour
> y inclure ce pilote snd_cmipci
>
> Le plus simple étant l'utilisation des noyaux Debian, qui fonction nent
> fort bien.

Oui vous avez tout à fait raison, mais enfin ! les habitudes ont du mal à
changer, j'ai donc recompilé mon noyau et j'ai rajouter le module
maintenant il apparaît dans un lsmod, mais toujours pas de son .
En faisant un aplay -l , j'ai deux cartes sons comme avant, ma troisià ¨me
carte est toujours ignorée.
Je ne sais pas quoi faire, les docs existantes sont souvent vieilles et n on
adaptées à la version squeeze que j'ai, maintenant ou se trouve les
fichiers de config alsa et comment les modifier !!!.
Comment si je fait un dpkg-reconfigure alsa-base s'arrête sans mess age.
Alsaconf a également disparu, même si il n'était pas par fait il rendait
des services.
Au secours, plus d'une journée pour configurer une carte son c'est p as
brillant !!!
A l'avance merci.
Philippe


Je réitère mon appel au secours, après plusieurs modificatio ns et essais je
suis au même point.
Résumons : actuellement sur ma squeeze je n'arrive pas à activer ma nouvelle
carte son, les modules sons snd_cmipci sont bien chargés automatiquem ent, un
lsmod le prouve, mais ma carte son est ignorée superbement un aplay,l me
donne toujours que deux cartes sons, on dirait qu'il y a un paramètre de ma
configuration qui bloque toute arrivée d'un nouveau matériel son. Si je lance
un live-cd : Kaella ou lenny elle est bien reconnue et le son activé.
Dans syslog je ne vois rien d'anormal, auriez vous une idée ou une pis te car
je désespère de trouver une solution.
A l'avance Merci.
Philippe

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Philippe Merlin
Le #19314621
Re Bonsoir,
Le lundi 11 mai 2009, Philippe Merlin a écrit :
Bonsoir,

Le dimanche 10 mai 2009, Philippe Merlin a écrit :
> Le dimanche 10 mai 2009, Jean-Michel OLTRA a écrit :
> > Bonjour,
> >
> >
> > Le samedi 09 mai 2009, Philippe Merlin a écrit...
> >
> > > > # modprobe snd_cmipci ?
> >
> > Je double le message, car le premier ne semble pas être arrivà © : si
> > c'est un noyau maison, il te faut le reconfigurer, et le recompiler
> > pour y inclure ce pilote snd_cmipci
> >
> > Le plus simple étant l'utilisation des noyaux Debian, qui foncti onnent
> > fort bien.
>
> Oui vous avez tout à fait raison, mais enfin ! les habitudes ont du mal
> à changer, j'ai donc recompilé mon noyau et j'ai rajouter le module
> maintenant il apparaît dans un lsmod, mais toujours pas de son . En
> faisant un aplay -l , j'ai deux cartes sons comme avant, ma troisià ¨me
> carte est toujours ignorée.
> Je ne sais pas quoi faire, les docs existantes sont souvent vieilles et
> non adaptées à la version squeeze que j'ai, maintenant ou se trouve les
> fichiers de config alsa et comment les modifier !!!.
> Comment si je fait un dpkg-reconfigure alsa-base s'arrête sans me ssage.
> Alsaconf a également disparu, même si il n'était pas p arfait il
> rendait des services.
> Au secours, plus d'une journée pour configurer une carte son c'est pas
> brillant !!!
> A l'avance merci.
> Philippe

Je réitère mon appel au secours, après plusieurs modificat ions et essais je
suis au même point.
Résumons : actuellement sur ma squeeze je n'arrive pas à active r ma
nouvelle carte son, les modules sons snd_cmipci sont bien chargés
automatiquement, un lsmod le prouve, mais ma carte son est ignorée
superbement un aplay,l me donne toujours que deux cartes sons, on dirait
qu'il y a un paramètre de ma configuration qui bloque toute arrivà ©e d'un
nouveau matériel son. Si je lance un live-cd : Kaella ou lenny elle est
bien reconnue et le son activé. Dans syslog je ne vois rien d'anorma l,
auriez vous une idée ou une piste car je désespère de trou ver une solution.
A l'avance Merci.
Philippe


Du nouveau après avoir à regarder plus attentivement le dmesg, j' ai remarqué
ce message inquiétant qui expliquerait tout.
cannot find the slot for index 0 (range 0-0), error: -16
C-Media PCI: probe of 0000:01:06.0 failed with error -12
Après une recherche sur Google, j'ai également vu qu'un patch Ker nel
2.6.26-git17 avait été fait pour résoudre (peut être) c e pb : il
modifie /sound/core/init.c et en regardant ma version j'ai vu que ce patch
n'avait pas été mis en
service :https://www.linuxhq.com/kernel/v2.6/26-git17/sound/core/init.c
cela m'ennuie d'appliquer ce patch existe t'il une version
de /sound/core/init.c déjà patchée.
A l'avance merci pour votre aide.
Philippe


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Philippe Merlin
Le #19325401
Bonjour,
Le lundi 11 mai 2009, Philippe Merlin a écrit :
Re Bonsoir,

Le lundi 11 mai 2009, Philippe Merlin a écrit :


Mes ennuis continuent, je n'ai toujours pas de son, j'ai fait de multiples
essais en modifiant le noyau fait maison, toujours sans succès.
Pour être le plus standard je me suis résolu à installer le dernier noyau
Debian Squeeze/Lenny .
Au démarrage de ce nouveau noyau, j'ai eu droit cependant à un me ssage
intéressant :
Setting up ALSA...warning: 'alsactl restore' failed with error message 'No
state is present for card CMI8738
Tue May 12 23:34:39 2009: Unknown hardware: "CMI8738-MC6" "CMedia
PCI" "" "0x153b" "0x1144"
Tue May 12 23:34:39 2009: Hardware is initialized using a guess method
Tue May 12 23:34:39 2009: /usr/share/alsa/init/default:22: unable to conver t
dB value '-20dB' to internal integer range
..........
No state is present for card CMI8738'...Invalid card number.
Tue May 12 23:34:45 2009: Usage: amixer <options> [command]
.................
et cela répéter une dizaine de fois
Au deuxième boot un dmesg donne :
cannot find the slot for index 0 (range 0-0), error: -16
C-Media PCI: probe of 0000:01:06.0 failed with error -12

Pour les lecteurs qui n'auraient pas suivi l'ensemble des messages,
Je résume, actuellement sur ma squeeze je n'arrive pas à activer ma
nouvelle carte son, les modules sons qui vont avec cette carte snd_cmipci
sont bien chargés automatiquement, un lsmod le prouve, mais ma carte s on est
ignorée superbement un aplay,l me donne toujours que deux cartes sons
Si je boote d'un live-cd : Kaella ou Live-CD Lenny j'ai le son et toutes mes
cartes existent bien.
Je suppose que le problème vient d'ALSA et d'un fichier conf véro lé, comment
pourrais je réinitialisé ALSA ? Désinstaller ALSA par un apt -get -- purge
remove les paquets ALSA ?
Avez vous un Avis la dessus et comment m'en sortir ?
Merci d'avance pour vos suggestions.
Philippe




--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Jean-Yves F. Barbier
Le #19326411
Philippe Merlin a écrit :
.........

Tue May 12 23:34:39 2009: Unknown hardware: "CMI8738-MC6" "CMedia


...........

Pour les lecteurs qui n'auraient pas suivi l'ensemble des messages,
Je résume, actuellement sur ma squeeze je n'arrive pas à activer ma
nouvelle carte son, les modules sons qui vont avec cette carte snd_cmipci
sont bien chargés automatiquement, un lsmod le prouve, mais ma carte son est
ignorée superbement un aplay,l me donne toujours que deux cartes sons


^^^^^^^^^^^^^^^^^^
Si je boote d'un live-cd : Kaella ou Live-CD Lenny j'ai le son et toutes mes
cartes existent bien.



On va tâcher moyen d'éviter une polémique endémique et cyclique sur Debian:

search result
alsa cm8738-mc6 => http://alsa.opensrc.org/Cmipci
(mais ce n'est pas le plus important:)
debian difference entre testing et unstable =>
http://www.debian.org/doc/manuals/debian-faq/ch-choosing.fr.html

Nous disons donc que 1-Tu as plusieurs cartes son, 2-Que tu utilises une
branche NON-STABLE de Debian.
C'est un peu comme mettre ses mômes dans une voiture prototype sans
ceintures et sans savoir si après un crash euroNcap il restera quelque
chose de la voiture...

JY
--
Afternoon very favorable for romance. Try a single person for a change.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Philippe Merlin
Le #19326931
Bonjour,
Le mercredi 13 mai 2009, Jean-Yves F. Barbier a écrit :
Philippe Merlin a écrit :
.........

> Tue May 12 23:34:39 2009: Unknown hardware: "CMI8738-MC6" "CMedia

...........

> Pour les lecteurs qui n'auraient pas suivi l'ensemble des messages,
> Je résume, actuellement sur ma squeeze je n'arrive pas à act iver ma
> nouvelle carte son, les modules sons qui vont avec cette carte
> snd_cmipci sont bien chargés automatiquement, un lsmod le prouve, mais ma
> carte son est ignorée superbement un aplay,l me donne toujours que deux
> cartes sons

^^^^^^^^^^^^^^^^^^

> Si je boote d'un live-cd : Kaella ou Live-CD Lenny j'ai le son et
> toutes mes cartes existent bien.

On va tâcher moyen d'éviter une polémique endémique e t cyclique sur Debian:

search result
alsa cm8738-mc6 => http://alsa.opensrc.org/Cmipci
(mais ce n'est pas le plus important:)
debian difference entre testing et unstable =>
http://www.debian.org/doc/manuals/debian-faq/ch-choosing.fr.html

Nous disons donc que 1-Tu as plusieurs cartes son, 2-Que tu utilises une
branche NON-STABLE de Debian.
C'est un peu comme mettre ses mômes dans une voiture prototype sans
ceintures et sans savoir si après un crash euroNcap il restera quelq ue
chose de la voiture...

JY


Tout d'abord je te remercie pour ton lien Alsa, je ne le connaissais pas.
Par contre la suite de ton message me laisse perplexe, tu penses que je sui s
victime d'un bug "Alsa /squeeze" ? Et si je retournais à Lenny pour A lsa ,
je verrais ma carte son ?
Merci pour ta réponse.
Philippe


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Publicité
Poster une réponse
Anonyme