Numbers "inutilisablement lent"

Le
patpro ~ patrick proniewski
Bonjour,

depuis hier j'ai remarqué que Numbers est affligeant de lenteur. Je ne
parle pas de la lenteur habituelle pour toutes les appli iWork, je parle
de cet ensemble de symptômes :
- jusqu'à plusieurs minutes d'attente entre le click et son effet (menu,
inspecteur, cellule)
- processeur à 100% pour le process Numbers pendant ces périodes
- swap qui gonfle, avec une pointe à 3Go

Pour preuve, il m'a fallu entre 1h et 1h30 pour faire ce graph
<http://www.patpro.net/images/blog/spam/spamblog2.png> à partir d'un
fichier contenant déjà le tableau de données. Ça prend normalement 2
minutes, le plus long étant le choix de la couleur.

J'ai un bipro G5 2GHz, et 2,5 Go de RAM, en 10.5.2 toutes mises à jour
faites.

Help.

patpro

--
A vendre : KVM IP 16 ports APC
http://patpro.net/blog/index.php/2008/01/12/133
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Eric Levenez
Le #3196381
Le 10/04/08 14:23, dans « patpro ~ patrick proniewski »
depuis hier j'ai remarqué que Numbers est affligeant de lenteur. Je ne
parle pas de la lenteur habituelle pour toutes les appli iWork,


Lenteur habituelle ? Je ne trouve pas.

je parle
de cet ensemble de symptômes :
- jusqu'à plusieurs minutes d'attente entre le click et son effet (menu,
inspecteur, cellule...)
- processeur à 100% pour le process Numbers pendant ces périodes
- swap qui gonfle, avec une pointe à 3Go


Et bien voilà. Tu donnes toi-même la cause du problème : le swap.

Pour preuve, il m'a fallu entre 1h et 1h30 pour faire ce graph
fichier contenant déjà le tableau de données. Ça prend normalement 2
minutes, le plus long étant le choix de la couleur.

J'ai un bipro G5 2GHz, et 2,5 Go de RAM, en 10.5.2 toutes mises à jour
faites.


Tu n'as pas assez de RAM par rapport à ce que tu demandes à ta machine. Tu
ne devrais pas swapper.

--
Éric Lévénez -- Unix is not only an OS, it's a way of life.

patpro ~ patrick proniewski
Le #3196311
In article Eric Levenez
Et bien voilà. Tu donnes toi-même la cause du problème : le swap.


nop, ce n'est pas recevable. Un fichier Numbers de moins de 200 lignes
sur 2 colonnes ne peut pas être responsable d'un pic de swap de 3 Go.

Tu n'as pas assez de RAM par rapport à ce que tu demandes à ta machine. Tu
ne devrais pas swapper.


Je manipule des fichiers Numbers bien plus lourds, avec des dizaines de
tables liées par des formules, des milliers de lignes, et des pages
entières de graph, dans des conditions d'utilisation identiques (mêmes
appli lancées, ...) sans swaper.

Alors soit les dernieres mises à jour de la 10.5 ont cassé des choses,
soit Numbers est aussi buggué que windows.

patpro

--
A vendre : KVM IP 16 ports APC
http://patpro.net/blog/index.php/2008/01/12/133

Eric Levenez
Le #3196221
Le 10/04/08 23:06, dans « patpro ~ patrick proniewski »
In article Eric Levenez
Et bien voilà. Tu donnes toi-même la cause du problème : le swap.


nop, ce n'est pas recevable. Un fichier Numbers de moins de 200 lignes
sur 2 colonnes ne peut pas être responsable d'un pic de swap de 3 Go.


Il ne devrait pas en effet.

Tu n'as pas assez de RAM par rapport à ce que tu demandes à ta machine. Tu
ne devrais pas swapper.


Je manipule des fichiers Numbers bien plus lourds, avec des dizaines de
tables liées par des formules, des milliers de lignes, et des pages
entières de graph, dans des conditions d'utilisation identiques (mêmes
appli lancées, ...) sans swaper.

Alors soit les dernieres mises à jour de la 10.5 ont cassé des choses,
soit Numbers est aussi buggué que windows.


Il faudrait analyser ce qu'il se passe sur ta machine quand elle swappe :
qui occupe la mémoire, qui swappe...

Si c'est ton fichier de 200 lignes qui entraîne un bug de Numbers, il faut
faire un bug report à Apple. Tu peux aussi m'envoyer ce fichier pour que je
regarde si cela fait la même chose sur ma machine.

--
Éric Lévénez -- Unix is not only an OS, it's a way of life.


patpro ~ patrick proniewski
Le #3196211
In article Eric Levenez
Il faudrait analyser ce qu'il se passe sur ta machine quand elle swappe :
qui occupe la mémoire, qui swappe...


ouaip...

Si c'est ton fichier de 200 lignes qui entraîne un bug de Numbers, il faut
faire un bug report à Apple. Tu peux aussi m'envoyer ce fichier pour que je
regarde si cela fait la même chose sur ma machine.


J'ai bazardé le fichier, mais j'ai encore les data, je vais le recréer.

patpro

--
A vendre : KVM IP 16 ports APC
http://patpro.net/blog/index.php/2008/01/12/133

Eric Levenez
Le #3196141
Le 11/04/08 07:34, dans « patpro ~ patrick proniewski »
In article Eric Levenez
Il faudrait analyser ce qu'il se passe sur ta machine quand elle swappe :
qui occupe la mémoire, qui swappe...


ouaip...


Bin ouais. Sans analyser le problème et sa cause, impossible de le
contourner ou de le corriger. Et si c'est un bug Apple, il FAUT le leur
dire.

Si c'est ton fichier de 200 lignes qui entraîne un bug de Numbers, il faut
faire un bug report à Apple. Tu peux aussi m'envoyer ce fichier pour que je
regarde si cela fait la même chose sur ma machine.


J'ai bazardé le fichier, mais j'ai encore les data, je vais le recréer.


Ok.

--
Éric Lévénez -- Unix is not only an OS, it's a way of life.


patpro ~ Patrick Proniewski
Le #3196101
In article Eric Levenez
Bin ouais. Sans analyser le problème et sa cause, impossible de le
contourner ou de le corriger. Et si c'est un bug Apple, il FAUT le leur
dire.


En attendant de recréer mon fichier, j'ai lu les log système
correspondants à la période troublée, et j'ai trouvé :

Apr 9 14:16:21 cassandre /Applications/iWork
'08/Numbers.app/Contents/MacOS/Numbers[4876]: ATS AutoActivation:
MDQueryExecute failed! (params: queryString =
{com_apple_ats_name_family ==
"HelveticaNeue"}, valueListAttrs = {<CFArray 0x7e080e0
[0xa0698174]>{type = immutable, count = 1, values = (n 0 :
<CFString 0xa093ff40 [0xa0698174]>{contents = "kMDItemContentType"}n)
}}, sortingAttrs = {<CFArray 0x7e06fe0 [0xa0698174]>{type = immutable,
count = 1, values = (n 0 : <CFString 0xa093fe70
[0xa0698174]>{contents = "kMDItemContentModificationDate"}n)}
}, scopeList = {<CFArray 0x7e07000 [0xa0698174]>{type = immutable, count
= 1, values = (n 0 : <CFString 0xa09410b0 [0xa0698174]>{contents
= "kMDQueryScopeComputer"}n)}}.)
Apr 9 14:16:31 cassandre /Applications/iWork
'08/Numbers.app/Contents/MacOS/Numbers[4876]: ATS AutoActivation:
MDQueryExecute failed! (params: queryString =
{com_apple_ats_name_family ==
"HelveticaNeue-Bold"}, valueListAttrs = {<CFArray 0x7e18660
[0xa0698174]>{type = immutable, count = 1, values = (n 0 :
<CFString 0xa093ff40 [0xa0698174]>{contents = "kMDItemContentT
ype"}n)}}, sortingAttrs = {<CFArray 0x7e186b0 [0xa0698174]>{type =
immutable, count = 1, values = (n 0 : <CFString 0xa093fe70
[0xa0698174]>{contents = "kMDItemContentModificationDa
te"}n)}}, scopeList = {<CFArray 0x7e18a90 [0xa0698174]>{type =
immutable, count = 1, values = (n 0 : <CFString 0xa09410b0
[0xa0698174]>{contents = "kMDQueryScopeComputer"}n)}}.)
Apr 9 14:16:41 cassandre /Applications/iWork
'08/Numbers.app/Contents/MacOS/Numbers[4876]: ATS AutoActivation:
MDQueryExecute failed! (params: queryString =
{com_apple_ats_name_family ==
"LucidaGrande"}, valueListAttrs = {<CFArray 0x9f76ec0 [0xa0698174]>{type
= immutable, count = 1, values = (n 0 : <CFString 0xa093ff40
[0xa0698174]>{contents = "kMDItemContentType"}n)
}}, sortingAttrs = {<CFArray 0x9f76e20 [0xa0698174]>{type = immutable,
count = 1, values = (n 0 : <CFString 0xa093fe70
[0xa0698174]>{contents = "kMDItemContentModificationDate"}n)}
}, scopeList = {<CFArray 0x9f76f50 [0xa0698174]>{type = immutable, count
= 1, values = (n 0 : <CFString 0xa09410b0 [0xa0698174]>{contents
= "kMDQueryScopeComputer"}n)}}.)
Apr 9 14:16:41 cassandre /Applications/iWork
'08/Numbers.app/Contents/MacOS/Numbers[4876]: ATS AutoActivation:
encountered unknown Spotlight Error too many times. Temporarily
disbling Aut
oActivation feature...


J'ai pareil pour MT-Newswatcher le même jour (mais au même moment) qui
se lançait très lentement. Idem à un moment pour Safari, qui a lui aussi
subit des lenteurs. Néanmoins, aucun des deux n'a eu le comportement
catastrophique de Numbers.

Un grep dans mes log montre que ces cas graves de lenteurs correspondent
aux seules occurrences de "ATS AutoActivation" trouvées dans l'ensemble
des log système.

Peut être quelque chose de moisi à l'échelle de l'OS ("malheureusement",
j'ai rebooté depuis).

A suivre.

--
A vendre ! http://www.patpro.net/blog/index.php/2008/01/12/133

Eric Levenez
Le #3196011
Le 11/04/08 14:41, dans Patrick Proniewski »
Un grep dans mes log montre que ces cas graves de lenteurs correspondent
aux seules occurrences de "ATS AutoActivation" trouvées dans l'ensemble
des log système.


D'après ce que je crois comprends c'est le système de gestion de fonts ATS
qui s'est envoyé en l'air. Il faudrait peut être que tu vérifies le disque,
puis les fonts installées, puis peut-être relancer l'indexation Spotlight.

Mais maintenant tu as toujours ces lenteurs et ces accès swap ?

--
Éric Lévénez -- Unix is not only an OS, it's a way of life.

patpro ~ patrick proniewski
Le #3195551
In article Eric Levenez
Mais maintenant tu as toujours ces lenteurs et ces accès swap ?


J'ai reconstitué un fichier identique (mêmes données). Je ne swap plus,
je n'ai plus le problème constaté dans les log. Néanmoins, j'ai toujours
la lenteur monstrueuse.

tu trouveras le fichier ici :


Tu peux essayer de jouer avec le graph (le déformer, changer des
paramètres comme la couleur, ...)

Chez moi c'est la roue multicolore à chaque action. J'ai passé 10 bonnes
minutes à faire ce @#! de fichiers. C'est absolument anormal et
décourageant.

patpro

--
A vendre : KVM IP 16 ports APC
http://patpro.net/blog/index.php/2008/01/12/133

pas.de.spam
Le #3195531
patpro ~ patrick proniewski
In article Eric Levenez
Mais maintenant tu as toujours ces lenteurs et ces accès swap ?


J'ai reconstitué un fichier identique (mêmes données). Je ne swap plus,
je n'ai plus le problème constaté dans les log. Néanmoins, j'ai toujours
la lenteur monstrueuse.

tu trouveras le fichier ici :


Tu peux essayer de jouer avec le graph (le déformer, changer des
paramètres comme la couleur, ...)

Chez moi c'est la roue multicolore à chaque action. J'ai passé 10 bonnes
minutes à faire ce @#! de fichiers. C'est absolument anormal et
décourageant.


J'ai lu un truc à ce propos, lenteur d'iWorks, etc. C'était dû à une
fonte corrompue. Et une Fonte système qui plus est. Je croyais que
c'était ici, mais ce doit être ailleurs.

SI ça peut aider.


--
PO.

Pour m'écrire : po_taubaty(arobas)yahoo(point)fr


anneleguennec
Le #3209381
patpro ~ patrick proniewski

Chez moi c'est la roue multicolore à chaque action. J'ai passé 10 bonnes
minutes à faire ce @#! de fichiers. C'est absolument anormal et
décourageant.


J'ai aussi ce gag : dans ta première colonne, toutes les dates sont
soulignées comme si le correcteur orthographique n'arrivait pas à
corriger du texte, et à la fin, ton format de dates est passé en
anglais. Normal ?

Publicité
Poster une réponse
Anonyme