Numéro du jour en fonction de la date actuelle

Le
Michel68
Bonjour,

Sur ma feuil1 j'ai un tableau avec en ligne 2 du lundi au dimanche et en A1
la date du jour, est il possible en passant par une formule de'arriver à ce
résultat

A B C D E F
G
1 13/9/07
2 Lundi Mardi Mercredi Jeudi Vendredi Samedi Dimanche
10 11 12 13 14 15
16


Un vrai casse tete ce truc j'ai chercher en faisant rechercheH+ le jour
extrait de A1 mais sans résultat.
Si qq à une solution
Merci
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
JB
Le #4747711
Bonjour,

En A2: ¡-JOURSEM(A1-1)+1

http://cjoint.com/?jnihAnovi2

JB
http://boisgontierjacques.free.fr

On 13 sep, 07:53, "Michel68"
Bonjour,

Sur ma feuil1 j'ai un tableau avec en ligne 2 du lundi au dimanche et en A1
la date du jour, est il possible en passant par une formule de'arriver à ce
résultat

A B C D E F
G
1 13/9/07
2 Lundi Mardi Mercredi Jeudi Vendredi Samedi Dimanche
10 11 12 13 14 15
16

Un vrai casse tete ce truc j'ai chercher en faisant rechercheH+ le jour
extrait de A1 mais sans résultat.
Si qq à une solution
Merci


papou
Le #4747701
Bonjour
Formule en A3 :
=SI(JOURSEM(A1;2)=1;A2;A1-(JOURSEM(A1;2)-1))
Puis formule à partir de B3 :
£+1

Cordialement
Pascal

"Michel68" 46e8d05c$0$13866$
Bonjour,

Sur ma feuil1 j'ai un tableau avec en ligne 2 du lundi au dimanche et en
A1 la date du jour, est il possible en passant par une formule de'arriver
à ce résultat

A B C D E F G
1 13/9/07
2 Lundi Mardi Mercredi Jeudi Vendredi Samedi Dimanche
10 11 12 13 14 15 16


Un vrai casse tete ce truc j'ai chercher en faisant rechercheH+ le jour
extrait de A1 mais sans résultat.
Si qq à une solution
Merci



papou
Le #4747691
Oups:
=SI(JOURSEM(A1;2)=1;A1;A1-(JOURSEM(A1;2)-1))

Cordialement
Pascal

"papou"
Bonjour
Formule en A3 :
=SI(JOURSEM(A1;2)=1;A2;A1-(JOURSEM(A1;2)-1))
Puis formule à partir de B3 :
£+1

Cordialement
Pascal

"Michel68" 46e8d05c$0$13866$
Bonjour,

Sur ma feuil1 j'ai un tableau avec en ligne 2 du lundi au dimanche et en
A1 la date du jour, est il possible en passant par une formule de'arriver
à ce résultat

A B C D E F G
1 13/9/07
2 Lundi Mardi Mercredi Jeudi Vendredi Samedi Dimanche
10 11 12 13 14 15 16


Un vrai casse tete ce truc j'ai chercher en faisant rechercheH+ le jour
extrait de A1 mais sans résultat.
Si qq à une solution
Merci







LSteph
Le #4747671
Bonjour,

Pas besoin de rechercher, si j'ai bien compris le but

on affiche directement la semaine dans toute la plage
en fonction de la date en A1
Si on est sûr de démarrer Lundi en colonne A
on se sert de la colonne ainsi, de A2 à recopier jusqu'E2 (Samedi)
=SI(JOURSEM($A$1)=COLONNE()+1;$A$1;B2-1)
et pour la cellule F2 (Dimanche)
=SI(JOURSEM($A$1)=1;$A$1;A2+6)

(pour les lignes 2 et 3 ce sera une question de format jjjj ou jj )

Cordialement.

lSteph

Bonjour,

Sur ma feuil1 j'ai un tableau avec en ligne 2 du lundi au dimanche et en A1
la date du jour, est il possible en passant par une formule de'arriver à ce
résultat

A B C D E F
G
1 13/9/07
2 Lundi Mardi Mercredi Jeudi Vendredi Samedi Dimanche
10 11 12 13 14 15
16


Un vrai casse tete ce truc j'ai chercher en faisant rechercheH+ le jour
extrait de A1 mais sans résultat.
Si qq à une solution
Merci




Michel68
Le #4747641
Rebonjour,

Merci à JB comme d'hab et Papou, la solution est tellement simple que s'en
est à se cogner la tête, 4 heures à chercher et vous en 5 mn paf.
Merci encore pour votre rapidité et votre gentillesse
Publicité
Poster une réponse
Anonyme