numéroter des doublons

Le
Nicoh
Bonjour à tous,

J'utilise la formule suivante pour repérer des doublons :
SI(BR517="";"";SI(NB.SI($BR$93:$BR940;BR517)>1;"Doublon";"")).
Est-il possible de numéroter les doublons ?

Exemple :
colonne A colonne B
AA doublon 1
AB
AA doublon 1
BA doublon 2
BA doublon 2
CC doublon 3
CA
CC doublon 3
AA doublon 1

D'avance merci pour vos réponses.

Nicoh.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel
Le #4798661
Bonjour.
En B1 : =SI(A1="";"";SI(NB.SI(A:A;A1)>1;"doublon1"))
En B2, formule matricielle (valider avec CTRL+MAJ+Entrée :
=SI(A2="";"";SI(NB.SI(A:A;A2)>1;SI(ESTNA(EQUIV(A2;$A$1:A1;0));"doublon"&MAX(CNUM(SI($B$1:B1="";0;DROITE($B$1:B1;NBCAR($B$1:B1)-7)))+1);INDEX(B:B;EQUIV(A2;$A$1:A1;0)))))
à recopier vers le bas.
Cordialement.
Daniel

"Nicoh"
Bonjour à tous,

J'utilise la formule suivante pour repérer des doublons :
SI(BR517="";"";SI(NB.SI($BR$93:$BR940;BR517)>1;"Doublon";"")).
Est-il possible de numéroter les doublons ?

Exemple :
colonne A colonne B
AA doublon 1
AB
AA doublon 1
BA doublon 2
BA doublon 2
CC doublon 3
CA
CC doublon 3
AA doublon 1

D'avance merci pour vos réponses.

Nicoh.



dre
Le #4798481
Bonjour,

Autre solution :

Laisser la ligne 1 vide
Mettre la colonne B au format : "doublon "Standard
En B2 :
SI(NB.SI(A$2:A$10;A2)=1;"";SI(NB.SI(A$2:A2;A2)=1;MAX(B$1:B1)+1;RECHERCHEV(A2;A$1:B1;2;0)))
formule à étirer vers le bas.

dré




Bonjour à tous,

J'utilise la formule suivante pour repérer des doublons :
SI(BR517="";"";SI(NB.SI($BR$93:$BR940;BR517)>1;"Doublon";"")).
Est-il possible de numéroter les doublons ?

Exemple :
colonne A colonne B
AA doublon 1
AB
AA doublon 1
BA doublon 2
BA doublon 2
CC doublon 3
CA
CC doublon 3
AA doublon 1

D'avance merci pour vos réponses.

Nicoh.



Nicoh
Le #4798141
Bonjour Daniel,

Même si je n'ai pas tout compris dans ta formule, cela répond exactement à
mes attentes.

Nicoh


Bonjour.
En B1 : =SI(A1="";"";SI(NB.SI(A:A;A1)>1;"doublon1"))
En B2, formule matricielle (valider avec CTRL+MAJ+Entrée :
=SI(A2="";"";SI(NB.SI(A:A;A2)>1;SI(ESTNA(EQUIV(A2;$A$1:A1;0));"doublon"&MAX(CNUM(SI($B$1:B1="";0;DROITE($B$1:B1;NBCAR($B$1:B1)-7)))+1);INDEX(B:B;EQUIV(A2;$A$1:A1;0)))))
à recopier vers le bas.
Cordialement.
Daniel

"Nicoh"
Bonjour à tous,

J'utilise la formule suivante pour repérer des doublons :
SI(BR517="";"";SI(NB.SI($BR$93:$BR940;BR517)>1;"Doublon";"")).
Est-il possible de numéroter les doublons ?

Exemple :
colonne A colonne B
AA doublon 1
AB
AA doublon 1
BA doublon 2
BA doublon 2
CC doublon 3
CA
CC doublon 3
AA doublon 1

D'avance merci pour vos réponses.

Nicoh.








Publicité
Poster une réponse
Anonyme