NVidia sur Debian (oui, encore ;-)))

Le
David BERCOT
Re-Bonjour,

Je m'arrache les cheveux depuis quelques semaines avec l'installation
de drivers NVidia alors, au bout du rouleau (oui, oui, c'est dur ;-))),
je me résous à vous demander de l'aide

Je voudrais donc avoir une configuration graphique satisfaisante et je
n'arrive à rien. Tout d'abord, lors de l'installation de X, je n'ai
aucun driver de spécifié dans xorg.conf !!! Bien évidemment,=
la
résolution choisie est moyenne ;-)
J'ai donc essayé d'installer les drivers à la sauce Debian :
m-a a-i nvidia-kernel-legacy-173xx-source (et aussi,
nvidia-kernel-source) sans succès ! En gros, je n'ai pas de message
d'erreur significatif, mais quasiment un simple : nvidia.ko failed to
build !
Je précise au passage que je suis en 2.6.29-1-amd64.

Qu'à cela ne tienne, je me suis rabattu sur les drivers NVidia. Là
encore, impossible de faire quoi que soit : il ne trouve pas kernel.h
qui est situé, non pas dans /usr/src/linux-headers-2.6.29-1-amd64, mais
dans linux-headers-2.6.29-1-common ! Et si je copie juste kernel.h
(pour l'aider ;-))), ça ne marche pas mieux : il me dit que les sources
du noyau ne sont pas configurées !!!

Auriez-vous une piste pour moi ?
Avez-vous réussi à installer des drivers NVidia non libres (propr=
io ou
pas) sur un noyau 2.6.29 ?

Merci d'avance.

David.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Julien
Le #19062241
Salut,

J'ai déjà eu des problèmes en mixant des versions de driver nvidia. Donc
tout d'abord dé-installe nvidia-kernel-legacy-173xx-source et tout ce
qui est legacy.

Il faut que tu ai les mêmes version partout :

- noyau sur lequel ta machine démarre
- source du noyau dans /usr/src
- module installé

Pour ton pb de compilation, essaie de créer un lien
symbolique /usr/src/linux/ qui pointe
vers /usr/src/linux-headers-2.6.29-1-common ou autre ...
sinon installe les sources complète du noyau :

aptitude install linux-source-2.6 je crois

Julien.


Le lundi 06 avril 2009 à 11:04 +0200, David BERCOT a écrit :
Re-Bonjour,

Je m'arrache les cheveux depuis quelques semaines avec l'installation
de drivers NVidia alors, au bout du rouleau (oui, oui, c'est dur ;-))),
je me résous à vous demander de l'aide...

Je voudrais donc avoir une configuration graphique satisfaisante et je
n'arrive à rien. Tout d'abord, lors de l'installation de X, je n'ai
aucun driver de spécifié dans xorg.conf !!! Bien évidemment, la
résolution choisie est... moyenne ;-)
J'ai donc essayé d'installer les drivers à la sauce Debian :
m-a a-i nvidia-kernel-legacy-173xx-source (et aussi,
nvidia-kernel-source) sans succès ! En gros, je n'ai pas de message
d'erreur significatif, mais quasiment un simple : nvidia.ko failed to
build !
Je précise au passage que je suis en 2.6.29-1-amd64.

Qu'à cela ne tienne, je me suis rabattu sur les drivers NVidia. Là
encore, impossible de faire quoi que soit : il ne trouve pas kernel.h
qui est situé, non pas dans /usr/src/linux-headers-2.6.29-1-amd64, mais
dans linux-headers-2.6.29-1-common ! Et si je copie juste kernel.h
(pour l'aider ;-))), ça ne marche pas mieux : il me dit que les sources
du noyau ne sont pas configurées !!!

Auriez-vous une piste pour moi ?
Avez-vous réussi à installer des drivers NVidia non libres (proprio ou
pas) sur un noyau 2.6.29 ?

Merci d'avance.

David.




--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Guy Roussin
Le #19062231
Bonjour,

Idem pour moi (en i386), ma carte son était mal supportée
(grésillements) par le
2.6.26 alors j'ai essayé le 2.6.29. Aucun pb avec nv et avec ma car te
son, mais
impossible d'installer les drivers proprio nvidia ...
Finalement, je me suis rabattu sur le 2.6.28 du depot de e-tobi.net. qui
fonctionne
très bien avec nvidia (180.22) m-a a-i nvidia et ma carte son. J'ai pas
encore
testé vpdau mais ça devrait théoriquement le faire ...

Guy


David BERCOT a écrit :
Re-Bonjour,

Je m'arrache les cheveux depuis quelques semaines avec l'installation
de drivers NVidia alors, au bout du rouleau (oui, oui, c'est dur ;-))),
je me résous à vous demander de l'aide...

Je voudrais donc avoir une configuration graphique satisfaisante et je
n'arrive à rien. Tout d'abord, lors de l'installation de X, je n'a i
aucun driver de spécifié dans xorg.conf !!! Bien évidemm ent, la
résolution choisie est... moyenne ;-)
J'ai donc essayé d'installer les drivers à la sauce Debian :
m-a a-i nvidia-kernel-legacy-173xx-source (et aussi,
nvidia-kernel-source) sans succès ! En gros, je n'ai pas de messag e
d'erreur significatif, mais quasiment un simple : nvidia.ko failed to
build !
Je précise au passage que je suis en 2.6.29-1-amd64.

Qu'à cela ne tienne, je me suis rabattu sur les drivers NVidia. Là  
encore, impossible de faire quoi que soit : il ne trouve pas kernel.h
qui est situé, non pas dans /usr/src/linux-headers-2.6.29-1-amd64, mais
dans linux-headers-2.6.29-1-common ! Et si je copie juste kernel.h
(pour l'aider ;-))), ça ne marche pas mieux : il me dit que les so urces
du noyau ne sont pas configurées !!!

Auriez-vous une piste pour moi ?
Avez-vous réussi à installer des drivers NVidia non libres (p roprio ou
pas) sur un noyau 2.6.29 ?

Merci d'avance.

David.






--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
David BERCOT
Le #19062311
Le Mon, 06 Apr 2009 11:12:02 +0200,
Julien
Salut,

J'ai déjà eu des problèmes en mixant des versions de driver nvidia.
Donc tout d'abord dé-installe nvidia-kernel-legacy-173xx-source et
tout ce qui est legacy.

Il faut que tu ai les mêmes version partout :
- noyau sur lequel ta machine démarre
- source du noyau dans /usr/src
- module installé



C'est ok pour les 2 premiers, mais justement, le module, je n'arrive
pas à le construire !!!

Pour ton pb de compilation, essaie de créer un lien
symbolique /usr/src/linux/ qui pointe
vers /usr/src/linux-headers-2.6.29-1-common ou autre ...
sinon installe les sources complète du noyau :



Il existe déjà, et j'ai essayé les deux répertoires... sans succès !
J'ai aussi installé les sources complètes, mais ça n'a pas l 'air de lui
faire grand-chose...

aptitude install linux-source-2.6 je crois



Eh oui, je ne trouve rien du tout ;-)

David.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
David BERCOT
Le #19062451
Le Mon, 06 Apr 2009 11:18:19 +0200,
Guy Roussin
Bonjour,

Idem pour moi (en i386), ma carte son était mal supportée
(grésillements) par le
2.6.26 alors j'ai essayé le 2.6.29. Aucun pb avec nv et avec ma cart e
son, mais
impossible d'installer les drivers proprio nvidia ...



Même raison de changer de noyau : carte son qui grésille ;-)
En revanche, je n'arrive même pas à utiliser nv !!!
Supposons, dans un premier temps, que je souhaite juste avoir la
résolution native de mon écran, sans accélération 3D. C omment
pourrais-je avoir un driver (nv ?) par défaut ? Avec un
dpkg-reconfigure xserver-xorg, il ne demande plus le driver à utiliser
(c'est ce qu'il faisait avant)...

Finalement, je me suis rabattu sur le 2.6.28 du depot de e-tobi.net.
qui fonctionne
très bien avec nvidia (180.22) m-a a-i nvidia et ma carte son. J'ai
pas encore
testé vpdau mais ça devrait théoriquement le faire ...



J'avoue que je n'ai pas très envie de rajouter un nouveau dépot e t de
re-changer de noyau... Mais bon, si je n'arrive vraiment à rien, je
ferai ça...

Merci.

David.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
newbeewan
Le #19062691
Le 06/04/2009 11:04, David BERCOT a écrit :
Re-Bonjour,

Je m'arrache les cheveux depuis quelques semaines avec l'installation
de drivers NVidia alors, au bout du rouleau (oui, oui, c'est dur ;-))),
je me résous à vous demander de l'aide...

Je voudrais donc avoir une configuration graphique satisfaisante et je
n'arrive à rien. Tout d'abord, lors de l'installation de X, je n'ai
aucun driver de spécifié dans xorg.conf !!! Bien évidemment, la
résolution choisie est... moyenne ;-)
J'ai donc essayé d'installer les drivers à la sauce Debian :
m-a a-i nvidia-kernel-legacy-173xx-source (et aussi,
nvidia-kernel-source) sans succès ! En gros, je n'ai pas de message
d'erreur significatif, mais quasiment un simple : nvidia.ko failed to
build !
Je précise au passage que je suis en 2.6.29-1-amd64.

Qu'à cela ne tienne, je me suis rabattu sur les drivers NVidia. Là
encore, impossible de faire quoi que soit : il ne trouve pas kernel.h
qui est situé, non pas dans /usr/src/linux-headers-2.6.29-1-amd64, mais
dans linux-headers-2.6.29-1-common ! Et si je copie juste kernel.h
(pour l'aider ;-))), ça ne marche pas mieux : il me dit que les sources
du noyau ne sont pas configurées !!!

Auriez-vous une piste pour moi ?
Avez-vous réussi à installer des drivers NVidia non libres (proprio ou
pas) sur un noyau 2.6.29 ?

Merci d'avance.

David.




Le driver nvidia ne compile pas sur le noyau 2.6.29 du fait d'un bug
dans les headers : http://bugs.debian.org/cgi-bin/bugreport.cgi?bugR0706

Il y a un contournement décrit dans le bug précité...

@ +

Mourad

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Samy Mezani
Le #19062681
Le 06.04.2009 11:39, David BERCOT a écrit :
Le Mon, 06 Apr 2009 11:18:19 +0200,
Guy Roussin
Bonjour,

Idem pour moi (en i386), ma carte son était mal supportée
(grésillements) par le
2.6.26 alors j'ai essayé le 2.6.29. Aucun pb avec nv et avec ma carte
son, mais
impossible d'installer les drivers proprio nvidia ...



Même raison de changer de noyau : carte son qui grésille ;-)
En revanche, je n'arrive même pas à utiliser nv !!!
Supposons, dans un premier temps, que je souhaite juste avoir la
résolution native de mon écran, sans accélération 3D. Comment
pourrais-je avoir un driver (nv ?) par défaut ? Avec un
dpkg-reconfigure xserver-xorg, il ne demande plus le driver à utiliser
(c'est ce qu'il faisait avant)...

Finalement, je me suis rabattu sur le 2.6.28 du depot de e-tobi.net.
qui fonctionne
très bien avec nvidia (180.22) m-a a-i nvidia et ma carte son. J'ai
pas encore
testé vpdau mais ça devrait théoriquement le faire ...



J'avoue que je n'ai pas très envie de rajouter un nouveau dépot et de
re-changer de noyau... Mais bon, si je n'arrive vraiment à rien, je
ferai ça...

Merci.

David.




Bonjour,
Tu as juste à ajouter/modifier dans la section Devices de ton
/etc/X11/xorg.conf :
Driver "nv"
et tu redémarres X
C'est tout.

Samy

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Guy Roussin
Le #19062671
David,

Moi j'ai simplement fait un "dpkg-reconfigure xserver-xorg"
et le xorg.conf est vraiment minimaliste ... Normalement pas
besoin de spécifier le driver dans la section device de xorg.conf,
X sait reconnaître automatiquement la carte video.

Essayes de forcer en saisissant à la main la ligne driver de la
section device de xorg.conf :
Driver "nv"
tu peux aussi essayer avec :
Driver "vesa"

Sinon regardes (et transmet nous) les log (/var/log/Xorg.0.log)

NB: X doit même démarrer correctement sans fichier xorg.conf
(mais en qwerty)

Regardes aussi avec lspci -v si c'est bien une carte nvidia qui est
reconnue ... (tu as peut etre un chipset intégré ?)

Guy


Même raison de changer de noyau : carte son qui grésille ;-)
En revanche, je n'arrive même pas à utiliser nv !!!
Supposons, dans un premier temps, que je souhaite juste avoir la
résolution native de mon écran, sans accélération 3 D. Comment
pourrais-je avoir un driver (nv ?) par défaut ? Avec un
dpkg-reconfigure xserver-xorg, il ne demande plus le driver à util iser
(c'est ce qu'il faisait avant)...


Finalement, je me suis rabattu sur le 2.6.28 du depot de e-tobi.net.
qui fonctionne
très bien avec nvidia (180.22) m-a a-i nvidia et ma carte son. J' ai
pas encore
testé vpdau mais ça devrait théoriquement le faire ...




J'avoue que je n'ai pas très envie de rajouter un nouveau dép ot et de
re-changer de noyau... Mais bon, si je n'arrive vraiment à rien, j e
ferai ça...

Merci.

David.




--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
David BERCOT
Le #19062751
Le Mon, 06 Apr 2009 11:56:17 +0200,
Samy Mezani
Bonjour,
Tu as juste à ajouter/modifier dans la section Devices de ton
/etc/X11/xorg.conf :
Driver "nv"
et tu redémarres X
C'est tout.



Sur le papier, ça me parait ok, mais dans les faits :
NV : No matching Device section for instance (BusID PCI:0:1:3) found
NV : No matching Device section for instance (BusID PCI:3:0:0) found
No devices detected.

Fatal server error:
no screens found

David.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
David BERCOT
Le #19062741
Le Mon, 06 Apr 2009 11:26:26 +0200,
newbeewan
Le driver nvidia ne compile pas sur le noyau 2.6.29 du fait d'un bug
dans les headers :
http://bugs.debian.org/cgi-bin/bugreport.cgi?bugR0706



Ouf, ça me rassure ;-) Merci pour cette info...

Il y a un contournement décrit dans le bug précité...



J'ai regardé rapidement et ça ne me semble pas si trivial que à §a. Mais
je reverrai ça à tête reposée...

David.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
newbeewan
Le #19063691
Le 06/04/2009 12:29, David BERCOT a écrit :
Le Mon, 06 Apr 2009 11:26:26 +0200,
newbeewan
Le driver nvidia ne compile pas sur le noyau 2.6.29 du fait d'un bug
dans les headers :
http://bugs.debian.org/cgi-bin/bugreport.cgi?bugR0706




Ouf, ça me rassure ;-) Merci pour cette info...



de rien ;)

Il y a un contournement décrit dans le bug précité...




J'ai regardé rapidement et ça ne me semble pas si trivial que ça. Mais
je reverrai ça à tête reposée...



C'est clairement pas trivial, il y a un bug ouvert dans pour le noyau
2.6.29... il semble que la version 2.6.29-2 arrive avec la correction :
http://bugs.debian.org/cgi-bin/bugreport.cgi?bugR1472
Donc wait and see, ce n'est plus qu'une question d'heures !
David.




++

Mourad

--
Membre de l'April - « promouvoir et défendre le logiciel libre » - http://www.april.org

Rejoignez maintenant plus de 4500 personnes, associations, entreprises et
collectivités qui soutiennent notre action


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Publicité
Poster une réponse
Anonyme