nvidia + compiz : d

Le
Alain Dawson
Bonsoir,

Voici un problème que je traîne depuis plusieurs versions de Debian
(actuellement : SID, et auparavant Lenny) avec Compiz, Gnome et le
driver propriétaire NVidia (ma carte est une Geforce 6150).

Au démarrage, Compiz est d'une lenteur extrême qui le rend inutilisable.
Par exemple, le déplacement d'une fenêtre se fait avec un délai de
quelques secondes, quand il se fait. Les choses allaient mieux depuis
quelques temps sous SID, mais le changement d'écran pour un 23 pouces en
1920 x 1080 a fait réapparaître le problème en pire. Les solutions sont
plus ou moins aléatoires : attendre quelques minutes sans rien toucher
(parfois ça suffit !), recharger compiz, sortir de la session et y
revenir, relancer le PC. Je viens de trouver une solution plus efficace,
mais encore vraiment bricolée : mettre le PC en veille et le ranimer. Au
retour, Compiz fonctionne correctement

J'ai l'impression, dit en termes naïfs, qu'au lancement de Compiz la
carte n'est pas "prête" a accepter un gros travail (d'ailleurs le
chargement de la 1ère session est plutôt long), mais qu'en relançant
Compiz ou la session Gnome, ou encore en mettant en veille et en
réveillant le PC, elle s'y retrouve mieux. Peut-on traduire ça en termes
de réservation de mémoire, par exemple ? Toujours est-il que je suppose
qu'il faudrait que je passe les bonnes options dans xorg.conf, ou autre
fichier de configuration, mais je n'ai pas encore trouvé comment, malgré
mes tâtonnements

Alors, si quelqu'un a une piste, je suis preneur

Merci d'avance !

Alain


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/1289936586.3476.17.camel@pundit
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jean-Yves F. Barbier
Le #22800151
On Tue, 16 Nov 2010 20:43:06 +0100, Alain Dawson


Au démarrage, Compiz est d'une lenteur extrême qui le rend inut ilisable.



Que renvoie la Cde:
glxinfo|grep rend
?

--
I am two fools, I know, for loving, and for saying so.
-- John Donne

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Alain Dawson
Le #22800271
Le mardi 16 novembre 2010 à 20:56 +0100, Jean-Yves F. Barbier a écrit :
On Tue, 16 Nov 2010 20:43:06 +0100, Alain Dawson


> Au démarrage, Compiz est d'une lenteur extrême qui le rend inutilisable.

Que renvoie la Cde:
glxinfo|grep rend
?



Voilà :

direct rendering: Yes
OpenGL renderer string: GeForce 6150/PCI/SSE2
GL_NVX_conditional_render, GL_SGIS_generate_mipmap,
GL_SGIS_texture_lod,



--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme