Nvidia : Problème avec glx

Le
geo cherchetout
Bonsoir,

J'ai toujours ma carte graphique MSI N210, mon OS est toujours Mageia 2
(x86_64) et mon environnement préféré xfce4. Ne pouvant me satisfaire du
pilote 'nouveau' pour des raisons exposées dans un post récent, j'ai du
revenir à nvidia.
Dans un premier temps, mes fenêtres avaient perdu leur décoration. Ce fut
résolu en chargeant le module nvidia avec l'option "NVreg_EnableMSI=1".

Un autre problème reste à résoudre, dont je n'ai encore découvert qu'une
manifestation : Je ne peux pas lancer le jeu pinball :

$ pinball
Initing SDL

0 joysticks were found.
X Error of failed request: BadWindow (invalid Window parameter)
Major opcode of failed request: 137 (NV-GLX)
Minor opcode of failed request: 4 ()
Resource id in failed request: 0x300000f
Serial number of failed request: 35
Current serial number in output stream: 35

$ glxinfo
name of display: :0.0
X Error of failed request: BadWindow (invalid Window parameter)
Major opcode of failed request: 137 (NV-GLX)
Minor opcode of failed request: 4 ()
Resource id in failed request: 0x3400003
Serial number of failed request: 33
Current serial number in output stream: 33

Ce n'est pas en soit un problème crucial, mais sa solution m'aiderait à
attendre de pouvoir utiliser 'nouveau'. (Qui permettait d'utiliser Pinball
mais en faisant le poirier, exercice qui n'est plus de mon âge.)
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
geo cherchetout
Le #24531041
Le 31/05/2012 22:25, j'ai écrit :

J'ai toujours ma carte graphique MSI N210, mon OS est toujours Mageia 2
(x86_64) et mon environnement préféré xfce4. Ne pouvant me satisfaire du
pilote 'nouveau' pour des raisons exposées dans un post récent, j'ai du
revenir à nvidia.
Dans un premier temps, mes fenêtres avaient perdu leur décoration. Ce fut
résolu en chargeant le module nvidia avec l'option "NVreg_EnableMSI=1".



Bouarf, c'était nécessaire avant que je confie la mise au point de cette
horlogerie complexe à l'outil XFdrake fourni par ma distribution. Ce n'est
pas la première fois, mais cette fois-ci j'ai répondu « oui » à la question
« Êtes vous satisfait du résultat ? » (Une fenêtre toute blanche comme les
fois précédentes). Résultat : La machine a plongé instantanément dans un
coma apparent dont j'ai pu la sortir à la troisième ou quatrième des
combinaisons de touches magiques, suivie une minute plus tard d'un
ctl+alt+del. Au réveil, tout fonctionne avec le pilote nvidia. :-) Et même
sans faire figurer cette option "NVreg_EnableMSI=1" dans mon menu.lst.
À bientôt pour de nouvelles aventures.
Publicité
Poster une réponse
Anonyme