openvpn + déport X

Le
Vincent Besse
Bonjour,

comme le sujet le laisse à penser, j' ai un problème d' affichage
déporté d' applications graphiques à travers un tunnel openvpn.

Le serveur est une Dedibox en etch (OpenVPN 2.0.9-4), les clients sont
soit des Sid soit une Ubuntu (désolé). Les symptomes sont les memes,
que j' essaie de déporter entre deux clients ou du serveur vers un
client en faisant des 'ssh -X'.

Que se passe-t-il donc?
Ceci:
Si je me connecte depuis un client sur la Dédibox par un 'ssh -X
moi@adresse.publique.du.serveur' , j' ai bien une session ouverte, un
'echo $DISPLAY' me donne 'localhost:10.0', et j' ai bien un xterm qui
s' ouvre sur mon poste client quand je tape 'xterm'.
Si je me connecte avec 'ssh -X moi@adresse.vpn.du.serveur', j' ouvre
une session, $DISPLAY vaut toujours 'localhost:10.0', par contre si j'
essaie de lancer un xterm, il ne se passe _rien_ pendanttrès
longtemps. Ctrl-C est inopérant et je suis obligé de lancer une seconde
session ssh pour pouvoir killer le processus. A ce stade-là, le clavier
est perdu dans la première session et il me faut aussi killer cette
session.

Le but final est de pouvoir faire du VNC au travers du VPN. Quand j' ai
vu que VNC ne marchait pas, j' ai simplifié mes essais pour en aboutir
à ce constat. J' ose espérer que résoudre mon problème de terminal
devrait me résoudre le problème VNC.

Je ne sais pas trop vers où regarder, config du VPN, config SSH, autre ?
Toute aide est la bienvenue.

Et le plus râlant c' est que je fais du VNC et du RDP sans problème
entre un bureau Microsoft et un client Linux.

Merci,
Vincent

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
  • Le smartphone Sony Xperia X voit sa résistance aux immersions testée durant deux ...
  • Présentation du Wendelstein 7-X le réacteur à fusion nucléaire le plus grand jamais ...
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
dominix
Le #18232311
Vincent Besse a écrit :
Bonjour,

comme le sujet le laisse à penser, j' ai un problème d' affichage
déporté d' applications graphiques à travers un tunnel openvpn.

Le serveur est une Dedibox en etch (OpenVPN 2.0.9-4), les clients sont
soit des Sid soit une Ubuntu (désolé...). Les symptomes sont les memes,
que j' essaie de déporter entre deux clients ou du serveur vers un
client en faisant des 'ssh -X'.

Que se passe-t-il donc?
Ceci:
Si je me connecte depuis un client sur la Dédibox par un 'ssh -X
' , j' ai bien une session ouverte, un
'echo $DISPLAY' me donne 'localhost:10.0', et j' ai bien un xterm qui
s' ouvre sur mon poste client quand je tape 'xterm'.
Si je me connecte avec 'ssh -X ', j' ouvre
une session, $DISPLAY vaut toujours 'localhost:10.0', par contre si j'
essaie de lancer un xterm, il ne se passe _rien_ pendant...très
longtemps. Ctrl-C est inopérant et je suis obligé de lancer une seconde
session ssh pour pouvoir killer le processus. A ce stade-là, le clavier
est perdu dans la première session et il me faut aussi killer cette
session.

Le but final est de pouvoir faire du VNC au travers du VPN. Quand j' ai
vu que VNC ne marchait pas, j' ai simplifié mes essais pour en aboutir
à ce constat. J' ose espérer que résoudre mon problème de terminal
devrait me résoudre le problème VNC.

Je ne sais pas trop vers où regarder, config du VPN, config SSH, autre ?
Toute aide est la bienvenue.

Et le plus râlant c' est que je fais du VNC et du RDP sans problème
entre un bureau Microsoft et un client Linux.

Merci,
Vincent




ca ressemble a un problème de MTU, ajoute mtu-test a la fin de ton
fichier de config du clien. (et attend 2-3 minutes avant de lancer ton
xterm.

mes 2 xpf
--
dominix

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Vincent Besse
Le #18235161
Bonjour,

je me réponds, en remerciant au passage dominix pour s' être penché s ur
l' histoire.

J' ai juste passé OpenVPN de UDP à TCP et là tout à l' air de march er,
xterm, VNC, ...

Cette victoire me laisse néanmoins quelque peu dubitatif. J' avais cru
comprendre qu' OpenVPN encapsulait tout, y compris le trafic TCP, dans
de l' UDP. Donc à priori, même en cas de perte de paquets UDP, le TCP
décapsulé devrait faire son boulot? C' est un peu hors-sujet sur cette
liste, j' en conviens, mais si quelqu' un peut diriger ses lumières de
ce coté, ben je serai super-content :)
D' autant que si le bug est en dehors de mes neurones, je serai ravi de
le faire remonter!

Bonnes fêtes,
Vincent

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme