[Orange] Catastrophique nouveau firmware Livebox Sagem

Le
Lea GRIS
Suivi dans : news:fr.reseaux.internet.fournisseurs

Bonjour,

Ce matin j'ai eu une bien mauvaise surprise.

Pendant 6h la liebox Sagem a mis à jour son firmware. Donc plus
d'internet ni de téléphone pendant tout ce temps. (offre net)

Et quelle ne fut pas ma déconvenue en découvrant toutes les
fonctionnalités retirées et les monstrueux bricolages ajoutés :

* Plus d'option pour configurer les plages IP DHCP

* Plus d'option pour arrêter ou configurer le relai DNS
- Le nouveau relai DNS, modifie et altère les réponses DNS
- Tous les noms de domaine en alias CNAME sont traduit en enregistrement A
- Il n'est plus possible d'interroger d'autres types d'enregistrement
DNS. plus de TXT plus de CNAME, plus de AAAA, plus de SRV, plus de MX

* Plus moyen de configurer une connexion en PPPOA. C'est PPPOE sans
aucune option et rien d'autre.
- Donc, retour à un MTU de 1472 au lieu de 1500 quant on passe en PPPOA.

* Presque toutes les commandes ont disparues de l'interface telnet
- Plus de SNMP pour suivre et tracer les débits entrants et sortants
- Plus de syslog sur une autre machine pour tracer les évènement de
connexion/déconnexion entre autre.
- Plus de configuration du relai PSTN pour ceux qui ont une ligne
analogique et veulent recevoir leurs appels sur le téléphone connecté à
la Livebox

Voici tout ce qu'il reste en telnet :
telnet 192.168.1.1
Trying 192.168.1.1
Connected to 192.168.1.1.
Escape character is '^]'.
login: root
Password: ****
[root @ home]$ ls
exit
ls
home
wlan
save
adsl
sndcp
reboot
erase
version
show
load
ping


À Dieu Orange :
- Bridage des fonctionnalités Livebox
- Mise à jour intempestive avec interruption de service pendant 6h
- Incompétence de la téléassistance technique
- Mensonge de la téléassistance technique (un technicien doit toujours
me rappeler).

Je pars voir ailleurs chez Nerim.

--
Léa Gris
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Dominique ROUSSEAU
Le #6439851
Le mer, 30 avr 2008 at 14:33 GMT, Lea GRIS
Je pars voir ailleurs chez Nerim.


T'aurais pas du les quitter :-)

Patrice
Le #6440301
"Dominique ROUSSEAU" news:
Le mer, 30 avr 2008 at 14:33 GMT, Lea GRIS
Je pars voir ailleurs chez Nerim.


T'aurais pas du les quitter :-)


Bah, tout le monde ne peut pas en dire autant, je ne regrette pas de les
avoir quittés..


Lea GRIS
Le #6440291
Je pars voir ailleurs chez Nerim.


T'aurais pas du les quitter :-)


Ton nom me dit qqchose, tu fréquentais pas Fidonet Ramses BBS il y a ...
mmm ... longtemps :) ?

--
Léa Gris


Pascal Hambourg
Le #6446461
Salut,


* Plus d'option pour arrêter ou configurer le relai DNS
- Le nouveau relai DNS, modifie et altère les réponses DNS
- Tous les noms de domaine en alias CNAME sont traduit en enregistrement A
- Il n'est plus possible d'interroger d'autres types d'enregistrement
DNS. plus de TXT plus de CNAME, plus de AAAA, plus de SRV, plus de MX


J'avais vu ça pour les AAAA en dépannant des gens qui trouvaient leur
connexion lente), mais d'après ce que tu dis c'est encore bien pire.

* Plus moyen de configurer une connexion en PPPOA. C'est PPPOE sans
aucune option et rien d'autre.


C'est d'autant plus nul qu'avec un modem-routeur ADSL je ne vois pas de
raison de préférer PPPoE à PPPoA.

- Donc, retour à un MTU de 1472 au lieu de 1500 quant on passe en PPPOA.


C'est d'autant plus nul qu'on pourrait d'utiliser des trames ethernet
sur AAL5 de 1508 octets pour avoir un MTU de 1500 en PPPoE. Il y a une
RFC à ce sujet.

Au fait, le MTU PPPoE, c'est 1492 et pas 1472, non ?

Je pars voir ailleurs chez Nerim.


Bienvenue. :-)

Dominique ROUSSEAU
Le #6534561
Le mer, 30 avr 2008 at 18:13 GMT, Lea GRIS
Je pars voir ailleurs chez Nerim.


T'aurais pas du les quitter :-)


Ton nom me dit qqchose, tu fréquentais pas Fidonet Ramses BBS il y a ...
mmm ... longtemps :) ?


Très très peu probable.

Mais je me souviens bien qu'on se soit déjà croisé sur les ng internes
de Nerim, y'a quelque années.



Lea GRIS
Le #6537221
Salut,


* Plus d'option pour arrêter ou configurer le relai DNS
- Le nouveau relai DNS, modifie et altère les réponses DNS
- Tous les noms de domaine en alias CNAME sont traduit en
enregistrement A
- Il n'est plus possible d'interroger d'autres types d'enregistrement
DNS. plus de TXT plus de CNAME, plus de AAAA, plus de SRV, plus de MX


J'avais vu ça pour les AAAA en dépannant des gens qui trouvaient leur
connexion lente), mais d'après ce que tu dis c'est encore bien pire.


Oui très génant et impactant si tu a un réseau IPv6 d'actif quelque part
sur le systme.

Toutes requêtes autre que CNAME ou A n'obtient aucune réponse DNS. Il
faut attendre le timeout évidement. C'est ce qui cause un énorme
ralentissement avec tout client tentant de résoudre un enregistrement
AAAA avant l'enregistrement A. Et comme il n'y a pas de réponse dutout,
le résultat n'est pas mis en cache et ça recommence pour chaque requête.

La men table :/

-10 Orange

Et avec un service type Avahi (Zeroconf) c'est encore pire. Ça
questionne les services "Bonjour" et les enregistrements _Protocole IN
SRV, je te raconte pas le pataquès de délais quant il doit attendre un
timeout.

--
Léa Gris


Pascal Hambourg
Le #6538061

J'avais vu ça pour les AAAA en dépannant des gens qui trouvaient leur
connexion lente), mais d'après ce que tu dis c'est encore bien pire.


Oui très génant et impactant si tu a un réseau IPv6 d'actif quelque part
sur le systme.


Même pas besoin de réseau IPv6 actif. Il suffit d'avoir la pile IPv6
activée sur la machine et des applications compatibles IPv6, ce qui est
le cas par défaut de pas de distributions GNU/Linux, des Windows récents
et probablement de MacOS.

Toutes requêtes autre que CNAME ou A n'obtient aucune réponse DNS. Il
faut attendre le timeout évidement. C'est ce qui cause un énorme
ralentissement avec tout client tentant de résoudre un enregistrement
AAAA avant l'enregistrement A. Et comme il n'y a pas de réponse dutout,
le résultat n'est pas mis en cache et ça recommence pour chaque requête.


Heureusement certains navigateurs comme Firefox ont leur propre cache de
noms qui fait que seul le premier accès à un site est long.

Et avec un service type Avahi (Zeroconf) c'est encore pire.


Oui mais bon, utiliser ces trucs-là c'est un peu tendre le bâton pour se
faire battre. :-p


y
Le #6659251
On 2 mai, 15:41, Pascal Hambourg
Même pas besoin de réseau IPv6 actif. Il suffit d'avoir la pile IPv6
activée sur la machine et des applications compatibles IPv6, ce qui est
le cas par défaut de pas de distributions GNU/Linux, des Windows récen ts
et probablement de MacOS.


Je confirme: Chez mes vieux parents qui n'ont franchement pas besoin
d'être emmerdés par Orange (ils ont découvert un PC à 65 ans l'ann ée
dernière), le firmware de la livebox semble avoir changé en milieu de
semaine dernière... avec les lenteurs décrites. Je les ai installés en
double boot XP/Linux (ubuntu 6.06 LTS) et XP marchait bien ce qui m'a
mis la puçe à l'oreille. Bon, ça dépanne qq jours, mais ils préf èrent
ubuntu (simplicité de gnome, pas d'antivirus/firewall qui bipe pour
chaque truc).

Ce WE un coup de ssh -D PORT chez eux, le firefox sur ma machine avec
pour proxy localhost:PORT... et me voilà pouvant aller sur la page de
conf de leur box sans faire 1000 bornes pour constater que ça n'avait
plus vraiment la même tronche et que le firmware avait changé: Le
genre de "hasard" qui trompe pas. Les essais orientant vers des pb de
dns, il est vrai que les dig A passent... pas les dig AAAA.

J'ai d'abord essayé de blacklister ipv6 dans /etc/modprobe.d/
blacklist : Ca marche pas. Une explication serait bienvenue car je
pensais que sans support IPV6, ça résoudrait le pb. Bin non, il semble
que même sans ipv6, on continue à faire des requêtes AAA! Bug or
feature??? Il est vrai qu'une pile ipv6 semble laisser des traces même
sans ipv6.

Ensuite, comme ils sont en IP fixe, modifier le /etc/resolv.conf (et
le /etc/network/interface pour leur wifi IP fixe s'il rinçe le
resolv.conf, puis le /etc/dhcp3/dhclient.conf si un de ces jours ils
leur vient a l'idée d'utiliser un cable, eth0 étant en dhcp...) a
permis de contourner le problème.

D'ailleurs, avant de me demander si j'avais une idée du problème...
ils avaient essayé de passer dans la semaine à la boutique Orange du
coin: 50m de queue à l'extérieur de la boutique avec des gens la
deadbox sous le bras :-)

M'est avis qu'Orange va avoir intérêt à:
1) Arrêter le déploiement en urgence.
2) Corriger sa version écrite avec les pieds (par un indien payé à
coups de trique?).

A+

adechilly
Le #6666831
On May 19, 2:10 pm, ""
On 2 mai, 15:41, Pascal Hambourg
Même pas besoin de réseau IPv6 actif. Il suffit d'avoir la pile IPv6
activée sur la machine et des applications compatibles IPv6, ce qui es t
le cas par défaut de pas de distributions GNU/Linux, des Windows réc ents
et probablement de MacOS.


Je confirme: Chez mes vieux parents qui n'ont franchement pas besoin
d'être emmerdés par Orange (ils ont découvert un PC à 65 ans l'ann ée
dernière), le firmware de la livebox semble avoir changé en milieu de
semaine dernière... avec les lenteurs décrites. Je les ai installés en
double boot XP/Linux (ubuntu 6.06 LTS) et XP marchait bien ce qui m'a
mis la puçe à l'oreille. Bon, ça dépanne qq jours, mais ils préf èrent
ubuntu (simplicité de gnome, pas d'antivirus/firewall qui bipe pour
chaque truc).

Ce WE un coup de ssh -D PORT chez eux, le firefox sur ma machine avec
pour proxy localhost:PORT... et me voilà pouvant aller sur la page de
conf de leur box sans faire 1000 bornes pour constater que ça n'avait
plus vraiment la même tronche et que le firmware avait changé: Le
genre de "hasard" qui trompe pas. Les essais orientant vers des pb de
dns, il est vrai que les dig A passent... pas les dig AAAA.

J'ai d'abord essayé de blacklister ipv6 dans /etc/modprobe.d/
blacklist : Ca marche pas. Une explication serait bienvenue car je
pensais que sans support IPV6, ça résoudrait le pb. Bin non, il semble
que même sans ipv6, on continue à faire des requêtes AAA! Bug or
feature??? Il est vrai qu'une pile ipv6 semble laisser des traces même
sans ipv6.

Ensuite, comme ils sont en IP fixe, modifier le /etc/resolv.conf (et
le /etc/network/interface pour leur wifi IP fixe s'il rinçe le
resolv.conf, puis le /etc/dhcp3/dhclient.conf si un de ces jours ils
leur vient a l'idée d'utiliser un cable, eth0 étant en dhcp...) a
permis de contourner le problème.

D'ailleurs, avant de me demander si j'avais une idée du problème...
ils avaient essayé de passer dans la semaine à la boutique Orange du
coin: 50m de queue à l'extérieur de la boutique avec des gens la
deadbox sous le bras :-)

M'est avis qu'Orange va avoir intérêt à:
1) Arrêter le déploiement en urgence.
2) Corriger sa version écrite avec les pieds (par un indien payé à
coups de trique?).

A+


Hello à tous,

suite à un upgrade firmware la nuit dernière, je remarque des lenteurs
sur HTTP (pas autant sur le reste).

Savez vous comment faire pour faire un fallback de cet upgrade
firmware?
Et eviter l'upgrade automatique ?

Merci d'avance,


Ash
Le #6696891
(...)

D'ailleurs, avant de me demander si j'avais une idée du problème...
ils avaient essayé de passer dans la semaine à la boutique Orange du
coin: 50m de queue à l'extérieur de la boutique avec des gens la
deadbox sous le bras :-)

M'est avis qu'Orange va avoir intérêt à:
1) Arrêter le déploiement en urgence.
2) Corriger sa version écrite avec les pieds (par un indien payé à
coups de trique?).




Salut

Tu ne crois pas si bien dire.

Ma Livebox Sagem avait essayé de se mettre à jour, et elle est restée
des heures durant à clignoter, sans y parvenir.
J'ai fini par la faire échanger.
Celle-ci semble vouloir garder l'ancien firmware (qui fonctionne très
bien) et j'espère seulement que leurs mises à jour automatiques ont été
arrêtées.
C'est vraiment pénible ce système de maj auto.
On a besoin d'avoir une Livebox pour le téléphone illimité (à moins
qu'il y ait un moyen de prendre un routeur dsl qui fasse la voip, mais
est-ce qu'Orange voudra bien de lui si on leur donne l'adresse MAC ?
j'en doute fort... ). J'étais bien content de mon ancien routeur dsl
D-Link que je pouvais flashouiller avec des firmwares russes,
australiens, ou destinés à un autre modèle. Et quand ça marchait pas,
ben je réussissais toujours à faire un repair.
J'avais bien essayé sur la Livebox Sagem mais aucun utilitaire de
réparation ne voulait fonctionner... et en plus c'est moche ce gros truc
blanc :).

Ash.

Publicité
Poster une réponse
Anonyme