Ouvrir deux bases sur le même PC

Le
Nathalie Lebas
Bonjour à tous,
J'ai deux bases de noms différents, bien sûr, que je souhaite pouvoir ouvrir
en même temps sur le même PC. Sur ce PC, j'ai 4 bases différentes et j'arrive
à en ouvrir 3 sans problème en même temps et passer de l'une à l'autre.
Par contre, deux de ces bases n'arrivent jamais à être ouverte en même
temps. Si j'ouvre l'une des 2 et que j'essais d'ouvrir la deuxième ensuite,
le formulaire en cours sur la première s'affiche et vis et versa.
Les deux bases sont dans des répetoires différents de mon PC et elles sont
liées à des tables différentes, dans des bases différentes, dans des
répertoires du serveur différents !
Ces deux bases sont proches en structure, j'ai utilisé une copie de la
première pour construire le seconde, est-ce l'explication à ce phénomène.
Quoi faire pour ouvrir les 2 en même temps ?
Merci de vos réponses.
--
Nathalie
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Tisane
Le #6314191
Bonjour Nathalie,

J'ai deux bases de noms différents, bien sûr, que je souhaite pouvoir
ouvrir
en même temps sur le même PC. Sur ce PC, j'ai 4 bases différentes et
j'arrive
à en ouvrir 3 sans problème en même temps et passer de l'une à l'autre.
Par contre, deux de ces bases n'arrivent jamais à être ouverte en même
temps. Si j'ouvre l'une des 2 et que j'essais d'ouvrir la deuxième
ensuite,
le formulaire en cours sur la première s'affiche et vis et versa.
Les deux bases sont dans des répetoires différents de mon PC et elles sont
liées à des tables différentes, dans des bases différentes, dans des
répertoires du serveur différents !
Ces deux bases sont proches en structure, j'ai utilisé une copie de la
première pour construire le seconde, est-ce l'explication à ce phénomène.
Quoi faire pour ouvrir les 2 en même temps ?


Ouvre chaque base à l'aide d'un raccourci dans lequel tu indiques ET le
chemin d'Access ET le chemin de ta base, soit par exemple :
"C:Program FilesMicrosoft OfficeOFFICE11MSACCESS.EXE"
"X:Ton_CheminTa_Base.mdb"
Est-ce que c'est mieux ?

--
Tisane

Nathalie Lebas
Le #6314171
Bonjour Tisane,
Fidèle au poste, et les vacances ?
Merci de me répondre.
Je suis en cours de mise en place des bases fractionnées dont nous avons
déjà parlé ensemble. Je commence par mes deux plus petites bases et cela
commence mal !!! je suis incapable de les ouvrir ensemble comme tu as pu le
lire.
J'ouvre les deux bases par raccourci, dans les propriétés de celui-ci, j'ai :
Cible : C:DHLDHL.mdb
Démarrer dans :C:DHL
mais où mettre : "C:Program FilesMicrosoft OfficeOFFICE11MSACCESS.EXE"
A+
--
Nathalie



Bonjour Nathalie,

J'ai deux bases de noms différents, bien sûr, que je souhaite pouvoir
ouvrir
en même temps sur le même PC. Sur ce PC, j'ai 4 bases différentes et
j'arrive
à en ouvrir 3 sans problème en même temps et passer de l'une à l'autre.
Par contre, deux de ces bases n'arrivent jamais à être ouverte en même
temps. Si j'ouvre l'une des 2 et que j'essais d'ouvrir la deuxième
ensuite,
le formulaire en cours sur la première s'affiche et vis et versa.
Les deux bases sont dans des répetoires différents de mon PC et elles sont
liées à des tables différentes, dans des bases différentes, dans des
répertoires du serveur différents !
Ces deux bases sont proches en structure, j'ai utilisé une copie de la
première pour construire le seconde, est-ce l'explication à ce phénomène.
Quoi faire pour ouvrir les 2 en même temps ?


Ouvre chaque base à l'aide d'un raccourci dans lequel tu indiques ET le
chemin d'Access ET le chemin de ta base, soit par exemple :
"C:Program FilesMicrosoft OfficeOFFICE11MSACCESS.EXE"
"X:Ton_CheminTa_Base.mdb"
Est-ce que c'est mieux ?

--
Tisane





Tisane
Le #6314161

[...]
J'ouvre les deux bases par raccourci, dans les propriétés de celui-ci,
j'ai :
Cible : C:DHLDHL.mdb
Démarrer dans :C:DHL
mais où mettre : "C:Program FilesMicrosoft OfficeOFFICE11MSACCESS.EXE"


Dans la cible, juste avant C:DHLDHL.mdb
Vérifie le chemin d'accès à MsAccess.exe. Il n'est peut-être pas le même
chez toi.

--
Tisane (toujours en vacances, même quand elle travaille ;-)


Bonjour Nathalie,

J'ai deux bases de noms différents, bien sûr, que je souhaite pouvoir
ouvrir
en même temps sur le même PC. Sur ce PC, j'ai 4 bases différentes et
j'arrive
à en ouvrir 3 sans problème en même temps et passer de l'une à l'autre.
Par contre, deux de ces bases n'arrivent jamais à être ouverte en même
temps. Si j'ouvre l'une des 2 et que j'essais d'ouvrir la deuxième
ensuite,
le formulaire en cours sur la première s'affiche et vis et versa.
Les deux bases sont dans des répetoires différents de mon PC et elles
sont
liées à des tables différentes, dans des bases différentes, dans des
répertoires du serveur différents !
Ces deux bases sont proches en structure, j'ai utilisé une copie de la
première pour construire le seconde, est-ce l'explication à ce
phénomène.
Quoi faire pour ouvrir les 2 en même temps ?


Ouvre chaque base à l'aide d'un raccourci dans lequel tu indiques ET le
chemin d'Access ET le chemin de ta base, soit par exemple :
"C:Program FilesMicrosoft OfficeOFFICE11MSACCESS.EXE"
"X:Ton_CheminTa_Base.mdb"
Est-ce que c'est mieux ?

--
Tisane





jerome crevecoeur
Le #6314151
Hello,

As-tu un message d'erreur ou est-ce que les fenêtres se figent?
Peux tu ouvrir tes tables liées directement dans l'autre application
frontale?

As-tu vérifié dans Outils/OPtions/Onglet Avancé si:
-Mode d'ouverture en mode partagé
-Verrouillage par défaut Aucun

Cordialement

Bonjour Tisane,
Fidèle au poste, et les vacances ?
Merci de me répondre.
Je suis en cours de mise en place des bases fractionnées dont nous av ons
déjà parlé ensemble. Je commence par mes deux plus petites bases et cela
commence mal !!! je suis incapable de les ouvrir ensemble comme tu as p u le
lire.
J'ouvre les deux bases par raccourci, dans les propriétés de celui- ci, j'ai :
Cible : C:DHLDHL.mdb
Démarrer dans :C:DHL
mais où mettre : "C:Program FilesMicrosoft OfficeOFFICE11MSACCESS .EXE"
A+


Nathalie Lebas
Le #6314141
Tiens Jérôme, pas en vacances !, bonjour,
Je ne peux pas ouvrir la deuxième base (celle sur le Pc avec l'application)
même en maintenance si la première est ouverte. Par contre, je peux ouvrir
les deux bases avec les données directement sur le serveur.
Je n'ai aucun message d'erreur. Lorsque je tente d'ouvrir une des deux bases
alors que l'autre est déjà ouverte, il affiche le formulaire en cours de la
base déjà ouverte et n'ouvre pas la deuxième base. C'est un peu comme si tu
veux ouvrir une base déjà ouverte, il t'affiche l'écran de la base déjà
ouverte, ce qui est normal.
Mais dans mon cas, il s'agit de deux bases différentes avec un nom différent
à des endroits différents donc je ne comprends pas. Le seul lien, pourrais-je
dire, est que j'ai créé la deuxième base à partir d'une copie de la première
car certains formulaires et structures de tables sont presque identiques.
Concernant les paramètres, les bases sont toutes en mode partagé par contre
toutes mes bases (celles-ci et les autres) sont en verrouillage
"enregistrement modifié" avec coché "ouvrir avec enregsitrements
verrouillés". J'ai appliqué ce paramétrage suite à une remarque lue sur le
forum.
A +
--
Nathalie



Hello,

As-tu un message d'erreur ou est-ce que les fenêtres se figent?
Peux tu ouvrir tes tables liées directement dans l'autre application
frontale?

As-tu vérifié dans Outils/OPtions/Onglet Avancé si:
-Mode d'ouverture en mode partagé
-Verrouillage par défaut Aucun

Cordialement

Bonjour Tisane,
Fidèle au poste, et les vacances ?
Merci de me répondre.
Je suis en cours de mise en place des bases fractionnées dont nous avons
déjà parlé ensemble. Je commence par mes deux plus petites bases et cela
commence mal !!! je suis incapable de les ouvrir ensemble comme tu as pu le
lire.
J'ouvre les deux bases par raccourci, dans les propriétés de celui-ci, j'ai :
Cible : C:DHLDHL.mdb
Démarrer dans :C:DHL
mais où mettre : "C:Program FilesMicrosoft OfficeOFFICE11MSACCESS.EXE"
A+






Thierry (ze Titi)
Le #6314131
Bonjour Nathalie,

une suggestion bête... As-tu essayé d'ouvrir une nouvelle base et
d'importer tous les objets de l'une des bases récalcitrantes ? Ensuite
tu réessaies d'ouvrir l'une des deux bases et celle nouvellement créée.

Dans ton message
Tiens Jérôme, pas en vacances !, bonjour,
Je ne peux pas ouvrir la deuxième base (celle sur le Pc avec l'application)
même en maintenance si la première est ouverte. Par contre, je peux ouvrir
les deux bases avec les données directement sur le serveur.
Je n'ai aucun message d'erreur. Lorsque je tente d'ouvrir une des deux bases
alors que l'autre est déjà ouverte, il affiche le formulaire en cours de la
base déjà ouverte et n'ouvre pas la deuxième base. C'est un peu comme si tu
veux ouvrir une base déjà ouverte, il t'affiche l'écran de la base déjà
ouverte, ce qui est normal.
Mais dans mon cas, il s'agit de deux bases différentes avec un nom différent
à des endroits différents donc je ne comprends pas. Le seul lien, pourrais-je
dire, est que j'ai créé la deuxième base à partir d'une copie de la première
car certains formulaires et structures de tables sont presque identiques.
Concernant les paramètres, les bases sont toutes en mode partagé par contre
toutes mes bases (celles-ci et les autres) sont en verrouillage
"enregistrement modifié" avec coché "ouvrir avec enregsitrements
verrouillés". J'ai appliqué ce paramétrage suite à une remarque lue sur le
forum.
A +
--
Nathalie



Hello,

As-tu un message d'erreur ou est-ce que les fenêtres se figent?
Peux tu ouvrir tes tables liées directement dans l'autre application
frontale?

As-tu vérifié dans Outils/OPtions/Onglet Avancé si:
-Mode d'ouverture en mode partagé
-Verrouillage par défaut Aucun

Cordialement

Bonjour Tisane,
Fidèle au poste, et les vacances ?
Merci de me répondre.
Je suis en cours de mise en place des bases fractionnées dont nous avons
déjà parlé ensemble. Je commence par mes deux plus petites bases et cela
commence mal !!! je suis incapable de les ouvrir ensemble comme tu as pu le
lire.
J'ouvre les deux bases par raccourci, dans les propriétés de celui-ci, j'ai
: Cible : C:DHLDHL.mdb
Démarrer dans :C:DHL
mais où mettre : "C:Program FilesMicrosoft OfficeOFFICE11MSACCESS.EXE"
A+






--
Cordialement,
Thierry

Tout pour réussir avec Access :
http://www.mpfa.info



Nathalie Lebas
Le #6314121
Ce qui me dérange dans mon histoire :
Si j'ouvre une autre base, lors qu'une des 2 en cause est déjà ouverte, le
phénomène ne se reproduit pas, mon autre base s'ouvre bien et affiche mon
formulaire d'accueil.
Donc je me demande pourquoi ces 2 bases ne veulent-elles pas cohabiter !
--
Nathalie



Hello,

As-tu un message d'erreur ou est-ce que les fenêtres se figent?
Peux tu ouvrir tes tables liées directement dans l'autre application
frontale?

As-tu vérifié dans Outils/OPtions/Onglet Avancé si:
-Mode d'ouverture en mode partagé
-Verrouillage par défaut Aucun

Cordialement

Bonjour Tisane,
Fidèle au poste, et les vacances ?
Merci de me répondre.
Je suis en cours de mise en place des bases fractionnées dont nous avons
déjà parlé ensemble. Je commence par mes deux plus petites bases et cela
commence mal !!! je suis incapable de les ouvrir ensemble comme tu as pu le
lire.
J'ouvre les deux bases par raccourci, dans les propriétés de celui-ci, j'ai :
Cible : C:DHLDHL.mdb
Démarrer dans :C:DHL
mais où mettre : "C:Program FilesMicrosoft OfficeOFFICE11MSACCESS.EXE"
A+






Nathalie Lebas
Le #6314111
Bonjour Thierry,
Merci de ta suggestion.
Je crois que je vais devenir folle !
J'ai créé une nouvelle base et importé l'application de la base existante
puis je l'ai installée dans le répertoire du PC et là CA MARCHE !!
Je ne comprends pas, que s'est-il passé ???
A+
--
Nathalie



Bonjour Nathalie,

une suggestion bête... As-tu essayé d'ouvrir une nouvelle base et
d'importer tous les objets de l'une des bases récalcitrantes ? Ensuite
tu réessaies d'ouvrir l'une des deux bases et celle nouvellement créée.

Dans ton message
Tiens Jérôme, pas en vacances !, bonjour,
Je ne peux pas ouvrir la deuxième base (celle sur le Pc avec l'application)
même en maintenance si la première est ouverte. Par contre, je peux ouvrir
les deux bases avec les données directement sur le serveur.
Je n'ai aucun message d'erreur. Lorsque je tente d'ouvrir une des deux bases
alors que l'autre est déjà ouverte, il affiche le formulaire en cours de la
base déjà ouverte et n'ouvre pas la deuxième base. C'est un peu comme si tu
veux ouvrir une base déjà ouverte, il t'affiche l'écran de la base déjà
ouverte, ce qui est normal.
Mais dans mon cas, il s'agit de deux bases différentes avec un nom différent
à des endroits différents donc je ne comprends pas. Le seul lien, pourrais-je
dire, est que j'ai créé la deuxième base à partir d'une copie de la première
car certains formulaires et structures de tables sont presque identiques.
Concernant les paramètres, les bases sont toutes en mode partagé par contre
toutes mes bases (celles-ci et les autres) sont en verrouillage
"enregistrement modifié" avec coché "ouvrir avec enregsitrements
verrouillés". J'ai appliqué ce paramétrage suite à une remarque lue sur le
forum.
A +
--
Nathalie



Hello,

As-tu un message d'erreur ou est-ce que les fenêtres se figent?
Peux tu ouvrir tes tables liées directement dans l'autre application
frontale?

As-tu vérifié dans Outils/OPtions/Onglet Avancé si:
-Mode d'ouverture en mode partagé
-Verrouillage par défaut Aucun

Cordialement

Bonjour Tisane,
Fidèle au poste, et les vacances ?
Merci de me répondre.
Je suis en cours de mise en place des bases fractionnées dont nous avons
déjà parlé ensemble. Je commence par mes deux plus petites bases et cela
commence mal !!! je suis incapable de les ouvrir ensemble comme tu as pu le
lire.
J'ouvre les deux bases par raccourci, dans les propriétés de celui-ci, j'ai
: Cible : C:DHLDHL.mdb
Démarrer dans :C:DHL
mais où mettre : "C:Program FilesMicrosoft OfficeOFFICE11MSACCESS.EXE"
A+






--
Cordialement,
Thierry

Tout pour réussir avec Access :
http://www.mpfa.info








Thierry (ze Titi)
Le #6314091
Ce qui s'est passé, je ne sais pas trop, je vais aller à la pêche aux
renseignements, ça m'intrigue.
L'essentiel est que ça fonctionne !
Bonne continuation.

En ce jour mémorable du vendredi 03/08/2007, tu as entrepris la lourde
tâche de taper sur ton clavier :
Bonjour Thierry,
Merci de ta suggestion.
Je crois que je vais devenir folle !
J'ai créé une nouvelle base et importé l'application de la base existante
puis je l'ai installée dans le répertoire du PC et là CA MARCHE !!
Je ne comprends pas, que s'est-il passé ???
A+
--
Nathalie



Bonjour Nathalie,

une suggestion bête... As-tu essayé d'ouvrir une nouvelle base et
d'importer tous les objets de l'une des bases récalcitrantes ? Ensuite
tu réessaies d'ouvrir l'une des deux bases et celle nouvellement créée.

Dans ton message
Tiens Jérôme, pas en vacances !, bonjour,
Je ne peux pas ouvrir la deuxième base (celle sur le Pc avec l'application)
même en maintenance si la première est ouverte. Par contre, je peux ouvrir
les deux bases avec les données directement sur le serveur.
Je n'ai aucun message d'erreur. Lorsque je tente d'ouvrir une des deux
bases alors que l'autre est déjà ouverte, il affiche le formulaire en
cours de la base déjà ouverte et n'ouvre pas la deuxième base. C'est un
peu comme si tu veux ouvrir une base déjà ouverte, il t'affiche l'écran de
la base déjà ouverte, ce qui est normal.
Mais dans mon cas, il s'agit de deux bases différentes avec un nom
différent à des endroits différents donc je ne comprends pas. Le seul
lien, pourrais-je dire, est que j'ai créé la deuxième base à partir d'une
copie de la première car certains formulaires et structures de tables sont
presque identiques. Concernant les paramètres, les bases sont toutes en
mode partagé par contre toutes mes bases (celles-ci et les autres) sont en
verrouillage "enregistrement modifié" avec coché "ouvrir avec
enregsitrements verrouillés". J'ai appliqué ce paramétrage suite à une
remarque lue sur le forum.
A +
--
Nathalie



Hello,

As-tu un message d'erreur ou est-ce que les fenêtres se figent?
Peux tu ouvrir tes tables liées directement dans l'autre application
frontale?

As-tu vérifié dans Outils/OPtions/Onglet Avancé si:
-Mode d'ouverture en mode partagé
-Verrouillage par défaut Aucun

Cordialement

Bonjour Tisane,
Fidèle au poste, et les vacances ?
Merci de me répondre.
Je suis en cours de mise en place des bases fractionnées dont nous avons
déjà parlé ensemble. Je commence par mes deux plus petites bases et cela
commence mal !!! je suis incapable de les ouvrir ensemble comme tu as pu
le lire.
J'ouvre les deux bases par raccourci, dans les propriétés de celui-ci,
j'ai
Cible : C:DHLDHL.mdb
Démarrer dans :C:DHL

mais où mettre : "C:Program FilesMicrosoft
OfficeOFFICE11MSACCESS.EXE" A+






--
Cordialement,
Thierry

Tout pour réussir avec Access :
http://www.mpfa.info






--
Cordialement,
Thierry

Tout pour réussir avec Access :
http://www.mpfa.info






Nathalie Lebas
Le #6314081
Merci de m'avoir sauvé !
Pour ceux comme moi qui partent en vacances, bonnes vacances et pour les
courageux qui restent, bon courage !!
Merci encore de votre aide à tous
--
Nathalie



Ce qui s'est passé, je ne sais pas trop, je vais aller à la pêche aux
renseignements, ça m'intrigue.
L'essentiel est que ça fonctionne !
Bonne continuation.

En ce jour mémorable du vendredi 03/08/2007, tu as entrepris la lourde
tâche de taper sur ton clavier :
Bonjour Thierry,
Merci de ta suggestion.
Je crois que je vais devenir folle !
J'ai créé une nouvelle base et importé l'application de la base existante
puis je l'ai installée dans le répertoire du PC et là CA MARCHE !!
Je ne comprends pas, que s'est-il passé ???
A+
--
Nathalie



Bonjour Nathalie,

une suggestion bête... As-tu essayé d'ouvrir une nouvelle base et
d'importer tous les objets de l'une des bases récalcitrantes ? Ensuite
tu réessaies d'ouvrir l'une des deux bases et celle nouvellement créée.

Dans ton message
Tiens Jérôme, pas en vacances !, bonjour,
Je ne peux pas ouvrir la deuxième base (celle sur le Pc avec l'application)
même en maintenance si la première est ouverte. Par contre, je peux ouvrir
les deux bases avec les données directement sur le serveur.
Je n'ai aucun message d'erreur. Lorsque je tente d'ouvrir une des deux
bases alors que l'autre est déjà ouverte, il affiche le formulaire en
cours de la base déjà ouverte et n'ouvre pas la deuxième base. C'est un
peu comme si tu veux ouvrir une base déjà ouverte, il t'affiche l'écran de
la base déjà ouverte, ce qui est normal.
Mais dans mon cas, il s'agit de deux bases différentes avec un nom
différent à des endroits différents donc je ne comprends pas. Le seul
lien, pourrais-je dire, est que j'ai créé la deuxième base à partir d'une
copie de la première car certains formulaires et structures de tables sont
presque identiques. Concernant les paramètres, les bases sont toutes en
mode partagé par contre toutes mes bases (celles-ci et les autres) sont en
verrouillage "enregistrement modifié" avec coché "ouvrir avec
enregsitrements verrouillés". J'ai appliqué ce paramétrage suite à une
remarque lue sur le forum.
A +
--
Nathalie



Hello,

As-tu un message d'erreur ou est-ce que les fenêtres se figent?
Peux tu ouvrir tes tables liées directement dans l'autre application
frontale?

As-tu vérifié dans Outils/OPtions/Onglet Avancé si:
-Mode d'ouverture en mode partagé
-Verrouillage par défaut Aucun

Cordialement

Bonjour Tisane,
Fidèle au poste, et les vacances ?
Merci de me répondre.
Je suis en cours de mise en place des bases fractionnées dont nous avons
déjà parlé ensemble. Je commence par mes deux plus petites bases et cela
commence mal !!! je suis incapable de les ouvrir ensemble comme tu as pu
le lire.
J'ouvre les deux bases par raccourci, dans les propriétés de celui-ci,
j'ai
Cible : C:DHLDHL.mdb
Démarrer dans :C:DHL

mais où mettre : "C:Program FilesMicrosoft
OfficeOFFICE11MSACCESS.EXE" A+






--
Cordialement,
Thierry

Tout pour réussir avec Access :
http://www.mpfa.info






--
Cordialement,
Thierry

Tout pour réussir avec Access :
http://www.mpfa.info











Publicité
Poster une réponse
Anonyme