pack Apache-MySQL-PHP

Le
Vincent
Bonjour,

j'ai un mal fou à configurer mon pc Linux en serveur (apache-php et mysql).

Sous windows j'utilise easyphp , existe t'il la même sous Linux ?

merci

http://devw.blogonyou.com
http://blogonyou.com
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
noone
Le #1901040
On Fri, 07 Sep 2007 20:14:56 +0200, Vincent wrote:

Bonjour,

j'ai un mal fou à configurer mon pc Linux en serveur (apache-php et mysql).

Sous windows j'utilise easyphp , existe t'il la même sous Linux ?

merci

http://devw.blogonyou.com
http://blogonyou.com


oui si tu utilises une ditrib qui est bien foutu (donc les
dépendances) oui.
allez une démo en live :

$ apt-cache search php4 | grep mod | grep "apache.*1"
libapache-mod-php4 - server-side, HTML-embedded scripting language (apache 1.3 module)
$ apt-get install libapache-mod-php4
Reading package lists... Done
Building dependency tree... Done
The following extra packages will be installed:
apache-common libzzip-0-12 php4-common
Suggested packages:
apache apache-ssl apache-perl php-pear
The following NEW packages will be installed
apache-common libapache-mod-php4 libzzip-0-12 php4-common
0 upgraded, 4 newly installed, 0 to remove and 0 not upgraded.
Need to get 2685kB of archives.
After unpacking 6726kB of additional disk space will be used.
Do you want to continue [Y/n]?



Ensuite y a plus qu'a faire la meme chose avec mysql

Mihamina (R12y) Rakotomandimby
Le #1901026
wrote:
j'ai un mal fou à configurer mon pc Linux en serveur (apache-php et mysql)
Sous windows j'utilise easyphp , existe t'il la même sous Linux ?



tu n'a pas dit quelle distribution tu utilises.

$ apt-cache
$ apt-get
Do you want to continue [Y/n]?
Ensuite y a plus qu'a faire la meme chose avec mysql


Pfff.
# apt-get install php5 mysql-server apache2

Et c'est bon. Pas besoin de "faire la meme chose" plusieurs fois.


Calimero
Le #1901025
Mihamina (R12y) Rakotomandimby wrote:
wrote:

j'ai un mal fou à configurer mon pc Linux en serveur (apache-php et
mysql)
Sous windows j'utilise easyphp , existe t'il la même sous Linux ?




tu n'a pas dit quelle distribution tu utilises.

$ apt-cache $ apt-get Do you want to continue [Y/n]?
Ensuite y a plus qu'a faire la meme chose avec mysql



Pfff.
# apt-get install php5 mysql-server apache2

Et c'est bon. Pas besoin de "faire la meme chose" plusieurs fois.


Il faut un petit "php[45]-mysql" aussi, pour ajouter le support MySQL
à PHP.

--
@+
Calimero



Mihamina (R12y) Rakotomandimby
Le #1901006
Calimero wrote:
# apt-get install php5 mysql-server apache2
Il faut un petit "php[45]-mysql" aussi



Sur ce cas, le meta-package LAMP n'aurait été de trop...
Je me tate de filer un bug.


Vincent
Le #1901003
heu?! j'ai rien compris :)

je suis désolé

Vincent


http://devw.blogonyou.com


"Mihamina (R12y) Rakotomandimby" message de news: fbseuf$24rk$
Calimero wrote:
# apt-get install php5 mysql-server apache2
Il faut un petit "php[45]-mysql" aussi



Sur ce cas, le meta-package LAMP n'aurait été de trop...
Je me tate de filer un bug.




Fabien LE LEZ
Le #1900986
On Fri, 7 Sep 2007 23:26:00 +0200, "Vincent" :

heu?! j'ai rien compris :)


D'après ton smiley, tu as l'air satisfait de n'avoir rien compris.
Si ce n'est pas effectivement le cas, jette un oeil sur ce site, c'est
une mine d'or :
Thierry B.
Le #1900953
--{ a plopé ceci: }--


$ apt-cache search php4 | grep mod | grep "apache.*1"


php4 is dying.

--
La loi est dure, mais c'est la loi, et elle est rappelée chaque
quinzaine par Thomas Nemeth (qui poste encore au moins ça) dans ses
conseils d'utilisation que tu aurais dû parcourir.
--{ Duralex, sed LaTeX }--

Publicité
Poster une réponse
Anonyme