Page toute blanche : pourquoi ?

Le
Gloops
Bonjour tout le monde,

J'ai un problème avec une de mes pages. Alors qu'elle s'affiche très =

bien sous Firefox (si on met de côté le caractère esthétiquement =

discutable de la mise en forme, ce qui est un autre sujet), Internet
Explorer s'avère incapable d'afficher autre chose qu'une page toute bla=
nche.

Plus étrange encore, la version anglaise de la même page s'affiche bi=
en
dans les deux, alors que je ne vois pas de différence flagrante de
structure.

Ce problème se pose (du moins j'en ai pris conscience) depuis que j'ai =

passé ces deux pages à la norme XHTML, pour pouvoir les migrer
ultérieurement vers ASP.

J'ai été alerté par le fait que lors de la lecture de comparaison, =

j'obtiens le contenu des deux pages si je lis la page française en
premier, alors que si je lis la page anglaise en premier, la française =

reste vide. Il faut préciser pour ceux à qui ça dira quelque chose,=
que
ce que j'appelle lecture de comparaison charge la première page dans un=
e
structure XmlDataDocument, et la deuxième dans un webBrowser, car je
n'ai pas trouvé le moyen pour le moment de lire un GetElementById dans =

un XmlDataDocument. Ceci sera suivi dans le groupe csharp, je le
mentionne ici à titre de curiosité. Dans la page française le webBr=
owser
voit 8 éléments au lieu d'une soixantaine. Dans ces huit éléments=
il y a
HEAD et BODY donc il ne devrait pas être exclus de trouver le reste à=

l'intérieur, mais il faudra y passer plus de temps.

Voici donc l'adresse de la page coquette :

http://www.zailes.org/fr/Retard/Retard.htm

et celle de la version anglaise, qui s'affiche dans les deux navigateurs =
:

http://www.zailes.org/en/Retard/Delayed_launch_of_a_program.htm

J'ai vu une erreur (même une incohérence) dans la mention des langues=
,
en tête de page, je gèrerai ceci dans la semaine, mais je ne m'attend=
s
pas à un miracle juste à partir de ceci.

Si quelqu'un va plus vite que moi, je veux bien un tuyau

Testé sous Firefox 2.0.0.12, Internet Explorer 7.0.5730.13, webBrowser =

de mshtml 4.0.0.0 à partir de VS2005, le tout sur Windows XP Home (mise=

à jour il y a une ou deux semaines).
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Gloops
Le #12830291
[Incompatibilité d'une page avec IE]

Ne cherchez plus, j'ai trouvé.

J'ai remplacé


par


Firefox accepte les deux, mais IE n'accepte que la deuxième syntaxe.


_____________________________________
Gloops a écrit, le 24/02/2008 23:14 :
Bonjour tout le monde,

J'ai un problème avec une de mes pages. Alors qu'elle s'affiche trè s
bien sous Firefox (si on met de côté le caractère esthétiquemen t
discutable de la mise en forme, ce qui est un autre sujet), Internet
Explorer s'avère incapable d'afficher autre chose qu'une page toute
blanche.

Plus étrange encore, la version anglaise de la même page s'affiche bien
dans les deux, alors que je ne vois pas de différence flagrante de
structure.

Ce problème se pose (du moins j'en ai pris conscience) depuis que j'a i
passé ces deux pages à la norme XHTML, pour pouvoir les migrer
ultérieurement vers ASP.

J'ai été alerté par le fait que lors de la lecture de comparaison ,
j'obtiens le contenu des deux pages si je lis la page française en
premier, alors que si je lis la page anglaise en premier, la français e
reste vide. Il faut préciser pour ceux à qui ça dira quelque chos e, que
ce que j'appelle lecture de comparaison charge la première page dans une
structure XmlDataDocument, et la deuxième dans un webBrowser, car je
n'ai pas trouvé le moyen pour le moment de lire un GetElementById dan s
un XmlDataDocument. Ceci sera suivi dans le groupe csharp, je le
mentionne ici à titre de curiosité. Dans la page française le web Browser
voit 8 éléments au lieu d'une soixantaine. Dans ces huit élémen ts il y a
HEAD et BODY donc il ne devrait pas être exclus de trouver le reste à
l'intérieur, mais il faudra y passer plus de temps.

Voici donc l'adresse de la page coquette :

http://www.zailes.org/fr/Retard/Retard.htm

et celle de la version anglaise, qui s'affiche dans les deux navigateur s :

http://www.zailes.org/en/Retard/Delayed_launch_of_a_program.htm

J'ai vu une erreur (même une incohérence) dans la mention des langu es,
en tête de page, je gèrerai ceci dans la semaine, mais je ne m'atte nds
pas à un miracle juste à partir de ceci.

Si quelqu'un va plus vite que moi, je veux bien un tuyau ...

Testé sous Firefox 2.0.0.12, Internet Explorer 7.0.5730.13, webBrowse r
de mshtml 4.0.0.0 à partir de VS2005, le tout sur Windows XP Home (mi se
à jour il y a une ou deux semaines).



Schmol 44
Le #12830281
Gloops avait écrit le 25/02/2008 :
[Incompatibilité d'une page avec IE]

Ne cherchez plus, j'ai trouvé.

J'ai remplacé


par


Firefox accepte les deux, mais IE n'accepte que la deuxième syntaxe.


_____________________________________
Gloops a écrit, le 24/02/2008 23:14 :
Bonjour tout le monde,

J'ai un problème avec une de mes pages. Alors qu'elle s'affiche très bien
sous Firefox (si on met de côté le caractère esthétiquement discutable de
la mise en forme, ce qui est un autre sujet), Internet Explorer s'avère
incapable d'afficher autre chose qu'une page toute blanche.

Plus étrange encore, la version anglaise de la même page s'affiche bien
dans les deux, alors que je ne vois pas de différence flagrante de
structure.

Ce problème se pose (du moins j'en ai pris conscience) depuis que j'ai
passé ces deux pages à la norme XHTML, pour pouvoir les migrer
ultérieurement vers ASP.

J'ai été alerté par le fait que lors de la lecture de comparaison,
j'obtiens le contenu des deux pages si je lis la page française en premier,
alors que si je lis la page anglaise en premier, la française reste vide.
Il faut préciser pour ceux à qui ça dira quelque chose, que ce que
j'appelle lecture de comparaison charge la première page dans une structure
XmlDataDocument, et la deuxième dans un webBrowser, car je n'ai pas trouvé
le moyen pour le moment de lire un GetElementById dans un XmlDataDocument.
Ceci sera suivi dans le groupe csharp, je le mentionne ici à titre de
curiosité. Dans la page française le webBrowser voit 8 éléments au lieu
d'une soixantaine. Dans ces huit éléments il y a HEAD et BODY donc il ne
devrait pas être exclus de trouver le reste à l'intérieur, mais il faudra y
passer plus de temps.

Voici donc l'adresse de la page coquette :

http://www.zailes.org/fr/Retard/Retard.htm

et celle de la version anglaise, qui s'affiche dans les deux navigateurs :

http://www.zailes.org/en/Retard/Delayed_launch_of_a_program.htm

J'ai vu une erreur (même une incohérence) dans la mention des langues, en
tête de page, je gèrerai ceci dans la semaine, mais je ne m'attends pas à
un miracle juste à partir de ceci.

Si quelqu'un va plus vite que moi, je veux bien un tuyau ...

Testé sous Firefox 2.0.0.12, Internet Explorer 7.0.5730.13, webBrowser de
mshtml 4.0.0.0 à partir de VS2005, le tout sur Windows XP Home (mise à jour
il y a une ou deux semaines).






Bonjour et Bravo,

Hier j'ai regardé le source de tes 2 pages et le haut me paraissait
bizarre, mais ça ne m'a pas sauté aux yeux ;-)
J'ai déjà remarqué que "FireFox" était plus "laxiste" au niveau de la
lecture des balises que IE :-(
J'ai par exemple un livre d'or sur mon site en PHP, je ne peux entrer
dans le menu de gestion qu'avec "FireFox" et apparemment je ne suis pas
le seul, j'ai posté au créateur qui n'a pas trouvé la solution, il y a
plus d'un an. :-?

--
Amicalement
Schmol 44
e-mail : hcheli@#nospam#club-internet.fr
Site perso : http://hcheli.ville-orvault.net/

"Une Question eststupide tant qu'elle n'est pas posée"
Jean Pierre
Le #12830271
Dans son message news:u%,
Gloops
Bonjour tout le monde,

J'ai un problème avec une de mes pages. Alors qu'elle s'affiche très
bien sous Firefox (si on met de côté le caractère esthétiquement
discutable de la mise en forme, ce qui est un autre sujet), Internet
Explorer s'avère incapable d'afficher autre chose qu'une page toute
blanche.
Plus étrange encore, la version anglaise de la même page s'affiche
bien dans les deux, alors que je ne vois pas de différence flagrante
de structure.

Ce problème se pose (du moins j'en ai pris conscience) depuis que j'ai
passé ces deux pages à la norme XHTML, pour pouvoir les migrer
ultérieurement vers ASP.

J'ai été alerté par le fait que lors de la lecture de comparaison,
j'obtiens le contenu des deux pages si je lis la page française en
premier, alors que si je lis la page anglaise en premier, la française
reste vide. Il faut préciser pour ceux à qui ça dira quelque chose,
que ce que j'appelle lecture de comparaison charge la première page
dans
une structure XmlDataDocument, et la deuxième dans un webBrowser, car
je n'ai pas trouvé le moyen pour le moment de lire un GetElementById
dans
un XmlDataDocument. Ceci sera suivi dans le groupe csharp, je le
mentionne ici à titre de curiosité. Dans la page française le
webBrowser voit 8 éléments au lieu d'une soixantaine. Dans ces huit
éléments il y a HEAD et BODY donc il ne devrait pas être exclus de
trouver le reste à l'intérieur, mais il faudra y passer plus de temps.

Voici donc l'adresse de la page coquette :

http://www.zailes.org/fr/Retard/Retard.htm

et celle de la version anglaise, qui s'affiche dans les deux
navigateurs :
http://www.zailes.org/en/Retard/Delayed_launch_of_a_program.htm

J'ai vu une erreur (même une incohérence) dans la mention des langues,
en tête de page, je gèrerai ceci dans la semaine, mais je ne m'attends
pas à un miracle juste à partir de ceci.

Si quelqu'un va plus vite que moi, je veux bien un tuyau ...

Testé sous Firefox 2.0.0.12, Internet Explorer 7.0.5730.13, webBrowser
de mshtml 4.0.0.0 à partir de VS2005, le tout sur Windows XP Home
(mise à jour il y a une ou deux semaines).



Bonjour,

Je viens de tester tes 2 liens et chez moi les 2 s'ouvrent sans problème
sous IE7.

Cdt.

Jean Pierre.
Hans Le Roy
Le #12830251
Bonjour Jean-Pierre,

"Jean Pierre" news:uyHtgF%

Bonjour,

Je viens de tester tes 2 liens et chez moi les 2 s'ouvrent sans problème
sous IE7.

Cdt.

Jean Pierre.



Comme Gloops a posté ce matin qu'il avait trouvé le hic, je crois que le
problème est résolu entretemps.

A+

Hans
Gloops
Le #12830181
Hans Le Roy a écrit, le 25/02/2008 21:19 :
Comme Gloops a posté ce matin qu'il avait trouvé le hic, je crois q ue le
problème est résolu entretemps.

A+

Hans



Finalement, il ne faut pas désespérer d'usenet : mon message du matin a
bien été lu :)
Gloops
Le #12830171
Schmol 44 a écrit, le 25/02/2008 09:37 :
Bonjour et Bravo,

Hier j'ai regardé le source de tes 2 pages et le haut me paraissait
bizarre, mais ça ne m'a pas sauté aux yeux ;-)



La chance que j'avais c'est que l'une des deux fonctionnait, je n'avais
plus qu'à comparer les syntaxes.

A propos, merci à ceux qui ont cherché. C'est un peu tardif et noyé dans
la masse, mais c'est dit ;)

J'ai déjà remarqué que "FireFox" était plus "laxiste" au niveau de la
lecture des balises que IE :-(



A vrai dire, w3.org n'est pas du même avis, puisque ma page avait été
déclarée "valid xhtml 1.1", avec une syntaxe comme avec l'autre.

Ce sont les concepteurs d'IE qui ont oublié d'implémenter la premiè re
syntaxe. Enfin bon, là, je suis en train de m'enfoncer en plein dans la
polémique que j'avais soigneusement évitée en première approche ; )

J'ai par exemple un livre d'or sur mon site en PHP, je ne peux entrer
dans le menu de gestion qu'avec "FireFox" et apparemment je ne suis pas
le seul, j'ai posté au créateur qui n'a pas trouvé la solution, i l y a
plus d'un an. :-?



Dis toujours l'adresse, il y aura bien quelques curieux pour aller voir.
Gloops
Le #12830161
Gloops a écrit, le 28/02/2008 19:19 :
J'ai par exemple un livre d'or sur mon site en PHP, je ne peux entrer
dans le menu de gestion qu'avec "FireFox" et apparemment je ne suis
pas le seul, j'ai posté au créateur qui n'a pas trouvé la soluti on, il
y a plus d'un an. :-?



Dis toujours l'adresse, il y aura bien quelques curieux pour aller voir .




Ah oui, à la réflexion, si c'est le menu de gestion, ça risque d'ê tre un
peu délicat à faire tester par tout le monde ...
Schmol 44
Le #12830111
Gloops avait écrit le 28/02/2008 :
Gloops a écrit, le 28/02/2008 19:19 :
J'ai par exemple un livre d'or sur mon site en PHP, je ne peux entrer dans
le menu de gestion qu'avec "FireFox" et apparemment je ne suis pas le
seul, j'ai posté au créateur qui n'a pas trouvé la solution, il y a plus
d'un an. :-?



Dis toujours l'adresse, il y aura bien quelques curieux pour aller voir.




Ah oui, à la réflexion, si c'est le menu de gestion, ça risque d'être un peu
délicat à faire tester par tout le monde ...



Oui, c'est exactement ce que je pensais à la lecture de ton 1er Post.
lol
merci quand même ;-)

--
Amicalement
Schmol 44
e-mail : hcheli@#nospam#club-internet.fr
Site perso : http://hcheli.ville-orvault.net/

"Une Question eststupide tant qu'elle n'est pas posée"
Publicité
Poster une réponse
Anonyme