Panne Firewire matérielle

Le
michele
Bestiole : MacBook Pro 15' core 2 duo 2,33 Ghz A1211 2006

Le Firewire 400 et 800 ne sont plus reconnus et crééent un problème au
démarrage : le boot n'arrive jamais sur le bureau.

Pour que le mac fonctionne nickel, il faut retirer les extensions
Firewire du système et tout va nickel.

J'ai vidé la PRam, j'ai resetté le SMC : pareil.

J'ai testé avec plusieurs systèmes : Snow usé sur DD, Snow neuf sur DD,
Lion neuf sur DD, les 2 systèmes sur CD, pareil :
Tant qu'il y a les extensions, ça boote très difficilement ou ça pédale
en rond indéfiniment.

En boot sur un live CD Linux (zorin), impec vu qu'il n'y a pas de driver
Firewire dans ma version 9 Lite.

Notes :
- Le jus passe bel et bien dans les tuyaux puisque les diodes des
disques externes s'allument et que les disques grattent.
.
- Une fois la carte-mère démontée, je ne trouve nulle part de point
brûlé ni sur les puces ni sur les soudures.

C'est pas que je sois tellement attachée au FW sur ce mac qui devrait
normalement finir chez un copain avec windows, mais quand même, je ne
vois pas où est la panne.

Mais le montage de la bestiole en target sur mon MBP i7 pour aller
fouillasser dans le disque peut parfois bien servir avec windows.

Et puis, j'aime comprendre.
Alors, je fais comment pour isoler le problème ?

--
Zoé demanda à Robinson de la croire et Robinson Crusoé
Quand les gros seront maigres, les maigres seront morts
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 4
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
voir_le_reply-to
Le #26387850
michele
Et puis, j'aime comprendre.



Là, c'est pas gagné ! Voir les fils récents sur fcom-ox !

Et ma propre expérience avec le macbook 13" unibody de ma fille
(ex-mien), sur lequel la tentative d'échange du DD par un SSD 250 a tenu
de la magie noire. Des boots externes avec demande de réinstallation
"from scratch" qui proposaient parfois snow léo, parfois El Capitan...
des blocages à mi-chemin laissant entendre en sous-jacent des problèmes
hardwares mystérieux...

Finalement il est "tombé en marche". Après plusieurs tentatives
successives et identiques (comme quoi il ne faut pas désespérer). Il y a
encore eu quelques salves de kernel panic comme je n'en ai jamais vues
(pour les débuts de chaque utilisateur) puis désormais une raisonnable
stabilité qui me fait hésiter à chercher plus loin (initialiser la PR ou
la SMC, comme toi ?). Il la joue "propre"... (et nous on la joue backups
fréquents et multiples !)

Alors, je fais comment pour isoler le problème ?



Dans la suite de ci-dessus : est-ce que ça vaut le coup de chercher si
désormais il fonctionne avec juste ça en moins ? J'ignore totalement si
le "wirefire" du mode Target est compatible avec le Thunderbolt via
adaptateurs (ni même si de tels adaptateurs existent, et si oui : 800 ou
400 ?), mais de toutes façons ça risque d'être éphémère, au fil des
renouvellements obligés (programmés ou pas).

Un simple vol ou cambriolage, incendie ou dégât des eaux, peut te forcer
à un ré-achat neuf qui va tout bouleverser (l'occasion n'étant pas
forcément disponible à l'identique de ce que tu voudrais).

Récemment, tant qu'à devoir racheter ainsi un Apple TV avec les sous de
l'assurance, j'ai opté pour le nouveau (avec ce khon de Siri). Gros
malin ! Incompatible avec mon iPad 2 et mon iPhone 4 ! C'est pas que je
m'en servais tant que ça du renvoi sur l'écran du télé, mais en famille,
pour montrer à tous une photo ou deux, c'était bien pratique ! Grrr !

Bref, bon courage et tiens nous au courant (j'aime m'instruire !).

--
Gérald
michele
Le #26387851
Gerald wrote: [...] te forcer à un ré-achat neuf



Ah non, ça, c'est pas possible. Je suis incapable de jeter un truc qui
fonctionne (ou dont les avanies sont sous contrôle et inopérantes) quand
je sais que quelqu'un sera très heureux de pouvoir s'en servir.

Si je sais le faire, je répare, je suis incapable de faire autrement,
c'est nerveux.
Le genre "je jette parce que le neuf, c'est tellement plus beaucoup
mieux", ça me hérisse le poil.

Bref, bon courage et tiens nous au courant (j'aime m'instruire !).



Ben, à part trouver un electronicien pour tester avec le "compteur qui a
une aiguille" pour savoir où "le flux d'informations est arrêté" et
éventuellement faire une déviation avec un cable pour faire passer les
infos par un autre chemin, je vois pas.
(Ça te situe mon niveau en électronique).


Tu me diras, je connais un MBP 2010 avec la puce SMC dans les choux ; je
me disais que trouver une CM avec vidéo dans les choux, lui prendre sa
puce SMC vivante et la resouder sur ma CM, ce serait bien... Sauf que je
ne sais pas faire la partie dessoudage x 2 + ressoudage.
Enfin, la dernière fois que j'ai pris un fer, y'a eu des dégâts...

--
Zoé demanda à Robinson de la croire et Robinson Crusoé
Quand les gros seront maigres, les maigres seront morts
J.P
Le #26387854
In article (michele) wrote:

Pour que le mac fonctionne nickel, il faut retirer les extensions
Firewire du système



Ça se trouve où sous SL ?
J'ai un iMac 7,1 qui a un pb avec le FW400.
Le FW800 marche mais le 400 ne veut plus monter aucun de mes 3 disques
externes qui montent bien en USB.

--
Jean-Pierre
voir_le_reply-to
Le #26387878
michele
> Gerald wrote: [...] te forcer à un ré-achat neuf

Ah non, ça, c'est pas possible. Je suis incapable de jeter un truc qui
fonctionne



J'évoquais des cas où tu te trouvais *privée* de ta machine, pour une
raison ou une autre (volée...) !

Le genre "je jette parce que le neuf, c'est tellement plus beaucoup
mieux", ça me hérisse le poil.



Idem, à preuve l'ancienneté des éléments que je décrivais : macbook fin
2008, iPad2, iPhone4...

(Ça te situe mon niveau en électronique).



Ne te dévalorise pas : tu as su prouver bien des fois ici-même
...l'étendue de ta ténacité :-)

Et j'en profite d'ailleurs pour te demander de me rappeler les commandes
de vidage de PRAM (maj-pomme-p-r ? ou quelque chose comme ça ?) et reset
de SMC (vidage complet de batterie et recharge max ? ou autre ?) que tu
évoquais dans ta contrib' initiale. D'avance merci (flemmard d'aller
chercher sur le web !)

(Le macbook a des vapeurs au niveau charge batterie suite au changement
de disque et restauration système, or elle est neuve de décembre
dernier. Je trouve aussi que le ventilo tourne beaucoup, bien que la
machine ne soit que tiède mais pas chaude, ce qui peut expliquer la
batterie aussi...).

--
Gérald
Le Moustique
Le #26387877
Le 04/02/2016 09:07, Gerald a écrit :
Et j'en profite d'ailleurs pour te demander de me rappeler les commandes
de vidage de PRAM (maj-pomme-p-r ? ou quelque chose comme ça ?) et reset
de SMC (vidage complet de batterie et recharge max ? ou autre ?) que tu
évoquais dans ta contrib' initiale. D'avance merci (flemmard d'aller
chercher sur le web !)




"Ordinateurs portables Mac non dotés d’une batterie amovible

Les ordinateurs portables Mac non dotés d’une batterie amovible incluent
les suivants : le MacBook Pro (début 2009 et modèles ultérieurs), tous
les modèles de MacBook Air, le MacBook (fin 2009) et le MacBook (Retina,
12 pouces, début 2015).

Pour réinitialiser le SMC :

Éteignez l’ordinateur.
Branchez l’adaptateur MagSafe ou USB-C à une source d’alimentation,
ainsi qu’à votre ordinateur.
Sur le clavier intégré, appuyez simultanément sur les touches Maj +
Ctrl + Option (de gauche) et sur le bouton d’alimentation.
Relâchez en même temps toutes les touches et le bouton d’alimentation.
Appuyez sur le bouton d’alimentation pour allumer l’ordinateur.

Il est possible que le voyant des adaptateurs secteur MagSafe change de
couleur, ou s’éteigne temporairement, lorsque vous réinitialisez le SMC.
Ordinateurs portables Mac dotés d’une batterie amovible

Les anciens MacBook et MacBook Pro sont dotés d’une batterie amovible.

Pour réinitialiser le SMC :

Éteignez l’ordinateur.
Déconnectez l’adaptateur secteur MagSafe de l’ordinateur, le cas
échéant.
Retirez la batterie.
Maintenez le bouton d’alimentation enfoncé pendant cinq secondes.
Relâchez le bouton d’alimentation.
Reconnectez la batterie et rebranchez l’adaptateur secteur MagSafe.
Appuyez sur le bouton d’alimentation pour allumer l’ordinateur."


(Source : https://support.apple.com/fr-fr/HT201295)


(Le macbook a des vapeurs au niveau charge batterie suite au changement
de disque et restauration système, or elle est neuve de décembre
dernier. Je trouve aussi que le ventilo tourne beaucoup, bien que la
machine ne soit que tiède mais pas chaude, ce qui peut expliquer la
batterie aussi...).



Si tu as installé un SSD non-Apple, la gestion du trim est prise en
charge par ElCap mais pas par Yosemite (on peut la forcer en exécutant
la commande "sudo trimforce enable" dans le Terminal), et encore moins
par les OS précédents (ce qui impose l'usage de Trim Enabler, appli
facile à trouver et gratuite dans sa version de base).

De même pour le ventilateur : le SSD non-Apple ne renvoyant pas
l'information de température telle que la carte-mère l'attend, cette
dernière enclenche le ventilo à pleine vitesse. Utilise une appli comme
MacsFanControl (gratuite aussi), à utiliser dès le démarrage bien sûr.


--
/)
-:oo= Guillaume
)
Je nettoyais mon clavier, et le coup est parti tout seul.
voir_le_reply-to
Le #26387884
Le Moustique
Pour réinitialiser le SMC [...]

Si tu as installé un SSD non-Apple, la gestion du trim est prise en
charge par ElCap [...]

De même pour le ventilateur : le SSD non-Apple ne renvoyant pas
l'information de température telle que la carte-mère l'attend, cette
dernière enclenche le ventilo à pleine vitesse. Utilise une appli comme
MacsFanControl (gratuite aussi), à utiliser dès le démarrage bien sûr.



Informations complètes, efficaces, que du bonheur.

Grand merci à toi (du coup je renomme pour que ça puisse servir)

--
Gérald
michele
Le #26387952
Gerald : vidage de PRAM (maj-pomme-p-r) ?



Pour la PRam :

Machine éteinte.
- Enfoncer les 4 touches en même temps : CMD + ALT + P + R
- Appuyez sur le bouton de démarrage (avec le pied)
tout en maintenant les 4 touches enfoncées.
- Ne pas lâcher les 4 touches les touches enfoncées jusqu'à
ce que l'ordinateur redémarre à 2 reprises (2 fois le boing).

--
Zoé demanda à Robinson de la croire et Robinson Crusoé
Quand les gros seront maigres, les maigres seront morts
michele
Le #26387953
Le Moustique : Trim Enabler


Je préfère cameleon. Gratuit itou.

SSD non-Apple ; info de température ; CM enclenche le ventilo
à pleine vitesse. Utilise MacsFanControl.



J'ai mis des SSD partout (512 Go dans mon Early 2011 de mon côté) et
jamais eu d'affolement des ventilos. Pourtant je fais du photoshop sur
de grosse images velues.


--
Zoé demanda à Robinson de la croire et Robinson Crusoé
Quand les gros seront maigres, les maigres seront morts
michel.vauquois
Le #26387960
michele
- Enfoncer les 4 touches en même temps : CMD + ALT + P + R
- Appuyez sur le bouton de démarrage (avec le pied)
tout en maintenant les 4 touches enfoncées.



C'est peut-être plus simple de démarrer d'abord puis de faire
cmd + alt + P + R... surtout que ça marche aussi bien !
--
Michel Vauquois
Que Dieu vous garde... Moi j'ai pas le temps (RD)
MàJ 2015 : Matière à voir :
michele
Le #26388044
J.P : Ça se trouve où sous SL ?
J'ai un iMac 7,1 qui a un pb avec le FW400.
Le FW800 marche mais le 400 ne veut plus monter aucun
de mes 3 disques externes qui montent bien en USB.




Ce sont les mêmes extensions pour le 400 et le 800.

Dans mon Mavericks (pareil que pour Snow. Peut-être les extensions
portent-elles un nom un peu différent) :
DisqueDur -> Dossier Systèmer -> Dossier Bibliothèquer -> Dossier
Extensions :
IOFireWireAVC.kext
IOFireWireFamily.kext
IOFireWireIP.kext
IOFireWireSBP2.kext
IOFireWireSerialBusProtocolTransport.kext

Si tu les vires, le 400 comme le 800 sera inactif.

Tel que tu décris ton problème, ça sent les disques durs externes
auto-alimentés qui demandent trop d'alim au FW 400.
Publicité
Poster une réponse
Anonyme