Paquets cassés

Le
Bernard Meylan
Lors d'une mise à jour (Linux Mint 9) l'installateur refuse de continuer
parce que j'aurais soi-disant des paquets cassés mais Synaptic, avec
le filtre "cassés" ne me montre rien du tout pas de paquets cassés!
C'est ennuyeux parce que la MàJ est bloquée

Des idées pour continuer?

Bernard
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jacques Pronchery
Le #22992581
Le 05/01/2011 19:21, Bernard Meylan a écrit :
Lors d'une mise à jour (Linux Mint 9) l'installateur refuse de continuer
parce que j'aurais soi-disant des paquets cassés... mais Synaptic, avec
le filtre "cassés" ne me montre rien du tout... pas de paquets cassés!
C'est ennuyeux parce que la MàJ est bloquée...

Des idées pour continuer?

Bernard



Bonjour,

Regarde la doc de apt-get il y a des commandes pour réparer.
Sinon sauvegarde tes données et installe Linux Mint 10

Jacques.
jp willm
Le #22993491
Bonjour,

Le 05/01/2011 19:21, Bernard Meylan a écrit :
Lors d'une mise à jour (Linux Mint 9) l'installateur refuse de continuer
parce que j'aurais soi-disant des paquets cassés... mais Synaptic, avec
le filtre "cassés" ne me montre rien du tout... pas de paquets cassés!
C'est ennuyeux parce que la MàJ est bloquée...

Des idées pour continuer?



Essayez :

sudo dpkg --configure -a

--
http://pagesperso-orange.fr/willms/
Hugolino
Le #22996651
Le 05-01-2011, Bernard Meylan
Lors d'une mise à jour (Linux Mint 9) l'installateur refuse de continuer
parce que j'aurais soi-disant des paquets cassés...



Quel est le message d'erreur exactement ?

mais Synaptic, avec le filtre "cassés" ne me montre rien du tout...
pas de paquets cassés! C'est ennuyeux parce que la MàJ est
bloquée...

Des idées pour continuer?



Un bon début :
aptitude -f install

HTH


--
IMPORTANT NOTICE TO PURCHASERS: The entire physical universe, including
this product, may one day collapse back into an infinitesimally small
space. Should another universe subsequently re-emerge, the existence of
this product in that universe cannot be guaranteed.
Bernard Meylan
Le #22999961
Le 07. 01. 11 00:08, Hugolino a écrit :

Un bon début :
aptitude -f install



Le problème est résolu... par arrêt de l'arbitre!

J'ai bien fait les 2 commandes

sudo dpkg --configure -a
aptitude -f install

ce qui n'a rien donné du tout, le message d'erreur persistant. J'ai donc
tenté la MàJ par paquets de 5, en me disant que le paquet qui causait ce
message allait forcément se trouver dans un de ces groupes. C'est vers
la fin, alors que pratiquement tous les paquets étaient à jour, que le
coupable s'est démasqué: le paquet KDE qui gère les effets de bureau. Je
ne m'en sert pas donc je me suis dit: hop! loin du bal! Depuis... plus
de bureau! Rien que du noir... ;-) J'ai dû désinstaller des dépendances
par erreur... Pas grave, je vais réinstaller tout ça en Mint 10 64.

Merci pour vos réactions.

Bernard
jp willm
Le #23000281
Hello,

Le 07/01/2011 22:37, Bernard Meylan a écrit :
C'est vers
la fin, alors que pratiquement tous les paquets étaient à jour, que le
coupable s'est démasqué:



Et tu es sûr d'avoir assez de place sur ta partition ?

df ou df -h

--
http://perso.orange.fr/willms/index.html
Publicité
Poster une réponse
Anonyme