parametre vga au boot

Le
Rice Cooker
Bonjour,

j'ai un petit souci depuis un moment pas bien grave mais je voudrais
comprendre.
Je démarre mon noyau ainsi (extrait de mon menu.lst de grub) :

<--
title Debian GNU/Linux, kernel 2.6.27.1
root (hd0,0)
kernel /boot/vmlinuz-2.6.27.1 root=/dev/sda1 ro vgay1 splash=silent
initrd /boot/initrd.img-2.6.27.1
>

Depuis, je crois, une mise à jour de mon système, le paramètre vgay1 ne
semble plus être pris en compte, je me retrouve avec une console
"basique" (80 colonnes, il me semble).

J'utilise un noyau compilé par mes soins, qui n'a pas bougé depuis
un moment (et avant ça fonctionnait avec ce même noyau).

J'ai essayé de voir ce qui se passait par un
dmesg | more
mais je ne trouve pas d'infos intéressantes dans ce qu'il me donne.

pour info :
# grub --version
grub (GNU GRUB 0.97)

Quelqu'un aurait une idée ?

--
Tanguy
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Emmanuel Florac
Le #21434571
Le Wed, 24 Mar 2010 11:10:14 +0100, Rice Cooker a écrit:


Depuis, je crois, une mise à jour de mon système, le paramètre vgay1
ne semble plus être pris en compte, je me retrouve avec une console
"basique" (80 colonnes, il me semble).

J'utilise un noyau compilé par mes soins, qui n'a pas bougé depuis un
moment (et avant ça fonctionnait avec ce même noyau).



Tu n'as pas changé de carte graphique ou autre?

--
Jesus saves but only Buddha makes incremental backups.
Rice Cooker
Le #21435321
Le Wed, 24 Mar 2010 20:17:49 +0000, Emmanuel Florac a écrit:

Le Wed, 24 Mar 2010 11:10:14 +0100, Rice Cooker a écrit:


Depuis, je crois, une mise à jour de mon système, le paramètre vgay1
ne semble plus être pris en compte, je me retrouve avec une console
"basique" (80 colonnes, il me semble).

J'utilise un noyau compilé par mes soins, qui n'a pas bougé depuis un
moment (et avant ça fonctionnait avec ce même noyau).



Tu n'as pas changé de carte graphique ou autre?




non non, la seule chose qui ait changé, c'est que j'ai fait
une mise à jour de mon système.
J'ai du mal à comprendre ce qui s'est passé ; si déjà quelqu'un
pouvait me dire où chercher ça m'avancerait, parce que là franchement,
je sèche.


--
Tanguy
Dominique MICOLLET
Le #21435671
Rice Cooker wrote:

non non, la seule chose qui ait changé, c'est que j'ai fait
une mise à jour de mon système.
J'ai du mal à comprendre ce qui s'est passé ; si déjà quelqu'un
pouvait me dire où chercher ça m'avancerait, parce que là franchement,
je sèche.





Essayez de remplacer vga=... par vga=ask et de rebooter.

Si tout va bien, le noyau va vous demander de préciser quelle valeur
donner.

Sinon cela signifierai que votre noyau ne supporte plus cette
fonctionnalité : peut-être y a t'il eu une mise à jour de ce noyau ?

Il y a aussi des blagues avec le fait que la valeur numérique a été
interprétée pendant un temps en hexadecimal, puis en décimal (ou
l'inverse);
D'où l'intérêt du ask.

--
Dominique MICOLLET
Adresse email : enlever deux francs
Rice Cooker
Le #21436281
Le Thu, 25 Mar 2010 08:08:59 +0100, Dominique MICOLLET a écrit:




Essayez de remplacer vga=... par vga=ask et de rebooter.

Si tout va bien, le noyau va vous demander de préciser quelle valeur
donner.




J'avais essayé ça, mais je n'avais visiblement pas essayé les bonnes
valeurs. Je viens d'essayer avec vga05 et ça passe très bien.

Sinon cela signifierai que votre noyau ne supporte plus cette
fonctionnalité : peut-être y a t'il eu une mise à jour de ce noyau ?




non non, c'est le même depuis plus d'un an

Il y a aussi des blagues avec le fait que la valeur numérique a été
interprétée pendant un temps en hexadecimal, puis en décimal (ou
l'inverse);
D'où l'intérêt du ask.




merci !
Mais pour ma culture personnelle, qu'est ce qui a provoqué ce changement ?
(quel paquet ? Apparemment grub est toujours le même qu'il y a plusieurs
mois de cela.)



--
Tanguy
moi-meme
Le #21438501
Le Wed, 24 Mar 2010 11:10:14 +0100, Rice Cooker a écrit :

Depuis, je crois, une mise à jour de mon système, le paramètre vgay1
ne semble plus être pris en compte, je me retrouve avec une console
"basique" (80 colonnes, il me semble).



sur Debian lors d'une dernière mise à jour il a remis à jour (normal)
grub.

menu.lst était écrasé.

Va faire un tour du côté de /boot/grub/menu.lst des fois.
Rice Cooker
Le #21439611
Le Thu, 25 Mar 2010 14:51:31 +0000, moi-meme a écrit:


sur Debian lors d'une dernière mise à jour il a remis à jour (normal)
grub.




J'utilise la branche stable.
Dans la liste des mises à jour,
http://www.debian.org/News/2010/20100130
je ne vois pas grub.
Tu fais peut être référence à la branche unstable ou testing ?

menu.lst était écrasé.



Pas chez moi, d'après ce que je vois.


--
Tanguy
moi-meme
Le #21445721
Le Thu, 25 Mar 2010 18:58:15 +0100, Rice Cooker a écrit :

Tu fais peut être référence à la branche unstable ou testing ?



Ah non : du lenny pur et dur.
Rice Cooker
Le #21446071
Le Fri, 26 Mar 2010 21:30:48 +0000, moi-meme a écrit:



Ah non : du lenny pur et dur.




Tiens c'est curieux, la mise à jour t'a écrasé ton menu.lst ?
Pour ce que je vois sur mon pc, il est bien tel que je l'avais
laissé la dernière fois.


--
Tanguy
Dominique MICOLLET
Le #21447211
Rice Cooker wrote:

Le Thu, 25 Mar 2010 08:08:59 +0100, Dominique MICOLLET a écrit:
Sinon cela signifierai que votre noyau ne supporte plus cette
fonctionnalité : peut-être y a t'il eu une mise à jour de ce noyau ?




non non, c'est le même depuis plus d'un an



À moins qu'il ne s'agisse d'un noyau compilé in situ, s'il a plus d'un an,
je suis prêt à parier qu'il a subi quelques mises à jour de sécurité.

Mais pour ma culture personnelle, qu'est ce qui a provoqué ce changement ?
(quel paquet ? Apparemment grub est toujours le même qu'il y a plusieurs
mois de cela.)



Ben.... Il faudrait consulter /var/log/aptitude pour rechercher ce qui c'est
passé. Entre ce que l'on demande volontairement et ce qui se passe en
douce, il y a parfois des surprises si l'on n'est pas extrêmement attentif,
même si les gestionnaires de paquets sont généralement plutôt prévenants.

Je pencherai bien pour un changement du pilote vga de la carte, extérieur au
noyau (genre carte graphique surpuissante).

Cordialement.

--
Dominique MICOLLET
Adresse email : enlever deux francs
Rice Cooker
Le #21447251
Le Sat, 27 Mar 2010 10:58:59 +0100, Dominique MICOLLET a écrit:


À moins qu'il ne s'agisse d'un noyau compilé in situ, s'il a plus d'un
an, je suis prêt à parier qu'il a subi quelques mises à jour de
sécurité.




Comment ça ? C'est un noyau récupéré chez kernel.org, que j'ai configuré
et compilé ("à la Debian", j'ai fait un paquet deb à partir de tout ça)


Je pencherai bien pour un changement du pilote vga de la carte,
extérieur au noyau (genre carte graphique surpuissante).




C'est une carte assez basique (ATI radeon 7000).
J'utilise le driver "radeon".




--
Tanguy
Publicité
Poster une réponse
Anonyme