partage disques entre 98 et XP

Le
testeur
Bonjour,

Pour utiliser un ancien programme qui ne tourne que sous 98, j'ai réinstallé
W98-SE dans une machine virtuelle, le tout sous XP-SP3.
Pour partager les disques entre la machine réelle (NTFS) et W98, j'ai
également installé NTFS 98 qui fonctionne bien (vérifié en rajoutant un
disque NTFS dans la machine W98)
Par contre j'ai des problèmes de partage disque à travers le réseau.
La machine réelle XP voit bien les disques de la machine virtuelle W98, mais
impossible dans cette machine de connecter un lecteur réseau de la machine
réelle, j'ai toujours "Mot de passe incorrect Reessayez".
Je précise que les 2 machines ont le même user/mot de passe et workgroup.
Je fais cette manip tous les jours avec d'autres machines virtuelles sous XP
et Vista.
Sous W98 je ne peux entrer que le mot de passe, le user n'est pas demandé
(mais il est identique sur les 2 machines).
Ai je raté quelque chose ?

Merci d'avance.

Olivier
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Ascadix
Le #18204261
testeur n'a pas économisé ses octets pour nous raconter que:

Bonjour,

Pour utiliser un ancien programme qui ne tourne que sous 98, j'ai
réinstallé W98-SE dans une machine virtuelle,



Virtual PC ? VMware ?

le tout sous XP-SP3.



ça c'est l'hote ?

Pour partager les disques entre la machine réelle (NTFS) et W98, j'ai
également installé NTFS 98 qui fonctionne bien (vérifié en rajoutant
un disque NTFS dans la machine W98)



Si c'est pour accéder aux disques en réseau, aps besoin de NTFS98

Par contre j'ai des problèmes de partage disque à travers le réseau.
La machine réelle XP voit bien les disques de la machine virtuelle
W98, mais impossible dans cette machine de connecter un lecteur
réseau de la machine réelle, j'ai toujours "Mot de passe incorrect
Reessayez". Je précise que les 2 machines ont le même user/mot de passe et
workgroup. Je fais cette manip tous les jours avec d'autres machines
virtuelles sous XP et Vista.



J'éspére que ton partage sur le XP n'a pas un nom de +de 8 caractéres ?
Win9x ne sais pas gérer sinon.

Sous W98 je ne peux entrer que le mot de passe, le user n'est pas
demandé (mais il est identique sur les 2 machines).
Ai je raté quelque chose ?



Dasn les composants réseau du Win98, t'as quoi ?
"Ouverture de sesion Windows"
"Client réseau Microsoft"
"Gestionnaire de session individuelles Windows"
aut'chose ?

Essaye de mettre "Client réseau Microsoft" en ouverture de sesion principale

Merci d'avance.

Olivier



--
@+
Ascadix [MVP]
adresse @mail valide, mais ajoutez "sesame" dans l'objet pour que ça
arrive.
testeur
Le #18204591
Bonsoir, merci de m'avoir répondu.

ça c'est l'hote ?


Le test est fait sous VirtualPC2007, mais depuis j'ai essayé avec une autre
machine reelle sous W98 : idem

Si c'est pour accéder aux disques en réseau, pas besoin de NTFS98


Effectivement, mais je n'y ai pensé qu'après, comme ça ne marchait pas j'ai
eu le réflexe NTFS

J'éspére que ton partage sur le XP n'a pas un nom de +de 8 caractéres ?
Win9x ne sais pas gérer sinon.


Non , j'ai essayé avec plusieurs noms, y compris le partage administratif
(T$), idem
Mais j'ai déja le même message lorsque je clique sur le nom de la machine,
qui lui fait 9 caractères, est ce une piste ?

aut'chose ?


Dans ouverture de session, j'ai 2 choix :
Client pour les réseaux..
Ouverture de session windows

C'est déja positionné sur Client pour les réseaux ..

Essaye de mettre "Client réseau Microsoft" en ouverture de sesion
principale



Je vais essayer de faire le test entre deux machines virtuelles (une XP
,l'autre W98) avec des noms < 8 caractères.

Olivier
testeur
Le #18204861
Problème résolu:
C'est bien le nom de la machine qui fait 9 caractères qui pose problème.
Merci Microsoft pour le message d'erreur très explicite !
Je connaissais les restrictions pour les nom de fichiers, mais pas pour les
noms de machines .

Olivier
Ascadix
Le #18205281
testeur n'a pas économisé ses octets pour nous raconter que:

Problème résolu:
C'est bien le nom de la machine qui fait 9 caractères qui pose
problème. Merci Microsoft pour le message d'erreur très explicite !
Je connaissais les restrictions pour les nom de fichiers, mais pas
pour les noms de machines .



Bizarre, la limite sur le nom NETBIOS des machines il est à 15 car.
Par contre il est très chatouilleux sur les caractères, t'as intérêt à
rester dans le jeu de caractères [a-z;0-9] sans signes, ponctuation ni
accentuation

Un autre truc qui me reviens à l'esprit comme complication loufoque, c'est
un pb de mot de passe expiré ..pas expiré.

ça ne semble pas systématique, qq recherches rapide ne m'ont rien données et
n'ayant pu trop affaire à Win98, j'ai pas trop fouillé, mais grosso-modo il
se produit parfois le gag suivant:

Tu à un XP ..avec un compte "toto", son mot de passe pas vide, par ex :
"password"
Tout marche bien ..et un jour pan, les client XP peuvent toujours se
connecter ..mais plus les Win9x
Une des causes loufoques que j'ai eu c'est si en créant le compte sur le XP
t'as coché la case "le mot de passe n'expire jamais" ( bon ok c'est pas bien
..mais on le fait tous ) ..et bien, quand ce mot de passe dépasse la durée
de vie des mot de passe sur ce système, les clients Win98 ne peuvent plus se
connecter alors que les XP ne sont pas gênés.
Il suffit sur le XP de passer par la console de gestion user et de redéfinir
le mot de passe ( même en remettant le même) et ça remarche instantanément
pour les Win98 par le réseau

ça ne se produit que en poste à poste apparemment, je ne l'ai jamais eu sur
des postes reliés à un domaine avec ouverture de session sur domaine.

Olivier



--
@+
Ascadix [MVP]
adresse @mail valide, mais ajoutez "sesame" dans l'objet pour que ça
arrive.
testeur
Le #18209081
C'est pourtant bien la cause du problème, j'ai revalidé avec des noms de 8
et 9 caractères sur machine virtuelle, puis machine réelle, ça ne marche
pour W98 que si les machines du réseau ont un nom de 8 caractères ou moins.
Merci et bonnes fêtes

Olivier
Heffgé
Le #18283951
Bonjour,

Je ne mets pas en doute tes conclusions, les faits sont têtus, mais il y a
un truc entre XP et Win98 à propos de la résolution des noms Netbios. Pour
que ça fonctionne il faut sous XP activer "Netbios avec TCP/IP" dans les
propriétés avancées de TCP/IP (onglet WINS). Je suppose que c'était OK de ce
côté ?

Par contre ça doit marcher sans problème avec "ouverture de session
Windows".

Heffgé
testeur
Le #18284321
Non, je ne pense pas que Netbios avec TCP/IP soit nécessaire, c'est un
ancien protocole qui n'est plus utilisé, et chez moi il n'est pas activé sur
aucune machine..
Tests à l'appuis, c'est vraiment la longueur du nom réseau de la machine
qui importe.

Olivier
Ascadix
Le #18286491
testeur n'a pas économisé ses octets pour nous raconter que:

Non, je ne pense pas que Netbios avec TCP/IP soit nécessaire, c'est un
ancien protocole qui n'est plus utilisé, et chez moi il n'est pas
activé sur aucune machine..



Ho Ho Ho ..on va voir arrivee l'ami JCB qui va pousser un grand
NANNNNNNNNNNNNNNNNNNNNNNNN :-)

Tu confond NetBios et NetBEUI

NetBEUI est effectivement obsoléte et plus guère utilisé (on peut le mettre
sur XP, mais faut fouiller au fin fond du CD), actuellement on utilise
majoritairement IP

NetBIOS ..c'est nettement au-dessus come protocole, grosso-modo c'est lié à
toutes les fonctions de partage fichiers/imp et admin distantes de Widnwso,
ça peut s'utiliser par dessus IP, IPX, Netbeui, etc ....

Tests à l'appuis, c'est vraiment la longueur du nom réseau de la
machine qui importe.



Ben oui ..mais normalement ( et réélement ) la limite c'est à 15 caractères,
c'est anormal que tu soit bloqué à 9.


Olivier



--
@+
Ascadix [MVP]
adresse @mail valide, mais ajoutez "sesame" dans l'objet pour que ça
arrive.
testeur
Le #18287541
Autant pour moi, j'ai répondu un peu vite, c'est vrai que ça apparait dans
les propriétés comme Partage de fichiers et d'imprimantes et pas comme
Netbios.
J'avais un vague souvenir de Netbeui de ma jeunesse qui m'a induit d'erreur
!

Pour le problème en référence, j'ai refait les tests dans tous les sens, et
j'en arrive toujours à la même conclusion.
Pourtant mon windows98 est tout frais installé à partir du CD officiel
W98SE, et il ne voit les disques réseau que si la machine distante fait
moins de 9 caractères.
Enfin je fais avec....

Olivier
Heffgé
Le #18306451
J'ai profité de cette occasion pour tenter de confirmer ce qui n'était qu'un
vague souvenir. Il y a pas mal d'articles sur la toile qui traitent de ce
sujet dont:
http://membres.lycos.fr/ptinux/article.php3?id_article=3
http://technet.microsoft.com/fr-fr/library/cc738412.aspx
http://www.linux-france.org/~fclerc/article/serveur/netbios/#retour1

Depuis Windows 2000 il n'y a plus besoin de NBT (Netbios sur TCP/IP) pour la
résolution des noms mais ça reste une obligation pour les systèmes
antérieurs et donc dans un environnement mixte. Pour éviter les diffusions à
tout va on passe par un serveur WINS (Windows Internet Name Service) ou un
fichier lmhosts (là les adresses doivent être fixes).

Les noms Netbios sont de longueur fixe et font effectivement 15 caractères
(bourrage à blanc pour les noms plus courts) plus un qui contient un code
indiquant ce qui est nommé.

Comme on est dans un univers un peu spécial (machine virtuelle) est-ce qu'il
n'y aurait pas quelque chose d'ajouté au nom que tu donnes et que tu ne
verrais pas ? Peut-être que l'une des commandes nbtstat permettrait de
vérifier ça ?

FG
Publicité
Poster une réponse
Anonyme