Partage de disques d'un serveur Windows 7 avec linux

Le
Totor1er
Bonjour à tous.

Je voudrais, au travers de linux, accéder à des disques
partagés d'un serveur Windows 7.

2 disques ont été partagés sans mot de passe, avec "tout le
monde".
A partir d'ordis sous Windows, RAS, j'y accède sans
sourciller.
Mais à partir de Linux, quelle que soit la distrib, soit ça
plante, soit (les KDE), le SMBClient doit être configuré.

Il me demande en effet un login, mot de passe, domaine.
Pour le domaine, j'ai indiqué le workgroup, mais pour le
login, j'ai essayé plein de trucs:

Tout le monde, Everyone, NomDeServeurTout le monde, idem avec
everyone, \NomDeServeurtout le monde (idem everyone), en
mettant dans tous les essais l'adresse IP à la place du nom du
serveur

Bref, plein d'essais se soldant par un échec.

Maintenant, je n'ai plus d'idée. Pouvez vous m'aider?
Merci!
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Professeur M
Le #20433171
Le Tue, 27 Oct 2009 10:51:17 +0100, Totor1er a écrit :

2 disques ont été partagés sans mot de passe, avec "tout le monde".



houlà ! pas glop.

Tout le monde, Everyone, NomDeServeurTout le monde



NomDeServeur"Tout le monde" ?
Totor1er
Le #20433241
Professeur Méphisto wrote:

Le Tue, 27 Oct 2009 10:51:17 +0100, Totor1er a écrit :

2 disques ont été partagés sans mot de passe, avec "tout le




monde".

houlà ! pas glop.

Tout le monde, Everyone, NomDeServeurTout le monde



NomDeServeur"Tout le monde" ?



Hélas non cela ne fonctionne pas.

Mais je viens de trouver un palliatif: KNetAttach
Grâce à lui (adresse IP, le nom du disque partagé), j'ai monté
mes 2 disques.

Mais bon... Sans cela j'y serais encore.
Ceci dit, pour apprendre, je voudrais poursuivre
l'investigation.
Vincent Verdon
Le #20436971
Bonsoir,

Totor1er a écrit :
Bonjour à tous.

Je voudrais, au travers de linux, accéder à des disques
partagés d'un serveur Windows 7.

2 disques ont été partagés sans mot de passe, avec "tout le
monde".
A partir d'ordis sous Windows, RAS, j'y accède sans
sourciller.
Mais à partir de Linux, quelle que soit la distrib, soit ça
plante, soit (les KDE), le SMBClient doit être configuré.

Il me demande en effet un login, mot de passe, domaine.
Pour le domaine, j'ai indiqué le workgroup, mais pour le
login, j'ai essayé plein de trucs:




Il me semble qu'à partir de Vista, les mots de passes ne sont plus les
mêmes que sous NT/XP. Cela pose pb pour l'intégration de ces machines
dans des domaines contrôlés par un serveur Samba. Peut-être que la manip
inverse pose aussi ces mêmes problèmes ?
Pour info, il est possible de demander à Vista (et je suppose à Seven)
d'utiliser l'ancien système de mots de passe)

Amicalement, Vincent Verdon
GuiGui
Le #20442151
Totor1er a écrit :
Bonjour à tous.

Je voudrais, au travers de linux, accéder à des disques
partagés d'un serveur Windows 7.

2 disques ont été partagés sans mot de passe, avec "tout le
monde".
A partir d'ordis sous Windows, RAS, j'y accède sans
sourciller.
Mais à partir de Linux, quelle que soit la distrib, soit ça
plante, soit (les KDE), le SMBClient doit être configuré.

Il me demande en effet un login, mot de passe, domaine.
Pour le domaine, j'ai indiqué le workgroup, mais pour le
login, j'ai essayé plein de trucs:

Tout le monde, Everyone, NomDeServeurTout le monde, idem avec
everyone, \NomDeServeurtout le monde (idem everyone), en
mettant dans tous les essais l'adresse IP à la place du nom du
serveur...

Bref, plein d'essais se soldant par un échec.

Maintenant, je n'ai plus d'idée. Pouvez vous m'aider?
Merci!




Vérifiez la version de samba. Pour Win7 c'est samba 3.3 minimum
Totor1er
Le #20442371
Vincent Verdon wrote:

Bonsoir,

Totor1er a écrit :
Bonjour à tous.

Je voudrais, au travers de linux, accéder à des disques
partagés d'un serveur Windows 7.

2 disques ont été partagés sans mot de passe, avec "tout le
monde".
A partir d'ordis sous Windows, RAS, j'y accède sans
sourciller.
Mais à partir de Linux, quelle que soit la distrib, soit ça
plante, soit (les KDE), le SMBClient doit être configuré.

Il me demande en effet un login, mot de passe, domaine.
Pour le domaine, j'ai indiqué le workgroup, mais pour le
login, j'ai essayé plein de trucs:




Il me semble qu'à partir de Vista, les mots de passes ne


sont plus les
mêmes que sous NT/XP. Cela pose pb pour l'intégration de ces


machines
dans des domaines contrôlés par un serveur Samba. Peut-être


que la manip
inverse pose aussi ces mêmes problèmes ?
Pour info, il est possible de demander à Vista (et je


suppose à Seven)
d'utiliser l'ancien système de mots de passe)

Amicalement, Vincent Verdon



Bonsoir!

Pour répondre à tous, j'ai la version 3.4.2 de Samba
Je suis arrivé à monter chaque disque à la main dans Dolphin:
smb://IPduServeur/LettreDuDisque
Cela me suffit, même si l'ouverture du disque est un peu
longuette....

Bonne soirée!
Publicité
Poster une réponse
Anonyme