Partage Samba instable

Le
Sil
Bonjour,

Depuis à la mise à jour d'un serveur de Wheezy à Jessie cette semaine,
j'ai des problèmes de stabilité de connexion aux partages Samba. Ce
serveur date d'Etch mais est issu d'un clone plus ancien.
Lorsque je lance la commande suivante deux fois de suite, je n'ai pas le
même résultat :
moi@serveur:~$ smbclient //serveur/partage -Ulogin%mdp -cdu
session setup failed: NT_STATUS_UNSUCCESSFUL
moi@serveur:~$ smbclient //serveur/partage -Ulogin%mdp -cdu
Domain=[WORKGROUP] OS=[Unix] Server=[Samba 4.1.17-Debian]

37009 blocks of size 4194304. 2990 blocks available
Total number of bytes: 71304696

Les relances successives fonctionnent, mais si j’attends environ 1
minute, la commande échoue de nouveau.

Voici un extrait de mon smb.conf :
[global]
#display charset = UTF-8
workgroup = WORKGROUP
server string = %h server
obey pam restrictions = Yes
passwd program = /usr/bin/passwd %u
passwd chat = *EntersnewsUNIXspassword:* %n
*RetypesnewsUNIXspassword:* %n *passwordsupdatedssuccessfully* .
syslog = 3
log file = /var/log/samba/log.%m
max log size = 1000
printcap name = cups
#os level = 255
#preferred master = Auto
#domain master = No
dns proxy = No
#wins support = Yes
#ldap ssl = no
panic action = /usr/share/samba/panic-action %d
invalid users = root
….
[partage]
comment = Partage serveur
path = /home/partage
force user = login
read only = No
force create mode = 0770
force directory mode = 0770

Un extrait de auth.log :
Dec 11 08:12:25 serveur smbd[21715]: pam_unix(samba:session): session
opened for user login by (uid=0)
Dec 11 08:12:25 serveur smbd[21715]: pam_unix(samba:session): session
closed for user login

J'ai fait un strace d'une commande réussie et d'une qui a échoue, mais
du charabia pour moi.
Je ne vois plus où chercher. Toute aide sera la bienvenue.
Merci
Sil
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Olivier Bitsch
Le #26381432
--001a11c385fa50d3eb052700567b
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: quoted-printable

Désolé pour la réponse tardive.

Les informations de log sont un peu limitées pour faire un diagnotics.
Cependant j'ai eu des problèmes similaires récemment (mais ç a n'a peut-être
rien à voir avec le problème ici), mon soucis était lié à un problème avec
winbind alors que je ne l'utilisais pas. Un petit apt-get remove winbind à
résolu mon problème (lié également à l'authentific ation).

Peut-être un petit log un peu plus bavard serait utile ?

Olivier.

Le 11 décembre 2015 à 08:33, Sil
Bonjour,

Depuis à la mise à jour d'un serveur de Wheezy à Jessie ce tte semaine,
j'ai des problèmes de stabilité de connexion aux partages Samba . Ce serveur
date d'Etch mais est issu d'un clone plus ancien.
Lorsque je lance la commande suivante deux fois de suite, je n'ai pas le
même résultat :
:~$ smbclient //serveur/partage -Ulogin%mdp -cdu
session setup failed: NT_STATUS_UNSUCCESSFUL
:~$ smbclient //serveur/partage -Ulogin%mdp -cdu
Domain=[WORKGROUP] OS=[Unix] Server=[Samba 4.1.17-Debian]

37009 blocks of size 4194304. 2990 blocks available
Total number of bytes: 71304696

Les relances successives fonctionnent, mais si j’attends environ 1 minute,
la commande échoue de nouveau.

Voici un extrait de mon smb.conf :
[global]
#display charset = UTF-8
workgroup = WORKGROUP
server string = %h server
obey pam restrictions = Yes
passwd program = /usr/bin/passwd %u
passwd chat = *EntersnewsUNIXspassword:* %nn
*RetypesnewsUNIXspassword:* %nn *passwordsupdatedssuccessfully* .
syslog = 3
log file = /var/log/samba/log.%m
max log size = 1000
printcap name = cups
#os level = 255
#preferred master = Auto
#domain master = No
dns proxy = No
#wins support = Yes
#ldap ssl = no
panic action = /usr/share/samba/panic-action %d
invalid users = root
….
[partage]
comment = Partage serveur
path = /home/partage
force user = login
read only = No
force create mode = 0770
force directory mode = 0770

Un extrait de auth.log :
Dec 11 08:12:25 serveur smbd[21715]: pam_unix(samba:session): session
opened for user login by (uid=0)
Dec 11 08:12:25 serveur smbd[21715]: pam_unix(samba:session): session
closed for user login

J'ai fait un strace d'une commande réussie et d'une qui a échou e, mais du
charabia pour moi.
Je ne vois plus où chercher. Toute aide sera la bienvenue.
Merci
Sil





--001a11c385fa50d3eb052700567b
Content-Type: text/html; charset=UTF-8
Content-Transfer-Encoding: quoted-printable

<br>
Depuis à la mise à jour d&#39;un serveur de Wheezy à Jessie cette semaine, j&#39;ai des problèmes de stabilité de connexion a ux partages Samba. Ce serveur date d&#39;Etch mais est issu d&#39;un clone plus ancien.<br>
Lorsque je lance la commande suivante deux fois de suite, je n&#39;ai pas l e même résultat :<br>
:~$ smbclient //serveur/partage -Ulogin%mdp -cdu<br>
session setup failed: NT_STATUS_UNSUCCESSFUL<br>
:~$ smbclient //serveur/partage -Ulogin%mdp -cdu<br>
Domain=[WORKGROUP] OS=[Unix] Server=[Samba 4.1.17-Debian]<br>
<br>
        37009 blocks of size 4194304. 2990 blocks avail able<br>
Total number of bytes: 71304696<br>
<br>
Les relances successives fonctionnent, mais si j’attends environ 1 minute, la commande échoue de nouveau.<br>
<br>
Voici un extrait de mon smb.conf :<br>
[global]<br>
    #display charset = UTF-8<br>
    workgroup = WORKGROUP<br>
    server string = %h server<br>
    obey pam restrictions = Yes<br>
    passwd program = /usr/bin/passwd %u<br>
    passwd chat = *EntersnewsUNIXspassword:* %nn *Retypesn ewsUNIXspassword:* %nn *passwordsupdatedssuccessfully* .<br>
    syslog = 3<br>
    log file = /var/log/samba/log.%m<br>
    max log size = 1000<br>
    printcap name = cups<br>
    #os level = 255<br>
    #preferred master = Auto<br>
    #domain master = No<br>
    dns proxy = No<br>
    #wins support = Yes<br>
    #ldap ssl = no<br>
    panic action = /usr/share/samba/panic-action %d<br>
    invalid users = root<br>
….<br>
[partage]<br>
    comment = Partage serveur<br>
    path = /home/partage<br>
    force user = login<br>
    read only = No<br>
    force create mode = 0770<br>
    force directory mode = 0770<br>
<br>
Un extrait de auth.log :<br>
Dec 11 08:12:25 serveur smbd[21715]: pam_unix(samba:session): session opene d for user login by (uid=0)<br>
Dec 11 08:12:25 serveur smbd[21715]: pam_unix(samba:session): session close d for user login<br>
<br>
J&#39;ai fait un strace d&#39;une commande réussie et d&#39;une qui a échoue, mais du charabia pour moi.<br>
Je ne vois plus où chercher. Toute aide sera la bienvenue.<br>
Merci<span class="HOEnZb"><font color="#888888"><br>
Sil<br>
<br>
</font></span></blockquote></div><br></div>

--001a11c385fa50d3eb052700567b--
Sil
Le #26381757
Le 16/12/2015 10:14, Olivier Bitsch a écrit :
Désolé pour la réponse tardive.

Les informations de log sont un peu limitées pour faire un diagnotics.
Cependant j'ai eu des problèmes similaires récemment (mais ça n'a peut-être
rien à voir avec le problème ici), mon soucis était lié à un problème avec
winbind alors que je ne l'utilisais pas. Un petit apt-get remove winbind à
résolu mon problème (lié également à l'authentification).

Peut-être un petit log un peu plus bavard serait utile ?

Olivier.


Bonjour,

Au niveau log j'ai bien été incapable de trouver la moindre erreur...
J'ai épluché tout le contenu de /var/log/samba sans résultat.
Par contre depuis que j'ai désinstallé Winbind la problème a disparu. Ça
fait maintenant 3 jours que je n'ai plus d'erreurs. Je n'utilisait pas
WinBind non plus.

Entre temps j'ai trouvé ce bug :
https://bugzilla.samba.org/show_bug.cgi?id604
Ils conseillent d'ajouter une option imapd au smb.conf pour ceux qui
utilisent Winbind.

Merci pour le tuyau.
Sil
Publicité
Poster une réponse
Anonyme