partition cassee, des fois oui des fois non

Le
Az Sam
Bonjour,

J'ai un soucis pas banal, je ne me l'explique absolument pas, toute piste
d'explication serait bienvenue
C'est un peu complique, je vais essayer d'expliquer au mieux.

Voila le cas :
J'ai 3 disques durs avec chacun un systeme XP bootable a l'envie (par le
bios et par le boot.ini, les 3 disk sont actifs, les disk 1 et 2 sont
bootables directement)

Disk 1 : Sata - C:en Fat32 (20Go) - D: en Fat32 (110 Go) - E: en Fat32 (110
Go) - Xp familial Sp1 (celui de tous les jours)
particularite : E: sert de stockage pour le "mes documents" du systeme ainsi
qu'un dossier document partage pour le reseau local (mais pas le Doc partage
du systeme, un rep cree expres, j'ai jamais reussi a lui faire changer son
doc partage systeme)
Ce deplacement du "mes doc" est fait par un glisse depose et verifie par
TweakUI que l'inscription dans le registre est correcte.

Disk 2 : Pata maitre - F: NTFS (75Go) Xp fam Sp1 (le meme) qui sert pour les
tests divers et varies mais qui lui aussi utilise le meme "Mes documents" et
"doc partagés" sur la partition E:
particularite : les 40Go suivants sont une capsule backup Paragon Exact
Image (donc invisible sous les XP)

Disk 3 : Pata esclave - G: Fat32 (160Go) Xp Pro Sp1 - Qui sert de secours
(quasi vide pour l'instant) , lui utilise son propre mes doc tel que Windows
le definit a l'installation
Je precise de suite que les lettres de lecteurs sont toujours attibuees de
la meme facon quelque soit le systeme qui est demarre.

C'est la seconde fois que le pb survient :
Apres une mise a jour Windows Update du systeme de travail sur disk1 (52
d'un coup car il n'avait pas ete fait) au reboot j'ai un chkdsk sur E qui me
fout le binz en me recuperant des croisements par milliers, cluster apres
cluster.

Le truc bizarre (pour moi) c'ets que, apres ce chkdsk au boot, si je demarre
sur le Fam de travail (sur le Sata en Fat32, donc celui de la MaJ) je
retrouve mes dossiers de E: intacts, tout fonctionne.
Mais si je boote sur le Disk 2 en Ntfs, cette partition E devient soudain
illisible, cabalistique comme les scandisk savent si bien le faire (fichiers
en Asci et mis en Dossiers).
En fait le 1ere fois c'etait le contraire : E: etait casse pour l'OS qui
venait d'etre mis a jour (fat32), et lisible par celui qui sert de test
(Ntfs)

Si je boote sur le disk 3 , XP pro, j'ai eu 2 comportments :
la 1er fois le E etait illisible, cette fois, il etait parfaitement lisible.

Bien que fonctionnel, si je force un chkdsk au boot depuis n'importe lequel
des systemes, il me trouve des croisements sans cesse et finit pas tout
bousiller (genre un scan depuis le disk2Ê repare rien ca casse juste un
peu plus pour lui meme, un scan depuis le disk 1Ê casse ce qui etait ok,
un scan depuis le disk 3Ê casse encore et toujours.)
La seul solution est de supprimmer la partition et de la recreer. Puis de
tout remettre.

Une derniere precision, cette configuration fonctionne tres bien depuis des
mois de cette facon, c'est seulement apres la MaJ WUpdate que ca
s'embrouille. (mais j'ai guezr envie de me les faire une a une pour toruver
laquelle serait en cause)

Ce truc me turlupine, comment un systeme de fichier peut il etre vu bon par
un OS et casse par un autre ??


Xpost sur 4 groupes et Suivi sur fr.comp.sys.pc, qui me semble le plus
generaliste

--
Cordialement,
Az Sam.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Az Sam
Le #14258561
"Az Sam" news:463bab95$0$25940$
Bonjour,

J'ai un soucis pas banal, je ne me l'explique absolument pas, toute piste
d'explication serait bienvenue
C'est un peu complique, je vais essayer d'expliquer au mieux.

Voila le cas :
J'ai 3 disques durs avec chacun un systeme XP bootable a l'envie (par le
bios et par le boot.ini, les 3 disk sont actifs, les disk 1 et 2 sont
bootables directement)

Disk 1 : Sata - C:en Fat32 (20Go) - D: en Fat32 (110 Go) - E: en Fat32


(110
Go) - Xp familial Sp1 (celui de tous les jours)
particularite : E: sert de stockage pour le "mes documents" du systeme


ainsi
qu'un dossier document partage pour le reseau local (mais pas le Doc


partage
du systeme, un rep cree expres, j'ai jamais reussi a lui faire changer son
doc partage systeme)
Ce deplacement du "mes doc" est fait par un glisse depose et verifie par
TweakUI que l'inscription dans le registre est correcte.

Disk 2 : Pata maitre - F: NTFS (75Go) Xp fam Sp1 (le meme) qui sert pour


les
tests divers et varies mais qui lui aussi utilise le meme "Mes documents"


et
"doc partagés" sur la partition E:
particularite : les 40Go suivants sont une capsule backup Paragon Exact
Image (donc invisible sous les XP)

Disk 3 : Pata esclave - G: Fat32 (160Go) Xp Pro Sp1 - Qui sert de secours
(quasi vide pour l'instant) , lui utilise son propre mes doc tel que


Windows
le definit a l'installation
Je precise de suite que les lettres de lecteurs sont toujours attibuees de
la meme facon quelque soit le systeme qui est demarre.

C'est la seconde fois que le pb survient :
Apres une mise a jour Windows Update du systeme de travail sur disk1 (52
d'un coup car il n'avait pas ete fait) au reboot j'ai un chkdsk sur E qui


me
fout le binz en me recuperant des croisements par milliers, cluster apres
cluster.

Le truc bizarre (pour moi) c'ets que, apres ce chkdsk au boot, si je


demarre
sur le Fam de travail (sur le Sata en Fat32, donc celui de la MaJ) je
retrouve mes dossiers de E: intacts, tout fonctionne.
Mais si je boote sur le Disk 2 en Ntfs, cette partition E devient soudain
illisible, cabalistique comme les scandisk savent si bien le faire


(fichiers
en Asci et mis en Dossiers).
En fait le 1ere fois c'etait le contraire : E: etait casse pour l'OS qui
venait d'etre mis a jour (fat32), et lisible par celui qui sert de test
(Ntfs)

Si je boote sur le disk 3 , XP pro, j'ai eu 2 comportments :
la 1er fois le E etait illisible, cette fois, il etait parfaitement


lisible.

Bien que fonctionnel, si je force un chkdsk au boot depuis n'importe


lequel
des systemes, il me trouve des croisements sans cesse et finit pas tout
bousiller (genre un scan depuis le disk2Ê repare rien ca casse juste un
peu plus pour lui meme, un scan depuis le disk 1Ê casse ce qui etait ok,
un scan depuis le disk 3Ê casse encore et toujours.)
La seul solution est de supprimmer la partition et de la recreer. Puis de
tout remettre.

Une derniere precision, cette configuration fonctionne tres bien depuis


des
mois de cette facon, c'est seulement apres la MaJ WUpdate que ca
s'embrouille. (mais j'ai guezr envie de me les faire une a une pour


toruver
laquelle serait en cause)

Ce truc me turlupine, comment un systeme de fichier peut il etre vu bon


par
un OS et casse par un autre ??



Je viens apporter des nouvelles.
J'ai decide d'utiliser MBSA pour choisir mes mises a jour et les installer
une a une (excellent cet outil)
J'ai redemarre a chaque fois meme quand c'etait pas forcement necessaire, je
n'ai pas trouver quelle etait le mise a jour en cause (si tant est qu'il y
en aie une).
Mais avec MBSA, j'ai beaucoup moins de Maj a faire, que sur Wupdate..

Du point de vue des disques j'ai demarre la console de recup sur cd pour
passer un chkdsk.
Ma CM fonctionne de telle maniere que l'ordre des disques apres un boot sur
cd est :
1- Disque PATA 1aire Maitre (le 120 ou est le systeme XP fam NTFS)
2- Disque PATA 1aire Esclave (le 160 ou est le XP pro en Fat 32)
3- Disque Sata 1aire (le 250 ou ets le XP fam Fat 32 dont une des partoche
est problematique)

J'ai choisi le rep de travail de chaque Windows pour le fonctionnement de la
console de recup puis j'ai passe un chkdsk sur la partition en cause:
- Console sur le Disk 3 - partoche fonctionnelle (pas de reparation de la
part de chkdsk)
- console sur le disk 2 - idem
- console sur le disk 1 - partoche cassee, reparation de chkdsk ,
suppression de milliers de clusters et de croisements.

Au reboot normal (sur disque 3 donc) toute la partoche est foutue (merci
chkdsk)
Je reboote sur le disque 1 (le NTFS) : pareil , la partoche qui vient d'etre
reparee est toujours HS (et au demarrage j'ai le chkdsk qui demande de suite
a le reparer de nouveau ce que j'annule dans les 10 sec)

[a ce stade j'ai redemarre une console de recup sur disque 1 et refait un
chkdsk sur la partoche a pb : aucune faute trouvee !]

Conclusions :
-depuis la console de recup les resultats sont similaires a ceux obtenu pas
l'utilisation du chkdsk en mode console depuis l'un ou l'autre des systemes.
-chkdsk lui meme, ne fait pas la meme analyse selon le disque utilse pour le
boot (je demarre en fait sur le Disque 3 puis je bascule l'install du disque
1 par le boot ini)

Je continue mes investigations.



--
Cordialement,
Az Sam.
Publicité
Poster une réponse
Anonyme