Partitions sur DD externe USB

Le
CriCri
Salut tlm

J'ai 3 DD 2.5" récupérés de portables H/S:
- 2 Hitachi de 20 et 40 Go
- 1 Toshiba de 6 Go.

Comme c'est souvent le cas, ils avaient tous une partition cachée pour
la récupération du système; que j'ai récupérée.
- pour le Toshiba en éditant manuellement la table des partitions (avec
PartEdit32 de PowerQuest), suivi par le re-partitionnement souhaité avec
Partition Magic.
- pour les Hitachi avec leur propre outil qui re-paramètre l'IDE
directement (puisque la partition cachée n'est visible à aucun soft
normal); suivi par les mêmes étapes que ci-dessus.

Jusque là, tout va bien.
PM, chkdsk et le Gestionnaire de disques s'accordent pour dire qu'il n'y
a aucune erreur et ils se comportent tous parfaitement normalement
installés dans un fixe avec un adaptateur IDE 2.5" --> 3.5".

En revanche, ce que je souhaite faire avec eux est de les mettre dans
des boîtiers externes USB. Avec deux partitions (FAT32 car ils pourront
être utilisés avec des systèmes sous W98SE): l'une (petite) pour des
outils de test et de diagnostic et l'autre (ce qui reste) pour le
transfert de programmes d'installation, données etc.

Le Toshiba marche nickel comme ça.
Par contre les Hitachi déconnent.

S'il n'y a qu'une seule partition, ça peut marcher; mais dès que je la
partage, que ce soit manuellement, avec PM ou le Gestionnaire de disques
le résultat est le même: lors de la copie (par glisser-déplacer sur un
fixe sous WXP Pro SP2) (je précise que tous les fichiers concernés sont
normaux et peuvent être copiés n'importe où ailleurs sans difficulté),
je reçois l'insulte suivant:
--
Impossible de copier machin : Le fichier spécifié est introuvable.
Vérifiez que le chemin et le nom de fichier spécifiés sont corrects.
--
Or, 'machin' existe bel et bien dans la source. En fait souvent il
s'appelle 'machin.exe' ou 'machin.dll', mais la boîte d'erreur ne
reprend pas l'extension. (Ce n'est pas le même fichier deux fois de
suite non plus.)
(En tout cas, puisqu'on peut supposer qu'il s'agit d'une erreur de la
destination, pourquoi se plaindre de la source?)

Tout de suite après cette erreur une deuxième avertissement saute de la
barre des tâches:
--
L'écriture décalée a échouée machin chose
--
- ce qui est bien curieux, car j'ai désactivé l'écriture décalée sur
cette unité
En même temps la fenêtre de destination se ferme toute seule, car
l'unité USB entière 'disparait'.

Auriez-vous des propositions honnêtes à me faire?

Amicalement
CriCri

--
bitwyse [PGP KeyID 0xA79C8F2C]
Les conseils - c'est ce qu'on demande quand on connaît déjà la réponse
mais aurait préféré ne pas la savoir.
http://www.le-maquis.net
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 3
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Michel__D
Le #17438331
CriCri a écrit :
Salut tlm

J'ai 3 DD 2.5" récupérés de portables H/S:
- 2 Hitachi de 20 et 40 Go
- 1 Toshiba de 6 Go.

Comme c'est souvent le cas, ils avaient tous une partition cachée pour
la récupération du système; que j'ai récupérée.
- pour le Toshiba en éditant manuellement la table des partitions (avec
PartEdit32 de PowerQuest), suivi par le re-partitionnement souhaité avec
Partition Magic.
- pour les Hitachi avec leur propre outil qui re-paramètre l'IDE
directement (puisque la partition cachée n'est visible à aucun soft
normal); suivi par les mêmes étapes que ci-dessus.

Jusque là, tout va bien.
PM, chkdsk et le Gestionnaire de disques s'accordent pour dire qu'il n'y
a aucune erreur et ils se comportent tous parfaitement normalement
installés dans un fixe avec un adaptateur IDE 2.5" --> 3.5".

En revanche, ce que je souhaite faire avec eux est de les mettre dans
des boîtiers externes USB. Avec deux partitions (FAT32 car ils pourront
être utilisés avec des systèmes sous W98SE): l'une (petite) pour des
outils de test et de diagnostic et l'autre (ce qui reste) pour le
transfert de programmes d'installation, données etc.

Le Toshiba marche nickel comme ça.
Par contre les Hitachi déconnent.

S'il n'y a qu'une seule partition, ça peut marcher; mais dès que je la
partage, que ce soit manuellement, avec PM ou le Gestionnaire de disques
le résultat est le même: lors de la copie (par glisser-déplacer sur un
fixe sous WXP Pro SP2) (je précise que tous les fichiers concernés sont
normaux et peuvent être copiés n'importe où ailleurs sans difficulté),
je reçois l'insulte suivant:
--------
Impossible de copier machin : Le fichier spécifié est introuvable.
Vérifiez que le chemin et le nom de fichier spécifiés sont corrects.
--------
Or, 'machin' existe bel et bien dans la source. En fait souvent il
s'appelle 'machin.exe' ou 'machin.dll', mais la boîte d'erreur ne
reprend pas l'extension. (Ce n'est pas le même fichier deux fois de
suite non plus.)
(En tout cas, puisqu'on peut supposer qu'il s'agit d'une erreur de la
destination, pourquoi se plaindre de la source?)

Tout de suite après cette erreur une deuxième avertissement saute de la
barre des tâches:
--------
L'écriture décalée a échouée... machin chose...
--------
- ce qui est bien curieux, car j'ai désactivé l'écriture décalée sur
cette unité...
En même temps la fenêtre de destination se ferme toute seule, car
l'unité USB entière 'disparait'.

Auriez-vous des propositions honnêtes à me faire?



As-tu restaurer une séquence de démarrage classique au niveau du MBR ?

Fixmbr sous la console de récupération ou
Fdisk /mbr sous DOS (il n'y aura pas de restriction vu que c'est FATxx)
VerrNum
Le #17438511
"CriCri" discussion : 48ea0659$0$949$
--------
L'écriture décalée a échouée... machin chose...
--------
- ce qui est bien curieux, car j'ai désactivé l'écriture décalée sur
cette unité...
En même temps la fenêtre de destination se ferme toute seule, car
l'unité USB entière 'disparait'.

Auriez-vous des propositions honnêtes à me faire?



Souvent les boitiers externes IDE USB aiment que les disques soient en
position Master si ce n'est pas déjà fait.
CriCri
Le #17440151
VerrNum a écrit :

Souvent les boitiers externes IDE USB aiment que les disques soient
en position Master si ce n'est pas déjà fait.



Il le sont tous (car anciennement les seuls disques des portables) -
donc 'Master' ou 'Single' (pour ceux-ci c'est pareil).

Merci...
CriCri

--
bitwyse [PGP KeyID 0xA79C8F2C]
Les conseils - c'est ce qu'on demande quand on connaît déjà la réponse
mais aurait préféré ne pas la savoir.
http://www.le-maquis.net
Michel__D
Le #17439401
Michel__D a écrit :
CriCri a écrit :
Salut tlm

J'ai 3 DD 2.5" récupérés de portables H/S:
- 2 Hitachi de 20 et 40 Go
- 1 Toshiba de 6 Go.

Comme c'est souvent le cas, ils avaient tous une partition cachée pour
la récupération du système; que j'ai récupérée.
- pour le Toshiba en éditant manuellement la table des partitions (avec
PartEdit32 de PowerQuest), suivi par le re-partitionnement souhaité avec
Partition Magic.
- pour les Hitachi avec leur propre outil qui re-paramètre l'IDE
directement (puisque la partition cachée n'est visible à aucun soft
normal); suivi par les mêmes étapes que ci-dessus.

Jusque là, tout va bien.
PM, chkdsk et le Gestionnaire de disques s'accordent pour dire qu'il n'y
a aucune erreur et ils se comportent tous parfaitement normalement
installés dans un fixe avec un adaptateur IDE 2.5" --> 3.5".

En revanche, ce que je souhaite faire avec eux est de les mettre dans
des boîtiers externes USB. Avec deux partitions (FAT32 car ils pourront
être utilisés avec des systèmes sous W98SE): l'une (petite) pour des
outils de test et de diagnostic et l'autre (ce qui reste) pour le
transfert de programmes d'installation, données etc.

Le Toshiba marche nickel comme ça.
Par contre les Hitachi déconnent.

S'il n'y a qu'une seule partition, ça peut marcher; mais dès que je la
partage, que ce soit manuellement, avec PM ou le Gestionnaire de disques
le résultat est le même: lors de la copie (par glisser-déplacer sur un
fixe sous WXP Pro SP2) (je précise que tous les fichiers concernés sont
normaux et peuvent être copiés n'importe où ailleurs sans difficulté),
je reçois l'insulte suivant:
--------
Impossible de copier machin : Le fichier spécifié est introuvable.
Vérifiez que le chemin et le nom de fichier spécifiés sont corrects.
--------
Or, 'machin' existe bel et bien dans la source. En fait souvent il
s'appelle 'machin.exe' ou 'machin.dll', mais la boîte d'erreur ne
reprend pas l'extension. (Ce n'est pas le même fichier deux fois de
suite non plus.)
(En tout cas, puisqu'on peut supposer qu'il s'agit d'une erreur de la
destination, pourquoi se plaindre de la source?)

Tout de suite après cette erreur une deuxième avertissement saute de la
barre des tâches:
--------
L'écriture décalée a échouée... machin chose...
--------
- ce qui est bien curieux, car j'ai désactivé l'écriture décalée sur
cette unité...
En même temps la fenêtre de destination se ferme toute seule, car
l'unité USB entière 'disparait'.

Auriez-vous des propositions honnêtes à me faire?



As-tu restaurer une séquence de démarrage classique au niveau du MBR ?

Fixmbr sous la console de récupération ou
Fdisk /mbr sous DOS (il n'y aura pas de restriction vu que c'est FATxx)



Bon laisse tomber ma 1ère réponse, mais je trouve bizarre les problèmes
que tu as rencontré pour préparer les disques Hitachi, as-tu essayer
de passer leur utilitaire pour voir si les disques ne donnent pas des
signes de faiblesse.
CriCri
Le #17440111
Michel__D a écrit :

As-tu restaurer une séquence de démarrage classique au niveau du MBR
?



Non - pourquoi? - la table des partitions est correcte et aucune
partition n'est bootable.
Tout a été fraîchement écrit par Partition Magic ou le Gestionnaire des
disques.

Amicalement
CriCri

PS - néanmoins, puisque tu l'as évoqué j'y ai jeté un coup d'oeil avec
un éditeur hexa et tout semble normal.

--
bitwyse [PGP KeyID 0xA79C8F2C]
Les conseils - c'est ce qu'on demande quand on connaît déjà la réponse
mais aurait préféré ne pas la savoir.
http://www.le-maquis.net
Ascadix
Le #17440411
Le 06/10/2008 14:36, CriCri a écrit :
Salut tlm

J'ai 3 DD 2.5" récupérés de portables H/S:
- 2 Hitachi de 20 et 40 Go
- 1 Toshiba de 6 Go.

Comme c'est souvent le cas, ils avaient tous une partition cachée pour
la récupération du système; que j'ai récupérée.
- pour le Toshiba en éditant manuellement la table des partitions (avec
PartEdit32 de PowerQuest), suivi par le re-partitionnement souhaité avec
Partition Magic.
- pour les Hitachi avec leur propre outil qui re-paramètre l'IDE
directement (puisque la partition cachée n'est visible à aucun soft
normal); suivi par les mêmes étapes que ci-dessus.

Jusque là, tout va bien.
PM, chkdsk et le Gestionnaire de disques s'accordent pour dire qu'il n'y
a aucune erreur et ils se comportent tous parfaitement normalement
installés dans un fixe avec un adaptateur IDE 2.5" --> 3.5".

En revanche, ce que je souhaite faire avec eux est de les mettre dans
des boîtiers externes USB. Avec deux partitions (FAT32 car ils pourront
être utilisés avec des systèmes sous W98SE): l'une (petite) pour des
outils de test et de diagnostic et l'autre (ce qui reste) pour le
transfert de programmes d'installation, données etc.

Le Toshiba marche nickel comme ça.
Par contre les Hitachi déconnent.

S'il n'y a qu'une seule partition, ça peut marcher; mais dès que je la
partage, que ce soit manuellement, avec PM ou le Gestionnaire de disques
le résultat est le même: lors de la copie (par glisser-déplacer sur un
fixe sous WXP Pro SP2) (je précise que tous les fichiers concernés sont
normaux et peuvent être copiés n'importe où ailleurs sans difficulté),
je reçois l'insulte suivant:
--------
Impossible de copier machin : Le fichier spécifié est introuvable.
Vérifiez que le chemin et le nom de fichier spécifiés sont corrects.
--------
Or, 'machin' existe bel et bien dans la source. En fait souvent il
s'appelle 'machin.exe' ou 'machin.dll', mais la boîte d'erreur ne
reprend pas l'extension. (Ce n'est pas le même fichier deux fois de
suite non plus.)
(En tout cas, puisqu'on peut supposer qu'il s'agit d'une erreur de la
destination, pourquoi se plaindre de la source?)

Tout de suite après cette erreur une deuxième avertissement saute de la
barre des tâches:
--------
L'écriture décalée a échouée... machin chose...
--------
- ce qui est bien curieux, car j'ai désactivé l'écriture décalée sur
cette unité...
En même temps la fenêtre de destination se ferme toute seule, car
l'unité USB entière 'disparait'.

Auriez-vous des propositions honnêtes à me faire?

Amicalement
CriCri




Vérifie les caractéristiques électrique des DD, p'tet que les Hitachi
que t'as sont + gourmand que le Tosh, dans ce cas:
- faut brancher aussi le 2° connecteur USB
- ou mettre l'alim
- dans tous les cas, éviter les port USB sur chip Via.
- si t'as que du Via sur ton PC, met les boitier DD/USB deriere un hub
AVEC alim indépendante

--
@+
Ascadix
adresse @mail valide, mais ajoutez "sesame" dans l'objet pour que ça
arrive.
CriCri
Le #17440401
Michel__D a écrit :

Bon laisse tomber ma 1ère réponse, mais je trouve bizarre les
problèmes que tu as rencontré pour préparer les disques Hitachi,
as-tu essayer de passer leur utilitaire pour voir si les disques ne
donnent pas des signes de faiblesse.



Non - mais je vais le faire demain (je l'ai déjà) - mais ça m'étonnerait
des deux (dont un presque neuf).
Ce qui me tracasse est que connectés via un adaptateur IDE ils marchent
sans faute (partitions et tout): mais dans un boîtier externe USB ça foire.
Bien sûr j'ai pensé à un éventuel défaut du boîtier, mais le Toshiba
marche impec' dans le même. (J'ai un autre boîtier - mais en attente de
réparation, et je ne veux pas trop investir dans d'autres encore si ça
ne va pas marcher.)

Merci.
CriCri

--
bitwyse [PGP KeyID 0xA79C8F2C]
Les conseils - c'est ce qu'on demande quand on connaît déjà la réponse
mais aurait préféré ne pas la savoir.
http://www.le-maquis.net
VerrNum
Le #17440601
"Ascadix" discussion : 48ea67f5$0$902$
Vérifie les caractéristiques électrique des DD, p'tet que les Hitachi que
t'as sont + gourmand que le Tosh, dans ce cas:
- faut brancher aussi le 2° connecteur USB
- ou mettre l'alim
- dans tous les cas, éviter les port USB sur chip Via.
- si t'as que du Via sur ton PC, met les boitier DD/USB deriere un hub
AVEC alim indépendante



Exact, des fois c'est le cable USB qui est trop long et qu'il vaut mieux
brancher derrière le PC et non en façade.
CriCri
Le #17440581
Salut

Ascadix a écrit :

Vérifie les caractéristiques électrique des DD, p'tet que les Hitachi
que t'as sont + gourmand que le Tosh,



Tu as raison (et ça je le sais): sur une autre machine les Hitachi ne
démarre pas même avec les deux connecteurs USB! - mais je connecte
systématiquement les deux sur la mienne, et s'il n'y a qu'une seule
partition ils marchent bien. Je ne crois pas qu'une deuxième partition
augmente la consommation... ;-)

- ou mettre l'alim



Y'en a pas :-(
Heu... c'est à dire qu'il y a bien une autre prise spéciale non-standard
(qui ressemble à celle d'un scanner Canon), mais aucun marquage
(tension, polarité...); et aucune possibilité d'alim mentionnée sur la
fiche du constructeur.

- dans tous les cas, éviter les port USB sur chip Via.



Merci pour le tuyau.
Mais j'ai un chipset Intel 865SE (sur une CM Asus P4P800E deLuxe).

Amicalement
CriCri

--
bitwyse [PGP KeyID 0xA79C8F2C]
Les conseils - c'est ce qu'on demande quand on connaît déjà la réponse
mais aurait préféré ne pas la savoir.
http://www.le-maquis.net
CriCri
Le #17440941
VerrNum a écrit :

Exact, des fois c'est le cable USB qui est trop long



Hmmm. Je veux bien mais le câble fourni n'atteint même pas le dessus de
mon bureau: chuis obligé de poser le boîtier directement sur la tour
(qui se trouve dessous).

et qu'il vaut mieux brancher derrière le PC et non en façade.



Vi, p'têt, si c'est déjà limite.
Sinon ça rajoute environ 30 cm depuis les connecteurs sur la CM - pas
excessif vu que la limite préconisé est d'environ 5 mètres.

--
bitwyse [PGP KeyID 0xA79C8F2C]
Les conseils - c'est ce qu'on demande quand on connaît déjà la réponse
mais aurait préféré ne pas la savoir.
http://www.le-maquis.net
Publicité
Poster une réponse
Anonyme