pas de carte son détectée + pas de /proc/asound

Le
andre_debian
Bonsoir,

Je tente d'installer cette carte son :

ATI HDMI Radéon HD 5700

(intégrée à la carte mère Asus, PCI)

Je n'ai pas de fichier /etc/proc/asound.
(comment le remettre ?)

Alsa est installé.

La carte son n'est pas du tout détectée.
(Elle fonctionne sous Windows seven)

Je suis sous Squeeze.

Grand merci d'une aide.

andré

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/201204271858.48587.andre_debian@numericable.fr
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Raphaël POITEVIN
Le #24435021
Bonsoir,
Le 27/04/12,
Bonsoir,

Je tente d'installer cette carte son :

ATI HDMI Radéon HD 5700



J'ai entendu dire que souvent ce genre de composant était un peu problé matique.

(intégrée à la carte mère Asus, PCI)

Je n'ai pas de fichier /etc/proc/asound.
(comment le remettre ?)



tu es sûr ? Chez moi c'est /proc/asound/* et non /etc/proc/asound/*
Il devrait au moins y avoi run fichier cards et un fichier modules.

Alsa est installé.

La carte son n'est pas du tout détectée.



Peut-être qu'il faudrait patcher ou backporter le noyau.
--
Raphaël POITEVIN

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/CAMmtCiXDoZ5CDkdqSzqA8eWF=
andre_debian
Le #24435091
On Friday 27 April 2012 19:38:00 Raphaël POITEVIN wrote:
Le 27/04/12, > Je tente d'installer cette carte son :
> ATI HDMI Radéon HD 5700
> (intégrée à la carte mère Asus, PCI)

J'ai entendu dire que souvent ce genre de composant était un peu
problématique.

> Je n'ai pas de fichier /etc/proc/asound.
> (comment le remettre ?)

tu es sûr ? Chez moi c'est /proc/asound/* et non /etc/proc/asound/*
Il devrait au moins y avoi run fichier cards et un fichier modules :



c'est "/proc/asound/"
Il est absent.

> Alsa est installé.
> La carte son n'est pas du tout détectée.

Peut-être qu'il faudrait patcher ou backporter le noyau.
Raphaël POITEVIN



Désolé, je ne sais pas comment " patcher ou backporter le noyau".

J'ai rajouté une carte vidéo "SoundBalster" (slot PCI).
Reboot mais toujours pareil.
Elle n'est pas détectée.

Merci.

andré

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Raphaël POITEVIN
Le #24435491
Le 27/04/12,
c'est "/proc/asound/"
Il est absent.

Désolé, je ne sais pas comment " patcher ou backporter le noyau".



Avant de backporter, il faudrait éventuellement envoyer sur laliste la
sortie de :
lspci -vv | grep snd
Peut-être que d'autres sur la liste auront une idée si on peut éviter
le backport.

Sinon pour backporter, il faut ajouter les dépôts dans le fichier
/etc/apt/sources.list :
deb http://backports.debian.org/ debian-backports squeeze-backports
main contrib non-free
Puis faire un aptitude update
Ensuite, instaler le bon package linux-image en fonction de
l'architecture.
Par exemple :
aptitude install linux-image-3.2.0-0.bpo.2-686-pae
si c'est un 32 bits.
--
Raphaël POITEVIN

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
andre_debian
Le #24436541
On Saturday 28 April 2012 14:38:02 you wrote:
On Saturday 28 April 2012 02:23:17 you wrote:
> Le 27/04/12, a écrit :
> > c'est "/proc/asound/"
> > Il est absent.

> > Désolé, je ne sais pas comment " patcher ou backporter le noyau".

> Avant de backporter, il faudrait éventuellement envoyer sur laliste la
> sortie de :
> lspci -vv | grep snd
> Peut-être que d'autres sur la liste auront une idée si on peut év iter
> le backport.

> Sinon pour backporter, il faut ajouter les dépôts dans le fichier
> /etc/apt/sources.list :
> deb http://backports.debian.org/ debian-backports squeeze-backports
> main contrib non-free
> Puis faire un aptitude update
> Ensuite, installer le bon package linux-image en fonction de
> l'architecture.
> Par exemple :
> aptitude install linux-image-3.2.0-0.bpo.2-686-pae
> si c'est un 32 bits.


---------------------------

Merci de ton aide.

La commande "lspci -vv | grep snd" n'indique rien.

# lspci
Audio device: ATI Technologies Inc Juniper HDMI Audio [Radeon HD 5700 Serie s]
Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 0a)

Les 2 cartes audio sont donc bien détectées.
(une carte intégrée à la CM + une carte sur slot PCI)

# /etc/init.d/./alsa-utils restart
-------------------------------------------------------------------------
alsactl store' failed with error message 'alsactl: get_control:239:
Cannot read control info '2,0,0,Front Playback Volume,0': Invalid
argument'...failed.
Setting up ALSA...warning: 'alsactl restore' failed with error message
'No state is present for card PCH
Unknown hardware: "HDA-Intel" "Realtek
ALC887" "HDA:10ec0887,10438445,00100302" "0x1043" "0x8445"
Unknown hardware: "HDA-Intel" "Realtek
ALC887" "HDA:10ec0887,10438445,00100302" "0x1043" "0x8445"
Hardware is initialized using a guess method
---------------------------------------------------

Le problème vient de l'installation de Debian sur mon nouveau PC,
par copie du système venant de l'ancien PC (via rsync).

Comment réadapter une ou les 2 cartes son sur le nouveau PC
et le faire reconnaitre par alsa ?

Merci beaucoup d'avance.

andré

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
deb-account
Le #24437881
On 28/04/12 14:51, wrote:

Le problème vient de l'installation de Debian sur mon nouveau PC,
par copie du système venant de l'ancien PC (via rsync).




Quelle était la version du noyau ?
Pourquoi ne pas en profiter pour installer une version plus récente ?

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
andre_debian
Le #24439521
On Sunday 29 April 2012 08:51:24 deb-account wrote:
On 28/04/12 14:51, wrote:
> Le problème vient de l'installation de Debian sur mon nouveau PC,
> par copie du système venant de l'ancien PC (via rsync).

Quelle était la version du noyau ?
Pourquoi ne pas en profiter pour installer une version plus récente ?



La version du noyau est 2.6.32-5-686.

Il faudrait alors le recompiler ... ?

Quel serait l'intérêt dans ce problème de reconnaissance
de carte son ?

Bonne fin de soirée

andré

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
deb-account
Le #24440101
On 29/04/12 22:25, wrote:
La version du noyau est 2.6.32-5-686.

Il faudrait alors le recompiler ... ?



Je suppose.
Je crois qu'il y a des scripts debian pour ça.
Si tu ne veux pas te prendre la tête, tu peux faire une install fraîche
puisque c'est un nouveau PC.
Quel serait l'intérêt dans ce problème de reconnaissance
de carte son ?



Normalement, ta carte SB est prise en charge par le pilote emu10k1.
Tu devrais y voir plus clair en tapant "lspci -v" sous root.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme