= pas égal ?

Le
Jacquouille
Bonjour à tout le monde,

J'ai une liste de membres à chaque mois.
J'ai ajusté les lignes pour y insérer des nouveaux membres.
J'ai donc, sur chaque ligne, les mêmes nom et prénom.

Afin de contrôler ce travail, j'ai fait une colonne dans laquelle je voulais
mettre:
£³ÃÓãó=g3 > vrai ou faux.

Or, toutes les lignes me donnent "faux".
Pourtant, si je fais £³ > Ok
³Ã > OK
£Ã > OK

MAIS, si je mets = A3³Ã > FAUX
Existe-t-il une explication, svp?
Ne peut-on comparer que deux données à la fois?

Merci et bonne aprem

Jacques.
Jacquouille

" Le vin est au repas ce que le parfum est à la femme."



L'absence de virus dans ce courrier électronique a été vérifiée par le logiciel antivirus Avast.
http://www.avast.com
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
DanielCo
Le #26362540
Jacquouille a émis l'idée suivante :
Bonjour à tout le monde,

J'ai une liste de membres à chaque mois.
J'ai ajusté les lignes pour y insérer des nouveaux membres.
J'ai donc, sur chaque ligne, les mêmes nom et prénom.

Afin de contrôler ce travail, j'ai fait une colonne dans laquelle je voulais
mettre:
£³ÃÓãó=g3 ---> vrai ou faux.

Or, toutes les lignes me donnent "faux".
Pourtant, si je fais £³ ---> Ok
³Ã ---> OK
£Ã ---> OK

MAIS, si je mets = A3³Ã ---> FAUX
Existe-t-il une explication, svp?
Ne peut-on comparer que deux données à la fois?

Merci et bonne aprem

Jacques.
Jacquouille

" Le vin est au repas ce que le parfum est à la femme."


---
L'absence de virus dans ce courrier électronique a été vérifiée par le
logiciel antivirus Avast.
http://www.avast.com



Bonjour Jacquouille,
=NB.SI(A3:C3;A3)=3
Cordialement.
Daniel
Jacquouille
Le #26362544
Re
OK, Daniel. Grand merci

Peux-tu vérifier ceci chez toi, svp?

Sur une ligne (3) VIDE :

=NB.SI(A3:G3;A3)=7 -----> FAUX
=SI(ET(B3£;C3£;D3£;E3£;F3£;G3£);"VRAI";"FAUX") ---> VRAI

PS Si les cel sont remplies, la formule fonctionne très bien.
Merci et bonne aprem

Jacquouille

" Le vin est au repas ce que le parfum est à la femme."
"DanielCo" a écrit dans le message de groupe de discussion :
mpvoi5$j2p$

Jacquouille a émis l'idée suivante :
Bonjour à tout le monde,

J'ai une liste de membres à chaque mois.
J'ai ajusté les lignes pour y insérer des nouveaux membres.
J'ai donc, sur chaque ligne, les mêmes nom et prénom.

Afin de contrôler ce travail, j'ai fait une colonne dans laquelle je
voulais mettre:
£³ÃÓãó=g3 ---> vrai ou faux.

Or, toutes les lignes me donnent "faux".
Pourtant, si je fais £³ ---> Ok
³Ã ---> OK
£Ã ---> OK

MAIS, si je mets = A3³Ã ---> FAUX
Existe-t-il une explication, svp?
Ne peut-on comparer que deux données à la fois?

Merci et bonne aprem

Jacques.
Jacquouille

" Le vin est au repas ce que le parfum est à la femme."


---
L'absence de virus dans ce courrier électronique a été vérifiée par le
logiciel antivirus Avast.
http://www.avast.com



Bonjour Jacquouille,
=NB.SI(A3:C3;A3)=3
Cordialement.
Daniel


---
L'absence de virus dans ce courrier électronique a été vérifiée par le logiciel antivirus Avast.
http://www.avast.com
DanielCo
Le #26362546
Tu compliques, avec tes cellules vides :
=NB.SI(A3:F3;A3)=COLONNES(A3:F3)
Daniel





Jacquouille a exposé le 06/08/2015 :
Re
OK, Daniel. Grand merci

Peux-tu vérifier ceci chez toi, svp?

Sur une ligne (3) VIDE :

=NB.SI(A3:G3;A3)=7 -----> FAUX
=SI(ET(B3£;C3£;D3£;E3£;F3£;G3£);"VRAI";"FAUX") ---> VRAI

PS Si les cel sont remplies, la formule fonctionne très bien.
Merci et bonne aprem

Jacquouille

" Le vin est au repas ce que le parfum est à la femme."
"DanielCo" a écrit dans le message de groupe de discussion :
mpvoi5$j2p$

Jacquouille a émis l'idée suivante :
Bonjour à tout le monde,

J'ai une liste de membres à chaque mois.
J'ai ajusté les lignes pour y insérer des nouveaux membres.
J'ai donc, sur chaque ligne, les mêmes nom et prénom.

Afin de contrôler ce travail, j'ai fait une colonne dans laquelle je
voulais mettre:
£³ÃÓãó=g3 ---> vrai ou faux.

Or, toutes les lignes me donnent "faux".
Pourtant, si je fais £³ ---> Ok
³Ã ---> OK
£Ã ---> OK

MAIS, si je mets = A3³Ã ---> FAUX
Existe-t-il une explication, svp?
Ne peut-on comparer que deux données à la fois?

Merci et bonne aprem

Jacques.
Jacquouille

" Le vin est au repas ce que le parfum est à la femme."


---
L'absence de virus dans ce courrier électronique a été vérifiée par le
logiciel antivirus Avast.
http://www.avast.com



Bonjour Jacquouille,
=NB.SI(A3:C3;A3)=3
Cordialement.
Daniel


---
L'absence de virus dans ce courrier électronique a été vérifiée par le
logiciel antivirus Avast.
http://www.avast.com
Jacquouille
Le #26362550
Re

Ben non, car dans ton 2° exemple, colonness(A3:F3) ne fait que remplacer le
chiffre qui est dans ma formule, soit le 7.
Et, du coup, la formule affiche faux aussi.
Ma question est:pourquoi une formule affiche-t-elle VRAI et l'autre FAUX,
alors que la ligne est vide ......

Jacquouille

" Le vin est au repas ce que le parfum est à la femme."

"DanielCo" a écrit dans le message de groupe de discussion :
mpvs9m$sp2$

Tu compliques, avec tes cellules vides :
=NB.SI(A3:F3;A3)=COLONNES(A3:F3)
Daniel

Jacquouille a exposé le 06/08/2015 :
Re
OK, Daniel. Grand merci

Peux-tu vérifier ceci chez toi, svp?

Sur une ligne (3) VIDE :

=NB.SI(A3:G3;A3)=7 -----> FAUX
=SI(ET(B3£;C3£;D3£;E3£;F3£;G3£);"VRAI";"FAUX") ---> VRAI

PS Si les cel sont remplies, la formule fonctionne très bien.
Merci et bonne aprem

Jacquouille

" Le vin est au repas ce que le parfum est à la femme."
"DanielCo" a écrit dans le message de groupe de discussion :
mpvoi5$j2p$

Jacquouille a émis l'idée suivante :
Bonjour à tout le monde,

J'ai une liste de membres à chaque mois.
J'ai ajusté les lignes pour y insérer des nouveaux membres.
J'ai donc, sur chaque ligne, les mêmes nom et prénom.

Afin de contrôler ce travail, j'ai fait une colonne dans laquelle je
voulais mettre:
£³ÃÓãó=g3 ---> vrai ou faux.

Or, toutes les lignes me donnent "faux".
Pourtant, si je fais £³ ---> Ok
³Ã ---> OK
£Ã ---> OK

MAIS, si je mets = A3³Ã ---> FAUX
Existe-t-il une explication, svp?
Ne peut-on comparer que deux données à la fois?

Merci et bonne aprem

Jacques.
Jacquouille

" Le vin est au repas ce que le parfum est à la femme."


Bonjour Jacquouille,
=NB.SI(A3:C3;A3)=3
Cordialement.
Daniel




---
L'absence de virus dans ce courrier électronique a été vérifiée par le logiciel antivirus Avast.
http://www.avast.com
DanielCo
Le #26362549
Une cellule vide n'a pas de valeur par définition. C'est le genre de
truc tordu. Si A1 est vide et que tu écris ¡, tu obtiens 0 ? Si tu
veux obtenir vrai :
=OU(NB.SI(A3:F3;A3)=COLONNES(A3:F3);NB.VIDE(A3:F3)=COLONNES(A3:F3))
Daniel

Jacquouille a utilisé son clavier pour écrire :
Re

Ben non, car dans ton 2° exemple, colonness(A3:F3) ne fait que remplacer le
chiffre qui est dans ma formule, soit le 7.
Et, du coup, la formule affiche faux aussi.
Ma question est:pourquoi une formule affiche-t-elle VRAI et l'autre FAUX,
alors que la ligne est vide ......

Jacquouille

" Le vin est au repas ce que le parfum est à la femme."

"DanielCo" a écrit dans le message de groupe de discussion :
mpvs9m$sp2$

Tu compliques, avec tes cellules vides :
=NB.SI(A3:F3;A3)=COLONNES(A3:F3)
Daniel

Jacquouille a exposé le 06/08/2015 :
Jacquouille
Le #26362564
Bonsoir Daniel
tout à fait d'accord avec toi.
Dans ma naïveté, je croyais que, en comparant deux choses identiques, quelle
que soit leur valeur (même sans valeur), on devait obtenir VRAI.
Comme tu dis, c'est encore une vicieuseté d'Excel.
Merci de t'être penché sur ce problème on ne peut plus crucial pour
l'humanité. -))
Bonne soirée
Jacques.


Jacquouille

" Le vin est au repas ce que le parfum est à la femme."
"DanielCo" a écrit dans le message de groupe de discussion :
mpvvjf$59g$

Une cellule vide n'a pas de valeur par définition. C'est le genre de
truc tordu. Si A1 est vide et que tu écris ¡, tu obtiens 0 ? Si tu
veux obtenir vrai :
=OU(NB.SI(A3:F3;A3)=COLONNES(A3:F3);NB.VIDE(A3:F3)=COLONNES(A3:F3))
Daniel

Jacquouille a utilisé son clavier pour écrire :
Re

Ben non, car dans ton 2° exemple, colonness(A3:F3) ne fait que remplacer
le chiffre qui est dans ma formule, soit le 7.
Et, du coup, la formule affiche faux aussi.
Ma question est:pourquoi une formule affiche-t-elle VRAI et l'autre FAUX,
alors que la ligne est vide ......

Jacquouille

" Le vin est au repas ce que le parfum est à la femme."

"DanielCo" a écrit dans le message de groupe de discussion :
mpvs9m$sp2$

Tu compliques, avec tes cellules vides :
=NB.SI(A3:F3;A3)=COLONNES(A3:F3)
Daniel

Jacquouille a exposé le 06/08/2015 :




---
L'absence de virus dans ce courrier électronique a été vérifiée par le logiciel antivirus Avast.
http://www.avast.com
Publicité
Poster une réponse
Anonyme