Pas de son...

Le
Sushi
Bonjour,

Je suis nouveau sur debian et j'ai installe Etch sur mon PC. Tout
fonctionne plutot bien niveau hard, sauf le son.

Voila la situation:
Cote matos: AMD Sempron 64 et carte mere ASRock K8NF6G-VSTA (et comme
vous vous en doutez, VSTA =/ Linux). Elle dispose entre autre d'un
chipset NVidia NF-6100-405 et l'audio semble etre du RealTek
ALC861/ALC883 (?) selon les specs du constructeur. Un lspci me donne plutot:
00:05.0 Audio device: nVidia Corporation MCP61 High Definition Audio
(rev a2).
Niveau soft, c'est donc une base de Etch AMD64, mise a jour en 2.6.21 et
passee en SID.

Je dois admetre qu'en version Etch 'de base', apres qques galeres quand
meme, j'avais reussit a faire fonctionner l'audio. Mais depuis la mise a
jour du kernel, plus moyen de le faire fonctionner
Normalement, lors de la compilation du noyeau, j'ai bien configure tout
ce qui concerne le son, ALSA etc (par contre j'ai rien active d'OSS)
et comme driver, le hda_intel semble convenir. C'est la version d'Alsa
1.0.13r5 qui est installee.

Deja, au boot, il me donne des erreurs avec Alsa, genre "could no load
snd.ko" ou qque chose comme ca (desole je n'arrive pas a lire ca va trop
vite) et ensuite, une dizaine de lignes d'erreurs avec amixer
Ensuite, quand je fais un alsaconf, il dit "modinfo: could not find
module snd", se lance normalement, et ne trouve aucune carte son

Je ne comprend pas bien. J'ai essaye de tout desinstalle/reinstaller via
synaptic, mmais rien n'y fait. Je me suis tape pas mal de page google
mais rien de probant non plus. Il faut dire que j'ai une version
tres/trop a jour et pour trouver un support qui pourrait correspondre
c'est difficil! J'ai cette mauvaise habitude d'etre super a jour dans
mes softs, c'est plus fort que moi! :)
Je pensai qu'en passant a SID, je pourrais avoir, via aptitude/synaptic,
la derniere version d'alsa (1.0.14rc4 qui semble mieux gerer le fameux
MCP61), pareceque j'ai beaucoup de mal a installer celle-ci a la main ->
impossible de trouver un linux-header a jour pour mon noyeau!
(Linux-header, a vrais dire je ne sais ni vraiment ce que c'est, ni
comment me le procurer/fabriquer/generer). Et il semblerait qu'il
soit necessaire pour complier alsa. Je crois qu'elle est en
experimantale, ca veut dire quoi ?

Bref, je suis perdu la!
Je suis donc oblige de m'en remettre a vous!
Qqu'un aurait une idee/piste/etc.. ?

Merci d'avance, SUhsi.


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Vincent Bernat
Le #9557021
OoO En cette nuit nuageuse du lundi 14 mai 2007, vers 00:25, Sushi

Je dois admetre qu'en version Etch 'de base', apres qques galeres
quand meme, j'avais reussit a faire fonctionner l'audio. Mais depuis
la mise a jour du kernel, plus moyen de le faire fonctionner...
Normalement, lors de la compilation du noyeau, j'ai bien configure
tout ce qui concerne le son, ALSA etc... (par contre j'ai rien active
d'OSS) et comme driver, le hda_intel semble convenir. C'est la version
d'Alsa 1.0.13r5 qui est installee.



Pourquoi recompiler le noyau et ne pas utiliser le noyau 2.6.18 fourni
en standard ?
--
Replace repetitive expressions by calls to a common function.
- The Elements of Programming Style (Kernighan & Plauger)


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Sushi
Le #9556921
Vincent Bernat a ecrit:

Pourquoi recompiler le noyau et ne pas utiliser le noyau 2.6.18 fourni
en standard ?



En fait je me suis mal exprime: avec la version 2.6.18 de base, ma carte
son ne fonctionnait pas, j'ai ete oblige, dans un premier temps, de
mettre a jour en 2.6.20.x et c'est la que ca a marche. Ensuite, apres la
maj en 2.6.21, plus rien!
Si j'ai mis a jour mon kernel, c'est parceque j'avais lu, sur ce forum,
que ma carte son serait reconnue nativement avec un version plus recente
du noyeau...

A+ SUshi


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme