passage en 2.6.18 sur debian sarge

Le
Thierry B
Bonjour,

J'ai voulu tester un noyau de backports 2.6.18 sous mon serveur debian
sarge, vu que je suis actuellement sous la 2.6.15-686-smp de backports,
mais apparemment, ca foire pour la 2.6.18-3-686 et 2.6.18-4-686, avec
les mm types de messages:

~# aptitude install linux-image-2.6.18-3-686
Lecture des listes de paquets Fait
Construction de l'arbre des dépendances
Lecture de l'information d'état étendu
Initialisation de l'état des paquets Fait
Lecture des descriptions de tâches Fait
Les paquets suivants ont été conservés :
yaird
Les NOUVEAUX paquets suivants vont être installés :
linux-image-2.6.18-3-686
0 paquets mis à jour, 1 nouvellement installés, 0 à enlever et 1 non mis
à jour.
Il est nécessaire de télécharger 17,2Mo d'archives. Après dépaquetage,
53,0Mo seront utilisés.
Écriture de l'information d'état étendu Fait
Prendre : 1 http://www.backports.org sarge-backports/main
linux-image-2.6.18-3-686 2.6.18-8~bpo.1 [17,2MB]
17,2Mo téléchargés en 32ss (525ko/s)
Préconfiguration des paquets
Sélection du paquet linux-image-2.6.18-3-686 précédemment désélectionné.
(Lecture de la base de données 119306 fichiers et répertoires déjà
installés.)
Dépaquetage de linux-image-2.6.18-3-686 (à partir de
/linux-image-2.6.18-3-686_2.6.18-8~bpo.1_i386.deb)
Done.
Paramétrage de linux-image-2.6.18-3-686 (2.6.18-8~bpo.1)

Hmm. The package shipped with a symbolic link
/lib/modules/2.6.18-3-686/source
However, I can not read the target: Aucun fichier ou répertoire de ce type
Therefore, I am deleting /lib/modules/2.6.18-3-686/source

Running depmod.
Finding valid ramdisk creators.
Using mkinitrd.yaird to build the ramdisk.
yaird error: bad value in /boot/config-2.6.18-3-686:
CONFIG_DEFCONFIG_LIST="/lib/modules/$UNAME_RELEASE/.config" (fatal)
mkinitrd.yaird failed to create initrd image.
Failed to create initrd image.
dpkg : erreur de traitement de linux-image-2.6.18-3-686 (--configure) :
le sous-processus post-installation script a retourné une erreur de
sortie d'état 9
Des erreurs ont été rencontrées pendant l'exécution :
linux-image-2.6.18-3-686
E: Sub-process /usr/bin/dpkg returned an error code (1)
Ouille ! Quelque chose ne s'est pas bien passé lors de l'installation
des paquets. Tentative de réparation :
Paramétrage de linux-image-2.6.18-3-686 (2.6.18-8~bpo.1)
Running depmod.
Finding valid ramdisk creators.
Using mkinitrd.yaird to build the ramdisk.
yaird error: bad value in /boot/config-2.6.18-3-686:
CONFIG_DEFCONFIG_LIST="/lib/modules/$UNAME_RELEASE/.config" (fatal)
mkinitrd.yaird failed to create initrd image.
Failed to create initrd image.
dpkg : erreur de traitement de linux-image-2.6.18-3-686 (--configure) :
le sous-processus post-installation script a retourné une erreur de
sortie d'état 9
Des erreurs ont été rencontrées pendant l'exécution :
linux-image-2.6.18-3-686
Lecture des listes de paquets Fait
Construction de l'arbre des dépendances
Lecture de l'information d'état étendu
Initialisation de l'état des paquets Fait
Lecture des descriptions de tâches Fait

J'ai pas testé des 2.6.18 plus anciennes.

Qu'en pensez-vous?

Merci :-)


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Thierry B
Le #9534441
Vincent Bernat a écrit :
OoO En ce début d'après-midi ensoleillé du samedi 07 avril 2007, vers
15:50, Thierry B
Les paquets suivants ont été conservés :
yaird
Les NOUVEAUX paquets suivants vont être installés :
linux-image-2.6.18-3-686


[...]
Using mkinitrd.yaird to build the ramdisk.
yaird error: bad value in /boot/config-2.6.18-3-686:
CONFIG_DEFCONFIG_LIST="/lib/modules/$UNAME_RELEASE/.config" (fatal)
mkinitrd.yaird failed to create initrd image.



Quelle version de yaird ? Tu peux aussi essayer le initramfs-tools des
backports à la place.



Apparemment j'utilise yaird et initramfs-tools de backports:

# apt-cache showpkg yaird
Package: yaird
Versions:
0.0.12-18(/var/lib/apt/lists/ftp.fr.debian.org_debian_dists_etch_main_binary-i386_Packages)
0.0.12-8bpo1(/var/lib/dpkg/status)

# apt-cache showpkg initramfs-tools
Package: initramfs-tools
Versions:
0.85g(/var/lib/apt/lists/ftp.fr.debian.org_debian_dists_etch_main_binary-i386_Packages)
0.85e~bpo.1(/var/lib/apt/lists/www.backports.org_debian_dists_sarge-backports_main_binary-i386_Packages)

Merci :-)


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Vincent Bernat
Le #9534431
OoO En ce début d'après-midi ensoleillé du samedi 07 avril 2007, vers
15:50, Thierry B
Les paquets suivants ont été conservés :
yaird
Les NOUVEAUX paquets suivants vont être installés :
linux-image-2.6.18-3-686


[...]
Using mkinitrd.yaird to build the ramdisk.
yaird error: bad value in /boot/config-2.6.18-3-686:
CONFIG_DEFCONFIG_LIST="/lib/modules/$UNAME_RELEASE/.config" (fatal)
mkinitrd.yaird failed to create initrd image.



Quelle version de yaird ? Tu peux aussi essayer le initramfs-tools des
backports à la place.
--
printk("autofs: Out of inode numbers -- what the heck did you do??n");
2.0.38 /usr/src/linux/fs/autofs/root.c


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Vincent Bernat
Le #9534381
OoO Lors de la soirée naissante du samedi 07 avril 2007, vers 18:54,
Thierry B
Using mkinitrd.yaird to build the ramdisk.
yaird error: bad value in /boot/config-2.6.18-3-686:
CONFIG_DEFCONFIG_LIST="/lib/modules/$UNAME_RELEASE/.config" (fatal)
mkinitrd.yaird failed to create initrd image.



Quelle version de yaird ? Tu peux aussi essayer le initramfs-tools des
backports à la place.





Apparemment j'utilise yaird et initramfs-tools de backports:



Ben, vire yaird pour qu'il utilise initramfs-tools. ;-)
--
BOFH excuse #267:
The UPS is on strike.


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Thierry B
Le #9534371
Vincent Bernat a écrit :
OoO Lors de la soirée naissante du samedi 07 avril 2007, vers 18:54,
Thierry B
Using mkinitrd.yaird to build the ramdisk.
yaird error: bad value in /boot/config-2.6.18-3-686:
CONFIG_DEFCONFIG_LIST="/lib/modules/$UNAME_RELEASE/.config" (fatal)
mkinitrd.yaird failed to create initrd image.


Quelle version de yaird ? Tu peux aussi essayer le initramfs-tools des
backports à la place.





Apparemment j'utilise yaird et initramfs-tools de backports:



Ben, vire yaird pour qu'il utilise initramfs-tools. ;-)



Re,

Quand je veux enlever yaird, il veut m'enlever mon noyau courant et
d'autres aussi (tous les noyaux backports):

~# aptitude purge yaird
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture de l'information d'état étendu
Initialisation de l'état des paquets... Fait
Lecture des descriptions de tâches... Fait
Les paquets suivants ne sont pas utilisés et vont être ENLEVÉS :
libc6-i686 libhtml-template-perl libparse-recdescent-perl
Les paquets suivants seront automatiquement ENLEVÉS :
linux-image-2.6.14-2-686 linux-image-2.6.14-2-686-smp
linux-image-2.6.15-1-686-smp
Les paquets suivants seront ENLEVÉS :
linux-image-2.6.14-2-686 linux-image-2.6.14-2-686-smp
linux-image-2.6.15-1-686-smp yaird
0 paquets mis à jour, 0 nouvellement installés, 7 à enlever et 0 non mis
à jour.
Il est nécessaire de télécharger 0o d'archives. Après dépaquetage, 155Mo
seront libérés.
Voulez-vous continuer ? [Y/n/?]

Euh, ou sinon je tente de reinstaller initramfs-tools, en esperant qu'il
l'utilise par defaut?
Parce que c'est risqué de le laisser virer le noyau courant...lol

Merci :-)


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Vincent Bernat
Le #9534351
OoO Pendant le journal télévisé du samedi 07 avril 2007, vers 20:43,
Thierry B
Quand je veux enlever yaird, il veut m'enlever mon noyau courant et
d'autres aussi (tous les noyaux backports):



C'est curieux. Dans mon souvenir, les noyaux de backports acceptent
aussi bien initramfs-tools et yaird. Que donne "aptitude show
linux-image-2.6.15-1-686-smp" ? Et dpkg -l initramfs-tools ? Parce que
apt-cache showpkg montre les versions dispos, pas forcément celles
installées.
--
I WILL NOT DO MATH IN CLASS
I WILL NOT DO MATH IN CLASS
I WILL NOT DO MATH IN CLASS
-+- Lisa Simpson on chalkboard in episode BABF07


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Thierry B
Le #9534341
Vincent Bernat a écrit :
OoO Pendant le journal télévisé du samedi 07 avril 2007, vers 20:43,
Thierry B
Quand je veux enlever yaird, il veut m'enlever mon noyau courant et
d'autres aussi (tous les noyaux backports):



C'est curieux. Dans mon souvenir, les noyaux de backports acceptent
aussi bien initramfs-tools et yaird. Que donne "aptitude show
linux-image-2.6.15-1-686-smp" ? Et dpkg -l initramfs-tools ? Parce que
apt-cache showpkg montre les versions dispos, pas forcément celles
installées.



Re,

Voila:

~# aptitude show linux-image-2.6.15-1-686-smp
Paquet : linux-image-2.6.15-1-686-smp
Nouveau: oui
État: installé
Automatiquement installé: non
Version : 2.6.15-7bpo1
Priorité : optionnel
Section : base
Responsable : Debian Kernel Team Taille décompressée : 48,2M
Dépend: module-init-tools (>= 0.9.13), initramfs-tools | yaird |
linux-initramfs-tool
Recommande: libc6-i686
Suggère: linux-doc-2.6.15 | linux-source-2.6.15, lilo (>= 19.1) | grub,
fdutils
Fournit: linux-image-2.6, linux-image
Description : Linux kernel 2.6.15 image on PPro/Celeron/PII/PIII/P4 SMP
machines
This package provides the binary image and pre-built loadable modules for
Linux kernel 2.6.15 on multi-processor Pentium Pro/Celeron/Pentium
II/Pentium
III/Pentium 4 machines.

This packages is produced using an updated kernel packaging system and
replaces older kernel-image packages


dpkg -l initramfs-tools
Souhait=inconnU/Installé/suppRimé/Purgé/H=à garder
| État=Non/Installé/fichier-Config/dépaqUeté/échec-conFig/H=semi-installé
|/ Err?=(aucune)/H=à garder/besoin Réinstallation/X=les deux (État,Err:
majuscule=mauvais)
||/ Nom Version Description
+++-==============-==============-=========================================== un initramfs-tool <néant> (aucune description n'est disponible)

Autant pour moi, initramfs-tools n'est pas installé...

Mais,

# aptitude install initramfs-tools
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture de l'information d'état étendu
Initialisation de l'état des paquets... Fait
Lecture des descriptions de tâches... Fait
E: Impossible de corriger les problèmes, des paquets défecteux sont en
mode « garder en l'état ».
E: Impossible de corriger les dépendances, certains paquets ne peuvent
pas être installés
E: Unable to resolve some dependencies!
Certains paquets ont des dépendances non résolues. Ceci peut signifier
que vous avez demandé une situation impossible ou que vous utilisez la
distribution instable qui a besoin de paquets qui n'ont pas encore été créés
ou qui ne sont pas encore sortis « d'incoming ».

Les paquets suivants ont des dépendances non satisfaites :
initramfs-tools: Dépend: udev (>= 0.086-1) mais 0.056-3 doit être
installé

Je remarque de même que je n'ai pas udev sur ma machine:

# dpkg -l | grep "udev"

Du fait, qu'initramfs-tools requiert udev (>= 0.086-1), j'ai forcé dans
le fichier /etc/apt/preferences, pour qu'il mette la version backports
d'udev.

Je vérifie que c'est bien celle la qui sera installée:

# apt-cache policy udev
udev:
Installé : (aucun)
Candidat : 0.105-3~bpo.1
Étiquette de paquet : 0.105-3~bpo.1
Table de version :
0.105-4 999
100 http://ftp.fr.debian.org etch/main Packages
0.105-3~bpo.1 999
200 http://www.backports.org sarge-backports/main Packages
0.056-3 999
900 http://ftp.fr.debian.org stable/main Packages

Mais par contre en voulant installer udev:

# aptitude install udev
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture de l'information d'état étendu
Initialisation de l'état des paquets... Fait
Lecture des descriptions de tâches... Fait
Les paquets suivants ne sont pas utilisés et vont être ENLEVÉS :
libc6-i686 libhtml-template-perl libparse-recdescent-perl yaird
Les NOUVEAUX paquets suivants vont être automatiquement installés :
libvolume-id0
Les paquets suivants seront automatiquement ENLEVÉS :
hotplug kernel-image-2.6.8-2-386 kernel-image-2.6.8-3-686
linux-image-2.6.14-2-686 linux-image-2.6.14-2-686-smp
linux-image-2.6.15-1-686-smp module-init-tools
Les NOUVEAUX paquets suivants vont être installés :
libvolume-id0 udev
Les paquets suivants seront ENLEVÉS :
hotplug kernel-image-2.6.8-2-386 kernel-image-2.6.8-3-686
linux-image-2.6.14-2-686 linux-image-2.6.14-2-686-smp
linux-image-2.6.15-1-686-smp module-init-tools
0 paquets mis à jour, 2 nouvellement installés, 11 à enlever et 0 non
mis à jour.
Il est nécessaire de télécharger 323ko d'archives. Après dépaquetage,
242Mo seront libérés.
Voulez-vous continuer ? [Y/n/?]

Donc, il veut toujours me supprimer mes noyaux de backports + ceux de
sarge mnt lol.

Merci :-)


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Thierry B
Le #9534331
Thierry B a écrit :
Vincent Bernat a écrit :
OoO Pendant le journal télévisé du samedi 07 avril 2007, vers 20:43,
Thierry B
Quand je veux enlever yaird, il veut m'enlever mon noyau courant et
d'autres aussi (tous les noyaux backports):



C'est curieux. Dans mon souvenir, les noyaux de backports acceptent
aussi bien initramfs-tools et yaird. Que donne "aptitude show
linux-image-2.6.15-1-686-smp" ? Et dpkg -l initramfs-tools ? Parce que
apt-cache showpkg montre les versions dispos, pas forcément celles
installées.



Re,

Voila:

~# aptitude show linux-image-2.6.15-1-686-smp
Paquet : linux-image-2.6.15-1-686-smp
Nouveau: oui
État: installé
Automatiquement installé: non
Version : 2.6.15-7bpo1
Priorité : optionnel
Section : base
Responsable : Debian Kernel Team Taille décompressée : 48,2M
Dépend: module-init-tools (>= 0.9.13), initramfs-tools | yaird |
linux-initramfs-tool
Recommande: libc6-i686
Suggère: linux-doc-2.6.15 | linux-source-2.6.15, lilo (>= 19.1) | grub,
fdutils
Fournit: linux-image-2.6, linux-image
Description : Linux kernel 2.6.15 image on PPro/Celeron/PII/PIII/P4 SMP
machines
This package provides the binary image and pre-built loadable modules for
Linux kernel 2.6.15 on multi-processor Pentium Pro/Celeron/Pentium
II/Pentium
III/Pentium 4 machines.

This packages is produced using an updated kernel packaging system and
replaces older kernel-image packages


dpkg -l initramfs-tools
Souhait=inconnU/Installé/suppRimé/Purgé/H=à garder
| État=Non/Installé/fichier-Config/dépaqUeté/échec-conFig/H=semi-installé
|/ Err?=(aucune)/H=à garder/besoin Réinstallation/X=les deux (État,Err:
majuscule=mauvais)
||/ Nom Version Description
+++-==============-==============-============================================

un initramfs-tool <néant> (aucune description n'est disponible)

Autant pour moi, initramfs-tools n'est pas installé...

Mais,

# aptitude install initramfs-tools
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture de l'information d'état étendu
Initialisation de l'état des paquets... Fait
Lecture des descriptions de tâches... Fait
E: Impossible de corriger les problèmes, des paquets défecteux sont en
mode « garder en l'état ».
E: Impossible de corriger les dépendances, certains paquets ne peuvent
pas être installés
E: Unable to resolve some dependencies!
Certains paquets ont des dépendances non résolues. Ceci peut signifier
que vous avez demandé une situation impossible ou que vous utilisez la
distribution instable qui a besoin de paquets qui n'ont pas encore été
créés
ou qui ne sont pas encore sortis « d'incoming ».

Les paquets suivants ont des dépendances non satisfaites :
initramfs-tools: Dépend: udev (>= 0.086-1) mais 0.056-3 doit être
installé

Je remarque de même que je n'ai pas udev sur ma machine:

# dpkg -l | grep "udev"

Du fait, qu'initramfs-tools requiert udev (>= 0.086-1), j'ai forcé dans
le fichier /etc/apt/preferences, pour qu'il mette la version backports
d'udev.

Je vérifie que c'est bien celle la qui sera installée:

# apt-cache policy udev
udev:
Installé : (aucun)
Candidat : 0.105-3~bpo.1
Étiquette de paquet : 0.105-3~bpo.1
Table de version :
0.105-4 999
100 http://ftp.fr.debian.org etch/main Packages
0.105-3~bpo.1 999
200 http://www.backports.org sarge-backports/main Packages
0.056-3 999
900 http://ftp.fr.debian.org stable/main Packages

Mais par contre en voulant installer udev:

# aptitude install udev
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture de l'information d'état étendu
Initialisation de l'état des paquets... Fait
Lecture des descriptions de tâches... Fait
Les paquets suivants ne sont pas utilisés et vont être ENLEVÉS :
libc6-i686 libhtml-template-perl libparse-recdescent-perl yaird
Les NOUVEAUX paquets suivants vont être automatiquement installés :
libvolume-id0
Les paquets suivants seront automatiquement ENLEVÉS :
hotplug kernel-image-2.6.8-2-386 kernel-image-2.6.8-3-686
linux-image-2.6.14-2-686 linux-image-2.6.14-2-686-smp
linux-image-2.6.15-1-686-smp module-init-tools
Les NOUVEAUX paquets suivants vont être installés :
libvolume-id0 udev
Les paquets suivants seront ENLEVÉS :
hotplug kernel-image-2.6.8-2-386 kernel-image-2.6.8-3-686
linux-image-2.6.14-2-686 linux-image-2.6.14-2-686-smp
linux-image-2.6.15-1-686-smp module-init-tools
0 paquets mis à jour, 2 nouvellement installés, 11 à enlever et 0 non
mis à jour.
Il est nécessaire de télécharger 323ko d'archives. Après dépaquetage,
242Mo seront libérés.
Voulez-vous continuer ? [Y/n/?]

Donc, il veut toujours me supprimer mes noyaux de backports + ceux de
sarge mnt lol.

Merci :-)





Bon, je crois que j'ai trouvé:

# aptitude show udev
Paquet : udev
État: non installé
Version : 0.105-4
Priorité : optionnel
Section : admin
Responsable : Marco d'Itri Taille décompressée : 922k
Dépend: libc6 (>= 2.3.6-6), libselinux1 (>= 1.32), libvolume-id0 (>=
0.103-1),
debconf (>= 0.5) | debconf-2.0, lsb-base (>= 3.0-6)
Pré-dépend: debconf (>= 0.5) | debconf-2.0
Est en conflit: hotplug, initscripts (< 2.85-16), lvm-common (< 1.5.13),
module-init-tools (< 3.2.2-1), initramfs-tools (<
0.39), hal (<
0.5.6-2), makedev (< 2.3.1-80), klibc-utils (<= 1.4.19-1)
Remplace: initramfs-tools (<= 0.41)
Description : /dev/ and hotplug management daemon
udev is a daemon which dynamically creates and removes device nodes from
/dev/, handles hotplug events and loads drivers at boot time.

En fait, la version de module-init-tools que j'utilise est en conflit
avec le udev de backports, donc je vais mettre le module-init-tools de
backports.

On se lance...lol

# aptitude install udev
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture de l'information d'état étendu
Initialisation de l'état des paquets... Fait
Lecture des descriptions de tâches... Fait
Les NOUVEAUX paquets suivants vont être automatiquement installés :
libvolume-id0
Les paquets suivants seront automatiquement ENLEVÉS :
hotplug
Les paquets suivants ont été conservés :
yaird
Les NOUVEAUX paquets suivants vont être installés :
libvolume-id0 udev
Les paquets suivants seront ENLEVÉS :
hotplug
0 paquets mis à jour, 2 nouvellement installés, 1 à enlever et 1 non mis
à jour.
Il est nécessaire de télécharger 323ko d'archives. Après dépaquetage,
651ko seront utilisés.
Voulez-vous continuer ? [Y/n/?] Y
Écriture de l'information d'état étendu... Fait
Prendre : 1 http://www.backports.org sarge-backports/main libvolume-id0
0.105-3~bpo.1 [63,1kB]
Prendre : 2 http://www.backports.org sarge-backports/main udev
0.105-3~bpo.1 [260kB]
323ko téléchargés en 1ss (242ko/s)
Préconfiguration des paquets ...
(Lecture de la base de données... 119299 fichiers et répertoires déjà
installés.)
Suppression de hotplug ...
Sélection du paquet libvolume-id0 précédemment désélectionné.
(Lecture de la base de données... 119277 fichiers et répertoires déjà
installés.)
Dépaquetage de libvolume-id0 (à partir de
.../libvolume-id0_0.105-3~bpo.1_i386.deb) ...
Sélection du paquet udev précédemment désélectionné.
Dépaquetage de udev (à partir de .../udev_0.105-3~bpo.1_i386.deb) ...

**************************************************************
* Please purge the hotplug package!
* (/etc/init.d/hotplug has been found on this system)
**************************************************************

Paramétrage de libvolume-id0 (0.105-3~bpo.1) ...

Paramétrage de udev (0.105-3~bpo.1) ...
sed: impossible de lire /etc/udev/rules.d/z25_persistent-net.rules:
Aucun fichier ou répertoire de ce type
Populating the new /dev filesystem temporarily mounted on
/tmp/udev.5koKnC/...
CONSOLE_LOG_LEVEL is of unaccepted value.
KERNEL_RINGBUF_SIZE is of unaccepted value.
Stopping system logging: syslog-ng.
Starting system logging: syslog-ng.

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture de l'information d'état étendu
Initialisation de l'état des paquets... Fait
Lecture des descriptions de tâches... Fait

Je viens de purger udev comme ils me disent.

Par contre ce qui me faire peur, c'est que je ne retouve plus les blocks
de mes lv de mon volume group (lvm)

# df -h
...................
/dev/mapper/VG0-Home 5,0G 3,1G 2,0G 62% /home
/dev/mapper/VG0-Videos
120G 106G 15G 88% /mnt/Videos
......................

Je les vois encore avec df -h, pq ils sont montés mais sinon:

# ls -l /dev/mapper/
total 0
crw-rw---- 1 root root 10, 63 2007-04-08 00:53 control

J'ai du peau car je pense que tant que je ne vais pas rebooter il n'y
aura pas de pb pour accéder aux lv qui sont deja montés, mais après j'ai
un peu peur...

Vous pensez que ca sera résolu au reboot, qui est necessaire quand on
passe de hotplug à udev?

Je regarderai ca demain, pq là j'ai pas la tete a brancher un ecran sur
mon serveur et à booter sur live cd, si au prochain reboot il ne detecte
plus mes lvs :-(

Merci :-)


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Thierry B
Le #9534321
Thierry B a écrit :
Thierry B a écrit :
Vincent Bernat a écrit :
OoO Pendant le journal télévisé du samedi 07 avril 2007, vers 20:43,
Thierry B
Quand je veux enlever yaird, il veut m'enlever mon noyau courant et
d'autres aussi (tous les noyaux backports):



C'est curieux. Dans mon souvenir, les noyaux de backports acceptent
aussi bien initramfs-tools et yaird. Que donne "aptitude show
linux-image-2.6.15-1-686-smp" ? Et dpkg -l initramfs-tools ? Parce que
apt-cache showpkg montre les versions dispos, pas forcément celles
installées.



Re,

Voila:

~# aptitude show linux-image-2.6.15-1-686-smp
Paquet : linux-image-2.6.15-1-686-smp
Nouveau: oui
État: installé
Automatiquement installé: non
Version : 2.6.15-7bpo1
Priorité : optionnel
Section : base
Responsable : Debian Kernel Team Taille décompressée : 48,2M
Dépend: module-init-tools (>= 0.9.13), initramfs-tools | yaird |
linux-initramfs-tool
Recommande: libc6-i686
Suggère: linux-doc-2.6.15 | linux-source-2.6.15, lilo (>= 19.1) |
grub, fdutils
Fournit: linux-image-2.6, linux-image
Description : Linux kernel 2.6.15 image on PPro/Celeron/PII/PIII/P4
SMP machines
This package provides the binary image and pre-built loadable modules
for
Linux kernel 2.6.15 on multi-processor Pentium Pro/Celeron/Pentium
II/Pentium
III/Pentium 4 machines.

This packages is produced using an updated kernel packaging system and
replaces older kernel-image packages


dpkg -l initramfs-tools
Souhait=inconnU/Installé/suppRimé/Purgé/H=à garder
| État=Non/Installé/fichier-Config/dépaqUeté/échec-conFig/H=semi-installé
|/ Err?=(aucune)/H=à garder/besoin Réinstallation/X=les deux
(État,Err: majuscule=mauvais)
||/ Nom Version Description
+++-==============-==============-============================================

un initramfs-tool <néant> (aucune description n'est disponible)

Autant pour moi, initramfs-tools n'est pas installé...

Mais,

# aptitude install initramfs-tools
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture de l'information d'état étendu
Initialisation de l'état des paquets... Fait
Lecture des descriptions de tâches... Fait
E: Impossible de corriger les problèmes, des paquets défecteux sont en
mode « garder en l'état ».
E: Impossible de corriger les dépendances, certains paquets ne peuvent
pas être installés
E: Unable to resolve some dependencies!
Certains paquets ont des dépendances non résolues. Ceci peut signifier
que vous avez demandé une situation impossible ou que vous utilisez la
distribution instable qui a besoin de paquets qui n'ont pas encore été
créés
ou qui ne sont pas encore sortis « d'incoming ».

Les paquets suivants ont des dépendances non satisfaites :
initramfs-tools: Dépend: udev (>= 0.086-1) mais 0.056-3 doit être
installé

Je remarque de même que je n'ai pas udev sur ma machine:

# dpkg -l | grep "udev"

Du fait, qu'initramfs-tools requiert udev (>= 0.086-1), j'ai forcé
dans le fichier /etc/apt/preferences, pour qu'il mette la version
backports d'udev.

Je vérifie que c'est bien celle la qui sera installée:

# apt-cache policy udev
udev:
Installé : (aucun)
Candidat : 0.105-3~bpo.1
Étiquette de paquet : 0.105-3~bpo.1
Table de version :
0.105-4 999
100 http://ftp.fr.debian.org etch/main Packages
0.105-3~bpo.1 999
200 http://www.backports.org sarge-backports/main Packages
0.056-3 999
900 http://ftp.fr.debian.org stable/main Packages

Mais par contre en voulant installer udev:

# aptitude install udev
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture de l'information d'état étendu
Initialisation de l'état des paquets... Fait
Lecture des descriptions de tâches... Fait
Les paquets suivants ne sont pas utilisés et vont être ENLEVÉS :
libc6-i686 libhtml-template-perl libparse-recdescent-perl yaird
Les NOUVEAUX paquets suivants vont être automatiquement installés :
libvolume-id0
Les paquets suivants seront automatiquement ENLEVÉS :
hotplug kernel-image-2.6.8-2-386 kernel-image-2.6.8-3-686
linux-image-2.6.14-2-686 linux-image-2.6.14-2-686-smp
linux-image-2.6.15-1-686-smp module-init-tools
Les NOUVEAUX paquets suivants vont être installés :
libvolume-id0 udev
Les paquets suivants seront ENLEVÉS :
hotplug kernel-image-2.6.8-2-386 kernel-image-2.6.8-3-686
linux-image-2.6.14-2-686 linux-image-2.6.14-2-686-smp
linux-image-2.6.15-1-686-smp module-init-tools
0 paquets mis à jour, 2 nouvellement installés, 11 à enlever et 0 non
mis à jour.
Il est nécessaire de télécharger 323ko d'archives. Après dépaquetage,
242Mo seront libérés.
Voulez-vous continuer ? [Y/n/?]

Donc, il veut toujours me supprimer mes noyaux de backports + ceux de
sarge mnt lol.

Merci :-)





Bon, je crois que j'ai trouvé:

# aptitude show udev
Paquet : udev
État: non installé
Version : 0.105-4
Priorité : optionnel
Section : admin
Responsable : Marco d'Itri Taille décompressée : 922k
Dépend: libc6 (>= 2.3.6-6), libselinux1 (>= 1.32), libvolume-id0 (>=
0.103-1),
debconf (>= 0.5) | debconf-2.0, lsb-base (>= 3.0-6)
Pré-dépend: debconf (>= 0.5) | debconf-2.0
Est en conflit: hotplug, initscripts (< 2.85-16), lvm-common (< 1.5.13),
module-init-tools (< 3.2.2-1), initramfs-tools (< 0.39),
hal (<
0.5.6-2), makedev (< 2.3.1-80), klibc-utils (<= 1.4.19-1)
Remplace: initramfs-tools (<= 0.41)
Description : /dev/ and hotplug management daemon
udev is a daemon which dynamically creates and removes device nodes from
/dev/, handles hotplug events and loads drivers at boot time.

En fait, la version de module-init-tools que j'utilise est en conflit
avec le udev de backports, donc je vais mettre le module-init-tools de
backports.

On se lance...lol

# aptitude install udev
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture de l'information d'état étendu
Initialisation de l'état des paquets... Fait
Lecture des descriptions de tâches... Fait
Les NOUVEAUX paquets suivants vont être automatiquement installés :
libvolume-id0
Les paquets suivants seront automatiquement ENLEVÉS :
hotplug
Les paquets suivants ont été conservés :
yaird
Les NOUVEAUX paquets suivants vont être installés :
libvolume-id0 udev
Les paquets suivants seront ENLEVÉS :
hotplug
0 paquets mis à jour, 2 nouvellement installés, 1 à enlever et 1 non mis
à jour.
Il est nécessaire de télécharger 323ko d'archives. Après dépaquetage,
651ko seront utilisés.
Voulez-vous continuer ? [Y/n/?] Y
Écriture de l'information d'état étendu... Fait
Prendre : 1 http://www.backports.org sarge-backports/main libvolume-id0
0.105-3~bpo.1 [63,1kB]
Prendre : 2 http://www.backports.org sarge-backports/main udev
0.105-3~bpo.1 [260kB]
323ko téléchargés en 1ss (242ko/s)
Préconfiguration des paquets ...
(Lecture de la base de données... 119299 fichiers et répertoires déjà
installés.)
Suppression de hotplug ...
Sélection du paquet libvolume-id0 précédemment désélectionné.
(Lecture de la base de données... 119277 fichiers et répertoires déjà
installés.)
Dépaquetage de libvolume-id0 (à partir de
.../libvolume-id0_0.105-3~bpo.1_i386.deb) ...
Sélection du paquet udev précédemment désélectionné.
Dépaquetage de udev (à partir de .../udev_0.105-3~bpo.1_i386.deb) ...

**************************************************************
* Please purge the hotplug package!
* (/etc/init.d/hotplug has been found on this system)
**************************************************************

Paramétrage de libvolume-id0 (0.105-3~bpo.1) ...

Paramétrage de udev (0.105-3~bpo.1) ...
sed: impossible de lire /etc/udev/rules.d/z25_persistent-net.rules:
Aucun fichier ou répertoire de ce type
Populating the new /dev filesystem temporarily mounted on
/tmp/udev.5koKnC/...
CONSOLE_LOG_LEVEL is of unaccepted value.
KERNEL_RINGBUF_SIZE is of unaccepted value.
Stopping system logging: syslog-ng.
Starting system logging: syslog-ng.

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture de l'information d'état étendu
Initialisation de l'état des paquets... Fait
Lecture des descriptions de tâches... Fait

Je viens de purger udev comme ils me disent.

Par contre ce qui me faire peur, c'est que je ne retouve plus les blocks
de mes lv de mon volume group (lvm)

# df -h
...................
/dev/mapper/VG0-Home 5,0G 3,1G 2,0G 62% /home
/dev/mapper/VG0-Videos
120G 106G 15G 88% /mnt/Videos
......................

Je les vois encore avec df -h, pq ils sont montés mais sinon:

# ls -l /dev/mapper/
total 0
crw-rw---- 1 root root 10, 63 2007-04-08 00:53 control

J'ai du peau car je pense que tant que je ne vais pas rebooter il n'y
aura pas de pb pour accéder aux lv qui sont deja montés, mais après j'ai
un peu peur...

Vous pensez que ca sera résolu au reboot, qui est necessaire quand on
passe de hotplug à udev?

Je regarderai ca demain, pq là j'ai pas la tete a brancher un ecran sur
mon serveur et à booter sur live cd, si au prochain reboot il ne detecte
plus mes lvs :-(

Merci :-)





Ouf, lol

Ils ne sont pas completmeent perdus :-)

# ls -l /dev/.static/dev/mapper/VG0-Home
brw-rw---- 1 root disk 253, 8 2006-10-30 15:20
/dev/.static/dev/mapper/VG0-Home

Bon, je suis quasiment sure, que c'est temporaire et que ca sera monté
là où il faut au prochain redemarrage.

Je vais quand même m'en assurer avant d'installer le linux-image-2.6.18
qui ne devrait plus poser de difficultés je pense gràce a toi :-)


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Vincent Bernat
Le #9534301
OoO En cette nuit nuageuse du dimanche 08 avril 2007, vers 01:21,
Thierry B
Ils ne sont pas completmeent perdus :-)



# ls -l /dev/.static/dev/mapper/VG0-Home
brw-rw---- 1 root disk 253, 8 2006-10-30 15:20
/dev/.static/dev/mapper/VG0-Home



Bon, je suis quasiment sure, que c'est temporaire et que ca sera monté
là où il faut au prochain redemarrage.



Ils seront créés automatiquement (lorsque le scan des disques a lieu
pour trouver l'ensembles des PV, VG, LV). Ils seront aussi dispos dans
/dev/VG0 (s'ils ne le sont pas déjà).
--
I WILL NOT SPANK OTHERS
I WILL NOT SPANK OTHERS
I WILL NOT SPANK OTHERS
-+- Bart Simpson on chalkboard in episode 8F14


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Thierry B
Le #9534281
Vincent Bernat a écrit :
OoO En cette nuit nuageuse du dimanche 08 avril 2007, vers 01:21,
Thierry B
Ils ne sont pas completmeent perdus :-)



# ls -l /dev/.static/dev/mapper/VG0-Home
brw-rw---- 1 root disk 253, 8 2006-10-30 15:20
/dev/.static/dev/mapper/VG0-Home



Bon, je suis quasiment sure, que c'est temporaire et que ca sera monté
là où il faut au prochain redemarrage.



Ils seront créés automatiquement (lorsque le scan des disques a lieu
pour trouver l'ensembles des PV, VG, LV). Ils seront aussi dispos dans
/dev/VG0 (s'ils ne le sont pas déjà).



Re,

Ouais, tout est nikel, je viens aussi d'installer le
linux-image-2.6.18-4-686, et tout roule :-)

Merci encore :-)


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme