Passage en 5.0

Le
fconangl
Bonjour à tous,
J'ai tenté un passage en 5.0 mais je me retrouve avec le message suivant.

debian:~# apt-get dselect-upgrade
Lecture des listes de paquets Fait
Construction de l'arbre des dépendances Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
binutils: Dépend: libc6 (>= 2.7-1) mais 2.3.6.ds1-13etch9+b1 est installé
libc6-dev: Dépend: libc6 (= 2.7-18) mais 2.3.6.ds1-13etch9+b1 est
installé
locales: Dépend: glibc-2.7-1
E: Dépendances manquantes. Essayez d'utiliser l'option -f.
debian:~# apt-get -f install
Lecture des listes de paquets Fait
Construction de l'arbre des dépendances Fait
Correction des dépendances Fait
Les paquets supplémentaires suivants seront installés :
libc6
Paquets suggérés :
glibc-doc libc6-i686
Les paquets suivants seront mis à jour :
libc6
1 mis à jour, 0 nouvellement installés, 0 à enlever et 1005 non mis à jour.
4 partiellement installés ou enlevés.
Il est nécessaire de prendre 4438ko dans les archives.
Après dépaquetage, 401ko d'espace disque seront libérés.
Souhaitez-vous continuer [O/n] ?
Réception de : 1 http://ftp.fr.debian.org lenny/main libc6 2.7-18 [4438kB]
4438ko réceptionnés en 15s (293ko/s)
Préconfiguration des paquets
(Lecture de la base de données 99406 fichiers et répertoires déjà
installés.)
Préparation du remplacement de libc6 2.3.6.ds1-13etch9+b1 (en utilisant
/arch
ives/libc6_2.7-18_i386.deb)
Checking for services that may need to be restarted
Checking init scripts
WARNING: init script for postgresql not found.
WARNING: init script for xscreensaver not found.

A non-dpkg owned copy of the libc6-i686 package was found.
It is not safe to upgrade the C library in this situation;
please remove that copy of the C library and try again.
dpkg : erreur de traitement de
/var/cache/apt/archives/libc6_2.7-18_i386.deb (--
unpack) :
le sous-processus pre-installation script a retourné une erreur de
sortie d'éta
t 1
Des erreurs ont été rencontrées pendant l'exécution :
/var/cache/apt/archives/libc6_2.7-18_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Merci pour vos lumières.
Fred.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Philippe Merlin
Le #18729621
Le samedi 21 février 2009, fconangl a écrit :
Bonjour à tous,
J'ai tenté un passage en 5.0 mais je me retrouve avec le message suivan t.

debian:~# apt-get dselect-upgrade
............
Merci pour vos lumières.


Normalement, si je me rappelle d'un message précédent.
apt-get update
puis:
apt ou aptitude install apt aptitude dpkg
puis :
apt-get ou aptitude dist-upgrade
il y a aussi la commande : aptitude safe-upgrade
A+
Philippe




--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Michel MOUNIER
Le #18729721
Philippe Merlin a écrit :
Le samedi 21 février 2009, fconangl a écrit :

Bonjour à tous,
J'ai tenté un passage en 5.0 mais je me retrouve avec le message suivant.

debian:~# apt-get dselect-upgrade
............
Merci pour vos lumières.



Normalement, si je me rappelle d'un message précédent.
apt-get update
puis:
apt ou aptitude install apt aptitude dpkg
puis :au ?
apt-get ou aptitude dist-upgrade
il y a aussi la commande : aptitude safe-upgrade
A+
Philippe







Bonsoir,

As-tu pris connaissance du document ci-dessous avant de démarrer ta mise
à niveau :

http://www.debian.org/releases/lenny/i386/release-notes/ch-about.fr.html

Bonne install

Michel

--
Michel Mounier
44°55'37"N 04°53'50"E
"Flouka"
39°03'57"N 08°27'37"E


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Jean-Michel OLTRA
Le #18729991
Bonjour,


Le samedi 21 février 2009, fconangl a écrit...



debian:~# apt-get dselect-upgrade
unpack) :
le sous-processus pre-installation script a retourné une erreur de
sortie d'éta t 1
Des erreurs ont été rencontrées pendant l'exécution :
/var/cache/apt/archives/libc6_2.7-18_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)




Je viens de faire plusieurs mises à jour vers Lenny avec :

aptitude update
installation d'aptitude, dpkg et consorts d'abord
re-aptitude
mise à jour des paquets par petites quantités.

--
jm

A.E.L. Sarl (R.C.S CASTRES 490843240)
http://www.spidboutic.fr


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Raphael Hertzog
Le #18732101
On Sat, 21 Feb 2009, fconangl wrote:
Bonjour à tous,
J'ai tenté un passage en 5.0 mais je me retrouve avec le message suivant.

A non-dpkg owned copy of the libc6-i686 package was found.
It is not safe to upgrade the C library in this situation;
please remove that copy of the C library and try again.
dpkg : erreur de traitement de
/var/cache/apt/archives/libc6_2.7-18_i386.deb (--
unpack) :




Que donne les commandes suivantes ?
dpkg -s libc6-i686
dpkg -S /lib/tls/i686/cmov/libc.so.6 /lib/i686/cmov/libc.so.6

Ensuite essayez de réinstaller libc6-i686 (en version etch) avant de faire
la mise à jour vers lenny.

Il semble que vous ayez le un des deux fichiers mentionnés ci-dessus sans
que libc6-i686 soit installé (ce qui n'est pas normal et surement la
conséquence d'une mauvaise manipulation).

Cordialement,
--
Raphaël Hertzog

Le best-seller français mis à jour pour Debian Etch :
http://www.ouaza.com/livre/admin-debian/

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Sylvain Sauvage
Le #18734131
Jean-Michel OLTRA, samedi 21 février 2009, 22:26:36 CET

Bonjour,



’jour,

Le samedi 21 février 2009, fconangl a écrit...

> debian:~# apt-get dselect-upgrade
> unpack) :
> le sous-processus pre-installation script a retourné une
> erreur de sortie d'éta t 1
> Des erreurs ont été rencontrées pendant l'exécution :
> /var/cache/apt/archives/libc6_2.7-18_i386.deb
> E: Sub-process /usr/bin/dpkg returned an error code (1)

Je viens de faire plusieurs mises à jour vers Lenny avec :

aptitude update
installation d'aptitude, dpkg et consorts d'abord
re-aptitude
mise à jour des paquets par petites quantités.



Il doit manquer des bouts dans ce que fconangl écrit.

J’ai fait une màj Etch→Lenny hier : la mise à   jour de la libc
demande d’arrêter certains services, dont les ?dm, il suffit de
refuser pour arriver à un arrêt de l’installation et une erreur
telle que celle qui est citée.
Ça m’est arrivé parce que la machine sert de TV/magn étoscope
et donc une session X est lancée d’office. J’ai honte …
En tout cas, par l’interface curses d’aptitude, ça s e fait en
une étape (u, U, !, g, g). Mais bon, ça dépend des paquets qui
sont installés…

--
Sylvain Sauvage

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
fconangl
Le #18743801
Bonsoir et merci pour votre aide,
Effectivement, comme le dit Raphaël, il y avait un problème avec libc6
qui d'aprés le système n'était pas installé.
Un mois auparavant, j'avais un problème avec ma gestion de paquets et le
loup a ressurgi lors de cette mise à jour...
Merci à tous.
Fred.


Raphael Hertzog a écrit :
On Sat, 21 Feb 2009, fconangl wrote:
Bonjour à tous,
J'ai tenté un passage en 5.0 mais je me retrouve avec le message suivant.

A non-dpkg owned copy of the libc6-i686 package was found.
It is not safe to upgrade the C library in this situation;
please remove that copy of the C library and try again.
dpkg : erreur de traitement de
/var/cache/apt/archives/libc6_2.7-18_i386.deb (--
unpack) :




Que donne les commandes suivantes ?
dpkg -s libc6-i686
dpkg -S /lib/tls/i686/cmov/libc.so.6 /lib/i686/cmov/libc.so.6

Ensuite essayez de réinstaller libc6-i686 (en version etch) avant de faire
la mise à jour vers lenny.

Il semble que vous ayez le un des deux fichiers mentionnés ci-dessus sans
que libc6-i686 soit installé (ce qui n'est pas normal et surement la
conséquence d'une mauvaise manipulation).

Cordialement,



--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
fconangl
Le #18788921
fconangl a écrit :
J'ai finalement réussi à passer en 5.0 grâce à apt.....
Je lisais différents posts parlant de la facilité d'utilisation
d'aptitude...je crois que je vais continuer avec apt.

Bonjour à tous,
J'ai tenté un passage en 5.0 mais je me retrouve avec le message suivant.

debian:~# apt-get dselect-upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
binutils: Dépend: libc6 (>= 2.7-1) mais 2.3.6.ds1-13etch9+b1 est installé
libc6-dev: Dépend: libc6 (= 2.7-18) mais 2.3.6.ds1-13etch9+b1 est
installé
locales: Dépend: glibc-2.7-1
E: Dépendances manquantes. Essayez d'utiliser l'option -f.
debian:~# apt-get -f install
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Correction des dépendances... Fait
Les paquets supplémentaires suivants seront installés :
libc6
Paquets suggérés :
glibc-doc libc6-i686
Les paquets suivants seront mis à jour :
libc6
1 mis à jour, 0 nouvellement installés, 0 à enlever et 1005 non mis à jour.
4 partiellement installés ou enlevés.
Il est nécessaire de prendre 4438ko dans les archives.
Après dépaquetage, 401ko d'espace disque seront libérés.
Souhaitez-vous continuer [O/n] ?
Réception de : 1 http://ftp.fr.debian.org lenny/main libc6 2.7-18 [4438kB]
4438ko réceptionnés en 15s (293ko/s)
Préconfiguration des paquets...
(Lecture de la base de données... 99406 fichiers et répertoires déjà
installés.)
Préparation du remplacement de libc6 2.3.6.ds1-13etch9+b1 (en utilisant
.../arch ives/libc6_2.7-18_i386.deb) ...
Checking for services that may need to be restarted...
Checking init scripts...
WARNING: init script for postgresql not found.
WARNING: init script for xscreensaver not found.

A non-dpkg owned copy of the libc6-i686 package was found.
It is not safe to upgrade the C library in this situation;
please remove that copy of the C library and try again.
dpkg : erreur de traitement de
/var/cache/apt/archives/libc6_2.7-18_i386.deb (--
unpack) :
le sous-processus pre-installation script a retourné une erreur de
sortie d'éta t 1
Des erreurs ont été rencontrées pendant l'exécution :
/var/cache/apt/archives/libc6_2.7-18_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Merci pour vos lumières.
Fred.




--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Vincent Danjean
Le #18910991
fconangl wrote:
Bonsoir et merci pour votre aide,
Effectivement, comme le dit Raphaël, il y avait un problème avec libc6
qui d'aprés le système n'était pas installé.



libc6-i686 pas libc6 (sans libc6, plus rien ne marcherait).

Ceci provient d'une version défectueuse de l'installeur de etch qui
installait les fichiers mais ne marquait pas le paquet comme installé. Les
développeurs de la libc6 ont ajouté le test supplémentaire qui a bloqué
votre mise à jour dès le problème détecté en affichant le message d'erreur.
La correction est assez simple, mais elle ne peut pas être automatique
(car elle touche des choses assez essentielles au système).

Sans ce test qui arrête l'installation de la nouvelle libc6 immédiatement,
on peut se retrouver avec un système possédant une libc6 non fonctionnelle
donc où plus aucun binaire lié avec la libc6 (dont bash...) ne fonctionnerait.
Là, c'est beaucoup plus technique pour analyser le problème et récupérer
la situation.

A+
Vincent

--
Vincent Danjean GPG key ID 0x9D025E87
GPG key fingerprint: FC95 08A6 854D DB48 4B9A 8A94 0BF7 7867 9D02 5E87
Unofficial pacakges: http://www-id.imag.fr/~danjean/deb.html#package
APT repo: deb http://perso.debian.org/~vdanjean/debian unstable main

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Publicité
Poster une réponse
Anonyme