Que ce passe t-il dans ma fonction ?

Le
Guy72
Bonjour,
J'ai cette fonction, elle ne fonctionne pas, ou ai-je ?
=SI(RECHERCHE("Gagné";AX12:AX42);"Gagné;""Perdu")
--
Cordialement
Guy
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 3
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
isabelle
Le #17422461
bonjour Guy,

il y a un guillemet au mauvais endroit,

=SI(RECHERCHE("Gagné";AX12:AX42);"Gagné";"Perdu")

isabelle

Guy72 a écrit :
Bonjour,
J'ai cette fonction, elle ne fonctionne pas, ou ai-je ............?
=SI(RECHERCHE("Gagné";AX12:AX42);"Gagné;""Perdu")


Daniel.C
Le #17422441
Bonsoir.
=SI(ESTNA(RECHERCHE("Gagné";AX12:AX42));"Perdu";"Gagné")
--
Cordialement.
Daniel
"Guy72"
Bonjour,
J'ai cette fonction, elle ne fonctionne pas, ou ai-je ............?
=SI(RECHERCHE("Gagné";AX12:AX42);"Gagné;""Perdu")
--
Cordialement
Guy



Guy72
Le #17422601
Bonjour Isabelle,
D'accord pour le guillemet.
Quand je mets la fonction =RECHERCHE("Gagné";AX12:AX42), j'ai bien la
réponse "Gagné"
Mais quand je mets la fonction.
=SI(RECHERCHE("Gagné";AX12:AX42);"Gagné";"Perdu").
Et pourtant, j'ai bien le texte "Gagné" dans AX12.
--
Cordialement
Guy

"isabelle" a écrit dans le message de news:

bonjour Guy,

il y a un guillemet au mauvais endroit,

=SI(RECHERCHE("Gagné";AX12:AX42);"Gagné";"Perdu")

isabelle

Guy72 a écrit :
Bonjour,
J'ai cette fonction, elle ne fonctionne pas, ou ai-je ............?
=SI(RECHERCHE("Gagné";AX12:AX42);"Gagné;""Perdu")




Guy72
Le #17422591
Bonjour Daniel
Ok ça fonctionne.
Merci
--
Cordialement
Guy

"Daniel.C" %23xwA$
Bonsoir.
=SI(ESTNA(RECHERCHE("Gagné";AX12:AX42));"Perdu";"Gagné")
--
Cordialement.
Daniel
"Guy72"
Bonjour,
J'ai cette fonction, elle ne fonctionne pas, ou ai-je ............?
=SI(RECHERCHE("Gagné";AX12:AX42);"Gagné;""Perdu")
--
Cordialement
Guy







Sam
Le #17422671
Bonjour,
a) dans la fonction SI le guillemet est mal positionné "Gagné";"Perdu")
b) la condition du SI semble incomplète , je mettrais plutôt
=SI(RECHERCHE("Gagné";AX12:AX42)="Gagné";"Gagné";"Perdu")
c) RECHERCHE nécessite un classement alphabétique de la zone de recherche

Je mettrais plutôt :
=SI(NB.SI(AX12:AX42;"gagné")>0;"gagné";"perdu")

Cordialement
Michel dit "Sam"

"Guy72"
Bonjour,
J'ai cette fonction, elle ne fonctionne pas, ou ai-je ............?
=SI(RECHERCHE("Gagné";AX12:AX42);"Gagné;""Perdu")
--
Cordialement
Guy



Guy72
Le #17422851
Je souhaiterais avoir un "" en plus de Gagné ou Perdu.
Possible ?
--
Cordialement
Guy
"Sam" 48e7cc94$0$879$


Bonjour,
a) dans la fonction SI le guillemet est mal positionné "Gagné";"Perdu")
b) la condition du SI semble incomplète , je mettrais plutôt
=SI(RECHERCHE("Gagné";AX12:AX42)="Gagné";"Gagné";"Perdu")
c) RECHERCHE nécessite un classement alphabétique de la zone de recherche

Je mettrais plutôt :
=SI(NB.SI(AX12:AX42;"gagné")>0;"gagné";"perdu")

Cordialement
Michel dit "Sam"

"Guy72"
Bonjour,
J'ai cette fonction, elle ne fonctionne pas, ou ai-je ............?
=SI(RECHERCHE("Gagné";AX12:AX42);"Gagné;""Perdu")
--
Cordialement
Guy







Guy72
Le #17423291
Oupss !!! fichier joint
http://cjoint.com/?kexRcneQor
--
Cordialement
Guy

"Guy72"
Je souhaiterais avoir un "" en plus de Gagné ou Perdu.
Possible ?
--
Cordialement
Guy
"Sam" 48e7cc94$0$879$


Bonjour,
a) dans la fonction SI le guillemet est mal positionné "Gagné";"Perdu")
b) la condition du SI semble incomplète , je mettrais plutôt
=SI(RECHERCHE("Gagné";AX12:AX42)="Gagné";"Gagné";"Perdu")
c) RECHERCHE nécessite un classement alphabétique de la zone de recherche

Je mettrais plutôt :
=SI(NB.SI(AX12:AX42;"gagné")>0;"gagné";"perdu")

Cordialement
Michel dit "Sam"

"Guy72"
Bonjour,
J'ai cette fonction, elle ne fonctionne pas, ou ai-je ............?
=SI(RECHERCHE("Gagné";AX12:AX42);"Gagné;""Perdu")
--
Cordialement
Guy











LSteph
Le #17423321
Bonsoir,

à valider en matricielle:

=SI(ET(J12:T12="");"";SI(ET(J12:T12=AZ12:BJ12);"gagné";"perdu"))

ctrl+maj+Entrée

--
lSteph

Guy72 a écrit :
Je souhaiterais avoir un "" en plus de Gagné ou Perdu.
Possible ?


Jacky
Le #17423311
RE...

=SI(NBVAL(J12:T12)<>6;"";SI(J12&L12&N12&O12&P12&R12&T12=AZ12&BB12&BD12&BF12&BH12&BJ12;"Gagné";"Perdu"))

Saisir sur une ligne
--
Salutations
JJ


"Guy72"
Oupss !!! fichier joint
http://cjoint.com/?kexRcneQor
--
Cordialement
Guy

"Guy72"
Je souhaiterais avoir un "" en plus de Gagné ou Perdu.
Possible ?
--
Cordialement
Guy
"Sam" 48e7cc94$0$879$


Bonjour,
a) dans la fonction SI le guillemet est mal positionné
"Gagné";"Perdu")
b) la condition du SI semble incomplète , je mettrais plutôt
=SI(RECHERCHE("Gagné";AX12:AX42)="Gagné";"Gagné";"Perdu")
c) RECHERCHE nécessite un classement alphabétique de la zone de
recherche

Je mettrais plutôt :
=SI(NB.SI(AX12:AX42;"gagné")>0;"gagné";"perdu")

Cordialement
Michel dit "Sam"

"Guy72"
Bonjour,
J'ai cette fonction, elle ne fonctionne pas, ou ai-je ............?
=SI(RECHERCHE("Gagné";AX12:AX42);"Gagné;""Perdu")
--
Cordialement
Guy















Guy72
Le #17424231
Bonjour Jacky et Steph,
Le problème est quand la solution est trouvée avant, les formules ne
fonctionnent pas.
Joint : http://cjoint.com/?kfjFVxvaM6
--
Cordialement
Guy
"Jacky" %
RE...

=SI(NBVAL(J12:T12)<>6;"";SI(J12&L12&N12&O12&P12&R12&T12=AZ12&BB12&BD12&BF12&BH12&BJ12;"Gagné";"Perdu"))

Saisir sur une ligne
--
Salutations
JJ


"Guy72"
Oupss !!! fichier joint
http://cjoint.com/?kexRcneQor
--
Cordialement
Guy

"Guy72"
Je souhaiterais avoir un "" en plus de Gagné ou Perdu.
Possible ?
--
Cordialement
Guy
"Sam" 48e7cc94$0$879$


Bonjour,
a) dans la fonction SI le guillemet est mal positionné "Gagné";"Perdu")
b) la condition du SI semble incomplète , je mettrais plutôt
=SI(RECHERCHE("Gagné";AX12:AX42)="Gagné";"Gagné";"Perdu")
c) RECHERCHE nécessite un classement alphabétique de la zone de
recherche

Je mettrais plutôt :
=SI(NB.SI(AX12:AX42;"gagné")>0;"gagné";"perdu")

Cordialement
Michel dit "Sam"

"Guy72"
Bonjour,
J'ai cette fonction, elle ne fonctionne pas, ou ai-je ............?
=SI(RECHERCHE("Gagné";AX12:AX42);"Gagné;""Perdu")
--
Cordialement
Guy



















Publicité
Poster une réponse
Anonyme