patch Office 2003 via GPO

Le
rej
Bonjour, j'ai une installation administrative d'Office2003 que j'installe sur
les postes par GPO. Je veux installer les patchs sur cette installation
administrative. J'ai suivi les directives qui se trouvent à ce lien
http://office.microsoft.com/en-us/ork2003/HA011402381033.aspx?pid=CH011480761033
Le problème est le suivant: lorsque le poste reçoit le GPO modifié,
l'application ne s'installe pas et j'ai un message d'erreur dans les logs qui
indique que la source n'est pas disponible ou que je n'ai pas les droits. Par
contre, si je crée un nouveau package avec la même installation
administrative qui a été «patché», l'installation se fait bien. Quelqu'un a
-t-il déjà eu ce problème ?
Merci de bien vouloir m'aider.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Mathieu CHATEAU
Le #660891
Bonjour,

Avez-vous supprimé c:MSOCache ou crée un mst qui supprime ce dossier ?
est-ce que la GPO qui a servie au déploiement initial est bien toujours
présente (avec le msi original) ?


--
Cordialement,
Mathieu CHATEAU
http://lordoftheping.blogspot.com


"rej" news:
Bonjour, j'ai une installation administrative d'Office2003 que j'installe
sur
les postes par GPO. Je veux installer les patchs sur cette installation
administrative. J'ai suivi les directives qui se trouvent à ce lien
http://office.microsoft.com/en-us/ork2003/HA011402381033.aspx?pid=CH011480761033
Le problème est le suivant: lorsque le poste reçoit le GPO modifié,
l'application ne s'installe pas et j'ai un message d'erreur dans les logs
qui
indique que la source n'est pas disponible ou que je n'ai pas les droits.
Par
contre, si je crée un nouveau package avec la même installation
administrative qui a été «patché», l'installation se fait bien. Quelqu'un
a
-t-il déjà eu ce problème ?
Merci de bien vouloir m'aider.




rej
Le #660380
Bonjour, non je n'ai pas de mst qui supprime le MSOCache. En fait, je ne
pense pas que c'est nécessaire dans mon cas. Je vais essayer d'être plus
explicite.
J'ai un dossier sur mon serveur qui est disponible à tous en lecture (autant
aux usagers qu'aux ordinateurs). Ce dossier est APPS. Dans ce dossier j'ai
créé un autre dossier que j'ai nommé OfficeSTD. Dans APPSOfficeSTD j'ai fait
une installation administrative de Office. J'ai ensuite créé mon GPO que j'ai
nommé Office2003 qui pointe sur APPSOfficeSTDSTD11.msi.
Je «ghost» un pc ( qui ne possède que Windows XPsp2) et j'applique le GPO
Office2003. Jusque là pas de problème.

Puisque ce GPO a été fait il y a plusieurs mois, il n'est plus à jour par
rapport aux patchs. (Bien sur, nous avons aussi un serveur qui envoie les
patchs mais c'est bien moins long de patcher le GPO pour le déploiement sur
les nouveaux PC).

Donc je trouve le lien
http://office.microsoft.com/en-us/ork2003/HA011402381033.aspx?pid=CH011480761033
qui indique comment patcher une installation administrative. Avant de faire
cette procédure, je fais un backup de mon dossier APPSOfficeSTD.

J'exécute la procédure directement dans APPSOfficeSTD. Tout ce passe bien
sans message d'erreur. Je ne touche pas à la programmation du GPO Office2003.
Je ghost un autre pc et j'applique le GPO Office2003. Et c'est là que ça ne
fonctionne pas. Comme le pc est fraichement ghosté, je ne pense pas que c'est
un problème de cache.

Par contre, si je fais une copie du dossier APPSOfficeSTD dans
APPSOfficeSTD-V1 et que je crée un GPO qui pointe sur ce nouveau dossier, et
bien ça fonctionne parfaitement!!! Et lorsque je regarde mon office, je vois
que les patchs sont bien installés.
C'est ce que je ne comprends pas, le GPO Office2003 n'a pas été modifié, il
pointe toujours sur le dossier APPSOfficeSTDSTD11.msi et ce fichier n'a pas
changé de nom.... Alors pourquoi j'ai un message qui m'indique que la source
n'est pas disponible? Il y a surement une astuce des GPO que je ne comprend
pas mais laquelle?


Bonjour,

Avez-vous supprimé c:MSOCache ou crée un mst qui supprime ce dossier ?
est-ce que la GPO qui a servie au déploiement initial est bien toujours
présente (avec le msi original) ?


--
Cordialement,
Mathieu CHATEAU
http://lordoftheping.blogspot.com


"rej" news:
Bonjour, j'ai une installation administrative d'Office2003 que j'installe
sur
les postes par GPO. Je veux installer les patchs sur cette installation
administrative. J'ai suivi les directives qui se trouvent à ce lien
http://office.microsoft.com/en-us/ork2003/HA011402381033.aspx?pid=CH011480761033
Le problème est le suivant: lorsque le poste reçoit le GPO modifié,
l'application ne s'installe pas et j'ai un message d'erreur dans les logs
qui
indique que la source n'est pas disponible ou que je n'ai pas les droits.
Par
contre, si je crée un nouveau package avec la même installation
administrative qui a été «patché», l'installation se fait bien. Quelqu'un
a
-t-il déjà eu ce problème ?
Merci de bien vouloir m'aider.







Mathieu CHATEAU
Le #660374
Votre gpo contient juste un batch qui appel le setup office ou bien est-ce
une publication d'office via GPO ?


--
Cordialement,
Mathieu CHATEAU
http://lordoftheping.blogspot.com


"rej" news:
Bonjour, non je n'ai pas de mst qui supprime le MSOCache. En fait, je ne
pense pas que c'est nécessaire dans mon cas. Je vais essayer d'être plus
explicite.
J'ai un dossier sur mon serveur qui est disponible à tous en lecture
(autant
aux usagers qu'aux ordinateurs). Ce dossier est APPS. Dans ce dossier j'ai
créé un autre dossier que j'ai nommé OfficeSTD. Dans APPSOfficeSTD j'ai
fait
une installation administrative de Office. J'ai ensuite créé mon GPO que
j'ai
nommé Office2003 qui pointe sur APPSOfficeSTDSTD11.msi.
Je «ghost» un pc ( qui ne possède que Windows XPsp2) et j'applique le GPO
Office2003. Jusque là pas de problème.

Puisque ce GPO a été fait il y a plusieurs mois, il n'est plus à jour par
rapport aux patchs. (Bien sur, nous avons aussi un serveur qui envoie les
patchs mais c'est bien moins long de patcher le GPO pour le déploiement
sur
les nouveaux PC).

Donc je trouve le lien
http://office.microsoft.com/en-us/ork2003/HA011402381033.aspx?pid=CH011480761033
qui indique comment patcher une installation administrative. Avant de
faire
cette procédure, je fais un backup de mon dossier APPSOfficeSTD.

J'exécute la procédure directement dans APPSOfficeSTD. Tout ce passe bien
sans message d'erreur. Je ne touche pas à la programmation du GPO
Office2003.
Je ghost un autre pc et j'applique le GPO Office2003. Et c'est là que ça
ne
fonctionne pas. Comme le pc est fraichement ghosté, je ne pense pas que
c'est
un problème de cache.

Par contre, si je fais une copie du dossier APPSOfficeSTD dans
APPSOfficeSTD-V1 et que je crée un GPO qui pointe sur ce nouveau dossier,
et
bien ça fonctionne parfaitement!!! Et lorsque je regarde mon office, je
vois
que les patchs sont bien installés.
C'est ce que je ne comprends pas, le GPO Office2003 n'a pas été modifié,
il
pointe toujours sur le dossier APPSOfficeSTDSTD11.msi et ce fichier n'a
pas
changé de nom.... Alors pourquoi j'ai un message qui m'indique que la
source
n'est pas disponible? Il y a surement une astuce des GPO que je ne
comprend
pas mais laquelle?


Bonjour,

Avez-vous supprimé c:MSOCache ou crée un mst qui supprime ce dossier ?
est-ce que la GPO qui a servie au déploiement initial est bien toujours
présente (avec le msi original) ?


--
Cordialement,
Mathieu CHATEAU
http://lordoftheping.blogspot.com


"rej" news:
Bonjour, j'ai une installation administrative d'Office2003 que
j'installe
sur
les postes par GPO. Je veux installer les patchs sur cette installation
administrative. J'ai suivi les directives qui se trouvent à ce lien
http://office.microsoft.com/en-us/ork2003/HA011402381033.aspx?pid=CH011480761033
Le problème est le suivant: lorsque le poste reçoit le GPO modifié,
l'application ne s'installe pas et j'ai un message d'erreur dans les
logs
qui
indique que la source n'est pas disponible ou que je n'ai pas les
droits.
Par
contre, si je crée un nouveau package avec la même installation
administrative qui a été «patché», l'installation se fait bien.
Quelqu'un
a
-t-il déjà eu ce problème ?
Merci de bien vouloir m'aider.









rej
Le #660090
Ce n'est pas un batch, c'est un déploiement attribué qui s'applique
directement aux ordinateurs via GPO.


Votre gpo contient juste un batch qui appel le setup office ou bien est-ce
une publication d'office via GPO ?


--
Cordialement,
Mathieu CHATEAU
http://lordoftheping.blogspot.com


"rej" news:
Bonjour, non je n'ai pas de mst qui supprime le MSOCache. En fait, je ne
pense pas que c'est nécessaire dans mon cas. Je vais essayer d'être plus
explicite.
J'ai un dossier sur mon serveur qui est disponible à tous en lecture
(autant
aux usagers qu'aux ordinateurs). Ce dossier est APPS. Dans ce dossier j'ai
créé un autre dossier que j'ai nommé OfficeSTD. Dans APPSOfficeSTD j'ai
fait
une installation administrative de Office. J'ai ensuite créé mon GPO que
j'ai
nommé Office2003 qui pointe sur APPSOfficeSTDSTD11.msi.
Je «ghost» un pc ( qui ne possède que Windows XPsp2) et j'applique le GPO
Office2003. Jusque là pas de problème.

Puisque ce GPO a été fait il y a plusieurs mois, il n'est plus à jour par
rapport aux patchs. (Bien sur, nous avons aussi un serveur qui envoie les
patchs mais c'est bien moins long de patcher le GPO pour le déploiement
sur
les nouveaux PC).

Donc je trouve le lien
http://office.microsoft.com/en-us/ork2003/HA011402381033.aspx?pid=CH011480761033
qui indique comment patcher une installation administrative. Avant de
faire
cette procédure, je fais un backup de mon dossier APPSOfficeSTD.

J'exécute la procédure directement dans APPSOfficeSTD. Tout ce passe bien
sans message d'erreur. Je ne touche pas à la programmation du GPO
Office2003.
Je ghost un autre pc et j'applique le GPO Office2003. Et c'est là que ça
ne
fonctionne pas. Comme le pc est fraichement ghosté, je ne pense pas que
c'est
un problème de cache.

Par contre, si je fais une copie du dossier APPSOfficeSTD dans
APPSOfficeSTD-V1 et que je crée un GPO qui pointe sur ce nouveau dossier,
et
bien ça fonctionne parfaitement!!! Et lorsque je regarde mon office, je
vois
que les patchs sont bien installés.
C'est ce que je ne comprends pas, le GPO Office2003 n'a pas été modifié,
il
pointe toujours sur le dossier APPSOfficeSTDSTD11.msi et ce fichier n'a
pas
changé de nom.... Alors pourquoi j'ai un message qui m'indique que la
source
n'est pas disponible? Il y a surement une astuce des GPO que je ne
comprend
pas mais laquelle?


Bonjour,

Avez-vous supprimé c:MSOCache ou crée un mst qui supprime ce dossier ?
est-ce que la GPO qui a servie au déploiement initial est bien toujours
présente (avec le msi original) ?


--
Cordialement,
Mathieu CHATEAU
http://lordoftheping.blogspot.com


"rej" news:
Bonjour, j'ai une installation administrative d'Office2003 que
j'installe
sur
les postes par GPO. Je veux installer les patchs sur cette installation
administrative. J'ai suivi les directives qui se trouvent à ce lien
http://office.microsoft.com/en-us/ork2003/HA011402381033.aspx?pid=CH011480761033
Le problème est le suivant: lorsque le poste reçoit le GPO modifié,
l'application ne s'installe pas et j'ai un message d'erreur dans les
logs
qui
indique que la source n'est pas disponible ou que je n'ai pas les
droits.
Par
contre, si je crée un nouveau package avec la même installation
administrative qui a été «patché», l'installation se fait bien.
Quelqu'un
a
-t-il déjà eu ce problème ?
Merci de bien vouloir m'aider.













sgf
Le #665242
Quand une rustine (patch) est appliquée sur un package d'installation, il se
peut qu'elle modifie le fichier MSI et, si c'est le cas, alors le GPO actuel
fait référence à un MSI qui pour lui n'existe plus. Car chaque fichier MSI à
une structure et une identité précise. S'il y a des changements (même si le
nom est identique) l'identité ne l'est plus. Donc pour le GPO le MSI n'est
plus disponible.
Publicité
Poster une réponse
Anonyme