pb d'acces des la page d'accueil

Le
Thomas
bonjour :-)


http://biocer.fr/

certains d'entre vous m'ont dit sur ce forum il y a qqes mois qu'ils
n'arrivaient pas à acceder à la page d'accueil
(désolé, j'ai pas eu le temps de m'occuper de ce pb à ce moment là)

pouvez vous vous manifester à nouveau, svp ? :-)


precisez moi si c'est bien l'erreur 406 que vous avez
(je suppose que c'est ca, mais j'ai pas souvenir que vous l'ayez précisé
à l'epoque)

<fantome.forums.tDeContes-EBAA33.18083915052007@news-4.proxad.net>

--
Informations sur Nicolas Sarkozy :
http://www.betapolitique.fr/spip.php?article0602
http://www.betapolitique.fr/spip.php?article0601
http://www.betapolitique.fr/spip.php?article0414
http://www.betapolitique.fr/spip.php?article0606
http://tDeContes.hd.free.fr/divers/Ruptures.pdf
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
rm
Le #11063041
Le jeudi 17 mai 2007 à 13:42, Thomas a écrit :

bonjour :-)



Salut,

http://biocer.fr/



arghh...

certains d'entre vous m'ont dit sur ce forum il y a qqes mois qu'ils
n'arrivaient pas à acceder à la page d'accueil
(désolé, j'ai pas eu le temps de m'occuper de ce pb à ce moment là)

pouvez vous vous manifester à nouveau, svp ? :-)

precisez moi si c'est bien l'erreur 406 que vous avez
(je suppose que c'est ca, mais j'ai pas souvenir que vous l'ayez précisé
à l'epoque)




pas mieux: avec Opera 9.20 [fr], pas de 406, mais "Vous tentez d'accèder à
l'adresse http://biocer.fr/, actuellement injoignable... ect..."
Un contrôle au sniffeur montre que la page index.fr.html (et elle seule)
est servie, mais pas affichée.
Avec Firefox 3.0a4 [en], oui, erreur "406 Not Acceptable"
le serveur répond HTTP/1.1 406 Not Acceptable
Date: Thu, 17 May 2007 12:13:01 GMT
Server: Apache/1.3.33 (Darwin)
Alternates: {"index.fr.html" 1 {type text/html} {language fr} {length
6527}}

Pas de soucis avec IE7 [fr], Firefox 2.0.0.3 [fr] et Swift 0.2 [en]

Fx2.0.0.3 envoie Accept-Language: fr,fr-fr;q=0.8,en-us;q=0.5,en;q=0.3
Fx 3.0a4 envoie Accept-Language: en-us,en;q=0.5
IE7 envoie sobrement Accept-Language: fr
Opera9 envoie Accept-Language: fr-FR,fr;q=0.9,en;q=0.8 par défaut mais même
en envoyant Accept-Language: fr, ça ne fonctionne pas mieux...
Swift n'envoie pas d'Accept-Language:

Bon courage !

@+
--
rm - http://opera-fr.com
Thomas
Le #11062631
In article (Dans l'article) rm
Le jeudi 17 mai 2007 à 13:42, Thomas a écrit :

> http://biocer.fr/

arghh...



qq ca veut dire ? :-D


> certains d'entre vous m'ont dit sur ce forum il y a qqes mois qu'ils
> n'arrivaient pas à acceder à la page d'accueil
> (désolé, j'ai pas eu le temps de m'occuper de ce pb à ce moment là)
>
> pouvez vous vous manifester à nouveau, svp ? :-)
>
> precisez moi si c'est bien l'erreur 406 que vous avez
> (je suppose que c'est ca, mais j'ai pas souvenir que vous l'ayez précisé
> à l'epoque)
>
>
pas mieux: avec Opera 9.20 [fr], pas de 406, mais "Vous tentez d'accèder à
l'adresse http://biocer.fr/, actuellement injoignable... ect..."



http://www.opera-fr.com/forum/viewtopic.php?pid238#p10238

c'est toi ra-mon ? :-)

au fait, j'ai oublié de demander,
http://biocer.fr/index.fr.html
ca marche, avec opera, ou pas non plus ?

Un contrôle au sniffeur montre que la page index.fr.html (et elle seule)
est servie, mais pas affichée.



effectivement, dans mes logs j'ai 200 en face d'opera
et t'as aucune idée d'où peut venir le pb ?


Avec Firefox 3.0a4 [en], oui, erreur "406 Not Acceptable"
le serveur rpond HTTP/1.1 406 Not Acceptable
Date: Thu, 17 May 2007 12:13:01 GMT
Server: Apache/1.3.33 (Darwin)
Alternates: {"index.fr.html" 1 {type text/html} {language fr} {length
6527}}



ok
comme je l'ai pas, pourrais tu m'enregistrer et m'envoyer le code html
que tu recois à ce moment là, stp, pour mon info ?

apres je vais essayer de faire une page d'erreur personnalisée (pour que
ca soit le moins desagreable possible), comme pour 403 et 404, si tu
veux bien m'aiguiller jusqu'à ce que ca marche bien :-)

pas d'idée non plus sur pourquoi Firefox 3.0a4 ne veut pas negocier avec
le serveur jusqu'à ce qu'ils s'entendent ? (d'apres ce qu'on m'a dit sur
fciws)



Pas de soucis avec IE7 [fr], Firefox 2.0.0.3 [fr] et Swift 0.2 [en]

Fx2.0.0.3 envoie Accept-Language: fr,fr-fr;q=0.8,en-us;q=0.5,en;q=0.3
IE7 envoie sobrement Accept-Language: fr



ok :-)


Opera9 envoie Accept-Language: fr-FR,fr;q=0.9,en;q=0.8 par défaut mais même
en envoyant Accept-Language: fr, ça ne fonctionne pas mieux...



ce pb a probablement rien à voir avec ca :-)


Fx 3.0a4 envoie Accept-Language: en-us,en;q=0.5
Swift n'envoie pas d'Accept-Language:



je crois que je viens de comprendre :-)

avant, je pensais que cette erreur 406 ne devrait jamais arriver, parce
que grace à LanguagePriority le serveur trouverais tjr qqch à servir
tout de suite

maintenant, j'ai compris que LanguagePriority sert si le client
n'indique rien du tout,
mais qu'il ne sert pas si le client indique des choix, mais qu'aucun
n'est disponible : dans ce cas là c'est la 406


Bon courage !



merci :-)

--
Informations sur Nicolas Sarkozy :
http://www.betapolitique.fr/spip.php?article0602
http://www.betapolitique.fr/spip.php?article0601
http://www.betapolitique.fr/spip.php?article0414
http://www.betapolitique.fr/spip.php?article0606
http://tDeContes.hd.free.fr/divers/Ruptures.pdf
rm
Le #11062611
Le dimanche 20 mai 2007 à 19:17, Thomas a écrit :

[...]
http://www.opera-fr.com/forum/viewtopic.php?pid238#p10238

c'est toi ra-mon ? :-)



J'en connais pas deux avec un pseudo aussi ridicule ;-P

au fait, j'ai oublié de demander,
http://biocer.fr/index.fr.html
ca marche, avec opera, ou pas non plus ?



Yes, enfin Oui. De même que toutes les sous-pages quand tu rajoutes à la
mano le index.fr.html
Reste toujours les vieux "problèmes" d'accentuations dûs aux charset
"macintosh" que'Opera ne supporte pas...

Un contrôle au sniffeur montre que la page index.fr.html (et elle seule)
est servie, mais pas affichée.



effectivement, dans mes logs j'ai 200 en face d'opera
et t'as aucune idée d'où peut venir le pb ?



En tout objectivité, pas d'Opera <:o), donc du serveur...

Avec Firefox 3.0a4 [en], oui, erreur "406 Not Acceptable"
le serveur rpond HTTP/1.1 406 Not Acceptable
Date: Thu, 17 May 2007 12:13:01 GMT
Server: Apache/1.3.33 (Darwin)
Alternates: {"index.fr.html" 1 {type text/html} {language fr} {length
6527}}



ok
comme je l'ai pas, pourrais tu m'enregistrer et m'envoyer le code html
que tu recois à ce moment là, stp, pour mon info ?

apres je vais essayer de faire une page d'erreur personnalisée (pour que
ca soit le moins desagreable possible), comme pour 403 et 404, si tu
veux bien m'aiguiller jusqu'à ce que ca marche bien :-)



ça te reclamerait un gros effort d'installer un firefox 3 en engliche ou un
Opera 9 si bien francisé ?

pas d'idée non plus sur pourquoi Firefox 3.0a4 ne veut pas negocier avec
le serveur jusqu'à ce qu'ils s'entendent ? (d'apres ce qu'on m'a dit sur
fciws)
[...]
Swift n'envoie pas d'Accept-Language:



je crois que je viens de comprendre :-)



non ?

avant, je pensais que cette erreur 406 ne devrait jamais arriver, parce
que grace à LanguagePriority le serveur trouverais tjr qqch à servir
tout de suite

maintenant, j'ai compris que LanguagePriority sert si le client
n'indique rien du tout,
mais qu'il ne sert pas si le client indique des choix, mais qu'aucun
n'est disponible : dans ce cas là c'est la 406



en tout cas, je crois que si biocer.fr n'avais pas été là j'aurais jamais
vu de 406 ailleurs que sur pigeot.fr

Bon courage !



merci :-)



@+
--
rm
Thomas
Le #11062401
In article (Dans l'article) rm
Le dimanche 20 mai 2007 à 19:17, Thomas a écrit :

> [...]
> http://www.opera-fr.com/forum/viewtopic.php?pid238#p10238
>
> c'est toi ra-mon ? :-)

J'en connais pas deux avec un pseudo aussi ridicule ;-P



:-)

(je te precise : quand j'ai ecrit ce msg, j'avais pas encore vu ta
reponse sur opera-fr.com, j'avais vu ton pseudo comme moderateur du
forum)



> au fait, j'ai oublié de demander,
> http://biocer.fr/index.fr.html
> ca marche, avec opera, ou pas non plus ?

Yes, enfin Oui. De même que toutes les sous-pages quand tu rajoutes à la
mano le index.fr.html



ah oui, c'est ca qui fait que j'ai cru que c'etait le meme pb que
l'erreur 406
c'est donc probablement lié à la negociation aussi

Reste toujours les vieux "problèmes" d'accentuations dûs aux charset
"macintosh" que'Opera ne supporte pas...



ca sera reglé quand j'aurai programmé mon serveur web (voir plus bas)
donc je ne m'en occupe pas maintenant


>> Un contrôle au sniffeur montre que la page index.fr.html (et elle seule)
>> est servie, mais pas affichée.
>
> effectivement, dans mes logs j'ai 200 en face d'opera
> et t'as aucune idée d'où peut venir le pb ?

En tout objectivité, pas d'Opera <:o), donc du serveur...



comment ca "En tout objectivité, pas d'Opera" ?
puisque tu reconnais qu'Opera recois le contenu de la page ?

je retire un peu de ce que j'ai dit, ca vient peut etre du serveur ...
mais j'aimerais bien qu'on (des experts qui connaissent bien Opera)
m'explique
pourquoi Opera refuse d'afficher la page alors qu'il la recoit entiere,
quel est le mecanisme qui fait qu'Opera affiche ou pas



>> Avec Firefox 3.0a4 [en], oui, erreur "406 Not Acceptable"
>> le serveur rpond HTTP/1.1 406 Not Acceptable
>> Date: Thu, 17 May 2007 12:13:01 GMT
>> Server: Apache/1.3.33 (Darwin)
>> Alternates: {"index.fr.html" 1 {type text/html} {language fr} {length
>> 6527}}
>
> ok
> comme je l'ai pas, pourrais tu m'enregistrer et m'envoyer le code html
> que tu recois à ce moment là, stp, pour mon info ?
>
> apres je vais essayer de faire une page d'erreur personnalisée (pour que
> ca soit le moins desagreable possible), comme pour 403 et 404, si tu
> veux bien m'aiguiller jusqu'à ce que ca marche bien :-)

ça te reclamerait un gros effort d'installer un firefox 3 en engliche ou un
Opera 9 si bien francisé ?



oui parce que je suis en train de monter mon activité professionnelle
(en CAE), cad que
- j'essaye de programmer des logiciels, dont un serveur web, pour que ca
soit plus pratique à l'avenir,
et j'espere pouvoir fournir des services avec ca (dont de l'hebergement)
- en attendant, je dois maintenir les sites web faits à la main

donc j'ai pas un temps illimité à passer sur ce pb,
donc si tu m'aides j'essaye de faire le maximum,
mais sinon tant pis, ca attendra mon serveur perso (que je devrais
maitriser à 100%)


avec icab, si je change de langue, j'ai tjr la reponse 200 directe, à
cause du "*" :
Accept-Language: fr, *;q=0.5



> pas d'idée non plus sur pourquoi Firefox 3.0a4 ne veut pas negocier avec
> le serveur jusqu'à ce qu'ils s'entendent ? (d'apres ce qu'on m'a dit sur
> fciws)
>[...]
>> Swift n'envoie pas d'Accept-Language:
>
> je crois que je viens de comprendre :-)

non ?

> avant, je pensais que cette erreur 406 ne devrait jamais arriver, parce
> que grace à LanguagePriority le serveur trouverais tjr qqch à servir
> tout de suite
>
> maintenant, j'ai compris que LanguagePriority sert si le client
> n'indique rien du tout,
> mais qu'il ne sert pas si le client indique des choix, mais qu'aucun
> n'est disponible : dans ce cas là c'est la 406

en tout cas, je crois que si biocer.fr n'avais pas été là j'aurais jamais
vu de 406 ailleurs que sur pigeot.fr



ah ?
peut etre que peu de monde utilise la negociation,
c'est vrai que je suis pas obligé, c'est pour etre pret à avoir des
pages en plusieurs langues (il en a été question à un moment)

--
Informations sur Nicolas Sarkozy :
http://www.betapolitique.fr/spip.php?article0602
http://www.betapolitique.fr/spip.php?article0601
http://www.betapolitique.fr/spip.php?article0414
http://www.betapolitique.fr/spip.php?article0606
http://tDeContes.hd.free.fr/divers/Ruptures.pdf
rm
Le #11062321
Salut,
Le lundi 21 mai 2007 à 18:57, Thomas a écrit :

[...]




En tout objectivité, pas d'Opera <:o), donc du serveur...



comment ca "En tout objectivité, pas d'Opera" ?



Disons que c'était une blague...

puisque tu reconnais qu'Opera recois le contenu de la page ?



Opera reçoit, relis moi, index.fr.html et c'est tout !
vois http://files.myopera.com/ra_mon/files/PacketsStreamReport_o9.html
Alors que Firefox recoit pas mal d'autres choses, les css en particulier...
vois http://files.myopera.com/ra_mon/files/PacketsStreamReport_fx2.html

Le seul truc qu'Opera fait après (dans le paquet suivant), c'est un
GET /favicon.ico
et il se prend un 404.

Ce que je ne pige pas c'est qu'Opera, normalement, commence à afficher la
page, même s'il n'a pas encore reçu les styles (c'est d'ailleurs ce qui le
différencie des autres si j'ai bien capté
http://nontroppo.org/test/Op7/loadtime.html )

Sinon, parmi les détails qui m'interpellent, par quel miracle divinatoire,
Firefox fait-il, dès le bout d'html reçu, son
GET /admin/css/sous-css/commun
alors qu'aucun tel chemin ne figure explicitement dans l'index.fr.html ?
et il récupère quand même le commun.css !

je retire un peu de ce que j'ai dit, ca vient peut etre du serveur ...
mais j'aimerais bien qu'on (des experts qui connaissent bien Opera)
m'explique
pourquoi Opera refuse d'afficher la page alors qu'il la recoit entiere,
quel est le mecanisme qui fait qu'Opera affiche ou pas



Les experts sont plutôt sur les groupes anglophones opera.* :-D
J'avais y'a quelques mois essayé...
http://groups.google.fr/group/opera.beta/browse_thread/thread/7bd979b393a5665a/c3b4985b8c8f6f10?lnk=st&q=&rnum=1&hl=fr#c3b4985b8c8f6f10
mais ça n'avait pas motivé les foules, mon "bad english" probablement.

[...]




ça te reclamerait un gros effort d'installer un firefox 3 en engliche ou un
Opera 9 si bien francisé ?



oui parce que je suis en train de monter mon activité professionnelle
(en CAE), cad que
- j'essaye de programmer des logiciels, dont un serveur web, pour que ca
soit plus pratique à l'avenir,
et j'espere pouvoir fournir des services avec ca (dont de l'hebergement)
- en attendant, je dois maintenir les sites web faits à la main

donc j'ai pas un temps illimité à passer sur ce pb,
donc si tu m'aides j'essaye de faire le maximum,
mais sinon tant pis, ca attendra mon serveur perso (que je devrais
maitriser à 100%)



j'ai pas non plus un temps illimité à passer sur ce problème qui n'est
d'ailleurs pas vraiment un problème pour moi, hein :)
Juste un site parmi quelques autres sur "passent" pas sur mon navigateur,
la routine :)

avec icab, si je change de langue, j'ai tjr la reponse 200 directe, à
cause du "*" :
Accept-Language: fr, *;q=0.5



C'est p't'être aussi parce que tes pages lui "cirent les pompes":
"Nous vous recommandons vivement d'utiliser des logiciels respectant les
standards, tels que Mozilla ou iCab"

:-)))

[...]







@+
--
rm
Publicité
Poster une réponse
Anonyme