Pb authentification IIS

Le
fdel
Bonjour,

Ce sujet vient d'être traité (réponse de jbongran) mais je n'arrive pas à
régler mon problème malgré les indications de jbongran.
J'ai un site WEB sous IIS 6 tournant sur un serveur Windows 2003 SP1
autonome (hors domaine). Je veux une authentification (basique ou intégrée).
Les clients utilisent IE7.
Si l'utilisateur fait partie du groupe des "administrateurs" la connexion au
site se fait sans problème.
Si l'utilisateur fait normalement partie du groupe "Users" la connexion est
refusée avec l'erreur http 401.1.
J'ai essayé les préconisations du KB 896861 sans succès.

Quelqu'un a-t-il une idée ?

Francis DELTEIL
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
jbongran
Le #11313301
fdel wrote:
Bonjour,

Ce sujet vient d'être traité (réponse de jbongran) mais je n'arrive
pas à régler mon problème malgré les indications de jbongran.
J'ai un site WEB sous IIS 6 tournant sur un serveur Windows 2003 SP1
autonome (hors domaine). Je veux une authentification (basique ou
intégrée). Les clients utilisent IE7.
Si l'utilisateur fait partie du groupe des "administrateurs" la
connexion au site se fait sans problème.
Si l'utilisateur fait normalement partie du groupe "Users" la
connexion est refusée avec l'erreur http 401.1.
J'ai essayé les préconisations du KB 896861 sans succès.

Quelqu'un a-t-il une idée ?

Francis DELTEIL



Une explication complète des erreurs 401.1 et 401.2 (en anglais)
http://www.microsoft.com/technet/prodtechnol/WindowsServer2003/Library/IIS/8feeaa51-c634-4de3-bfdc-e922d195a45e.mspx?mfr=true

Essayes par étapes, en ne validant qu'une seule méthode d'authentification.
Egalement vérifies dans IE (en bas à droite) dans quelle zone (intranet,
internet, etc) pense se trouver le navigateur.
Ensuite, toujours dans IE, dans les propriétés avancées, verifies comment
est géré l'envoi du mot de passe pour cette zone.
fdel
Le #11313291
Je suis en zone Internet et l'authentification intégrée est autorisée.
Si j'utilise l'application "Authentification et ff diagnostique" :
- avec le user j'obtiens
NTAuthenticationProviders
No Negotiate or Kerberos in the list of providers Path:W3SVC
AuthType:Kerberos
NTAuthenticationProviders
No Negotiate or Kerberos in the list of providers Path:W3SVC/1178770389/ROOT
AuthType:Kerberos
Test Authentication
Server's response: HTTP/1.1 401 Unauthorized
Learn about IIS status codes
Path:W3SVC/1178770389/ROOT
AuthType:NTLM
Diagnostics complete

- avec l'administrateur
NTAuthenticationProviders
No Negotiate or Kerberos in the list of providers Path:W3SVC
AuthType:Kerberos
NTAuthenticationProviders
No Negotiate or Kerberos in the list of providers Path:W3SVC/1178770389/ROOT
AuthType:Kerberos
Test Authentication
Server's response: HTTP/1.1 200 OK
Learn about IIS status codes
Path:W3SVC/1178770389/ROOT
AuthType:NTLM
Diagnostics complete


La negociation et Kerberos ne sont pas supportés mais cela me paraît normal.

Les users ont le droit d'ouvrir une session à partir du réseau (connexions
FTP déjà utilisées).

Je ne vois pas pourquoi seule la connexion "administrateur" fonctionne.

Francis DELTEIL

"jbongran" a écrit :

fdel wrote:
> Bonjour,
>
> Ce sujet vient d'être traité (réponse de jbongran) mais je n'arrive
> pas à régler mon problème malgré les indications de jbongran.
> J'ai un site WEB sous IIS 6 tournant sur un serveur Windows 2003 SP1
> autonome (hors domaine). Je veux une authentification (basique ou
> intégrée). Les clients utilisent IE7.
> Si l'utilisateur fait partie du groupe des "administrateurs" la
> connexion au site se fait sans problème.
> Si l'utilisateur fait normalement partie du groupe "Users" la
> connexion est refusée avec l'erreur http 401.1.
> J'ai essayé les préconisations du KB 896861 sans succès.
>
> Quelqu'un a-t-il une idée ?
>
> Francis DELTEIL

Une explication complète des erreurs 401.1 et 401.2 (en anglais)
http://www.microsoft.com/technet/prodtechnol/WindowsServer2003/Library/IIS/8feeaa51-c634-4de3-bfdc-e922d195a45e.mspx?mfr=true

Essayes par étapes, en ne validant qu'une seule méthode d'authentification.
Egalement vérifies dans IE (en bas à droite) dans quelle zone (intranet,
internet, etc) pense se trouver le navigateur.
Ensuite, toujours dans IE, dans les propriétés avancées, verifies comment
est géré l'envoi du mot de passe pour cette zone.





jbongran
Le #11313281
fdel wrote:
Je suis en zone Internet et l'authentification intégrée est autorisée.
Si j'utilise l'application "Authentification et ff diagnostique" :
- avec le user j'obtiens
NTAuthenticationProviders
No Negotiate or Kerberos in the list of providers Path:W3SVC
AuthType:Kerberos
NTAuthenticationProviders
No Negotiate or Kerberos in the list of providers
Path:W3SVC/1178770389/ROOT AuthType:Kerberos
Test Authentication
Server's response: HTTP/1.1 401 Unauthorized
Learn about IIS status codes
Path:W3SVC/1178770389/ROOT
AuthType:NTLM
Diagnostics complete

- avec l'administrateur
NTAuthenticationProviders
No Negotiate or Kerberos in the list of providers Path:W3SVC
AuthType:Kerberos
NTAuthenticationProviders
No Negotiate or Kerberos in the list of providers
Path:W3SVC/1178770389/ROOT AuthType:Kerberos
Test Authentication
Server's response: HTTP/1.1 200 OK
Learn about IIS status codes
Path:W3SVC/1178770389/ROOT
AuthType:NTLM
Diagnostics complete


La negociation et Kerberos ne sont pas supportés mais cela me paraît
normal.

Les users ont le droit d'ouvrir une session à partir du réseau
(connexions FTP déjà utilisées).

Je ne vois pas pourquoi seule la connexion "administrateur"
fonctionne.

Francis DELTEIL

"jbongran" a écrit :

fdel wrote:
Bonjour,

Ce sujet vient d'être traité (réponse de jbongran) mais je n'arrive
pas à régler mon problème malgré les indications de jbongran.
J'ai un site WEB sous IIS 6 tournant sur un serveur Windows 2003 SP1
autonome (hors domaine). Je veux une authentification (basique ou
intégrée). Les clients utilisent IE7.
Si l'utilisateur fait partie du groupe des "administrateurs" la
connexion au site se fait sans problème.
Si l'utilisateur fait normalement partie du groupe "Users" la
connexion est refusée avec l'erreur http 401.1.
J'ai essayé les préconisations du KB 896861 sans succès.

Quelqu'un a-t-il une idée ?

Francis DELTEIL



Une explication complète des erreurs 401.1 et 401.2 (en anglais)
http://www.microsoft.com/technet/prodtechnol/WindowsServer2003/Library/IIS/8feeaa51-c634-4de3-bfdc-e922d195a45e.mspx?mfr=true

Essayes par étapes, en ne validant qu'une seule méthode
d'authentification. Egalement vérifies dans IE (en bas à droite)
dans quelle zone (intranet, internet, etc) pense se trouver le
navigateur.
Ensuite, toujours dans IE, dans les propriétés avancées, verifies
comment est géré l'envoi du mot de passe pour cette zone.





L'envoi de l'authentification sur la zone internet n'est jamais une bonne
idée, mais bon c'est juste pour les tests, hein ;-)
http://support.microsoft.com/kb/871179
Publicité
Poster une réponse
Anonyme