Pb avec sommeprod conditions multiples

Le
magic-dd
bonjour

je butte sur une formule somme prod

la voici

=SOMMEPROD(($B$2:$B$1000=N17)*($D$2:$D$1000={1.21.41.11.13.22.23.12.3=
.42})*($G$2:$G$1000={"KRA"."CPA"}))*1)

si je fais en plusieurs étapes, cela fonctionne pour

=SOMMEPROD(($B$2:$B$1000=N17)*($D$2:$D$1000={1.21.41.11.13.22.23.12.3=
.42})*1)

mais des que je rajoute la suite ca ne marche pas

merci de votre aide
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 3
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jacquouille
Le #25698752
Bonsoir
Sans avoir bu et avec mes lunettes, je crois voir une parenthèse fermante en
trop...




Jacquouille

" Le vin est au repas ce que le parfum est à la femme."
"magic-dd" a écrit dans le message de groupe de discussion :


bonjour

je butte sur une formule somme prod

la voici

=SOMMEPROD(($B$2:$B$1000=N17)*($D$2:$D$1000={1.21.41.11.13.22.23.12.3.42})*($G$2:$G$1000={"KRA"."CPA"}))*1)

si je fais en plusieurs étapes, cela fonctionne pour

=SOMMEPROD(($B$2:$B$1000=N17)*($D$2:$D$1000={1.21.41.11.13.22.23.12.3.42})*1)

mais des que je rajoute la suite ca ne marche pas

merci de votre aide
magic-dd
Le #25698892
je vais vous mettre un exemple plus concret

3 colonnes

type, taille, couleur

le but est de connaitre le nombre de type défini parmi les tailles choisi es et les couleurs choisies

http://cjoint.com/?CJcvS3h5egr
Jacquouille
Le #25698952
Bonsoir
Baptiser les colonnes
Ensuite =SOMMEPROD((type="VELO")*(taille)*(couleur="rouge"))
etc
Avez-vous essayé le TCD ?


Jacquouille

" Le vin est au repas ce que le parfum est à la femme."
"magic-dd" a écrit dans le message de groupe de discussion :


je vais vous mettre un exemple plus concret

3 colonnes

type, taille, couleur

le but est de connaitre le nombre de type défini parmi les tailles choisies
et les couleurs choisies

http://cjoint.com/?CJcvS3h5egr
magic-dd
Le #25698942
Merci Jacquouille mais cela est un sommeprod simple

il fonctionne avec les differnetes tailles que je veux filtrer ainsi qu'un seul choix de couleur mais des que je luidemande 2 choix il ne sait plus fa ire




Avez-vous essayé le TCD ?



oui mais ne correspond pas à ce que je souhaite faire par la suite
Jacquouille
Le #25698932
Expliques-toi.
Tu veux deux choix .... les vélos rouges et les bleus ?



Jacquouille

" Le vin est au repas ce que le parfum est à la femme."
"magic-dd" a écrit dans le message de groupe de discussion :



Merci Jacquouille mais cela est un sommeprod simple

il fonctionne avec les differnetes tailles que je veux filtrer ainsi qu'un
seul choix de couleur mais des que je luidemande 2 choix il ne sait plus
faire




Avez-vous essayé le TCD ?



oui mais ne correspond pas à ce que je souhaite faire par la suite
magic-dd
Le #25698982
oui jacquouille

les velos en taille 16,18, 20 et ceux de couleur rouge, bleue

pas facile la chose

voir le detail dans le cjoint

j'ai plus de cheveux

Le mercredi 2 octobre 2013 22:19:24 UTC+2, Jacquouille a écrit :
Expliques-toi.

Tu veux deux choix .... les vélos rouges et les bleus ?







Jacquouille



" Le vin est au repas ce que le parfum est à la femme."

"magic-dd" a écrit dans le message de groupe de discussion :







Merci Jacquouille mais cela est un sommeprod simple



il fonctionne avec les differnetes tailles que je veux filtrer ainsi qu'u n

seul choix de couleur mais des que je luidemande 2 choix il ne sait plus

faire









> Avez-vous essayé le TCD ?



oui mais ne correspond pas à ce que je souhaite faire par la suite
Jacquouille
Le #25699042
Voilà pour les retrouver
Tu baptises tes colonnes, puis
=SOMMEPROD((TYPE="VELO")*((TAILLE)+(TAILLE )+(TAILLE"))*((COULEUR="rouge")+(COULEUR="bleu")))
et cela me donne 3 dans ton exemple.


Jacquouille

" Le vin est au repas ce que le parfum est à la femme."
"magic-dd" a écrit dans le message de groupe de discussion :


oui jacquouille

les velos en taille 16,18, 20 et ceux de couleur rouge, bleue

pas facile la chose

voir le detail dans le cjoint

j'ai plus de cheveux

Le mercredi 2 octobre 2013 22:19:24 UTC+2, Jacquouille a écrit :
Expliques-toi.

Tu veux deux choix .... les vélos rouges et les bleus ?







Jacquouille



" Le vin est au repas ce que le parfum est à la femme."

"magic-dd" a écrit dans le message de groupe de discussion :







Merci Jacquouille mais cela est un sommeprod simple



il fonctionne avec les differnetes tailles que je veux filtrer ainsi qu'un

seul choix de couleur mais des que je luidemande 2 choix il ne sait plus

faire









> Avez-vous essayé le TCD ?



oui mais ne correspond pas à ce que je souhaite faire par la suite
isabelle
Le #25699212
salut magic,

=SOMMEPROD((($A$2:$A$7=$G$2)*($B$2:$B$7={162022})+($C$2:$C$7="ROUGE")*($C$2:$C$7="BLEU")))

isabelle

Le 2013-10-02 16:30, magic-dd a écrit :
oui jacquouille

les velos en taille 16,18, 20 et ceux de couleur rouge, bleue

pas facile la chose

voir le detail dans le cjoint

j'ai plus de cheveux

Le mercredi 2 octobre 2013 22:19:24 UTC+2, Jacquouille a écrit :
Expliques-toi.

Tu veux deux choix .... les vélos rouges et les bleus ?







Jacquouille



" Le vin est au repas ce que le parfum est à la femme."

"magic-dd" a écrit dans le message de groupe de discussion :







Merci Jacquouille mais cela est un sommeprod simple



il fonctionne avec les differnetes tailles que je veux filtrer ainsi qu'un

seul choix de couleur mais des que je luidemande 2 choix il ne sait plus

faire









Avez-vous essayé le TCD ?





oui mais ne correspond pas à ce que je souhaite faire par la suite



isabelle
Le #25699252
ou selon ton exemple la plage finissant à la ligne 9

=SOMMEPROD((($A$2:$A$9=$G$2)*($B$2:$B$9={162022})+($C$2:$C$9="ROUGE")*($C$2:$C$9="BLEU")))

isabelle

Le 2013-10-02 19:50, isabelle a écrit :
salut magic,

=SOMMEPROD((($A$2:$A$7=$G$2)*($B$2:$B$7={162022})+($C$2:$C$7="ROUGE")*($C$2:$C$7="BLEU")))

isabelle
magic-dd
Le #25699412
merci les z'amis

mais une question me taraude

pourquoi ne peut on pas utiliser la syntaxe pour les couleurs comme celle d es tailles



Le jeudi 3 octobre 2013 02:06:39 UTC+2, isabelle a écrit :
ou selon ton exemple la plage finissant à la ligne 9



=SOMMEPROD((($A$2:$A$9=$G$2)*($B$2:$B$9={162022})+($C$2:$C$9="R OUGE")*($C$2:$C$9="BLEU")))



isabelle



Le 2013-10-02 19:50, isabelle a écrit :

> salut magic,

>

> =SOMMEPROD((($A$2:$A$7=$G$2)*($B$2:$B$7={162022})+($C$2:$C$7= "ROUGE")*($C$2:$C$7="BLEU")))

>

> isabelle
Publicité
Poster une réponse
Anonyme