Pb Background-image

Le
Emilie
Bonjour

dans une apli avec VS2008 je veux mettre une image en fond de cellule dans
une table sur ma masterpage.
en phase de construction l'image est bien affichée
par contre quand je lance l'appli, j'ai un écran blanc, la page située dans
le ContentPlaceHolder ne s'affiche pas
la ligne de code est :
<td style="background-image: url ('/C:/site/imagefonds.gif');">
Ai-je oublié du code qui provoque ce problème

Merci pour vos réponses
Emilie
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jérémy Jeanson
Le #17533941
Attention, td n'est pas vraiment copain avec la css il est possible que tu
rencontre des coucis avec.

Par contre dans ton cas je pense plutôt que c'est ton chemin qui pose des
soucis : je ne suis pas franchement convaincu qu'un serveur web va te
laisser utiliser directement un path vers l'un de ses lecteurs.

Si tu veux faire un test simple :
1. utilise un theme pour ton appli
2. ajoute une feuille de style
3. ajoute tes images (dans un répertoire qui leur soit propre c'est toujours
plus simple)... en plus tu pourras utiliser un chemin relatif à ta css, par
exemple : url('images/imagefonds.gif')
4. créé une classe pour ton td (et si ça ne marche pas intègre un div dans
ton td qui utilisera la css et ajout à la css un display:blok pour être
certain de remplire ta cellule td).

normalement cette solution marche à tout les coups.
--
Jérémy JEANSON
MCP
http://jeremy.blogdns.net

"Emilie" discussion : 48f5bdb1$0$887$
Bonjour

dans une apli avec VS2008 je veux mettre une image en fond de cellule dans
une table sur ma masterpage.
en phase de construction l'image est bien affichée
par contre quand je lance l'appli, j'ai un écran blanc, la page située
dans le ContentPlaceHolder ne s'affiche pas
la ligne de code est :
Ai-je oublié du code qui provoque ce problème

Merci pour vos réponses
Emilie



Publicité
Poster une réponse
Anonyme