Pb de chargement système, après utilisation de fsck.

Le
michael.van-nieuwenhoven
Bonjour,

Utilisateur de la Debian GNU/Linux Etch, j'ai converti des fichiers
vidéos avi en iso, avec l'utilitaire mkisofs.
Après redémarrage du système, j'ai eu le message d'erreur suivant :
STARTING Avahi m DNS/DNS-SD Daemon : avahi-daemonth1 : Media Link Off Failed !
J'ai utilisé le contrôleur de systèmes de fichiers fsck (sans option) par mégarde !
Maintenant, je ne peux plus me logger, ni avoir les privilèges ROOT.
Enter runlevel : 2 ou 1 ou 3 ou 4 ou 5 ou même 6.
Init : no more processes left in this runlevel.
Quand au niveau d'exécution S, il renvoit :
sulogin : cannot open password database !
Cet affichage est maintenu deux secondes, puis revient à l'invite Enter runlevel.
De plus, lors du chargement du noyau, j'ai comme message d'erreur :
modprobe : FATAL : could not load /lib/modules/2.6.18-4-K7/modules.dep : no such file or directory.
INIT : version 2.86 booting
INIT : no inittab file found
J'ai l'impression d'être dans l'obligation de réinstaller
cette merveilleuse distribution, après avoir consulté :
- Les cahiers de l'Admin de Raphaël Hertzog.
- GNU/Linux magazine HS N° 28.
D'avance merci pour votre aide précieuse !


Cordialement,


Michaël Van Nieuwenhoven.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
François Cerbelle
Le #17372601
Le Lun 29 septembre 2008 14:50, a
écrit :
[...]
Maintenant, je ne peux plus me logger, ni avoir les privilèges ROOT.
Enter runlevel : 2 ou 1 ou 3 ou 4 ou 5 ou même 6.
Init : no more processes left in this runlevel.
Quand au niveau d'exécution S, il renvoit :
sulogin : cannot open password database !
Cet affichage est maintenu deux secondes, puis revient à l'invite Enter
runlevel.
De plus, lors du chargement du noyau, j'ai comme message d'erreur :
modprobe : FATAL : could not load /lib/modules/2.6.18-4-K7/modules.dep :
no such file or directory.
INIT : version 2.86 booting
INIT : no inittab file found
J'ai l'impression d'être dans l'obligation de réinstaller cette
merveilleuse distribution, après avoir consulté :



Salut,

Tous ces messages laissent penser que tu as un problème sur la partition
qui héberge le système de fichiers racine (/). Plutôt que de réinstaller,
tu télécharges l'image du CD d'installation, mais au démarrage, tu choisis
"rescue". Tu pourras accéder à un shell depuis le CD (une sorte de mini
live CD). A ce moment, tu pourras essayer de voir :
- si tu as toujours tes partitions avec fdisk
- si elles sont propres : e2fsck -f /dev/[hs]d[abcd][1234]
- si elles peuvent se monter : mount /dev/[hs]d[abcd][1234] /mnt
- si elles contiennent bien les fichiers attendus
- si tu peux les utiliser comme racine : chroot /mnt (apres avoir monté
celle qui doit contenir ta racine)
- si les paquets sont bon : aptitude install debsums ; debsums

Je sais que ce message est un peu synthétique, pour te donner les pistes à
suivre. Je ne les ai pas détaillées car ce serait un livre entier, sinon.
Par contre, si tu ne sais pas comment explorer une des pistes, tu peux
toujours me demander plus d'explications, ici, sur la liste.

Courage

Fanfan
--
http://www.cerbelle.net - http://www.afdm-idf.org

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme