PB de définition du moteur de script par défaut sous VISTA

Le
Jean-Claude BELLAMY
Hello World !

Sur une machine livrée avec VISTA Home Premium préinstallé, j'ai un problème
très agaçant :
Je n'arrive pas à définir le moteur de script par défaut (cscript.exe ou
wscript.exe) à l'aide de la commande pourtant classique :
cscript //H:cscript //Nologo //S
ou
cscript //H:wscript //S

(ou la même chose avec wscript)

A chaque fois, je me goinfre l'injure :
"Erreur CScript: Impossible de modifier l'environnement d'exécution
de scripts par défaut."

Et si j'exécute "wscript //H:cscript //Nologo //S", c'est la même chose,
sauf que l'injure en mode texte est remplacée par une injurebox, mais au
contenu identique !!!

NB: j'ai désactivé UAC, j'ai vérifié les permissions sur les fichiers, sur
les clefs,

Comme j'en avais ras le brocoli, j'ai écrit un script (en VBS) qui modifie
les clefs de la BDR de la même façon que la commande sus-citée le fait
normalement, ce script fonctionne au poil, je peux donc choisir entre
cscript.exe et wscript.exe.
Le principe est fort simple :
Le moteur de script par défaut est celui qui est défini dans les clefs :

HKEY_CLASSES_ROOTJSEFileShellOpenCommand
HKEY_CLASSES_ROOTJSFileShellOpenCommand
HKEY_CLASSES_ROOTVBSFileShellOpenCommand
HKEY_CLASSES_ROOTVBEFileShellOpenCommand
HKEY_CLASSES_ROOTWSFFileShellOpenCommand

tandis que "l'autre" est défini dans les clefs :

HKEY_CLASSES_ROOTJSEFileShellOpen2Command
HKEY_CLASSES_ROOTJSFileShellOpen2Command
HKEY_CLASSES_ROOTVBSFileShellOpen2Command
HKEY_CLASSES_ROOTVBEFileShellOpen2Command
HKEY_CLASSES_ROOTWSFFileShellOpen2Command

les libellés respectifs, qui apparaissent dans le menu contextuel de
l'explorateur étant dans les clefs
HKEY_CLASSES_ROOTJSEFileShellOpen

et
HKEY_CLASSES_ROOTJSEFileShellOpen2


Donc avec ce script, j'ai résolu ponctuellement mon problème, et çà prouve
que ce n'est pas être un pb de droits, vu que mon script, lui, arrive bien à
modifier les clefs !

Mais cela ne me satisfait pas pleinement l'esprit
J'aimerais comprendre ce qui cloche dans mon système.

J'ai essayé sur une autre machine sous VISTA également (mais version
"Intégrale"), je n'ai pas de problème.

Je n'ai trouvé aucune info VALABLE à ce sujet sur le NET
Sur le MSDN, je lis ceci :
"Can't change default script host "
http://msdn2.microsoft.com/en-us/library/cy391bzc.aspx
This is usually a systems permission issue and the likely
cause is that the system registry has been locked by an
Administrator.

Vu que l'admin, c'est moi, si j'avais verrouillé la BDR, je le saurais !!!!
Je ne suis pas encore schizophrène !
Et mon script passe bien

Et j'aime la solution :
To correct this error :
Consult your Administrator about potential network
or security problems

Je me suis donc consulté, en m'informant qu'il y avait des problèmes
possibles de réseau ou de sécurité, mais je ne me suis rien répondu ! ;-)


Si vous avez des infos à ce sujet et/ou si vous avez rencontré le pb, je
suis preneur !
Merci par avance


--
May the Force be with You!
La Connaissance s'accroît quand on la partage
-
Jean-Claude BELLAMY [MVP]
http://www.bellamyjc.org ou http://jc.bellamy.free.fr
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Michel Claveau
Le #655546
Bonsoir !

J'aimerais bien essayer.

Mais je n'ai plus de courant depuis 2 heures. Seule la seconde batterie
de mon portable, et l'onduleur de la boîte réseau (routeur, switchs,
VPN) tiennent encore le coup.

Mais, j'essaierai dans les jours qui viennent.





--
@-salutations

Michel Claveau
moi
Le #655545
Notre ami Jean-Claude BELLAMY tapota :

Hello World !

Sur une machine livrée avec VISTA Home Premium préinstallé, j'ai un
problème très agaçant :
Je n'arrive pas à définir le moteur de script par défaut
(cscript.exe
ou wscript.exe) à l'aide de la commande pourtant classique :
cscript //H:cscript //Nologo //S
ou
cscript //H:wscript //S

(...)


Bonsoir,

J'ai eu un pb "assez analogue" et je n'ai jamais trouvé la solution.

Cela se produit avec UN login particulier
sur un portable (avec XP-Pro SP2 ) :

- refus de changer le moteur de script ( as you)
avec la fameuse commande

- refus de prendre les arguments du script
(en fait le tableau des arguments reste vide !)
et ça c'est assez inédit me semble-t-il ...
... je n'ai "rien trouvé nulle part" à ce propos...

J'ai perdu beaucoup de temps pour chercher la solution...
vainement.

donc ton pb n'est peut-être pas propre à Vista...

A+

Hb

Le Claude
Le #655314
Salut Jean Claude,

Que doit-on faire pour abréger ou tout au moins diminuer ta souffrance
? -:))))
J'ai Home Premium et je vais te raconter ce que j'ai vu :
Dans la ligne [Exécuter] (c'est bien là ?)

cscript //H:wscript //S : Motus !

cscript //H:cscript //Nologo //S :
une ardoise volante et rapide (trop pour moi) qui dit : {les propriétés ont
été enregistrées} ou un truc du genre

wscript //H:cscript //Nologo //S :
1° boîte de dialogue [Options de la ligne de commande ont été enregistrées]
==> [OK] ==>
2° boîte de dialogue [L'environnement d'éxécution de scripts wscript est
maintenant fixé à "cscript.exe"]

J'espère que je n'ai pas fait de c...ie, sinon je t'en voudrais toute ma
vie -:)))

Bon ! si tu veux faire un test sur un autre bécane tu dis, mais tu
expliques, pour moi c'est de l'Aléoute en graphie chinoise -:)))


--
Amicalement, Claude.

Claude CHARNEAU MVP-Shell/User.

La fé sense obras, morta es.


"Jean-Claude BELLAMY" message de news:
Hello World !

Sur une machine livrée avec VISTA Home Premium préinstallé, j'ai un
problème très agaçant :
Je n'arrive pas à définir le moteur de script par défaut (cscript.exe ou
wscript.exe) à l'aide de la commande pourtant classique :
cscript //H:cscript //Nologo //S
ou
cscript //H:wscript //S

(ou la même chose avec wscript)

A chaque fois, je me goinfre l'injure :
"Erreur CScript: Impossible de modifier l'environnement d'exécution
de scripts par défaut."

Et si j'exécute "wscript //H:cscript //Nologo //S", c'est la même chose,
sauf que l'injure en mode texte est remplacée par une injurebox, mais au
contenu identique !!!

NB: j'ai désactivé UAC, j'ai vérifié les permissions sur les fichiers, sur
les clefs, ...

Comme j'en avais ras le brocoli, j'ai écrit un script (en VBS) qui modifie
les clefs de la BDR de la même façon que la commande sus-citée le fait
normalement, ce script fonctionne au poil, je peux donc choisir entre
cscript.exe et wscript.exe.
Le principe est fort simple :
Le moteur de script par défaut est celui qui est défini dans les clefs :

HKEY_CLASSES_ROOTJSEFileShellOpenCommand
HKEY_CLASSES_ROOTJSFileShellOpenCommand
HKEY_CLASSES_ROOTVBSFileShellOpenCommand
HKEY_CLASSES_ROOTVBEFileShellOpenCommand
HKEY_CLASSES_ROOTWSFFileShellOpenCommand

tandis que "l'autre" est défini dans les clefs :

HKEY_CLASSES_ROOTJSEFileShellOpen2Command
HKEY_CLASSES_ROOTJSFileShellOpen2Command
HKEY_CLASSES_ROOTVBSFileShellOpen2Command
HKEY_CLASSES_ROOTVBEFileShellOpen2Command
HKEY_CLASSES_ROOTWSFFileShellOpen2Command

les libellés respectifs, qui apparaissent dans le menu contextuel de
l'explorateur étant dans les clefs
HKEY_CLASSES_ROOTJSEFileShellOpen
...
et
HKEY_CLASSES_ROOTJSEFileShellOpen2
...

Donc avec ce script, j'ai résolu ponctuellement mon problème, et çà prouve
que ce n'est pas être un pb de droits, vu que mon script, lui, arrive bien
à modifier les clefs !

Mais cela ne me satisfait pas pleinement l'esprit ...
J'aimerais comprendre ce qui cloche dans mon système.

J'ai essayé sur une autre machine sous VISTA également (mais version
"Intégrale"), je n'ai pas de problème.

Je n'ai trouvé aucune info VALABLE à ce sujet sur le NET ...
Sur le MSDN, je lis ceci :
"Can't change default script host "
http://msdn2.microsoft.com/en-us/library/cy391bzc.aspx
This is usually a systems permission issue and the likely
cause is that the system registry has been locked by an
Administrator.

Vu que l'admin, c'est moi, si j'avais verrouillé la BDR, je le saurais
!!!!
Je ne suis pas encore schizophrène !
Et mon script passe bien ...

Et j'aime la solution :
To correct this error :
Consult your Administrator about potential network
or security problems

Je me suis donc consulté, en m'informant qu'il y avait des problèmes
possibles de réseau ou de sécurité, mais je ne me suis rien répondu ! ;-)


Si vous avez des infos à ce sujet et/ou si vous avez rencontré le pb, je
suis preneur !
Merci par avance ...


--
May the Force be with You!
La Connaissance s'accroît quand on la partage
----------------------------------------------------------
Jean-Claude BELLAMY [MVP]
http://www.bellamyjc.org ou http://jc.bellamy.free.fr



Publicité
Poster une réponse
Anonyme