PB Formule

Le
David Laulan
Bonsoir,
voilà une forule qui va chercher la quantité en fonction d'un code
commençant par lettre A et unité m²
=sommeprod((gauche(a1:a10)="A")*(e1:e10="m²")*f1:f10) avec colonne A les
codes, E l'unité et F le volume.
LA colonne G est le prix unitaire et la colonne H renferme la formule :
=si(estvide(E1);"";(F1 * G1))
Le souci est qu'il y a une valeur d'erreur lorsque j'utilise la formule plus
haut mais pour obtenir le montant se trouvant ds la colonne H.
Il y a certainement un solution, si on peut m'aider, Merci
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
garnote
Le #4236441
Salut David,

Si tu remplaces :
=SI(ESTVIDE(E1);"";F1*G1)
par :
=SI(ESTVIDE(E1);0;F1*G1)
quitte à mettre un format conditionnel sur F1:F10
pour camoufler le 0, la formule suivante fonctionne :
=SOMMEPROD((GAUCHE(A1:A10)="A")*(E1:E10="m2")*H1:H10)

Qu'en penses-tu ?
Serge


"David Laulan"
Bonsoir,
voilà une forule qui va chercher la quantité en fonction d'un code commençant par lettre A et unité m²
=sommeprod((gauche(a1:a10)="A")*(e1:e10="m²")*f1:f10) avec colonne A les codes, E l'unité et F le volume.
LA colonne G est le prix unitaire et la colonne H renferme la formule :
=si(estvide(E1);"";(F1 * G1))
Le souci est qu'il y a une valeur d'erreur lorsque j'utilise la formule plus haut mais pour obtenir le montant se trouvant ds la
colonne H.
Il y a certainement un solution, si on peut m'aider, Merci



Publicité
Poster une réponse
Anonyme