pb de gamma en passant de .MOV à .NIMPORTE_QUOI_DAUTRE

Le
pehache-tolai
Bonsoir,

je reviens avec un problème que j'avais déjà évoqué ici:

Quand je converti les fichiers *.mov issus de mon APN en *.mpg ou en
n'importe quoi d'autre que *.mov, je constate un assombrissement de l'image
quand je rejoue la video (apparemment une modification du gamma) sous Win
XP.

Mais aujourd'hui je pense pouvoir conclure que la luminosité n'est pas
modifiée dans les fichiers et que ce n'est qu'au rejeu que ça se passe. En
effet, si je copie bêtement le flux video (MJPEG) dans un fichier .avi sans
aucun réencodage (les valeurs des pixels ne sont donc pas modifées), je
constate l'assombrissement. Et si je recopie à nouveau le flux vers un
nouveau fichier .mov je retrouve la bonne luminosité

(pour info cette copie brute du flux video peut se faire avec l'utilitaire
en ligne de commande ffmpeg:
ffmpeg -i toto.mov -vcodec copy toto.avi)

Bref, les fichiers *.mov sont traités différemment de tous les autres
concernant la luminosité. Ce qui est un peu pénible (je ne sais pas si la
luminosité de mes videos est bonne, du coup, mais je suspecte qu'elle l'est
et que ce sont les fichiers autres que *.mov qui sont mal rejoués). Est-ce
que cette blague pourrait avoir son origine dans la différence historique de
gamma entre les Mac et les PC-windows ?

Ce qui est étonnant aussi c'est que bien que ce soit le même encodage
(MJPEG) dans le *.mov ou dans l'*.avi, ce ne soit pas le même codec et/ou
filtre directshow qui soit utilisé pour la visualisation J'utilise Media
Player Classic, et les codecs QT Alternative.

--
pehache
enlever NOSPAM. etc pour répondre / remove NOSPAM to reply
http://pehache.free.fr/public.html
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Stephane Legras-Decussy
Le #8337291
"pehache-tolai"

Mais aujourd'hui je pense pouvoir conclure que la luminosité n'est pas
modifiée dans les fichiers et que ce n'est qu'au rejeu que ça se passe. En
effet, si je copie bêtement le flux video (MJPEG) dans un fichier .avi
sans aucun réencodage (les valeurs des pixels ne sont donc pas modifées),
je constate l'assombrissement. Et si je recopie à nouveau le flux vers un
nouveau fichier .mov je retrouve la bonne luminosité



voici une mire de gamma encodée par mes soins...

http://cjoint.com/?dzdyPS8Hd2
en mpeg1


http://cjoint.com/?dzdG0DMkAN
en mov sorenson3

chez moi aucune difference d'affichage,
toutes les bandes sont distinctements séparées...

avec cette origine saine, vous pourrez conclure aussitot d'où vient le
problème chez vous :

problème de player, de carte video, de soft de conversion...
pehache-tolai
Le #8336681
"Stephane Legras-Decussy" a écrit dans le message de
news: 4605d267$0$29896$

voici une mire de gamma encodée par mes soins...

http://cjoint.com/?dzdyPS8Hd2
en mpeg1


http://cjoint.com/?dzdG0DMkAN
en mov sorenson3

chez moi aucune difference d'affichage,
toutes les bandes sont distinctements séparées...

avec cette origine saine, vous pourrez conclure aussitot d'où vient le
problème chez vous :

problème de player, de carte video, de soft de conversion...




Alors là un truc incroyable !

J'ouvre la mire mpeg avec MPC. Elle parait trop sombre. L'ouverture de la
mire .mov le confirme: elle est plus claire et on distingue mieux les tons
sombres (cela dit ce n'est pas parfait, mais bon...).

A partir de là j'ouvre à nouveau la mire mpeg dans une nouvelle fenêtre MPC,
mais *sans* fermer les fenêtres précédentes (notamment celle affichant déjà
la mire mpeg). Et là miracle: la mire mpeg est bien affichée (en tous cas
comme la mire .mov) !!! Par contre si je referme tout et que je rouvre la
mire mpeg, à nouveau elle est trop sombre...

Même effet sur mes videos, en fait. Ahurissant !

--
pehache
enlever NOSPAM. etc... pour répondre / remove NOSPAM... to reply
http://pehache.free.fr/public.html
pehache-tolai
Le #8336671
"pehache-tolai"

Alors là un truc incroyable !

J'ouvre la mire mpeg avec MPC. Elle parait trop sombre. L'ouverture
de la mire .mov le confirme: elle est plus claire et on distingue
mieux les tons sombres (cela dit ce n'est pas parfait, mais bon...).

A partir de là j'ouvre à nouveau la mire mpeg dans une nouvelle
fenêtre MPC, mais *sans* fermer les fenêtres précédentes (notamment
celle affichant déjà la mire mpeg). Et là miracle: la mire mpeg est
bien affichée (en tous cas comme la mire .mov) !!! Par contre si je
referme tout et que je rouvre la mire mpeg, à nouveau elle est trop
sombre...
Même effet sur mes videos, en fait. Ahurissant !



Un autre indice: dans la fenêtre de MPC qui affiche la mire trop sombre, la
mire n'apparait pas si je fais une capture d'écran, alors que dans la
fenêtre qui affiche bien la mire, l'image est bien capturée.

--
pehache
enlever NOSPAM. etc... pour répondre / remove NOSPAM... to reply
http://pehache.free.fr/public.html
pehache-tolai
Le #8336661
"pehache-tolai"

Un autre indice: dans la fenêtre de MPC qui affiche la mire trop
sombre, la mire n'apparait pas si je fais une capture d'écran, alors
que dans la fenêtre qui affiche bien la mire, l'image est bien
capturée.



indice n°3 : en baissant l'accélération video matérielle au niveau 2 (sur 5)
le problème est résolu...

--
pehache
enlever NOSPAM. etc... pour répondre / remove NOSPAM... to reply
http://pehache.free.fr/public.html
pehache-tolai
Le #8336601
"pehache-tolai"

...



Bon ben je crois j'ai trouvé: c'est la "superposition video" (video overlay)
qui met le bazar.

Les videos qui passent par la superposition video sont trop sombres avec les
réglages par défaut de la carte video. En modifiant ces réglages (luminosité
et constraste) sur le pilote de la carte (par un des onglets des paramètres
d'affichages) c'est corrigé. Attention: ce sont les paramètres de la
superposition video qu'il faut toucher, pas les autres. Ces paramètres
n'affectent que les videos qui passent par la superposition.

Maintenant pourquoi dans certains cas la video passe par la superposition
video et pas dans d'autres, ça je n'en sais rien...

Punaise, plusieurs années que je cherchais (pas activement, certes) la
solution de ce problème!

--
pehache
enlever NOSPAM. etc... pour répondre / remove NOSPAM... to reply
http://pehache.free.fr/public.html
Publicité
Poster une réponse
Anonyme