pb installation PDFlib-Lite

Le
thierry
Bonjour a tous,

J'essaie d'installer, sans tout casser, ce package (dépendance par
rapport a Joomla) mais:

/usr/ports/print/pdflib]$ sudo make install clean
> pdflib-7.0.4p4 cannot install: unknown LIBTOOL version: 15.
*** Error code 1

Stop in /usr/ports/print/pdflib.

Une idée ?

Merci
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
espie
Le #20750931
In article thierry
Bonjour a tous,

J'essaie d'installer, sans tout casser, ce package (dépendance par
rapport a Joomla) ... mais:

/usr/ports/print/pdflib]$ sudo make install clean
===> pdflib-7.0.4p4 cannot install: unknown LIBTOOL version: 15.
*** Error code 1

Stop in /usr/ports/print/pdflib.

Une idée ?



Deja, precise sur quoi t'essaie d'installer. Je sais que c'est pas OpenBSD,
mais tu ne dis meme pas si c'est Free ou Net ! Ni quelle version.

Ensuite, j'ai comme l'impression qu'il te manque un libtool 1.5.* quelque
part.
thierry
Le #20751091
Oupsss mille excuses ...
Je fais tourner un FreeBSD 8.0-RELEASE. J'ai deja installe la version
LIBTOOL 2.2.6b, mais j'ai la meme erreur.

Merci pour votre aide


Marc Espie a écrit :
In article thierry
Bonjour a tous,

J'essaie d'installer, sans tout casser, ce package (dépendance par
rapport a Joomla) ... mais:

/usr/ports/print/pdflib]$ sudo make install clean
===> pdflib-7.0.4p4 cannot install: unknown LIBTOOL version: 15.
*** Error code 1

Stop in /usr/ports/print/pdflib.

Une idée ?



Deja, precise sur quoi t'essaie d'installer. Je sais que c'est pas OpenBSD,
mais tu ne dis meme pas si c'est Free ou Net ! Ni quelle version.

Ensuite, j'ai comme l'impression qu'il te manque un libtool 1.5.* quelque
part.


espie
Le #20752271
In article thierry
Oupsss mille excuses ...
Je fais tourner un FreeBSD 8.0-RELEASE. J'ai deja installe la version
LIBTOOL 2.2.6b, mais j'ai la meme erreur.



Et tu crois qu'un libtool 2.2.6b, ca va correspondre a un libtool 1.5 ?

Pauvre naif ;-)
Miod Vallat
Le #20752381
> Et tu crois qu'un libtool 2.2.6b, ca va correspondre a un libtool 1.5 ?



Je suis sûr que tous deux sont écrits en dépit du bon sens et tentent de
te mettre autant de bâtons dans les roues.
espie
Le #20752541
In article Miod Vallat
Et tu crois qu'un libtool 2.2.6b, ca va correspondre a un libtool 1.5 ?



Je suis sûr que tous deux sont écrits en dépit du bon sens et tentent de
te mettre autant de bâtons dans les roues.



Oui, mais pas les memes batons, visiblement. Ou du moins, si c'est les memes,
personne n'a pris le temps de mettre au courant FreeBSD 8.
thierry
Le #20753081
Marc Espie a écrit :
In article Miod Vallat
Et tu crois qu'un libtool 2.2.6b, ca va correspondre a un libtool 1.5 ?


Je suis sûr que tous deux sont écrits en dépit du bon sens et tentent de
te mettre autant de bâtons dans les roues.



Oui, mais pas les memes batons, visiblement. Ou du moins, si c'est les memes,
personne n'a pris le temps de mettre au courant FreeBSD 8.




Mais qu'ils sont drôles en ce samedi ...
thierry
Le #20753591
Pauvre naïf ... original :) Dommage pour la faute d'orthographe ;)

Sinon, j'ai un peu cherché dans les archives de FreeBSD pour trouver la
version binaire de libtool-1.5.24, qui est maintenant installée ... Sauf
que j'ai l'erreur suivante:

===> pdflib-7.0.4p4 cannot install: unknown LIBTOOL version: 15.
*** Error code 1

Stop in /usr/ports/print/pdflib

Donc même erreur.

Merci pour votre humour ET support




Marc Espie a écrit :
In article thierry
Oupsss mille excuses ...
Je fais tourner un FreeBSD 8.0-RELEASE. J'ai deja installe la version
LIBTOOL 2.2.6b, mais j'ai la meme erreur.



Et tu crois qu'un libtool 2.2.6b, ca va correspondre a un libtool 1.5 ?

Pauvre naif ;-)



espie
Le #20753581
In article thierry
Pauvre naïf ... original :) Dommage pour la faute d'orthographe ;)



Pas d'accents sur mon clavier, et la flemme de les taper a coup de ^K...

Sinon, j'ai un peu cherché dans les archives de FreeBSD pour trouver la
version binaire de libtool-1.5.24, qui est maintenant installée ... Sauf
que j'ai l'erreur suivante:

===> pdflib-7.0.4p4 cannot install: unknown LIBTOOL version: 15.
*** Error code 1

Stop in /usr/ports/print/pdflib

Donc même erreur.

Merci pour votre humour ET support




Ah ben apres, faudra que tu attendes qu'un utilisateur de FreeBSD passe par
la.

Je subodore que ton systeme de ports s'attend a avoir un libtool 1.5 installe
d'une certaine facon, de maniere a dire au systeme que tu as bien LIBTOOL 15
qui repond au signalement.

Le message d'erreur provient clairement du systeme de ports lui-meme, donc
en allant traficouiller dans l'infrastructure, on doit pouvoir en trouver un
peu plus...

C'est tout ce que ma boule de cristal plus mes connaissances d'OpenBSD me
permettent de dire...
F. Senault
Le #20753691
Le 12 décembre 2009 à 15:30, thierry a écrit :

Pauvre naïf ... original :) Dommage pour la faute d'orthographe ;)

Sinon, j'ai un peu cherché dans les archives de FreeBSD pour trouver la
version binaire de libtool-1.5.24, qui est maintenant installée ... Sauf
que j'ai l'erreur suivante:

===> pdflib-7.0.4p4 cannot install: unknown LIBTOOL version: 15.
*** Error code 1

Stop in /usr/ports/print/pdflib



Dans le makefile du port, je vois une ligne :

USE_AUTOTOOLS= libtool:22

C'est bizarre qu'il aille chercher une autre version. Il n'y a pas une
variable parasite dans /etc/make.conf, par hasard ?

Fred
--
(About the antispam movement.) There is no organization. Nobody can make
deals, nobody has the authority to surrender.All people with pretensions
of "leadership" do is make it look like a small bunch of people with no
life. It's a *big* bunch of people with no life. (Paul Vader, nanae)
thierry
Le #20753911
F. Senault a écrit :
Le 12 décembre 2009 à 15:30, thierry a écrit :

Pauvre naïf ... original :) Dommage pour la faute d'orthographe ;)

Sinon, j'ai un peu cherché dans les archives de FreeBSD pour trouver la
version binaire de libtool-1.5.24, qui est maintenant installée ... Sauf
que j'ai l'erreur suivante:

===> pdflib-7.0.4p4 cannot install: unknown LIBTOOL version: 15.
*** Error code 1

Stop in /usr/ports/print/pdflib



Dans le makefile du port, je vois une ligne :

USE_AUTOTOOLS= libtool:22

C'est bizarre qu'il aille chercher une autre version. Il n'y a pas une
variable parasite dans /etc/make.conf, par hasard ?

Fred



J'ai refait un coup de cvsup ...
Maintenant j'ai, après avoir réinstallé la version 22 de libtool:

/usr/ports/print/pdflib]$ sudo make install clean
===> Building for pdflib-7.0.4p4
Makefile:6: config/mkcommon.inc: No such file or directory
Makefile:10: config/mksubdirs.inc: No such file or directory
gmake: *** No rule to make target `config/mksubdirs.inc'. Stop.
*** Error code 1

Stop in /usr/ports/print/pdflib.

Merci
Publicité
Poster une réponse
Anonyme