Pb de localhost (avec mpd)

Le
giggz
Bonjour,

Suis en debian sid à jour. J'utilise mpd avec comme client ario et
ncmpc. Il est configuré avec la conf par défaut (port 6600 en localhost).

Qd j'ai une connection internet, je ne rencontre aucun pb avec mpd, le
daemon se lance et tout fonctionne correctement.

Par contre qd je n'ai pas de connection internet (pas de wifi, pas de
rj45), le daemon mpd refuse de se lancer avec :
Starting Music Player Daemon: mpdcan't lookup host "localhost" at line
43: Temporary failure in name resolution

Pourtant :
11:14 giggz@thor ~ % cat /etc/hosts
127.0.0.1 localhost localhost.localdomain thor

# The following lines are desirable for IPv6 capable hosts
# (added automatically by netbase upgrade)

fe00::0 ip6-localnet ip6-localnet
ff00::0 ip6-mcastprefix ip6-mcastprefix
ff02::1 ip6-allnodes ip6-allnodes
ff02::2 ip6-allrouters ip6-allrouters
ff02::3 ip6-allhosts ip6-allhosts

# The following lines are desirable for IPv6 capable hosts
# (added automatically by netbase upgrade)

::1 ip6-localhost ip6-loopback


11:14 giggz@thor ~ % ping localhost
PING localhost (127.0.0.1) 56(84) bytes of data.
64 bytes from localhost (127.0.0.1): icmp_seq=1 ttld time=0.111 ms
64 bytes from localhost (127.0.0.1): icmp_seq=2 ttld time=0.089 ms
64 bytes from localhost (127.0.0.1): icmp_seq=3 ttld time=0.088 ms
64 bytes from localhost (127.0.0.1): icmp_seq=4 ttld time=0.090 ms

Les services se rapportant à internet que j'ai sont : ifplugd,
wpasupplicant (sans c'est pareil), firestarter pour le firewall.

Bref je ne sais que fairesi vous avez des idées.
Merci,
Guillaume

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
giggz
Le #18207291
giggz a écrit :
Bonjour,

Suis en debian sid à jour. J'utilise mpd avec comme client ario et
ncmpc. Il est configuré avec la conf par défaut (port 6600 en localhost).

Qd j'ai une connection internet, je ne rencontre aucun pb avec mpd, le
daemon se lance et tout fonctionne correctement.

Par contre qd je n'ai pas de connection internet (pas de wifi, pas de
rj45), le daemon mpd refuse de se lancer avec :
Starting Music Player Daemon: mpdcan't lookup host "localhost" at line
43: Temporary failure in name resolution

Pourtant :
11:14 ~ % cat /etc/hosts
127.0.0.1 localhost localhost.localdomain thor

# The following lines are desirable for IPv6 capable hosts
# (added automatically by netbase upgrade)

fe00::0 ip6-localnet ip6-localnet
ff00::0 ip6-mcastprefix ip6-mcastprefix
ff02::1 ip6-allnodes ip6-allnodes
ff02::2 ip6-allrouters ip6-allrouters
ff02::3 ip6-allhosts ip6-allhosts

# The following lines are desirable for IPv6 capable hosts
# (added automatically by netbase upgrade)

::1 ip6-localhost ip6-loopback


11:14 ~ % ping localhost
PING localhost (127.0.0.1) 56(84) bytes of data.
64 bytes from localhost (127.0.0.1): icmp_seq=1 ttld time=0.111 ms
64 bytes from localhost (127.0.0.1): icmp_seq=2 ttld time=0.089 ms
64 bytes from localhost (127.0.0.1): icmp_seq=3 ttld time=0.088 ms
64 bytes from localhost (127.0.0.1): icmp_seq=4 ttld time=0.090 ms

Les services se rapportant à internet que j'ai sont : ifplugd,
wpasupplicant (sans c'est pareil...), firestarter pour le firewall.

Bref je ne sais que faire...si vous avez des idées.
Merci,
Guillaume




De plus, si je fais une connection via mon modem 56k et que j'arrete
cette connection, mpd peut se lancer sans pb...étrange non ?

Bye

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
giggz
Le #18210711
giggz a écrit :
giggz a écrit :
Bonjour,

Suis en debian sid à jour. J'utilise mpd avec comme client ario et
ncmpc. Il est configuré avec la conf par défaut (port 6600 en localhost).

Qd j'ai une connection internet, je ne rencontre aucun pb avec mpd, le
daemon se lance et tout fonctionne correctement.

Par contre qd je n'ai pas de connection internet (pas de wifi, pas de
rj45), le daemon mpd refuse de se lancer avec :
Starting Music Player Daemon: mpdcan't lookup host "localhost" at line
43: Temporary failure in name resolution

Pourtant :
11:14 ~ % cat /etc/hosts
127.0.0.1 localhost localhost.localdomain thor

# The following lines are desirable for IPv6 capable hosts
# (added automatically by netbase upgrade)

fe00::0 ip6-localnet ip6-localnet
ff00::0 ip6-mcastprefix ip6-mcastprefix
ff02::1 ip6-allnodes ip6-allnodes
ff02::2 ip6-allrouters ip6-allrouters
ff02::3 ip6-allhosts ip6-allhosts

# The following lines are desirable for IPv6 capable hosts
# (added automatically by netbase upgrade)

::1 ip6-localhost ip6-loopback


11:14 ~ % ping localhost
PING localhost (127.0.0.1) 56(84) bytes of data.
64 bytes from localhost (127.0.0.1): icmp_seq=1 ttld time=0.111 ms
64 bytes from localhost (127.0.0.1): icmp_seq=2 ttld time=0.089 ms
64 bytes from localhost (127.0.0.1): icmp_seq=3 ttld time=0.088 ms
64 bytes from localhost (127.0.0.1): icmp_seq=4 ttld time=0.090 ms

Les services se rapportant à internet que j'ai sont : ifplugd,
wpasupplicant (sans c'est pareil...), firestarter pour le firewall.

Bref je ne sais que faire...si vous avez des idées.
Merci,
Guillaume




De plus, si je fais une connection via mon modem 56k et que j'arrete
cette connection, mpd peut se lancer sans pb...étrange non ?

Bye




Bon étant toujours dans le flou, j'aimerais savoir si parmi vous il y a
des utilisateurs de mpd qui réussissent à le faire fonctionner sans
avoir de réseau au boot de la machine.

Merci d'avance

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
giggz
Le #18218551
giggz a écrit :
giggz a écrit :
giggz a écrit :
Bonjour,

Suis en debian sid à jour. J'utilise mpd avec comme client ario et
ncmpc. Il est configuré avec la conf par défaut (port 6600 en localhost).

Qd j'ai une connection internet, je ne rencontre aucun pb avec mpd, le
daemon se lance et tout fonctionne correctement.

Par contre qd je n'ai pas de connection internet (pas de wifi, pas de
rj45), le daemon mpd refuse de se lancer avec :
Starting Music Player Daemon: mpdcan't lookup host "localhost" at line
43: Temporary failure in name resolution

Pourtant :
11:14 ~ % cat /etc/hosts
127.0.0.1 localhost localhost.localdomain thor

# The following lines are desirable for IPv6 capable hosts
# (added automatically by netbase upgrade)

fe00::0 ip6-localnet ip6-localnet
ff00::0 ip6-mcastprefix ip6-mcastprefix
ff02::1 ip6-allnodes ip6-allnodes
ff02::2 ip6-allrouters ip6-allrouters
ff02::3 ip6-allhosts ip6-allhosts

# The following lines are desirable for IPv6 capable hosts
# (added automatically by netbase upgrade)

::1 ip6-localhost ip6-loopback


11:14 ~ % ping localhost
PING localhost (127.0.0.1) 56(84) bytes of data.
64 bytes from localhost (127.0.0.1): icmp_seq=1 ttld time=0.111 ms
64 bytes from localhost (127.0.0.1): icmp_seq=2 ttld time=0.089 ms
64 bytes from localhost (127.0.0.1): icmp_seq=3 ttld time=0.088 ms
64 bytes from localhost (127.0.0.1): icmp_seq=4 ttld time=0.090 ms

Les services se rapportant à internet que j'ai sont : ifplugd,
wpasupplicant (sans c'est pareil...), firestarter pour le firewall.

Bref je ne sais que faire...si vous avez des idées.
Merci,
Guillaume



De plus, si je fais une connection via mon modem 56k et que j'arrete
cette connection, mpd peut se lancer sans pb...étrange non ?

Bye




Bon étant toujours dans le flou, j'aimerais savoir si parmi vous il y a
des utilisateurs de mpd qui réussissent à le faire fonctionner sans
avoir de réseau au boot de la machine.

Merci d'avance




Bon en continuant à chercher j'ai remarqué ça :
avec dans le mpd.conf :
bind_to_address "localhost"
port "6600"

le daemon mpd ne se lance pas et sort le message cité plus haut. Une
fois le réseau établi (via une ligne 56k), en faisant un :
netstat -an | grep -v unix | grep LISTEN

j'ai :
tcp 0 0 127.0.0.1:6600 0.0.0.0:* LISTEN


Par contre si j'ai dans mpd.conf :
#bind_to_address "localhost"
port "6600"

mpd se lance sans le réseau et j'ai avec la commande netstat :
tcp6 0 0 :::6600 :::* LISTEN

Dans ce dernier cas, un certain nombre de client mpd ne focntionnent
pas...par contre ncmpc fonctionne à merveille.

Quelqu'un peut il m'expliquer ?
Pourquoi j'ai pas de localhost si je n'ai pas internet ? Enfin j'ai un
localhost parce que je peux le pinguer...mais mpd ne peut pas se
connecter dessus (pas de port en LISTEN).

bye

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
mouss
Le #18218671
giggz a écrit :
giggz a écrit :
giggz a écrit :
giggz a écrit :
Bonjour,

Suis en debian sid à jour. J'utilise mpd avec comme client ario et
ncmpc. Il est configuré avec la conf par défaut (port 6600 en localhost).

Qd j'ai une connection internet, je ne rencontre aucun pb avec mpd, le
daemon se lance et tout fonctionne correctement.

Par contre qd je n'ai pas de connection internet (pas de wifi, pas de
rj45), le daemon mpd refuse de se lancer avec :
Starting Music Player Daemon: mpdcan't lookup host "localhost" at line
43: Temporary failure in name resolution

Pourtant :
11:14 ~ % cat /etc/hosts
127.0.0.1 localhost localhost.localdomain thor

# The following lines are desirable for IPv6 capable hosts
# (added automatically by netbase upgrade)

fe00::0 ip6-localnet ip6-localnet
ff00::0 ip6-mcastprefix ip6-mcastprefix
ff02::1 ip6-allnodes ip6-allnodes
ff02::2 ip6-allrouters ip6-allrouters
ff02::3 ip6-allhosts ip6-allhosts

# The following lines are desirable for IPv6 capable hosts
# (added automatically by netbase upgrade)

::1 ip6-localhost ip6-loopback


11:14 ~ % ping localhost
PING localhost (127.0.0.1) 56(84) bytes of data.
64 bytes from localhost (127.0.0.1): icmp_seq=1 ttld time=0.111 ms
64 bytes from localhost (127.0.0.1): icmp_seq=2 ttld time=0.089 ms
64 bytes from localhost (127.0.0.1): icmp_seq=3 ttld time=0.088 ms
64 bytes from localhost (127.0.0.1): icmp_seq=4 ttld time=0.090 ms

Les services se rapportant à internet que j'ai sont : ifplugd,
wpasupplicant (sans c'est pareil...), firestarter pour le firewall.

Bref je ne sais que faire...si vous avez des idées.
Merci,
Guillaume



De plus, si je fais une connection via mon modem 56k et que j'arrete
cette connection, mpd peut se lancer sans pb...étrange non ?

Bye



Bon étant toujours dans le flou, j'aimerais savoir si parmi vous il y a
des utilisateurs de mpd qui réussissent à le faire fonctionner sans
avoir de réseau au boot de la machine.

Merci d'avance




Bon en continuant à chercher j'ai remarqué ça :
avec dans le mpd.conf :
bind_to_address "localhost"
port "6600"

le daemon mpd ne se lance pas et sort le message cité plus haut. Une
fois le réseau établi (via une ligne 56k), en faisant un :
netstat -an | grep -v unix | grep LISTEN

j'ai :
tcp 0 0 127.0.0.1:6600 0.0.0.0:* LISTEN


Par contre si j'ai dans mpd.conf :
#bind_to_address "localhost"
port "6600"

mpd se lance sans le réseau et j'ai avec la commande netstat :
tcp6 0 0 :::6600 :::* LISTEN

Dans ce dernier cas, un certain nombre de client mpd ne focntionnent
pas...par contre ncmpc fonctionne à merveille.




ça donne quoi avec

bind_to_address "127.0.0.1"
...


Quelqu'un peut il m'expliquer ?



pas moi. peut-être que mpd fait la résolution tout seul? si oui,
j'dirais bug.

Pourquoi j'ai pas de localhost si je n'ai pas internet ?



tu as un localhost. c'est mpd qui ne le trouve pas.

Enfin j'ai un
localhost parce que je peux le pinguer...mais mpd ne peut pas se
connecter dessus (pas de port en LISTEN).

bye




--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
giggz
Le #18223911
mouss a écrit :
giggz a écrit :
giggz a écrit :
giggz a écrit :
giggz a écrit :
Bonjour,

Suis en debian sid à jour. J'utilise mpd avec comme client ario et
ncmpc. Il est configuré avec la conf par défaut (port 6600 en localhost).

Qd j'ai une connection internet, je ne rencontre aucun pb avec mpd, le
daemon se lance et tout fonctionne correctement.

Par contre qd je n'ai pas de connection internet (pas de wifi, pas de
rj45), le daemon mpd refuse de se lancer avec :
Starting Music Player Daemon: mpdcan't lookup host "localhost" at line
43: Temporary failure in name resolution

Pourtant :
11:14 ~ % cat /etc/hosts
127.0.0.1 localhost localhost.localdomain thor

# The following lines are desirable for IPv6 capable hosts
# (added automatically by netbase upgrade)

fe00::0 ip6-localnet ip6-localnet
ff00::0 ip6-mcastprefix ip6-mcastprefix
ff02::1 ip6-allnodes ip6-allnodes
ff02::2 ip6-allrouters ip6-allrouters
ff02::3 ip6-allhosts ip6-allhosts

# The following lines are desirable for IPv6 capable hosts
# (added automatically by netbase upgrade)

::1 ip6-localhost ip6-loopback


11:14 ~ % ping localhost
PING localhost (127.0.0.1) 56(84) bytes of data.
64 bytes from localhost (127.0.0.1): icmp_seq=1 ttld time=0.111 ms
64 bytes from localhost (127.0.0.1): icmp_seq=2 ttld time=0.089 ms
64 bytes from localhost (127.0.0.1): icmp_seq=3 ttld time=0.088 ms
64 bytes from localhost (127.0.0.1): icmp_seq=4 ttld time=0.090 ms

Les services se rapportant à internet que j'ai sont : ifplugd,
wpasupplicant (sans c'est pareil...), firestarter pour le firewall.

Bref je ne sais que faire...si vous avez des idées.
Merci,
Guillaume



De plus, si je fais une connection via mon modem 56k et que j'arrete
cette connection, mpd peut se lancer sans pb...étrange non ?

Bye



Bon étant toujours dans le flou, j'aimerais savoir si parmi vous il y a
des utilisateurs de mpd qui réussissent à le faire fonctionner sans
avoir de réseau au boot de la machine.

Merci d'avance



Bon en continuant à chercher j'ai remarqué ça :
avec dans le mpd.conf :
bind_to_address "localhost"
port "6600"

le daemon mpd ne se lance pas et sort le message cité plus haut. Une
fois le réseau établi (via une ligne 56k), en faisant un :
netstat -an | grep -v unix | grep LISTEN

j'ai :
tcp 0 0 127.0.0.1:6600 0.0.0.0:* LISTEN


Par contre si j'ai dans mpd.conf :
#bind_to_address "localhost"
port "6600"

mpd se lance sans le réseau et j'ai avec la commande netstat :
tcp6 0 0 :::6600 :::* LISTEN

Dans ce dernier cas, un certain nombre de client mpd ne focntionnent
pas...par contre ncmpc fonctionne à merveille.




ça donne quoi avec

bind_to_address "127.0.0.1"
...



Starting Music Player Daemon: mpdcan't lookup host "127.0.0.1" at line
44: Address family for hostname not supported

Ben ça bloque aussi qd il n'y a pas de réseau.

A votre avis ça vaut un rapport de bug, ou c'est que chez moi ?

Bye

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Gilles Mocellin
Le #18227421
--nextPart307615370.4tVbNLIhgR
Content-Type: text/plain;
charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

Le Thursday 25 December 2008 23:30:55 giggz, vous avez écrit :
mouss a écrit :
> giggz a écrit :
>> giggz a écrit :
>>> giggz a écrit :
>>>> giggz a écrit :
>>>>> Bonjour,
>>>>>
>>>>> Suis en debian sid à jour. J'utilise mpd avec comme client ario et
>>>>> ncmpc. Il est configuré avec la conf par défaut (port 6600 en
>>>>> localhost).
>>>>>
>>>>> Qd j'ai une connection internet, je ne rencontre aucun pb avec mpd,
>>>>> le daemon se lance et tout fonctionne correctement.
>>>>>
>>>>> Par contre qd je n'ai pas de connection internet (pas de wifi, pas de
>>>>> rj45), le daemon mpd refuse de se lancer avec :
>>>>> Starting Music Player Daemon: mpdcan't lookup host "localhost" at
>>>>> line 43: Temporary failure in name resolution
>>>>>
>>>>> Pourtant :
>>>>> 11:14 ~ % cat /etc/hosts
>>>>> 127.0.0.1 localhost localhost.localdomain thor
>>>>>
>>>>> # The following lines are desirable for IPv6 capable hosts
>>>>> # (added automatically by netbase upgrade)
>>>>>
>>>>> fe00::0 ip6-localnet ip6-localnet
>>>>> ff00::0 ip6-mcastprefix ip6-mcastprefix
>>>>> ff02::1 ip6-allnodes ip6-allnodes
>>>>> ff02::2 ip6-allrouters ip6-allrouters
>>>>> ff02::3 ip6-allhosts ip6-allhosts
>>>>>
>>>>> # The following lines are desirable for IPv6 capable hosts
>>>>> # (added automatically by netbase upgrade)
>>>>>
>>>>> ::1 ip6-localhost ip6-loopback
>>>>>
>>>>> 11:14 ~ % ping localhost
>>>>> PING localhost (127.0.0.1) 56(84) bytes of data.
>>>>> 64 bytes from localhost (127.0.0.1): icmp_seq=1 ttld time=0 .111 ms
>>>>> 64 bytes from localhost (127.0.0.1): icmp_seq=2 ttld time=0 .089 ms
>>>>> 64 bytes from localhost (127.0.0.1): icmp_seq=3 ttld time=0 .088 ms
>>>>> 64 bytes from localhost (127.0.0.1): icmp_seq=4 ttld time=0 .090 ms
>>>>>
>>>>> Les services se rapportant à internet que j'ai sont : ifplugd,
>>>>> wpasupplicant (sans c'est pareil...), firestarter pour le firewall.
>>>>>
>>>>> Bref je ne sais que faire...si vous avez des idées.
>>>>> Merci,
>>>>> Guillaume
>>>>
>>>> De plus, si je fais une connection via mon modem 56k et que j'arrete
>>>> cette connection, mpd peut se lancer sans pb...étrange non ?
>>>>
>>>> Bye
>>>
>>> Bon étant toujours dans le flou, j'aimerais savoir si parmi vous il y a
>>> des utilisateurs de mpd qui réussissent à le faire fonctionner sa ns
>>> avoir de réseau au boot de la machine.
>>>
>>> Merci d'avance
>>
>> Bon en continuant à chercher j'ai remarqué ça :
>> avec dans le mpd.conf :
>> bind_to_address "localhost"
>> port "6600"
>>
>> le daemon mpd ne se lance pas et sort le message cité plus haut. Une
>> fois le réseau établi (via une ligne 56k), en faisant un :
>> netstat -an | grep -v unix | grep LISTEN
>>
>> j'ai :
>> tcp 0 0 127.0.0.1:6600 0.0.0.0:* LISTEN
>>
>>
>> Par contre si j'ai dans mpd.conf :
>> #bind_to_address "localhost"
>> port "6600"
>>
>> mpd se lance sans le réseau et j'ai avec la commande netstat :
>> tcp6 0 0 :::6600 :::* LISTEN
>>
>> Dans ce dernier cas, un certain nombre de client mpd ne focntionnent
>> pas...par contre ncmpc fonctionne à merveille.
>
> ça donne quoi avec
>
> bind_to_address "127.0.0.1"
> ...

Starting Music Player Daemon: mpdcan't lookup host "127.0.0.1" at line
44: Address family for hostname not supported

Ben ça bloque aussi qd il n'y a pas de réseau.

A votre avis ça vaut un rapport de bug, ou c'est que chez moi ?

Bye



Heu, tu es sur que ton interface loopback est bien montée ?
Dans /etc/network/interfaces, tu dois avoir ça :
auto lo
iface lo inet loopback

et un ifconfig lo doit répondre :
lo Link encap:Boucle locale
inet adr:127.0.0.1 Masque:255.0.0.0
adr inet6: ::1/128 Scope:Hôte
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:5787931 errors:0 dropped:0 overruns:0 frame:0
TX packets:5787931 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:0
RX bytes:4389287431 (4.0 GiB) TX bytes:4389287431 (4.0 GiB)




--nextPart307615370.4tVbNLIhgR
Content-Type: application/pgp-signature; name=signature.asc
Content-Description: This is a digitally signed message part.

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iEYEABECAAYFAklWA8wACgkQDltnDmLJYdAnkgCfXubgMq5SQV6A5kfMw04QYkL1
4aAAoKIbCXDy06QSlBDbrYhRFuZCHUse
=JKqT
-----END PGP SIGNATURE-----

--nextPart307615370.4tVbNLIhgR--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
giggz
Le #18229921
Gilles Mocellin a écrit :
Le Thursday 25 December 2008 23:30:55 giggz, vous avez écrit :
mouss a écrit :
giggz a écrit :
giggz a écrit :
giggz a écrit :
giggz a écrit :
Bonjour,

Suis en debian sid à jour. J'utilise mpd avec comme client ario et
ncmpc. Il est configuré avec la conf par défaut (port 6600 en
localhost).

Qd j'ai une connection internet, je ne rencontre aucun pb avec mpd,
le daemon se lance et tout fonctionne correctement.

Par contre qd je n'ai pas de connection internet (pas de wifi, pas de
rj45), le daemon mpd refuse de se lancer avec :
Starting Music Player Daemon: mpdcan't lookup host "localhost" at
line 43: Temporary failure in name resolution

Pourtant :
11:14 ~ % cat /etc/hosts
127.0.0.1 localhost localhost.localdomain thor

# The following lines are desirable for IPv6 capable hosts
# (added automatically by netbase upgrade)

fe00::0 ip6-localnet ip6-localnet
ff00::0 ip6-mcastprefix ip6-mcastprefix
ff02::1 ip6-allnodes ip6-allnodes
ff02::2 ip6-allrouters ip6-allrouters
ff02::3 ip6-allhosts ip6-allhosts

# The following lines are desirable for IPv6 capable hosts
# (added automatically by netbase upgrade)

::1 ip6-localhost ip6-loopback

11:14 ~ % ping localhost
PING localhost (127.0.0.1) 56(84) bytes of data.
64 bytes from localhost (127.0.0.1): icmp_seq=1 ttld time=0.111 ms
64 bytes from localhost (127.0.0.1): icmp_seq=2 ttld time=0.089 ms
64 bytes from localhost (127.0.0.1): icmp_seq=3 ttld time=0.088 ms
64 bytes from localhost (127.0.0.1): icmp_seq=4 ttld time=0.090 ms

Les services se rapportant à internet que j'ai sont : ifplugd,
wpasupplicant (sans c'est pareil...), firestarter pour le firewall.

Bref je ne sais que faire...si vous avez des idées.
Merci,
Guillaume


De plus, si je fais une connection via mon modem 56k et que j'arrete
cette connection, mpd peut se lancer sans pb...étrange non ?

Bye


Bon étant toujours dans le flou, j'aimerais savoir si parmi vous il y a
des utilisateurs de mpd qui réussissent à le faire fonctionner sans
avoir de réseau au boot de la machine.

Merci d'avance


Bon en continuant à chercher j'ai remarqué ça :
avec dans le mpd.conf :
bind_to_address "localhost"
port "6600"

le daemon mpd ne se lance pas et sort le message cité plus haut. Une
fois le réseau établi (via une ligne 56k), en faisant un :
netstat -an | grep -v unix | grep LISTEN

j'ai :
tcp 0 0 127.0.0.1:6600 0.0.0.0:* LISTEN


Par contre si j'ai dans mpd.conf :
#bind_to_address "localhost"
port "6600"

mpd se lance sans le réseau et j'ai avec la commande netstat :
tcp6 0 0 :::6600 :::* LISTEN

Dans ce dernier cas, un certain nombre de client mpd ne focntionnent
pas...par contre ncmpc fonctionne à merveille.


ça donne quoi avec

bind_to_address "127.0.0.1"
...


Starting Music Player Daemon: mpdcan't lookup host "127.0.0.1" at line
44: Address family for hostname not supported

Ben ça bloque aussi qd il n'y a pas de réseau.

A votre avis ça vaut un rapport de bug, ou c'est que chez moi ?

Bye



Heu, tu es sur que ton interface loopback est bien montée ?
Dans /etc/network/interfaces, tu dois avoir ça :
auto lo
iface lo inet loopback

et un ifconfig lo doit répondre :
lo Link encap:Boucle locale
inet adr:127.0.0.1 Masque:255.0.0.0
adr inet6: ::1/128 Scope:Hôte
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:5787931 errors:0 dropped:0 overruns:0 frame:0
TX packets:5787931 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:0
RX bytes:4389287431 (4.0 GiB) TX bytes:4389287431 (4.0 GiB)






Salut,

oui j'ai exactement tout ça...
De toute façon si je pingue ça fonctionne...

bye

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme