Pb lors d'expedition de mail lotus par vba

Le
stanislasRB
Bonjour à tous,

J'ai repris un code (génial) trouvé sur mpfe pour expédier des mails Lotus
notes en vba. Mon problème reste que ce code peut très bien fonctionner sur
quelques machines, mais plante sur d'autres, toujours à la même ligne =
Set objNotesSession = CreateObject("Notes.NotesSession")
Les OS sont les mêmes, les références cochées sont les mêmes, les versions
d'excel et lotus sont les mêmes, bref, je m'arrache un peu le peu de cheveux
qu'il me reste.
Si quelqu'un a une idée ?

Merci beaucoup par avance,
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel.C
Le #17870321
Bonjour.
Quel est le message ?
Cordialement.
Daniel

Bonjour à tous,

J'ai repris un code (génial) trouvé sur mpfe pour expédier des mails Lotus
notes en vba. Mon problème reste que ce code peut très bien fonctionner sur
quelques machines, mais plante sur d'autres, toujours à la même ligne > Set objNotesSession = CreateObject("Notes.NotesSession")
Les OS sont les mêmes, les références cochées sont les mêmes, les versions
d'excel et lotus sont les mêmes, bref, je m'arrache un peu le peu de cheveux
qu'il me reste.
Si quelqu'un a une idée ?

Merci beaucoup par avance,


stanislasRB
Le #17870311
Bonjour Daniel,

Msg "erreur #429 : Un composant activeX ne peut pas créer d'objet"

merci

"Daniel.C" a écrit :

Bonjour.
Quel est le message ?
Cordialement.
Daniel

> Bonjour à tous,
>
> J'ai repris un code (génial) trouvé sur mpfe pour expédier des mails Lotus
> notes en vba. Mon problème reste que ce code peut très bien fonctionner sur
> quelques machines, mais plante sur d'autres, toujours à la même ligne > > Set objNotesSession = CreateObject("Notes.NotesSession")
> Les OS sont les mêmes, les références cochées sont les mêmes, les versions
> d'excel et lotus sont les mêmes, bref, je m'arrache un peu le peu de cheveux
> qu'il me reste.
> Si quelqu'un a une idée ?
>
> Merci beaucoup par avance,





Daniel.C
Le #17871101
Tu dis que les références cochées sont les mêmes; quelles sont-elles ?
Essaie de réinscrire les dll correspondantes avec la commande Windows
regsrv32.exe.
A tout hasard, il y a un second exemple d'envoi de mail via Lotus sur
excelabo qui n'a pas l'air d'utiliser la commande createobject.
Enfin, tu pourrais utiliser (mais c'est juste une idée, je ne travaille
pas avec lotus) la ligne :
Set objNotesSession = GetObject(,"Notes.NotesSession")
à condition qu'une session Lotus soit démarrée.

Daniel

Bonjour Daniel,

Msg "erreur #429 : Un composant activeX ne peut pas créer d'objet"

merci

"Daniel.C" a écrit :

Bonjour.
Quel est le message ?
Cordialement.
Daniel

Bonjour à tous,

J'ai repris un code (génial) trouvé sur mpfe pour expédier des mails Lotus
notes en vba. Mon problème reste que ce code peut très bien fonctionner sur
quelques machines, mais plante sur d'autres, toujours à la même ligne >>> Set objNotesSession = CreateObject("Notes.NotesSession")
Les OS sont les mêmes, les références cochées sont les mêmes, les versions
d'excel et lotus sont les mêmes, bref, je m'arrache un peu le peu de
cheveux qu'il me reste.
Si quelqu'un a une idée ?

Merci beaucoup par avance,









stanislasRB
Le #17871901
Merci de tes conseils judicieux, mais hélas, le getobject et le createobject
renvoient tous les deux la même erreur, que lotus soit ouvert ou non.

les références ont été réinscrites, j'ai même ajouté les ref
Lotus Domino object et lotus notes automation classes sur les machines ou le
code ne fonctionne pas (alors qu'il fonctionne sans sur d'autres) mais rien à
faire, çà ne le fait pas..

Je ne sais même pas ou me renseigner, ce n'est pas vraiment un pb lotus, et
pourtant, depuis queje recherche un peu partout dans les forums, je ne suis
pas le seul a avoir le pb...

merci de ton interet pour le pb, en tout cas!
Daniel.C
Le #17873881
Tu peux encore essayer de renommer les dll correspondantes et de les
recopier, juste pour voir, depuis un poste qui fonctionne. Fais une
réinscription dans le registre avant de faire un test.
Daniel
"stanislasRB" message de news:
Merci de tes conseils judicieux, mais hélas, le getobject et le
createobject
renvoient tous les deux la même erreur, que lotus soit ouvert ou non.

les références ont été réinscrites, j'ai même ajouté les ref
Lotus Domino object et lotus notes automation classes sur les machines ou
le
code ne fonctionne pas (alors qu'il fonctionne sans sur d'autres) mais
rien à
faire, çà ne le fait pas..

Je ne sais même pas ou me renseigner, ce n'est pas vraiment un pb lotus,
et
pourtant, depuis queje recherche un peu partout dans les forums, je ne
suis
pas le seul a avoir le pb...

merci de ton interet pour le pb, en tout cas!






stanislasRB
Le #17880341
et non, j'ai tout réinscrit, à partir d'un poste qui fonctionne, mais
toujours rien...
merci beaucoup, j'y perd toutes mes notions de latin!..

"Daniel.C" a écrit :

Tu peux encore essayer de renommer les dll correspondantes et de les
recopier, juste pour voir, depuis un poste qui fonctionne. Fais une
réinscription dans le registre avant de faire un test.
Daniel
"stanislasRB" message de news:
> Merci de tes conseils judicieux, mais hélas, le getobject et le
> createobject
> renvoient tous les deux la même erreur, que lotus soit ouvert ou non.
>
> les références ont été réinscrites, j'ai même ajouté les ref
> Lotus Domino object et lotus notes automation classes sur les machines ou
> le
> code ne fonctionne pas (alors qu'il fonctionne sans sur d'autres) mais
> rien à
> faire, çà ne le fait pas..
>
> Je ne sais même pas ou me renseigner, ce n'est pas vraiment un pb lotus,
> et
> pourtant, depuis queje recherche un peu partout dans les forums, je ne
> suis
> pas le seul a avoir le pb...
>
> merci de ton interet pour le pb, en tout cas!
>
>
>
>





stanislasRB
Le #17888921
Je suis vraiment bloqué, et je ne vois pas vers ou chercher?
Je ne trouve pas grand chose dans le paramétrage de Lotus, ni dans les
forums Notes...
Si quelqu'un a une idée, un axe, un soupcon, une lueure ou une explication
(le rêve!), je lui vouerai une grande, très grande reconnaissance.

merci et bonne journée.

"stanislasRB" a écrit :

Bonjour à tous,

J'ai repris un code (génial) trouvé sur mpfe pour expédier des mails Lotus
notes en vba. Mon problème reste que ce code peut très bien fonctionner sur
quelques machines, mais plante sur d'autres, toujours à la même ligne > Set objNotesSession = CreateObject("Notes.NotesSession")
Les OS sont les mêmes, les références cochées sont les mêmes, les versions
d'excel et lotus sont les mêmes, bref, je m'arrache un peu le peu de cheveux
qu'il me reste.
Si quelqu'un a une idée ?

Merci beaucoup par avance,


isabelle
Le #17888991
bonjour stanislas,

se pourrait t'il que la variable objNotesSession soit déjà utilisée dans
un autre macro, comme étant un nom d'objet ,

isabelle

stanislasRB a écrit :
et non, j'ai tout réinscrit, à partir d'un poste qui fonctionne, mais
toujours rien...
merci beaucoup, j'y perd toutes mes notions de latin!..

"Daniel.C" a écrit :


Tu peux encore essayer de renommer les dll correspondantes et de les
recopier, juste pour voir, depuis un poste qui fonctionne. Fais une
réinscription dans le registre avant de faire un test.
Daniel
"stanislasRB" message de news:

Merci de tes conseils judicieux, mais hélas, le getobject et le
createobject
renvoient tous les deux la même erreur, que lotus soit ouvert ou non.

les références ont été réinscrites, j'ai même ajouté les ref
Lotus Domino object et lotus notes automation classes sur les machines ou
le
code ne fonctionne pas (alors qu'il fonctionne sans sur d'autres) mais
rien à
faire, çà ne le fait pas..

Je ne sais même pas ou me renseigner, ce n'est pas vraiment un pb lotus,
et
pourtant, depuis queje recherche un peu partout dans les forums, je ne
suis
pas le seul a avoir le pb...

merci de ton interet pour le pb, en tout cas!













stanislasRB
Le #17889701
Bonjour Isabelle,

c'est une bonne idée.
Mais hélas, quelque soit le nom de la variable, j'en arrive au même point


Function exp_mail()
On Error GoTo gesterror

dest = ""
destcc = ""
sujet = "test de transmission"

'######################################################
'Option 1 == OK chez moi / KO ailleurs #429
'Set session = CreateObject("Notes.NotesSession")
'Option 2 == çà passe mais renvoie une erreur d'initialisation
'Set session = CreateObject("Lotus.NotesSession")
'Option 3 == OK chez moi / KO ailleurs #429
Set session = GetObject("", "Notes.Notessession")
'==??
'set session = getobject("","Lotus.Notessession")
'######################################################

'Set session = session.Initialize '===> renvoi "objet requis"
'session.Initialize '===> renvoi "a database name must be provided"
Set file = session.getdatabase("", "")
file.openmail


"isabelle" a écrit :

bonjour stanislas,

se pourrait t'il que la variable objNotesSession soit déjà utilisée dans
un autre macro, comme étant un nom d'objet ,

isabelle

stanislasRB a écrit :
> et non, j'ai tout réinscrit, à partir d'un poste qui fonctionne, mais
> toujours rien...
> merci beaucoup, j'y perd toutes mes notions de latin!..
>
> "Daniel.C" a écrit :
>
>
>> Tu peux encore essayer de renommer les dll correspondantes et de les
>> recopier, juste pour voir, depuis un poste qui fonctionne. Fais une
>> réinscription dans le registre avant de faire un test.
>> Daniel
>> "stanislasRB" >> message de news:
>>
>>> Merci de tes conseils judicieux, mais hélas, le getobject et le
>>> createobject
>>> renvoient tous les deux la même erreur, que lotus soit ouvert ou non.
>>>
>>> les références ont été réinscrites, j'ai même ajouté les ref
>>> Lotus Domino object et lotus notes automation classes sur les machines ou
>>> le
>>> code ne fonctionne pas (alors qu'il fonctionne sans sur d'autres) mais
>>> rien à
>>> faire, çà ne le fait pas..
>>>
>>> Je ne sais même pas ou me renseigner, ce n'est pas vraiment un pb lotus,
>>> et
>>> pourtant, depuis queje recherche un peu partout dans les forums, je ne
>>> suis
>>> pas le seul a avoir le pb...
>>>
>>> merci de ton interet pour le pb, en tout cas!
>>>
>>>
>>>
>>>
>>>
>>
>>



stanislasRB
Le #17901841
ALLELUIA / ALLELUIA..................
J AI TROUVE............

C'est bête problême de bdr... Il suffit de lancer le fichier "notesw32.reg"
présent dans le repertoire Notes de Lotus!!!!

ET CA MARCHE ILLICO!

Merci à tous et très bonne journée

"stanislasRB" a écrit :

Bonjour à tous,

J'ai repris un code (génial) trouvé sur mpfe pour expédier des mails Lotus
notes en vba. Mon problème reste que ce code peut très bien fonctionner sur
quelques machines, mais plante sur d'autres, toujours à la même ligne > Set objNotesSession = CreateObject("Notes.NotesSession")
Les OS sont les mêmes, les références cochées sont les mêmes, les versions
d'excel et lotus sont les mêmes, bref, je m'arrache un peu le peu de cheveux
qu'il me reste.
Si quelqu'un a une idée ?

Merci beaucoup par avance,


Publicité
Poster une réponse
Anonyme