Pb Mise à jour de formules

Le
philou36
Bonjour !!

J'ai un soucis avec une macro. Avant j'avais cela :
Private Sub Worksheet_Change(ByVal Target As Range)
If Not Intersect(Target, [C2:C6]) Is Nothing Then
[H10].FormulaLocal = "=C7"
[H11].FormulaLocal = "=SI(B11<>"""";SI(B11>$C$6;"""";$C$7);"""")"
[H12].FormulaLocal = "=SI(B12<>"""";SI(B12>$C$6;"""";$C$7);"""")"
[H13].FormulaLocal = "=SI(B13<>"""";SI(B13>$C$6;"""";$C$7);"""")"
[H14].FormulaLocal = "=SI(B14<>"""";SI(B14>$C$6;"""";$C$7);"""")"
[H15].FormulaLocal = "=SI(B15<>"""";SI(B15>$C$6;"""";$C$7);"""")"
[H16].FormulaLocal = "=SI(B16<>"""";SI(B16>$C$6;"""";$C$7);"""")"
[H17].FormulaLocal = "=SI(B17<>"""";SI(B17>$C$6;"""";$C$7);"""")"
[H18].FormulaLocal = "=SI(B18<>"""";SI(B18>$C$6;"""";$C$7);"""")"

J'ai voulu rajouter
[f10].FormulaLocal = "=e5"
juste après
[H10].FormulaLocal = "=C7"

il plante en me disant :
Erreur d'execution 1004
Erreur definie par l'application ou par l'objet

Avez vu une idée ??

Un grand merci à vous pour votre patience !

Bonne journée.

Philippe
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
MichDenis
Le #18811481
Est-ce possible que ta feuille (au moins lesdites cellules) soient protégées ?



"philou36" discussion :
Bonjour !!

J'ai un soucis avec une macro. Avant j'avais cela :
Private Sub Worksheet_Change(ByVal Target As Range)
If Not Intersect(Target, [C2:C6]) Is Nothing Then
[H10].FormulaLocal = "Ç"
[H11].FormulaLocal = "=SI(B11<>"""";SI(B11>$C$6;"""";$C$7);"""")"
[H12].FormulaLocal = "=SI(B12<>"""";SI(B12>$C$6;"""";$C$7);"""")"
[H13].FormulaLocal = "=SI(B13<>"""";SI(B13>$C$6;"""";$C$7);"""")"
[H14].FormulaLocal = "=SI(B14<>"""";SI(B14>$C$6;"""";$C$7);"""")"
[H15].FormulaLocal = "=SI(B15<>"""";SI(B15>$C$6;"""";$C$7);"""")"
[H16].FormulaLocal = "=SI(B16<>"""";SI(B16>$C$6;"""";$C$7);"""")"
[H17].FormulaLocal = "=SI(B17<>"""";SI(B17>$C$6;"""";$C$7);"""")"
[H18].FormulaLocal = "=SI(B18<>"""";SI(B18>$C$6;"""";$C$7);"""")"
...
J'ai voulu rajouter
[f10].FormulaLocal = "å"
juste après
[H10].FormulaLocal = "Ç"

il plante en me disant :
Erreur d'execution 1004
Erreur definie par l'application ou par l'objet

Avez vu une idée ??

Un grand merci à vous pour votre patience !

Bonne journée.

Philippe
Publicité
Poster une réponse
Anonyme