Pb de montqge de clé et autres trucs USB sous SID

Le
giggz
Bonsoir,

Depuis quelques semaines, plus possible pour moi sous SID de monter mes
périphériques USB comme avant :
- sous le wm awesome j'utilise le gestionnaire de fichier pcmanfm qui
permet en cliquant sur l'icone qui apparait à l'insertion du truc USB de
monter ce dernier
- sous e17 les périphériques se montent maintenant automatiquement à
l'insertion.

Donc depuis 3 ou 4 semaines (en gros depuis la grosse mise à jour de Hal
avec l'apparition de devicekit) plus moyen de monter mes périphériques
comme indiqué ci-dessus. J'ai donc recours à la bonne vielle méthode
avec "mount".

Quelqu'un aurait des infos la-dessusest ce temporaire ? y a t il un
fichier hal à modifier?

bref si vous avez des pistes

Merci d'avance
Guillaume

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
giggz
Le #19390551
giggz a écrit :
Bonsoir,

Depuis quelques semaines, plus possible pour moi sous SID de monter mes
périphériques USB comme avant :
- sous le wm awesome j'utilise le gestionnaire de fichier pcmanfm qui
permet en cliquant sur l'icone qui apparait à l'insertion du truc USB de
monter ce dernier
- sous e17 les périphériques se montent maintenant automatiquement à
l'insertion.

Donc depuis 3 ou 4 semaines (en gros depuis la grosse mise à jour de Hal
avec l'apparition de devicekit) plus moyen de monter mes périphériques
comme indiqué ci-dessus. J'ai donc recours à la bonne vielle méthode
avec "mount".




je parle de consolekit et non de devicekit...

Quelqu'un aurait des infos la-dessus...est ce temporaire ? y a t il un
fichier hal à modifier...?

bref si vous avez des pistes...

Merci d'avance
Guillaume




--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
giggz
Le #19394081
giggz a écrit :
Bonsoir,

Depuis quelques semaines, plus possible pour moi sous SID de monter mes
périphériques USB comme avant :
- sous le wm awesome j'utilise le gestionnaire de fichier pcmanfm qui
permet en cliquant sur l'icone qui apparait à l'insertion du truc USB de
monter ce dernier
- sous e17 les périphériques se montent maintenant automatiquement à
l'insertion.

Donc depuis 3 ou 4 semaines (en gros depuis la grosse mise à jour de Hal
avec l'apparition de devicekit) plus moyen de monter mes périphériques
comme indiqué ci-dessus. J'ai donc recours à la bonne vielle méthode
avec "mount".

Quelqu'un aurait des infos la-dessus...est ce temporaire ? y a t il un
fichier hal à modifier...?

bref si vous avez des pistes...

Merci d'avance
Guillaume




Personne d'autre que moi a des problèmes de montage de clé USB en ce
moment (sans avoir KDE ou gnome) ?

Faut il modifier le fichier policikit.conf ?

Bye

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
giggz
Le #19394311
giggz a écrit :
giggz a écrit :
Bonsoir,

Depuis quelques semaines, plus possible pour moi sous SID de monter mes
périphériques USB comme avant :
- sous le wm awesome j'utilise le gestionnaire de fichier pcmanfm qui
permet en cliquant sur l'icone qui apparait à l'insertion du truc USB de
monter ce dernier
- sous e17 les périphériques se montent maintenant automatiquement à
l'insertion.

Donc depuis 3 ou 4 semaines (en gros depuis la grosse mise à jour de Hal
avec l'apparition de devicekit) plus moyen de monter mes périphériques
comme indiqué ci-dessus. J'ai donc recours à la bonne vielle méthode
avec "mount".

Quelqu'un aurait des infos la-dessus...est ce temporaire ? y a t il un
fichier hal à modifier...?

bref si vous avez des pistes...

Merci d'avance
Guillaume




Personne d'autre que moi a des problèmes de montage de clé USB en ce
moment (sans avoir KDE ou gnome) ?

Faut il modifier le fichier policikit.conf ?

Bye




Ok en modifiant le fichier policykit.conf de cette manière :
<match user="monuser">
<return result="yes"/>
</match>
</config>

Et en rebootant (le redémarrage des services est pour le moins chaotique
en ce moment...j'aime particulièrement le restart de dbus...je vous
laisse tester :) ), le montage des clés redeviant comme d'habitude!

bon je vais voir ça de plus près. ça ne me plait pas de donner tout
pouvoir à mon user!

bye

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
giggz
Le #19394301
giggz a écrit :
giggz a écrit :
giggz a écrit :
Bonsoir,

Depuis quelques semaines, plus possible pour moi sous SID de monter mes
périphériques USB comme avant :
- sous le wm awesome j'utilise le gestionnaire de fichier pcmanfm qui
permet en cliquant sur l'icone qui apparait à l'insertion du truc USB de
monter ce dernier
- sous e17 les périphériques se montent maintenant automatiquement à
l'insertion.

Donc depuis 3 ou 4 semaines (en gros depuis la grosse mise à jour de Hal
avec l'apparition de devicekit) plus moyen de monter mes périphériques
comme indiqué ci-dessus. J'ai donc recours à la bonne vielle méthode
avec "mount".

Quelqu'un aurait des infos la-dessus...est ce temporaire ? y a t il un
fichier hal à modifier...?

bref si vous avez des pistes...

Merci d'avance
Guillaume



Personne d'autre que moi a des problèmes de montage de clé USB en ce
moment (sans avoir KDE ou gnome) ?

Faut il modifier le fichier policikit.conf ?

Bye




Ok en modifiant le fichier policykit.conf de cette manière :
<match user="monuser">
<return result="yes"/>
</match>
</config>

Et en rebootant (le redémarrage des services est pour le moins chaotique
en ce moment...j'aime particulièrement le restart de dbus...je vous
laisse tester :) ), le montage des clés redeviant comme d'habitude!

bon je vais voir ça de plus près. ça ne me plait pas de donner tout
pouvoir à mon user!

bye




bon ça ça marche :

<match user="monuser">
<return result="yes" />
</match>
</match>
</config>


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
dju`
Le #19400221
giggz a écrit :
giggz a écrit :
giggz a écrit :
giggz a écrit :
Bonsoir,

Depuis quelques semaines, plus possible pour moi sous SID de monter mes
périphériques USB comme avant :
- sous le wm awesome j'utilise le gestionnaire de fichier pcmanfm qui
permet en cliquant sur l'icone qui apparait à l'insertion du truc USB de
monter ce dernier
- sous e17 les périphériques se montent maintenant automatiquement à
l'insertion.

Donc depuis 3 ou 4 semaines (en gros depuis la grosse mise à jour de Hal
avec l'apparition de devicekit) plus moyen de monter mes périphériques
comme indiqué ci-dessus. J'ai donc recours à la bonne vielle méthode
avec "mount".

Quelqu'un aurait des infos la-dessus...est ce temporaire ? y a t il un
fichier hal à modifier...?

bref si vous avez des pistes...

Merci d'avance
Guillaume



Personne d'autre que moi a des problèmes de montage de clé USB en ce
moment (sans avoir KDE ou gnome) ?

Faut il modifier le fichier policikit.conf ?

Bye



Ok en modifiant le fichier policykit.conf de cette manière :
<match user="monuser">
<return result="yes"/>
</match>
</config>

Et en rebootant (le redémarrage des services est pour le moins chaotique
en ce moment...j'aime particulièrement le restart de dbus...je vous
laisse tester :) ), le montage des clés redeviant comme d'habitude!

bon je vais voir ça de plus près. ça ne me plait pas de donner tout
pouvoir à mon user!

bye




bon ça ça marche :

<match user="monuser">
<return result="yes" />
</match>
</match>
</config>





Bonjour,

J'ai exactement le même problème. Et je m'étonne de la solution.
Pourquoi le montage de périphériques amovibles ne fonctionne-t-il plus
comme avant, c-a-d "out of the box" ? Pourquoi faut-il éditer un fichier
de configuration perdu dans /etc/PolicyKit/ pour que cela fonctionne à
nouveau ? A quoi sert le groupe "plugdev" si l'on ne peut pas le
spécifier dans ce fichier de configuration, et qu'à la place on doit
entrer un à un les noms des utilisateurs ? Est-ce pour cela que ce
fichier de configuration est vide par défaut ?

Franchement je suis effaré par ce changement et par la difficulté, pour
un utilisateur lambda, de faire face à ce cryptique message d'erreur
"org.freedesktop.Hal.Device.PermissionDeniedByPolicy [...]" émis par
dolphin par exemple.
--
--dju`

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
steve
Le #19400321
Bonjour,

Depuis quelques semaines, plus possible pour moi sous SID de monter mes
périphériques USB comme avant :












[snip]

J'ai exactement le même problème. Et je m'étonne de la solution.
Pourquoi le montage de périphériques amovibles ne fonctionne-t-il plus
comme avant, c-a-d "out of the box" ? Pourquoi faut-il éditer un fichier
de configuration perdu dans /etc/PolicyKit/ pour que cela fonctionne à
nouveau ? A quoi sert le groupe "plugdev" si l'on ne peut pas le
spécifier dans ce fichier de configuration, et qu'à la place on doit
entrer un à un les noms des utilisateurs ? Est-ce pour cela que ce
fichier de configuration est vide par défaut ?

Franchement je suis effaré par ce changement et par la difficulté, pour
un utilisateur lambda, de faire face à ce cryptique message d'erreur
"org.freedesktop.Hal.Device.PermissionDeniedByPolicy [...]" émis par
dolphin par exemple.



Je rappelle peut-être une évidence : vous utilisez SID. Il faut donc
s'attendre que les choses ne fonctionnent plus « out of the box », se
cassent du jour au lendemain, etc.. et surtout ne pas se plaindre de ça.
Si vous ne voulez pas de ce genre de comportements, utilisez la version stable.
SID n'est pas fait pour un utilisateur lambda.

steve

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
giggz
Le #19400381
dju` a écrit :
giggz a écrit :
giggz a écrit :
giggz a écrit :
giggz a écrit :
Bonsoir,

Depuis quelques semaines, plus possible pour moi sous SID de monter
mes
périphériques USB comme avant :
- sous le wm awesome j'utilise le gestionnaire de fichier pcmanfm qui
permet en cliquant sur l'icone qui apparait à l'insertion du truc
USB de
monter ce dernier
- sous e17 les périphériques se montent maintenant automatiquement à
l'insertion.

Donc depuis 3 ou 4 semaines (en gros depuis la grosse mise à jour
de Hal
avec l'apparition de devicekit) plus moyen de monter mes périphériques
comme indiqué ci-dessus. J'ai donc recours à la bonne vielle méthode
avec "mount".

Quelqu'un aurait des infos la-dessus...est ce temporaire ? y a t il un
fichier hal à modifier...?

bref si vous avez des pistes...

Merci d'avance
Guillaume



Personne d'autre que moi a des problèmes de montage de clé USB en ce
moment (sans avoir KDE ou gnome) ?

Faut il modifier le fichier policikit.conf ?

Bye



Ok en modifiant le fichier policykit.conf de cette manière :
<match user="monuser">
<return result="yes"/>
</match>
</config>

Et en rebootant (le redémarrage des services est pour le moins chaotique
en ce moment...j'aime particulièrement le restart de dbus...je vous
laisse tester :) ), le montage des clés redeviant comme d'habitude!

bon je vais voir ça de plus près. ça ne me plait pas de donner tout
pouvoir à mon user!

bye




bon ça ça marche :

<match user="monuser">
<return result="yes" />
</match>
</match>
</config>





Bonjour,

J'ai exactement le même problème. Et je m'étonne de la solution.
Pourquoi le montage de périphériques amovibles ne fonctionne-t-il plus
comme avant, c-a-d "out of the box" ? Pourquoi faut-il éditer un fichier
de configuration perdu dans /etc/PolicyKit/ pour que cela fonctionne à
nouveau ? A quoi sert le groupe "plugdev" si l'on ne peut pas le
spécifier dans ce fichier de configuration, et qu'à la place on doit
entrer un à un les noms des utilisateurs ? Est-ce pour cela que ce
fichier de configuration est vide par défaut ?

Franchement je suis effaré par ce changement et par la difficulté, pour
un utilisateur lambda, de faire face à ce cryptique message d'erreur
"org.freedesktop.Hal.Device.PermissionDeniedByPolicy [...]" émis par
dolphin par exemple.



Deuxième solution :
utiliser policykit-gnome.

Tu installes la chose et ensuite tu peux configurer via un gui tout
plein de chose.

Pour l'utilité de policykit et consort voir sur internet, google ou
autres moteurs de recherche te donneront les raisons.

Bye


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
giggz
Le #19400481
steve a écrit :
Bonjour,

Depuis quelques semaines, plus possible pour moi sous SID de monter mes
périphériques USB comme avant :












[snip]

J'ai exactement le même problème. Et je m'étonne de la solution.
Pourquoi le montage de périphériques amovibles ne fonctionne-t-il plus
comme avant, c-a-d "out of the box" ? Pourquoi faut-il éditer un fichier
de configuration perdu dans /etc/PolicyKit/ pour que cela fonctionne à
nouveau ? A quoi sert le groupe "plugdev" si l'on ne peut pas le
spécifier dans ce fichier de configuration, et qu'à la place on doit
entrer un à un les noms des utilisateurs ? Est-ce pour cela que ce
fichier de configuration est vide par défaut ?

Franchement je suis effaré par ce changement et par la difficulté, pour
un utilisateur lambda, de faire face à ce cryptique message d'erreur
"org.freedesktop.Hal.Device.PermissionDeniedByPolicy [...]" émis par
dolphin par exemple.



Je rappelle peut-être une évidence : vous utilisez SID. Il faut donc
s'attendre que les choses ne fonctionnent plus « out of the box », se
cassent du jour au lendemain, etc.. et surtout ne pas se plaindre de ça.
Si vous ne voulez pas de ce genre de comportements, utilisez la version stable.
SID n'est pas fait pour un utilisateur lambda.

steve




Pas de souci. c'est ce qui fait le charme de SID. Mais là j'avoue que
c'est assez pervers...on ne sait pas si c'est un bug ou alors si c'est
normal. Rien dans le changelog qui laisse entrevoir ça.

J'ai attendu plusieurs semaines en attendant de voir si ça s'arrange,
mais rien. d'où l'ouverture de ce fil pour avoir des pistes.

Il faut aussi bien que les gens utilisant SID se plaignent, sinon la
testing puis la stable ne seraient pas ce qu'elles sont...

Notons aussi que le groupe plugdev est voué à disparaitre.

Bye

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
dju`
Le #19400711
steve a écrit :

Je rappelle peut-être une évidence : vous utilisez SID. Il faut donc
s'attendre que les choses ne fonctionnent plus « out of the box », se
cassent du jour au lendemain, etc.. et surtout ne pas se plaindre de ça.
Si vous ne voulez pas de ce genre de comportements, utilisez la version stable.
SID n'est pas fait pour un utilisateur lambda.

steve




1/ Je suis en testing.
2/ Je ne me plaint pas, je constate juste que le comportement par défaut
me paraît contraignant à première vue puisque le montage de
périphériques amovibles ne fonctionne plus "tel quel". Maintenant je ne
conteste pas l'inclusion de PolicyKit et consorts... il va juste falloir
que je recherche un peu d'info sur le sujet alors que je n'en avait pas
l'intention jusqu'à présent ;)
--
--dju`

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Gabriel Moreau
Le #19553661
> 2/ Je ne me plaint pas,



Ben moi si. Commence a en avoir raz le bol des fichiers de config en XML
dans /etc !

gabriel


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Publicité
Poster une réponse
Anonyme