pb de parametre

Le
lina
bonjour famille access
j'ai créé un etat utilisant une requete avec parametre
le pb c'est que en affichant l'etat, la boite de dialogue du parametre
s'affiche deux fois, d'autre part j'ai inséré un graphique dans un sous etat,
cette fois la meme boite s'ouvre 4 fois!!!!!!!!
Indiquer moi l'erreur S.V.P ! merci !
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
ze Titi
Le #6226961
Salut lina !

Ton état est donc alimenté par une requête. Cette requête,
utilise-t-elle des sous-requêtes réclamant le même paramètre ?
Dans ton état d'origine (sans le graphique), y a t'il des sous états ?

En ce jour exceptionnel du dimanche 01/04/2007, tu nous as très
généreusement gratifié du message suivant:

bonjour famille access
j'ai créé un etat utilisant une requete avec parametre
le pb c'est que en affichant l'etat, la boite de dialogue du parametre
s'affiche deux fois, d'autre part j'ai inséré un graphique dans un sous etat,
cette fois la meme boite s'ouvre 4 fois!!!!!!!!
Indiquer moi l'erreur S.V.P ! merci !


--
Cordialement,
Ze Titi

Tout pour réussir avec Access :
http://www.mpfa.info

lina
Le #6226231
bonjour ze Titi !
alors pour ce qui est de la requete,
j'ai utilise une requete1 regoupement qui compte le nbre d'apparition de
certaines valeurs dans un champ (codApprec) , ensuite j'ai utilisé les champs
de cette requete1 dans une requete2 regroupement qui somme le champ compté ,
dans cette dernière, j'ai mis un paramètre dans un champ (codformation), tout
les champs de la requete 2 viennent de la requete1
ensuite j'ai utilise la requte 2 dans mon état, il n'y a pas de sous état
sauf le graphe
j'espère que je me suis bien expluiuqé cette fois, et qu'il ya vraiment une
solution!



Salut lina !

Ton état est donc alimenté par une requête. Cette requête,
utilise-t-elle des sous-requêtes réclamant le même paramètre ?
Dans ton état d'origine (sans le graphique), y a t'il des sous états ?

En ce jour exceptionnel du dimanche 01/04/2007, tu nous as très
généreusement gratifié du message suivant:

bonjour famille access
j'ai créé un etat utilisant une requete avec parametre
le pb c'est que en affichant l'etat, la boite de dialogue du parametre
s'affiche deux fois, d'autre part j'ai inséré un graphique dans un sous etat,
cette fois la meme boite s'ouvre 4 fois!!!!!!!!
Indiquer moi l'erreur S.V.P ! merci !


--
Cordialement,
Ze Titi

Tout pour réussir avec Access :
http://www.mpfa.info






ze Titi
Le #6226221
Bonjour lina

Essayons déjà de comprendre pourquoi le paramètre est demandé 2 fois
sans le graphique...
Comment ouvres-tu ton état ? Code, macro ?
Y a t'il du code dans l'état qui ferait appel à des champs de la
requête2 ?

Dans ton message
bonjour ze Titi !
alors pour ce qui est de la requete,
j'ai utilise une requete1 regoupement qui compte le nbre d'apparition de
certaines valeurs dans un champ (codApprec) , ensuite j'ai utilisé les champs
de cette requete1 dans une requete2 regroupement qui somme le champ compté ,
dans cette dernière, j'ai mis un paramètre dans un champ (codformation), tout
les champs de la requete 2 viennent de la requete1
ensuite j'ai utilise la requte 2 dans mon état, il n'y a pas de sous état
sauf le graphe
j'espère que je me suis bien expluiuqé cette fois, et qu'il ya vraiment une
solution!



Salut lina !

Ton état est donc alimenté par une requête. Cette requête,
utilise-t-elle des sous-requêtes réclamant le même paramètre ?
Dans ton état d'origine (sans le graphique), y a t'il des sous états ?

En ce jour exceptionnel du dimanche 01/04/2007, tu nous as très
généreusement gratifié du message suivant:

bonjour famille access
j'ai créé un etat utilisant une requete avec parametre
le pb c'est que en affichant l'etat, la boite de dialogue du parametre
s'affiche deux fois, d'autre part j'ai inséré un graphique dans un sous
etat, cette fois la meme boite s'ouvre 4 fois!!!!!!!!
Indiquer moi l'erreur S.V.P ! merci !


--
Cordialement,
Ze Titi

Tout pour réussir avec Access :
http://www.mpfa.info






--
Cordialement,
Ze Titi

Tout pour réussir avec Access :
http://www.mpfa.info



lina
Le #6224301
Bonjour ze titi!
désolee pr tout ce retard, je m'excuse aussi pr cette petite confusion, car
moi mm je n'arrivais pas a situé le pb, et enfin grace a votre dernière
question j'ai séparé, l'état et le graphe, puis j'ai compris que c'était
seulement le graphe qui faisait cette réapparition répétée
il est conçu sur la requete2 , sous form de secteurs, il affiche pour chaque
donnée d'un champs (appreciation) les sommes en format pourcentage

Dès que j'ai mis le nom de la requête et ses champs dans la proprieté source
de données de l'état, il a commencé a me répéter le parametre,qd je l'enlève
tout marche bien il l'affiche une seule fois et j'obtiens mon graphe
Mais qd j'ai mis le graphe comme sous état, alors que l'état initial a comme
source de donnée ma requete et ses champs, là il commense a me le répéter
pour l'instant, je les ai séparé ds mon programme, en attendant trouver la
solution a ce pb..............!



Dans ton message
bonjour ze Titi !
alors pour ce qui est de la requete,
j'ai utilise une requete1 regoupement qui compte le nbre d'apparition de
certaines valeurs dans un champ (codApprec) , ensuite j'ai utilisé les champs
de cette requete1 dans une requete2 regroupement qui somme le champ compté ,
dans cette dernière, j'ai mis un paramètre dans un champ (codformation), tout
les champs de la requete 2 viennent de la requete1
ensuite j'ai utilise la requte 2 dans mon état, il n'y a pas de sous état
sauf le graphe
j'espère que je me suis bien expluiuqé cette fois, et qu'il ya vraiment une
solution!



Salut lina !

Ton état est donc alimenté par une requête. Cette requête,
utilise-t-elle des sous-requêtes réclamant le même paramètre ?
Dans ton état d'origine (sans le graphique), y a t'il des sous états ?

En ce jour exceptionnel du dimanche 01/04/2007, tu nous as très
généreusement gratifié du message suivant:

bonjour famille access
j'ai créé un etat utilisant une requete avec parametre
le pb c'est que en affichant l'etat, la boite de dialogue du parametre
s'affiche deux fois, d'autre part j'ai inséré un graphique dans un sous
etat, cette fois la meme boite s'ouvre 4 fois!!!!!!!!
Indiquer moi l'erreur S.V.P ! merci !


--
Cordialement,
Ze Titi

Tout pour réussir avec Access :
http://www.mpfa.info






--
Cordialement,
Ze Titi

Tout pour réussir avec Access :
http://www.mpfa.info








Publicité
Poster une réponse
Anonyme