pb policykit + kde

Le
Adrien
Bonjour,

Lorsque je branche un disque dur eSata sous KDE, il ne se monte pas
automatiquement, mais je vois le disque dans dolphin. Quand je clique
dessus, j'obtiens le message d'erreur suivant :
Une erreur est survenue en accédant à « Disque_dur ». Message reçu :
org.freedesktop.Hal.Device.Volume.PermissionDenied: refusing to mount device
/dev/sdb2 for uid00

Et je n'arrive pas à trouver comment modifier les permissions de HAL (gérées
par policykit) dans systemsettings :-((

D'autres personnes ont-elles eu ce problème ? Si oui savez-vous comment le
résoudre ?

Système : Debian testing (amd64), KDE 4.5

Adrien

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/ikaj48$439$1@dough.gmane.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Adrien
Le #23159121
Thibault Dupuis wrote:

Normalement tu dois avoir quelque chose comme auth_admin dans la suite,
il faut passer son paramètre à "yes":
Il faut que ça soit de la forme suivante: <allow_active>yes</allow_active>



Ce paramètre était sur « auth_admin_keep ». Si je mets « yes » à la place,
ça ne change rien.

Faut-il lancer une commande pour prendre en compte la modification ? Pour
info j'ai redémarré le PC, histoire que les démons hal et autres soient
redémarrés proprement.

Adrien

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/ikat04$i4u$
Thibault Dupuis
Le #23159231
Le 26/02/2011 13:51, Adrien a écrit :
Thibault Dupuis wrote:

Normalement tu dois avoir quelque chose comme auth_admin dans la suite,
il faut passer son paramètre à "yes":
Il faut que ça soit de la forme suivante:<allow_active>yes</allow_active>


Ce paramètre était sur « auth_admin_keep ». Si je mets « yes » à la place,
ça ne change rien.

Faut-il lancer une commande pour prendre en compte la modification ? Pour
info j'ai redémarré le PC, histoire que les démons hal et autres soient
redémarrés proprement.

Adrien



En faite, il faut laisser le auth_admin_keep et mettre
<allow_active>yes</allow_active> juste en bas il me semble

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Adrien
Le #23159601
Thibault Dupuis wrote:

En faite, il faut laisser le auth_admin_keep et mettre
<allow_active>yes</allow_active> juste en bas il me semble



idem, ça ne change rien. Mais je m'étonne qu'il n'y ait pas un moyen plus
« user-friendly » pour changer ce paramètre.

Il me semble pourtant me souvenir d'un module de configuration pour
paramétrer ça dans systemsettings il y a longtemps. Savez-vous s'il va
revenir un jour ?

Adrien


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/ikb57s$ojv$
Mourad Jaber
Le #23159681
Le 26/02/2011 16:11, Adrien a écrit :
Thibault Dupuis wrote:

En faite, il faut laisser le auth_admin_keep et mettre
<allow_active>yes</allow_active> juste en bas il me semble


idem, ça ne change rien. Mais je m'étonne qu'il n'y ait pas un moyen plus
« user-friendly » pour changer ce paramètre.

Il me semble pourtant me souvenir d'un module de configuration pour
paramétrer ça dans systemsettings il y a longtemps. Savez-vous s'il va
revenir un jour ?

Adrien



Bonjour,

Une question bête, est-ce que ton utilisateur est dans le groupe plugdev ? Il me semble
que c'est ce groupe qui possède les droits de montage à chaud.

++

Mourad

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Thibault Dupuis
Le #23159671
Le 26 févr. 2011 à 16:24, Mourad Jaber a écrit :

Le 26/02/2011 16:11, Adrien a écrit :
Thibault Dupuis wrote:

En faite, il faut laisser le auth_admin_keep et mettre
<allow_active>yes</allow_active> juste en bas il me semble


idem, ça ne change rien. Mais je m'étonne qu'il n'y ait pas un moyen plus
« user-friendly » pour changer ce paramètre.

Il me semble pourtant me souvenir d'un module de configuration pour
paramétrer ça dans systemsettings il y a longtemps. Savez-vous s'il va
revenir un jour ?

Adrien



Bonjour,

Une question bête, est-ce que ton utilisateur est dans le groupe plugdev ? Il me semble que c'est ce groupe qui possède les droits de montage à chaud.

++

Mourad



Le groupe plugdev est une piste aussi!
Il me semble qu'il y a le groupe storage a ajouté à l'utilisateur.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Adrien
Le #23159661
Mourad Jaber wrote:

Une question bête, est-ce que ton utilisateur est dans le groupe plugdev ?
Il me semble que c'est ce groupe qui possède les droits de montage à
chaud.



Oui il en fait bien parti :-) D'ailleurs il n'y a aucun problème pour les
périphériques USB, ça bloque juste pour le eSata.

Adrien

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/ikb6ue$gf$
Sylvain L. Sauvage
Le #23162211
Le samedi 26 février 2011 à 16:41:02, Adrien a écrit :
[…]
Oui il en fait bien parti :-) D'ailleurs il n'y a aucun
problème pour les périphériques USB, ça bloque juste pour le
eSata.



Un périphérique USB est considéré comme (dé)bran chable par
défaut, donc manipulable par un utilisateur (et même s’il existe
des périphériques USB intégrés (caméra, lecteurs …), il n’y a pas
de raison (ni de possibilité) de les traiter autrement).
À l’opposé, il n’y a aucune différence mat érielle entre les
périphériques Sata et eSata. Les eSata sont juste sur une prise
qui est sortie du boîtier. Donc un périphérique (e)Sata est
toujours considéré comme fixe (donc comme un disque dur interne
puisqu’il n’y guère que des disques en Sata). Donc don t le
branchement est réservé à root.

Ça ne répond pas à la question (je ne sais pas comment on fait
depuis que ce n’est plus HAL qu’il faut tripoter (comme pro posé
précédemment)) mais ça explique pourquoi USB et eSata ne son t
pas gérés pareil…

--
Sylvain Sauvage

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Adrien
Le #23164041
Sylvain L. Sauvage wrote:

Un périphérique USB est considéré comme (dé)branchable par
défaut, donc manipulable par un utilisateur (et même s’il existe
des périphériques USB intégrés (caméra, lecteurs…), il n’y a pas
de raison (ni de possibilité) de les traiter autrement).
À l’opposé, il n’y a aucune différence matérielle entre les
périphériques Sata et eSata. Les eSata sont juste sur une prise
qui est sortie du boîtier. Donc un périphérique (e)Sata est
toujours considéré comme fixe (donc comme un disque dur interne
puisqu’il n’y guère que des disques en Sata). Donc dont le
branchement est réservé à root.

Ça ne répond pas à la question (je ne sais pas comment on fait
depuis que ce n’est plus HAL qu’il faut tripoter (comme proposé
précédemment)) mais ça explique pourquoi USB et eSata ne sont
pas gérés pareil…




Merci pour l'explication :-) En fait mon problème est qu'il n'existe pour le
moment pas d'interface pour modifier les droits de montage/démontage de
policykit.

Après recherches sur le web, il semblerait qu'il y a du changement dans
policykit (qui devient polkit) ; le module systemsettings n'existant pas
encore. Il est mentionné sur certains sites qu'il devrait revenir avec KDE
4.5, mais il semble que ce n'est pas le cas… Un bug sur Ubuntu a été ouvert
à ce propos :
https://bugs.launchpad.net/ubuntu/+source/polkit-kde-1/+bug/575428

Attendons la 4.6 pour voir si la situation va évoluer.

Adrien

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/ikg6oj$cgr$
Publicité
Poster une réponse
Anonyme