Pb de somme

Le
lauxeti
Bonjour,

J'ai un souci avec une somme (!!!)
Je desirerais faire la somme des rejets (B2) des rejets
B7,B10,B13,B16,B19

Col A ColB
Parc 1576
Rejets 0
Réalisé 1576
objectif 23.29%
Réalisé 16.54%
réel 575
rejet 367
% réalisé 36.17%
réel 4
rejet #N/A
% réalisé #N/A
réel 380
rejet 340
% réalisé 10.53%
réel 286
rejet 174
% réalisé 39.16%
réel 331
rejet 298
% réalisé 9.97%
et j'obtiens soit #N/A ou 0

Avez vous une idéé ?

PS les valeurs en Col B sont issues de formules (RECHERCHEV)

Merci à tous

Le Lauxeti
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
LSteph
Le #16414031
Bonjour,

Dès que tu as un #N/A dans une donnée tu va le retrouver dans le
résultat qui la prend en compte!

ainsi dans ta formule =somme(B7;B10;B13;B16;B19 ...

puisque B10 renvoie #Na aller voir prioritairement la donnée ou la
formule qui plante à l'origine de B10 et t'arranger pour que quel que
soit le résultat on ne puisse avoir de #NA

en outre ceci t'éviterait de devoir cibler 7.10.13
=sommeprod(($a$7:$a$20="rejet")*($b$7:$b$20))

sinon
revoir peut-être la disposition de ce tableau
Supposant que Parc qui se ballade tout seul est en entête avec les
formules de synthèse que tu souhaites et en dessous le détail serait
sans doute rangé mieux ainsi en trois colonnes:

|Reel |Rejet |%Réalisé

Par ailleurs
> PS les valeurs en Col B sont issues de formules (RECHERCHEV)
ceci laisse entrevoir la possibilité d'un sommeprod ou autre directement
sur les données sur lesquelles tu fais ta recherche.

Cordialement.

--
lSteph


lauxeti a écrit :
Bonjour,

J'ai un souci avec une somme (!!!)
Je desirerais faire la somme des rejets (B2) des rejets
B7,B10,B13,B16,B19

Col A ColB
Parc 1576
Rejets 0
Réalisé 1576
objectif 23.29%
Réalisé 16.54%
réel 575
rejet 367
% réalisé 36.17%
réel 4
rejet #N/A
% réalisé #N/A
réel 380
rejet 340
% réalisé 10.53%
réel 286
rejet 174
% réalisé 39.16%
réel 331
rejet 298
% réalisé 9.97%
et j'obtiens soit #N/A ou 0

Avez vous une idéé ?

PS les valeurs en Col B sont issues de formules (RECHERCHEV)

Merci à tous

Le Lauxeti


Rouch
Le #16414161
Bonjour,

Une autre formule est la suivante : =SOMME.SI(A2:A21;"=rejet";B2:B21)

Attention, il ne faut pas que tu ais de valeur #N/A et dans la celleule
du début tu la valeur Rejets (Avec un S) qui ne sera pas prise en
compte !!!

@+



Bonjour,

J'ai un souci avec une somme (!!!)
Je desirerais faire la somme des rejets (B2) des rejets
B7,B10,B13,B16,B19

Col A ColB
Parc 1576
Rejets 0
Réalisé 1576
objectif 23.29%
Réalisé 16.54%
réel 575
rejet 367
% réalisé 36.17%
réel 4
rejet #N/A
% réalisé #N/A
réel 380
rejet 340
% réalisé 10.53%
réel 286
rejet 174
% réalisé 39.16%
réel 331
rejet 298
% réalisé 9.97%
et j'obtiens soit #N/A ou 0

Avez vous une idéé ?

PS les valeurs en Col B sont issues de formules (RECHERCHEV)

Merci à tous

Le Lauxeti


Publicité
Poster une réponse
Anonyme