pb swap Etch & Vmware ESX 3.1

Le
Patrice
Bonjour,
nous utilisons de la virtualisation au sein de notre compagnie (pas XEN
) mais VMWARE ESX 3.1.
Alors que mes machines virtuelles ne possaient pas de problemes sous
SARGE (ou je ne m'en etait pas rendu compte), j 'ai constater une
utilisation anormale du SWAP saturant ainsi mes machines virtuelles.

En effet, j'ai des VM qui se comportent bizarrement sous linux : pb
d'ecrirure sur les file systems : FS se mettent en lecture seule
je suis obliger de rebooter la VM pour que cela fonctionne
avez vous une idée de l origine du probleme
Avez vous rencontrez ce type de pbs ? les avez vous résolus?

VM-winbind:~# updatedb
/usr/bin/updatedb: line 223: /var/cache/locate/locatedb.n: Système de
fichiers accessible en lecture seulement
sd 0:0:0:0: SCSI error: return code = 0x00020008

VM-winbind:~# dmesg
end_request: I/O error, dev sda, sector 4456511
Buffer I/O error on device sda1, logical block 557056
lost page write due to I/O error on sda1
Buffer I/O error on device sda1, logical block 557057
lost page write due to I/O error on sda1
sd 0:0:0:0: SCSI error: return code = 0x00020008
end_request: I/O error, dev sda, sector 4456863
Buffer I/O error on device sda1, logical block 557100
lost page write due to I/O error on sda1
sd 0:0:0:0: SCSI error: return code = 0x00020008
end_request: I/O error, dev sda, sector 4456983
Buffer I/O error on device sda1, logical block 557115
lost page write due to I/O error on sda1
Buffer I/O error on device sda1, logical block 557116
lost page write due to I/O error on sda1
EXT3-fs error (device sda1): read_block_bitmap: Cannot read block bitmap
- block_group = 17, block_bitmap = 557056
Remounting filesystem read-only
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Matthieu Clavier
Le #1888802
On 2007-06-21, Patrice


Bonjour,


Bonsoir,

nous utilisons de la virtualisation au sein de notre compagnie (pas XEN
) mais VMWARE ESX 3.1.
Alors que mes machines virtuelles ne possaient pas de problemes sous
SARGE (ou je ne m'en etait pas rendu compte), j 'ai constater une
utilisation anormale du SWAP saturant ainsi mes machines virtuelles.

En effet, j'ai des VM qui se comportent bizarrement sous linux : pb
d'ecrirure sur les file systems : FS se mettent en lecture seule
je suis obliger de rebooter la VM pour que cela fonctionne
avez vous une idée de l origine du probleme


Cela ressemble a un crash disque tout simple. Le serveur VMware
se comporte bien avec d'autres VMs ?
Il n'y a pas de message particulier dans les logs du serveur pendant
ces problèmes ? (via le VIC vous avez accés aux messages les plus
récents, sinon, dans /var/log)

Si vous en avais la possibilités, restaurez ce système
sur une nouvelle VMs, peut-être que les fichiers vmdk sont en mauvais
état. Ou alors, via le cdrom d'installation/rescue, faites une
sauvegarde, un formatage des partitions, puis une restauration.

Avez-vous installé les VMware tools ?

Vous devriez quand même voir cela avec le support VMware.

--
Matthieu Clavier

Patrice
Le #1888747
Bonjour
Vmware ne valide pas debian sur les ESX et puis cela m a fait ce pb que
sur ETCH (pas sur la SARGE)
c'est purement lié à la gestion du disque par vmware
je n'ai pas eu de nouveau crash depuis...


On 2007-06-21, Patrice

Bonjour,


Bonsoir,

nous utilisons de la virtualisation au sein de notre compagnie (pas XEN
) mais VMWARE ESX 3.1.
Alors que mes machines virtuelles ne possaient pas de problemes sous
SARGE (ou je ne m'en etait pas rendu compte), j 'ai constater une
utilisation anormale du SWAP saturant ainsi mes machines virtuelles.

En effet, j'ai des VM qui se comportent bizarrement sous linux : pb
d'ecrirure sur les file systems : FS se mettent en lecture seule
je suis obliger de rebooter la VM pour que cela fonctionne
avez vous une idée de l origine du probleme


Cela ressemble a un crash disque tout simple. Le serveur VMware
se comporte bien avec d'autres VMs ?
Il n'y a pas de message particulier dans les logs du serveur pendant
ces problèmes ? (via le VIC vous avez accés aux messages les plus
récents, sinon, dans /var/log)

Si vous en avais la possibilités, restaurez ce système
sur une nouvelle VMs, peut-être que les fichiers vmdk sont en mauvais
état. Ou alors, via le cdrom d'installation/rescue, faites une
sauvegarde, un formatage des partitions, puis une restauration.

Avez-vous installé les VMware tools ?

Vous devriez quand même voir cela avec le support VMware.




Publicité
Poster une réponse
Anonyme